aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorDirk Froemberg <dirk@FreeBSD.org>2001-01-07 13:52:24 +0000
committerDirk Froemberg <dirk@FreeBSD.org>2001-01-07 13:52:24 +0000
commit76f676a1dea4b73e5969785b5bc5787969063372 (patch)
tree21a484e734e9682347d7a996071082f18ebf90f6 /databases
parent10f90be831228b5610982f763c530bb790df868c (diff)
Notes
Diffstat (limited to 'databases')
-rw-r--r--databases/mysql322-server/Makefile3
-rw-r--r--databases/mysql322-server/files/patch-aq13
-rw-r--r--databases/mysql323-server/Makefile3
-rw-r--r--databases/mysql323-server/files/patch-aq13
-rw-r--r--databases/mysql40-server/Makefile3
-rw-r--r--databases/mysql40-server/files/patch-aq13
-rw-r--r--databases/mysql41-server/Makefile3
-rw-r--r--databases/mysql41-server/files/patch-aq13
-rw-r--r--databases/mysql50-server/Makefile3
-rw-r--r--databases/mysql50-server/files/patch-aq13
-rw-r--r--databases/mysql51-server/Makefile3
-rw-r--r--databases/mysql51-server/files/patch-aq13
-rw-r--r--databases/mysql54-server/Makefile3
-rw-r--r--databases/mysql54-server/files/patch-aq13
-rw-r--r--databases/mysql55-server/Makefile3
-rw-r--r--databases/mysql55-server/files/patch-aq13
-rw-r--r--databases/mysql60-server/Makefile3
-rw-r--r--databases/mysql60-server/files/patch-aq13
-rw-r--r--databases/percona55-server/Makefile3
-rw-r--r--databases/percona55-server/files/patch-aq13
20 files changed, 20 insertions, 140 deletions
diff --git a/databases/mysql322-server/Makefile b/databases/mysql322-server/Makefile
index 5add7d49505a..a5fb7be60bc4 100644
--- a/databases/mysql322-server/Makefile
+++ b/databases/mysql322-server/Makefile
@@ -25,7 +25,8 @@ CONFIGURE_ARGS= --localstatedir=${DB_DIR} \
--without-perl \
--without-debug \
--without-readline \
- --without-bench
+ --without-bench \
+ --with-low-memory
.if ${MACHINE_ARCH} == "i386"
CONFIGURE_ARGS+=--enable-assembler
.endif
diff --git a/databases/mysql322-server/files/patch-aq b/databases/mysql322-server/files/patch-aq
deleted file mode 100644
index 573324175921..000000000000
--- a/databases/mysql322-server/files/patch-aq
+++ /dev/null
@@ -1,13 +0,0 @@
---- sql/Makefile.in.orig Sat Jan 1 18:01:13 2000
-+++ sql/Makefile.in Wed Jan 5 20:28:17 2000
-@@ -317,6 +317,10 @@
- else :; fi
- sql_yacc.hh: sql_yacc.cc
-
-+# gcc takes a lot of memory and cpu time if it compiles sql_yacc.cc with -O
-+sql_yacc.o: sql_yacc.cc
-+ $(CXXCOMPILE) -O0 -c $<
-+
-
- # This directory's subdirectories are mostly independent; you can cd
- # into them and run `make' without going through this Makefile.
diff --git a/databases/mysql323-server/Makefile b/databases/mysql323-server/Makefile
index 1b7689d4608e..b952e987c71c 100644
--- a/databases/mysql323-server/Makefile
+++ b/databases/mysql323-server/Makefile
@@ -28,7 +28,8 @@ CONFIGURE_ARGS= --localstatedir=${DB_DIR} \
--without-readline \
--without-bench \
--with-mit-threads=no \
- --with-libwrap
+ --with-libwrap \
+ --with-low-memory
.if ${MACHINE_ARCH} == "i386"
CONFIGURE_ARGS+=--enable-assembler
.endif
diff --git a/databases/mysql323-server/files/patch-aq b/databases/mysql323-server/files/patch-aq
deleted file mode 100644
index 573324175921..000000000000
--- a/databases/mysql323-server/files/patch-aq
+++ /dev/null
@@ -1,13 +0,0 @@
---- sql/Makefile.in.orig Sat Jan 1 18:01:13 2000
-+++ sql/Makefile.in Wed Jan 5 20:28:17 2000
-@@ -317,6 +317,10 @@
- else :; fi
- sql_yacc.hh: sql_yacc.cc
-
-+# gcc takes a lot of memory and cpu time if it compiles sql_yacc.cc with -O
-+sql_yacc.o: sql_yacc.cc
-+ $(CXXCOMPILE) -O0 -c $<
-+
-
- # This directory's subdirectories are mostly independent; you can cd
- # into them and run `make' without going through this Makefile.
diff --git a/databases/mysql40-server/Makefile b/databases/mysql40-server/Makefile
index 1b7689d4608e..b952e987c71c 100644
--- a/databases/mysql40-server/Makefile
+++ b/databases/mysql40-server/Makefile
@@ -28,7 +28,8 @@ CONFIGURE_ARGS= --localstatedir=${DB_DIR} \
--without-readline \
--without-bench \
--with-mit-threads=no \
- --with-libwrap
+ --with-libwrap \
+ --with-low-memory
.if ${MACHINE_ARCH} == "i386"
CONFIGURE_ARGS+=--enable-assembler
.endif
diff --git a/databases/mysql40-server/files/patch-aq b/databases/mysql40-server/files/patch-aq
deleted file mode 100644
index 573324175921..000000000000
--- a/databases/mysql40-server/files/patch-aq
+++ /dev/null
@@ -1,13 +0,0 @@
---- sql/Makefile.in.orig Sat Jan 1 18:01:13 2000
-+++ sql/Makefile.in Wed Jan 5 20:28:17 2000
-@@ -317,6 +317,10 @@
- else :; fi
- sql_yacc.hh: sql_yacc.cc
-
-+# gcc takes a lot of memory and cpu time if it compiles sql_yacc.cc with -O
-+sql_yacc.o: sql_yacc.cc
-+ $(CXXCOMPILE) -O0 -c $<
-+
-
- # This directory's subdirectories are mostly independent; you can cd
- # into them and run `make' without going through this Makefile.
diff --git a/databases/mysql41-server/Makefile b/databases/mysql41-server/Makefile
index 1b7689d4608e..b952e987c71c 100644
--- a/databases/mysql41-server/Makefile
+++ b/databases/mysql41-server/Makefile
@@ -28,7 +28,8 @@ CONFIGURE_ARGS= --localstatedir=${DB_DIR} \
--without-readline \
--without-bench \
--with-mit-threads=no \
- --with-libwrap
+ --with-libwrap \
+ --with-low-memory
.if ${MACHINE_ARCH} == "i386"
CONFIGURE_ARGS+=--enable-assembler
.endif
diff --git a/databases/mysql41-server/files/patch-aq b/databases/mysql41-server/files/patch-aq
deleted file mode 100644
index 573324175921..000000000000
--- a/databases/mysql41-server/files/patch-aq
+++ /dev/null
@@ -1,13 +0,0 @@
---- sql/Makefile.in.orig Sat Jan 1 18:01:13 2000
-+++ sql/Makefile.in Wed Jan 5 20:28:17 2000
-@@ -317,6 +317,10 @@
- else :; fi
- sql_yacc.hh: sql_yacc.cc
-
-+# gcc takes a lot of memory and cpu time if it compiles sql_yacc.cc with -O
-+sql_yacc.o: sql_yacc.cc
-+ $(CXXCOMPILE) -O0 -c $<
-+
-
- # This directory's subdirectories are mostly independent; you can cd
- # into them and run `make' without going through this Makefile.
diff --git a/databases/mysql50-server/Makefile b/databases/mysql50-server/Makefile
index 1b7689d4608e..b952e987c71c 100644
--- a/databases/mysql50-server/Makefile
+++ b/databases/mysql50-server/Makefile
@@ -28,7 +28,8 @@ CONFIGURE_ARGS= --localstatedir=${DB_DIR} \
--without-readline \
--without-bench \
--with-mit-threads=no \
- --with-libwrap
+ --with-libwrap \
+ --with-low-memory
.if ${MACHINE_ARCH} == "i386"
CONFIGURE_ARGS+=--enable-assembler
.endif
diff --git a/databases/mysql50-server/files/patch-aq b/databases/mysql50-server/files/patch-aq
deleted file mode 100644
index 573324175921..000000000000
--- a/databases/mysql50-server/files/patch-aq
+++ /dev/null
@@ -1,13 +0,0 @@
---- sql/Makefile.in.orig Sat Jan 1 18:01:13 2000
-+++ sql/Makefile.in Wed Jan 5 20:28:17 2000
-@@ -317,6 +317,10 @@
- else :; fi
- sql_yacc.hh: sql_yacc.cc
-
-+# gcc takes a lot of memory and cpu time if it compiles sql_yacc.cc with -O
-+sql_yacc.o: sql_yacc.cc
-+ $(CXXCOMPILE) -O0 -c $<
-+
-
- # This directory's subdirectories are mostly independent; you can cd
- # into them and run `make' without going through this Makefile.
diff --git a/databases/mysql51-server/Makefile b/databases/mysql51-server/Makefile
index 1b7689d4608e..b952e987c71c 100644
--- a/databases/mysql51-server/Makefile
+++ b/databases/mysql51-server/Makefile
@@ -28,7 +28,8 @@ CONFIGURE_ARGS= --localstatedir=${DB_DIR} \
--without-readline \
--without-bench \
--with-mit-threads=no \
- --with-libwrap
+ --with-libwrap \
+ --with-low-memory
.if ${MACHINE_ARCH} == "i386"
CONFIGURE_ARGS+=--enable-assembler
.endif
diff --git a/databases/mysql51-server/files/patch-aq b/databases/mysql51-server/files/patch-aq
deleted file mode 100644
index 573324175921..000000000000
--- a/databases/mysql51-server/files/patch-aq
+++ /dev/null
@@ -1,13 +0,0 @@
---- sql/Makefile.in.orig Sat Jan 1 18:01:13 2000
-+++ sql/Makefile.in Wed Jan 5 20:28:17 2000
-@@ -317,6 +317,10 @@
- else :; fi
- sql_yacc.hh: sql_yacc.cc
-
-+# gcc takes a lot of memory and cpu time if it compiles sql_yacc.cc with -O
-+sql_yacc.o: sql_yacc.cc
-+ $(CXXCOMPILE) -O0 -c $<
-+
-
- # This directory's subdirectories are mostly independent; you can cd
- # into them and run `make' without going through this Makefile.
diff --git a/databases/mysql54-server/Makefile b/databases/mysql54-server/Makefile
index 1b7689d4608e..b952e987c71c 100644
--- a/databases/mysql54-server/Makefile
+++ b/databases/mysql54-server/Makefile
@@ -28,7 +28,8 @@ CONFIGURE_ARGS= --localstatedir=${DB_DIR} \
--without-readline \
--without-bench \
--with-mit-threads=no \
- --with-libwrap
+ --with-libwrap \
+ --with-low-memory
.if ${MACHINE_ARCH} == "i386"
CONFIGURE_ARGS+=--enable-assembler
.endif
diff --git a/databases/mysql54-server/files/patch-aq b/databases/mysql54-server/files/patch-aq
deleted file mode 100644
index 573324175921..000000000000
--- a/databases/mysql54-server/files/patch-aq
+++ /dev/null
@@ -1,13 +0,0 @@
---- sql/Makefile.in.orig Sat Jan 1 18:01:13 2000
-+++ sql/Makefile.in Wed Jan 5 20:28:17 2000
-@@ -317,6 +317,10 @@
- else :; fi
- sql_yacc.hh: sql_yacc.cc
-
-+# gcc takes a lot of memory and cpu time if it compiles sql_yacc.cc with -O
-+sql_yacc.o: sql_yacc.cc
-+ $(CXXCOMPILE) -O0 -c $<
-+
-
- # This directory's subdirectories are mostly independent; you can cd
- # into them and run `make' without going through this Makefile.
diff --git a/databases/mysql55-server/Makefile b/databases/mysql55-server/Makefile
index 1b7689d4608e..b952e987c71c 100644
--- a/databases/mysql55-server/Makefile
+++ b/databases/mysql55-server/Makefile
@@ -28,7 +28,8 @@ CONFIGURE_ARGS= --localstatedir=${DB_DIR} \
--without-readline \
--without-bench \
--with-mit-threads=no \
- --with-libwrap
+ --with-libwrap \
+ --with-low-memory
.if ${MACHINE_ARCH} == "i386"
CONFIGURE_ARGS+=--enable-assembler
.endif
diff --git a/databases/mysql55-server/files/patch-aq b/databases/mysql55-server/files/patch-aq
deleted file mode 100644
index 573324175921..000000000000
--- a/databases/mysql55-server/files/patch-aq
+++ /dev/null
@@ -1,13 +0,0 @@
---- sql/Makefile.in.orig Sat Jan 1 18:01:13 2000
-+++ sql/Makefile.in Wed Jan 5 20:28:17 2000
-@@ -317,6 +317,10 @@
- else :; fi
- sql_yacc.hh: sql_yacc.cc
-
-+# gcc takes a lot of memory and cpu time if it compiles sql_yacc.cc with -O
-+sql_yacc.o: sql_yacc.cc
-+ $(CXXCOMPILE) -O0 -c $<
-+
-
- # This directory's subdirectories are mostly independent; you can cd
- # into them and run `make' without going through this Makefile.
diff --git a/databases/mysql60-server/Makefile b/databases/mysql60-server/Makefile
index 1b7689d4608e..b952e987c71c 100644
--- a/databases/mysql60-server/Makefile
+++ b/databases/mysql60-server/Makefile
@@ -28,7 +28,8 @@ CONFIGURE_ARGS= --localstatedir=${DB_DIR} \
--without-readline \
--without-bench \
--with-mit-threads=no \
- --with-libwrap
+ --with-libwrap \
+ --with-low-memory
.if ${MACHINE_ARCH} == "i386"
CONFIGURE_ARGS+=--enable-assembler
.endif
diff --git a/databases/mysql60-server/files/patch-aq b/databases/mysql60-server/files/patch-aq
deleted file mode 100644
index 573324175921..000000000000
--- a/databases/mysql60-server/files/patch-aq
+++ /dev/null
@@ -1,13 +0,0 @@
---- sql/Makefile.in.orig Sat Jan 1 18:01:13 2000
-+++ sql/Makefile.in Wed Jan 5 20:28:17 2000
-@@ -317,6 +317,10 @@
- else :; fi
- sql_yacc.hh: sql_yacc.cc
-
-+# gcc takes a lot of memory and cpu time if it compiles sql_yacc.cc with -O
-+sql_yacc.o: sql_yacc.cc
-+ $(CXXCOMPILE) -O0 -c $<
-+
-
- # This directory's subdirectories are mostly independent; you can cd
- # into them and run `make' without going through this Makefile.
diff --git a/databases/percona55-server/Makefile b/databases/percona55-server/Makefile
index 1b7689d4608e..b952e987c71c 100644
--- a/databases/percona55-server/Makefile
+++ b/databases/percona55-server/Makefile
@@ -28,7 +28,8 @@ CONFIGURE_ARGS= --localstatedir=${DB_DIR} \
--without-readline \
--without-bench \
--with-mit-threads=no \
- --with-libwrap
+ --with-libwrap \
+ --with-low-memory
.if ${MACHINE_ARCH} == "i386"
CONFIGURE_ARGS+=--enable-assembler
.endif
diff --git a/databases/percona55-server/files/patch-aq b/databases/percona55-server/files/patch-aq
deleted file mode 100644
index 573324175921..000000000000
--- a/databases/percona55-server/files/patch-aq
+++ /dev/null
@@ -1,13 +0,0 @@
---- sql/Makefile.in.orig Sat Jan 1 18:01:13 2000
-+++ sql/Makefile.in Wed Jan 5 20:28:17 2000
-@@ -317,6 +317,10 @@
- else :; fi
- sql_yacc.hh: sql_yacc.cc
-
-+# gcc takes a lot of memory and cpu time if it compiles sql_yacc.cc with -O
-+sql_yacc.o: sql_yacc.cc
-+ $(CXXCOMPILE) -O0 -c $<
-+
-
- # This directory's subdirectories are mostly independent; you can cd
- # into them and run `make' without going through this Makefile.