aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorMatthew Seaman <matthew@FreeBSD.org>2013-05-04 06:24:53 +0000
committerMatthew Seaman <matthew@FreeBSD.org>2013-05-04 06:24:53 +0000
commit7ceab773004c50f8d7dd36b80315ab18681e10d0 (patch)
tree5cad0c0729eb488d52fa9ce0cf3b3d20dae15cbe /databases
parent3fcf6ba40cd5cd07621f3371d7c01fdce99b5dab (diff)
downloadports-7ceab773004c50f8d7dd36b80315ab18681e10d0.tar.gz
ports-7ceab773004c50f8d7dd36b80315ab18681e10d0.zip
Notes
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/phpmyadmin/Makefile7
-rw-r--r--databases/phpmyadmin/distinfo4
-rw-r--r--databases/phpmyadmin/pkg-descr23
-rw-r--r--databases/phpmyadmin35/Makefile136
-rw-r--r--databases/phpmyadmin35/distinfo2
-rw-r--r--databases/phpmyadmin35/files/config.inc.php.sample14
-rw-r--r--databases/phpmyadmin35/files/pkg-deinstall.in26
-rw-r--r--databases/phpmyadmin35/files/pkg-install.in25
-rw-r--r--databases/phpmyadmin35/files/pkg-message.in29
-rw-r--r--databases/phpmyadmin35/pkg-descr31
-rw-r--r--databases/phpmyadmin35/pkg-plist-chunk7
12 files changed, 290 insertions, 15 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 8c84d55bac8e..30422eb29af8 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -632,6 +632,7 @@
SUBDIR += php53-sybase_ct
SUBDIR += phpminiadmin
SUBDIR += phpmyadmin
+ SUBDIR += phpmyadmin35
SUBDIR += phppgadmin
SUBDIR += postgis
SUBDIR += postgis20
diff --git a/databases/phpmyadmin/Makefile b/databases/phpmyadmin/Makefile
index 668c08de93af..684d4e41ffd8 100644
--- a/databases/phpmyadmin/Makefile
+++ b/databases/phpmyadmin/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= phpMyAdmin
-DISTVERSION= 3.5.8.1
+DISTVERSION= 4.0.0
CATEGORIES= databases www
MASTER_SITES= SF/${PORTNAME:L}/${PORTNAME}/${DISTVERSION}
DISTNAME= ${PORTNAME}-${DISTVERSION}-all-languages
@@ -23,9 +23,9 @@ USE_PHP= ctype session filter mbstring json spl
# want this, either turn off GD in the config dialog, or else turn off
# FONTCONFIG in the graphics/gd port options.
-PHP_MODULE_OPTIONS= APC BZ2 GD MCRYPT OPENSSL PDF ZIP ZLIB
+PHP_MODULE_OPTIONS= APC BZ2 GD MCRYPT OPENSSL PDF XML ZIP ZLIB
OPTIONS_DEFINE= SUPHP ${PHP_MODULE_OPTIONS}
-OPTIONS_DEFAULT= APC BZ2 GD MCRYPT MYSQLI OPENSSL PDF ZIP ZLIB
+OPTIONS_DEFAULT= APC BZ2 GD MCRYPT MYSQLI OPENSSL PDF XML ZIP ZLIB
OPTIONS_MULTI= DB_connect
OPTIONS_MULTI_DB_connect= MYSQL MYSQLI
@@ -39,6 +39,7 @@ MYSQL_DESC= PHP MySQL support via mysql client
OPENSSL_DESC= PHP OpenSSL support
PDF_DESC= PHP PDFlib support
SUPHP_DESC= suPHP support
+XML_DESC= PHP XML support (Export to OpenDoc)
ZIP_DESC= PHP Zip compression support
ZLIB_DESC= PHP ZLIB support
diff --git a/databases/phpmyadmin/distinfo b/databases/phpmyadmin/distinfo
index 17dea4bc61b4..30bef073e5eb 100644
--- a/databases/phpmyadmin/distinfo
+++ b/databases/phpmyadmin/distinfo
@@ -1,2 +1,2 @@
-SHA256 (phpMyAdmin-3.5.8.1-all-languages.tar.xz) = c66737ff55369b1c9e4b116e68f3c517faf7c4bc17e289d008d74fde6c8260f6
-SIZE (phpMyAdmin-3.5.8.1-all-languages.tar.xz) = 3744808
+SHA256 (phpMyAdmin-4.0.0-all-languages.tar.xz) = b3a16c7397738cf3e65b54b9ad4178a19ce78d60753fb158b7eb6658d443b2ec
+SIZE (phpMyAdmin-4.0.0-all-languages.tar.xz) = 4347792
diff --git a/databases/phpmyadmin/pkg-descr b/databases/phpmyadmin/pkg-descr
index d5d513f6d406..0a321b81ceed 100644
--- a/databases/phpmyadmin/pkg-descr
+++ b/databases/phpmyadmin/pkg-descr
@@ -1,7 +1,8 @@
+Currently phpMyAdmin can:
- phpMyAdmin handles the administration of MySQL over the Web. It can:
- * browse and drop databases, tables, views, fields and indexes
- * create, copy, drop, rename and alter databases, tables, fields
+ * browse and drop databases, tables, views, columns and indexes
+ * display multiple results sets through stored procedures or queries
+ * create, copy, drop, rename and alter databases, tables, columns
and indexes
* maintain server, databases and tables, with proposals on server
configuration
@@ -9,23 +10,25 @@
* load text files into tables
* create and read dumps of tables
* export data to various formats: CSV, XML, PDF, ISO/IEC 26300 -
- OpenDocument Text and Spreadsheet, Word, Excel and LATEX formats
- * import data and MySQL structures from Microsoft Excel and
- OpenDocument spreadsheets, as well as XML, CSV, and SQL files
+ OpenDocument Text and Spreadsheet, Microsoft Word 2000, and
+ LATEX formats
+ * import data and MySQL structures from OpenDocument spreadsheets,
+ as well as XML, CSV, and SQL files
* administer multiple servers
* manage MySQL users and privileges
* check referential integrity in MyISAM tables
* using Query-by-example (QBE), create complex queries
automatically connecting required tables
- * create PDF graphics of your Database layout
+ * create PDF graphics of your database layout
* search globally in a database or a subset of it
* transform stored data into any format using a set of predefined
functions, like displaying BLOB-data as image or download-link
* track changes on databases, tables and views
* support InnoDB tables and foreign keys
* support mysqli, the improved MySQL extension
- * communicate in 57 different languages
- * synchronize two databases residing on the same as well as remote
- servers
+ * create, edit, call, export and drop stored procedures and
+ functions
+ * create, edit, export and drop events and triggers
+ * communicate in 62 different languages
WWW: http://www.phpmyadmin.net/
diff --git a/databases/phpmyadmin35/Makefile b/databases/phpmyadmin35/Makefile
new file mode 100644
index 000000000000..f74e7ff1346a
--- /dev/null
+++ b/databases/phpmyadmin35/Makefile
@@ -0,0 +1,136 @@
+# Created by: nbm
+# $FreeBSD$
+
+PORTNAME= phpMyAdmin35
+DISTVERSION= 3.5.8.1
+CATEGORIES= databases www
+MASTER_SITES= SF/${PORTNAME:L:S/35//}/${PORTNAME:S/35//}/${DISTVERSION}
+DISTNAME= ${PORTNAME:S/35//}-${DISTVERSION}-all-languages
+
+MAINTAINER= matthew@FreeBSD.org
+COMMENT= A set of PHP-scripts to manage MySQL over the web
+
+LICENSE= GPLv2
+
+IGNORE_WITH_PHP= 4
+USE_XZ= yes
+NO_BUILD= yes
+.if !defined(WITHOUT_PHP_DEPENDS)
+USE_PHP= ctype session filter mbstring json spl
+.endif
+
+# Note: default settings will pull in X11 client support. If you don't
+# want this, either turn off GD in the config dialog, or else turn off
+# FONTCONFIG in the graphics/gd port options.
+
+PHP_MODULE_OPTIONS= APC BZ2 GD MCRYPT OPENSSL PDF ZIP ZLIB
+OPTIONS_DEFINE= SUPHP ${PHP_MODULE_OPTIONS}
+OPTIONS_DEFAULT= APC BZ2 GD MCRYPT MYSQLI OPENSSL PDF ZIP ZLIB
+
+OPTIONS_MULTI= DB_connect
+OPTIONS_MULTI_DB_connect= MYSQL MYSQLI
+
+APC_DESC= PHP APC (animated progress bar) support
+BZ2_DESC= PHP bzip2 library support
+GD_DESC= PHP GD library support (requires X11)
+MCRYPT_DESC= PHP MCrypt library support
+MYSQLI_DESC= PHP Improved MySQL client support
+MYSQL_DESC= PHP MySQL support via mysql client
+OPENSSL_DESC= PHP OpenSSL support
+PDF_DESC= PHP PDFlib support
+SUPHP_DESC= suPHP support
+ZIP_DESC= PHP Zip compression support
+ZLIB_DESC= PHP ZLIB support
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MSUPHP}
+
+PKGNAMESUFFIX= -suphp
+RUN_DEPENDS+= ${LOCALBASE}/sbin/suphp:${PORTSDIR}/www/suphp
+WANT_PHP_CGI= yes
+
+.else
+
+WANT_PHP_WEB= yes
+
+.endif
+
+# USERS is only used with the SUPHP option
+GROUPS?= ${WWWGRP}
+CFGFILE= config.inc.php
+
+PLIST= ${WRKDIR}/plist
+PLIST_SUB+= PMA_GRP=${GROUPS}
+
+.if ${PORT_OPTIONS:MSUPHP}
+
+USERS?= _pma
+
+SUB_LIST+= PMA_USR=${USERS} \
+ PMA_GRP=${GROUPS}
+SUB_FILES+= pkg-install pkg-deinstall
+
+.endif
+
+SUB_LIST+= PKGNAME=${PKGNAME}
+SUB_FILES+= pkg-message
+
+LATEST_LINK= ${PORTNAME}${PKGNAMESUFFIX}
+
+.if !defined(WITHOUT_PHP_DEPENDS)
+
+.for opt in ${PHP_MODULE_OPTIONS} ${OPTIONS_MULTI_DB_connect}
+. if ${PORT_OPTIONS:M${opt}}
+USE_PHP+= ${opt:L}
+. endif
+.endfor
+
+.endif
+
+.SILENT:
+
+# When creating a package, empty directories will not be generated
+# from the pkg tarball. Therefore make sure no directories are empty.
+
+post-patch:
+ cd ${WRKSRC} ; \
+ for emptydir in $$( ${FIND} . -type d -empty -print ) ; do \
+ ${TOUCH} $${emptydir}/.keep-me ; \
+ done ; \
+ ${CP} ${FILESDIR}/${CFGFILE}.sample ${WRKSRC}/${CFGFILE}.sample ; \
+ ${FIND} . ! -type d ! -name ${CFGFILE}.sample ! -name '*.bak' | \
+ ${SORT} | ${SED} -e "s,^\.,%%WWWDIR%%," >${PLIST} ; \
+ ${CAT} ${PKGDIR}/pkg-plist-chunk >>${PLIST} ; \
+ ${FIND} . -type d | ${SORT} -r | ${SED} \
+ -e "s,^\.$$,@dirrmtry %%WWWDIR%%," \
+ -e "s,^\.,@dirrm %%WWWDIR%%," >>${PLIST}
+
+do-install: install-app install-conf
+
+install-app:
+ cd ${WRKSRC} ; \
+ for src in $$( ${FIND} . ! -name .cvsignore ! -name '*.bak' ) ; do \
+ dst=${WWWDIR}$${src#.} ; \
+ if ${TEST} -d "$$src" ; then \
+ ${MKDIR} "$$dst" ; \
+ else \
+ ${INSTALL_DATA} "$$src" "$$dst" ; \
+ fi \
+ done
+
+install-conf: install-app
+ cd ${WWWDIR} ; \
+ ${CHMOD} 0640 ${CFGFILE}.sample ; \
+ ${CHGRP} ${WWWGRP} ${CFGFILE}.sample ; \
+ if ${TEST} ! -f ${CFGFILE} ; then \
+ ${CP} -p ${CFGFILE}.sample ${CFGFILE} ; \
+ fi
+
+post-install:
+.if ${PORT_OPTIONS:MSUPHP}
+ ${SETENV} ${SCRIPTS_ENV} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+.endif
+ ${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/databases/phpmyadmin35/distinfo b/databases/phpmyadmin35/distinfo
new file mode 100644
index 000000000000..17dea4bc61b4
--- /dev/null
+++ b/databases/phpmyadmin35/distinfo
@@ -0,0 +1,2 @@
+SHA256 (phpMyAdmin-3.5.8.1-all-languages.tar.xz) = c66737ff55369b1c9e4b116e68f3c517faf7c4bc17e289d008d74fde6c8260f6
+SIZE (phpMyAdmin-3.5.8.1-all-languages.tar.xz) = 3744808
diff --git a/databases/phpmyadmin35/files/config.inc.php.sample b/databases/phpmyadmin35/files/config.inc.php.sample
new file mode 100644
index 000000000000..73f35478b952
--- /dev/null
+++ b/databases/phpmyadmin35/files/config.inc.php.sample
@@ -0,0 +1,14 @@
+<?php
+/* $FreeBSD$
+ *
+ * Skeleton configuration file -- this file is empty on a fresh
+ * installaton of phpmyadmin.
+ *
+ * Copy any settings you want to override from
+ * libraries/config.default.php or visit /phpmyadmin/setup/ to generate a
+ * basic configuration file
+ *
+ */
+
+
+?>
diff --git a/databases/phpmyadmin35/files/pkg-deinstall.in b/databases/phpmyadmin35/files/pkg-deinstall.in
new file mode 100644
index 000000000000..83204b698c11
--- /dev/null
+++ b/databases/phpmyadmin35/files/pkg-deinstall.in
@@ -0,0 +1,26 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+case $2 in
+ POST-DEINSTALL)
+ cat <<EOMSG
+The phpMyAdmin-suphp port has been deleted.
+If you are not upgrading and don't intend to use
+phpMyAdmin any more then you may wish to delete
+the %%PMA_USR%% account, which can be done with
+the following command:
+
+ # pw userdel %%PMA_USR%%
+EOMSG
+ if [ -d %%WWWDIR%% ] ; then
+ echo " # rm -rf %%WWWDIR%%/"
+ fi
+ echo
+ ;;
+esac
+
+#
+# That's All Folks!
+#
diff --git a/databases/phpmyadmin35/files/pkg-install.in b/databases/phpmyadmin35/files/pkg-install.in
new file mode 100644
index 000000000000..4a552295fda4
--- /dev/null
+++ b/databases/phpmyadmin35/files/pkg-install.in
@@ -0,0 +1,25 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+PATH=/usr/sbin:/usr/bin:/bin ; export PATH
+
+WWWDIR=%%WWWDIR%%
+pma_usr=%%PMA_USR%%
+pma_grp=%%PMA_GRP%%
+
+case $2 in
+
+ POST-INSTALL)
+
+ # Change ownership of the phpMyAdm directory
+
+ echo "===> Adjusting file ownership in $WWWDIR"
+ chown -R $pma_usr:$pma_grp $WWWDIR || exit 1
+ ;;
+esac
+
+#
+# That's All Folks!
+#
diff --git a/databases/phpmyadmin35/files/pkg-message.in b/databases/phpmyadmin35/files/pkg-message.in
new file mode 100644
index 000000000000..746af63a5999
--- /dev/null
+++ b/databases/phpmyadmin35/files/pkg-message.in
@@ -0,0 +1,29 @@
+
+%%PKGNAME%% has been installed into:
+
+ %%WWWDIR%%
+
+Please edit config.inc.php to suit your needs.
+
+To make phpMyAdmin available through your web site, I suggest
+that you add something like the following to httpd.conf:
+
+ Alias /phpmyadmin/ "%%WWWDIR%%/"
+
+ <Directory "%%WWWDIR%%/">
+ Options none
+ AllowOverride Limit
+
+ Order Deny,Allow
+ Deny from all
+ Allow from 127.0.0.1 .example.com
+ </Directory>
+
+SECURITY NOTE: phpMyAdmin is an administrative tool that has had several
+remote vulnerabilities discovered in the past, some allowing remote
+attackers to execute arbitrary code with the web server's user credential.
+All known problems have been fixed, but the FreeBSD Security Team strongly
+advises that any instance be protected with an additional protection layer,
+e.g. a different access control mechanism implemented by the web server
+as shown in the example. Do consider enabling phpMyAdmin only when it
+is in use.
diff --git a/databases/phpmyadmin35/pkg-descr b/databases/phpmyadmin35/pkg-descr
new file mode 100644
index 000000000000..d5d513f6d406
--- /dev/null
+++ b/databases/phpmyadmin35/pkg-descr
@@ -0,0 +1,31 @@
+
+ phpMyAdmin handles the administration of MySQL over the Web. It can:
+ * browse and drop databases, tables, views, fields and indexes
+ * create, copy, drop, rename and alter databases, tables, fields
+ and indexes
+ * maintain server, databases and tables, with proposals on server
+ configuration
+ * execute, edit and bookmark any SQL-statement, even batch-queries
+ * load text files into tables
+ * create and read dumps of tables
+ * export data to various formats: CSV, XML, PDF, ISO/IEC 26300 -
+ OpenDocument Text and Spreadsheet, Word, Excel and LATEX formats
+ * import data and MySQL structures from Microsoft Excel and
+ OpenDocument spreadsheets, as well as XML, CSV, and SQL files
+ * administer multiple servers
+ * manage MySQL users and privileges
+ * check referential integrity in MyISAM tables
+ * using Query-by-example (QBE), create complex queries
+ automatically connecting required tables
+ * create PDF graphics of your Database layout
+ * search globally in a database or a subset of it
+ * transform stored data into any format using a set of predefined
+ functions, like displaying BLOB-data as image or download-link
+ * track changes on databases, tables and views
+ * support InnoDB tables and foreign keys
+ * support mysqli, the improved MySQL extension
+ * communicate in 57 different languages
+ * synchronize two databases residing on the same as well as remote
+ servers
+
+WWW: http://www.phpmyadmin.net/
diff --git a/databases/phpmyadmin35/pkg-plist-chunk b/databases/phpmyadmin35/pkg-plist-chunk
new file mode 100644
index 000000000000..3c6168e40dd6
--- /dev/null
+++ b/databases/phpmyadmin35/pkg-plist-chunk
@@ -0,0 +1,7 @@
+@mode 640
+@group %%PMA_GRP%%
+@unexec if cmp -s %D/%%WWWDIR%%/config.inc.php.sample %D/%%WWWDIR%%/config.inc.php ; then rm -f %D/%%WWWDIR%%/config.inc.php ; fi
+%%WWWDIR%%/config.inc.php.sample
+@exec [ ! -f %B/config.inc.php ] && cp -p %B/%f %B/config.inc.php || true
+@mode
+@group