aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-12-01 07:39:02 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-12-01 07:39:02 +0000
commitd750615763ee2d3250de2115295079f66d813d1f (patch)
tree05b94e79be3ac272b9b617e50fc723ea52c6cf34 /databases
parent767bcfc72cf9c3574739d745cff6620fa75b0e74 (diff)
- Use features of bsd.wx.mk, especially USE_WX
PR: ports/101613 Submitted by: alepulver
Notes
Notes: svn path=/head/; revision=178433
Diffstat (limited to 'databases')
-rw-r--r--databases/pgadmin3-12/Makefile22
-rw-r--r--databases/pgadmin3/Makefile10
-rw-r--r--databases/pydbdesigner/Makefile4
3 files changed, 9 insertions, 27 deletions
diff --git a/databases/pgadmin3-12/Makefile b/databases/pgadmin3-12/Makefile
index 0b531fc08f81..e71b07a20be0 100644
--- a/databases/pgadmin3-12/Makefile
+++ b/databases/pgadmin3-12/Makefile
@@ -16,8 +16,10 @@ MAINTAINER= fjoe@FreeBSD.org
COMMENT= PostgreSQL database design and management system
USE_PGSQL= yes
+USE_WX= 2.6
+WX_COMPS= contrib
+WX_CONF_ARGS= relative
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-wx=${X11BASE} --with-wx-config=${WX_CONFIG}
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS}" LIBS="${PTHREAD_LIBS}"
CONFLICTS= pgadmin3-1.[456789]*
@@ -25,26 +27,12 @@ NO_LATEST_LINK= yes
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-WITHOUT_UNICODE= yes
-.endif
-
-pre-everything::
-.if !defined(WITHOUT_UNICODE)
- @${ECHO_MSG} "You can build non-Unicode version by defining WITHOUT_UNICODE."
-.endif
-
-.if !defined(WITHOUT_UNICODE)
-LIB_DEPENDS+= wx_gtk2u_stc-2.6.0:${PORTSDIR}/x11-toolkits/wxgtk26-unicode-contrib
-WX_CONFIG= wxgtk2u-2.6-config
+.if defined(WX_UNICODE)
PKGNAMESUFFIX= -unicode
PKGMESSAGE= ${PKGDIR}/pkg-message-unicode
post-install:
@${CAT} ${PKGMESSAGE}
-.else
-LIB_DEPENDS+= wx_gtk2_stc-2.6.0:${PORTSDIR}/x11-toolkits/wxgtk26-contrib
-WX_CONFIG= wxgtk2-2.6-config
-.endif # WITHOUT_UNICODE
+.endif
.include <bsd.port.post.mk>
diff --git a/databases/pgadmin3/Makefile b/databases/pgadmin3/Makefile
index e8d6603b5406..b344caed0bc7 100644
--- a/databases/pgadmin3/Makefile
+++ b/databases/pgadmin3/Makefile
@@ -24,16 +24,10 @@ CONFLICTS= pgadmin3-1.[12]*
USE_WX= 2.6
WX_COMPS= wx contrib
-WX_UNICODE= yes
WX_CONF_ARGS= relative
+WX_UNICODE= yes
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-IGNORE= cannot install: requires wchar_t
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/databases/pydbdesigner/Makefile b/databases/pydbdesigner/Makefile
index 6a1ccfd9938a..8a40be5f6f66 100644
--- a/databases/pydbdesigner/Makefile
+++ b/databases/pydbdesigner/Makefile
@@ -14,11 +14,11 @@ MASTER_SITE_SUBDIR=${PORTNAME}
MAINTAINER= xride@FreeBSD.org
COMMENT= Graphical designer for relational databases
-RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/wxPython/__init__.py:${PORTSDIR}/x11-toolkits/py-wxPython24
-
EXTRACT_AFTER_ARGS= | ${TAR} --exclude CVS -xf -
USE_PYTHON= 2.2+
+USE_WX= 2.4
+WX_COMPS= python
REINPLACE_ARGS= -i ""
WRKSRC= ${WRKDIR}/PyDBDesigner