aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2015-08-20 23:02:14 +0000
committerGabor Pali <pgj@FreeBSD.org>2015-08-20 23:02:14 +0000
commit39b8e49140afdb1d1d001c477befb4b05efa7fc3 (patch)
tree607a5ca77efd301a2b4dc49b05d108829fcffa77 /databases
parent75b64b1cb42c127b71646f039269eb7bd560d8ef (diff)
Notes
Diffstat (limited to 'databases')
-rw-r--r--databases/hs-esqueleto/Makefile7
-rw-r--r--databases/hs-esqueleto/distinfo4
-rw-r--r--databases/hs-esqueleto/pkg-descr7
-rw-r--r--databases/hs-hedis/Makefile8
-rw-r--r--databases/hs-hedis/distinfo4
-rw-r--r--databases/hs-mysql/Makefile3
-rw-r--r--databases/hs-mysql/distinfo4
-rw-r--r--databases/hs-mysql/pkg-descr4
-rw-r--r--databases/hs-persistent-sqlite/Makefile8
-rw-r--r--databases/hs-persistent-sqlite/distinfo4
-rw-r--r--databases/hs-persistent-template/Makefile7
-rw-r--r--databases/hs-persistent-template/distinfo4
-rw-r--r--databases/hs-persistent/Makefile10
-rw-r--r--databases/hs-persistent/distinfo4
14 files changed, 40 insertions, 38 deletions
diff --git a/databases/hs-esqueleto/Makefile b/databases/hs-esqueleto/Makefile
index edb2a6b10254..e2283ef17948 100644
--- a/databases/hs-esqueleto/Makefile
+++ b/databases/hs-esqueleto/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= esqueleto
-PORTVERSION= 1.4.4
-PORTREVISION= 1
+PORTVERSION= 2.4.1
CATEGORIES= databases haskell
MAINTAINER= haskell@FreeBSD.org
@@ -10,8 +9,8 @@ COMMENT= Type-safe EDSL for SQL queries on persistent backends
LICENSE= BSD3CLAUSE
-USE_CABAL= conduit>=1.1 monad-logger persistent>=1.3 resourcet \
- tagged>=0.2 text>=0.11 unordered-containers>=0.2
+USE_CABAL= blaze-html conduit>=1.1 monad-logger persistent>=2.1.1.7 \
+ resourcet>=1.1 tagged>=0.2 text>=0.11 unordered-containers>=0.2
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/databases/hs-esqueleto/distinfo b/databases/hs-esqueleto/distinfo
index d35301327ebf..ef71a71d1a91 100644
--- a/databases/hs-esqueleto/distinfo
+++ b/databases/hs-esqueleto/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cabal/esqueleto-1.4.4.tar.gz) = 401921e7d5d3c419f9dfbb408d6bbafeea08fb000d6137d0527add4291134503
-SIZE (cabal/esqueleto-1.4.4.tar.gz) = 29338
+SHA256 (cabal/esqueleto-2.4.1.tar.gz) = 12cc83bd2774906c29df20be8b77d11e0fc6efedadf208714494dc406cd8f7fd
+SIZE (cabal/esqueleto-2.4.1.tar.gz) = 39113
diff --git a/databases/hs-esqueleto/pkg-descr b/databases/hs-esqueleto/pkg-descr
index 09ad96fcf7eb..0db52257c36c 100644
--- a/databases/hs-esqueleto/pkg-descr
+++ b/databases/hs-esqueleto/pkg-descr
@@ -1,4 +1,9 @@
esqueleto is a bare bones, type-safe EDSL for SQL queries that works
-with unmodified persistent SQL backends.
+with unmodified persistent SQL backends. Its language closely resembles
+SQL, so you don't have to learn new concepts, just new syntax, and it's
+fairly easy to predict the generated SQL and optimize it for your
+backend. Most kinds of errors committed when writing SQL are caught as
+compile-time errors---although it is possible to write type-checked
+esqueleto queries that fail at runtime.
WWW: https://github.com/prowdsponsor/esqueleto
diff --git a/databases/hs-hedis/Makefile b/databases/hs-hedis/Makefile
index 6916deda2f11..cd043fd6242e 100644
--- a/databases/hs-hedis/Makefile
+++ b/databases/hs-hedis/Makefile
@@ -2,16 +2,16 @@
# $FreeBSD$
PORTNAME= hedis
-PORTVERSION= 0.6.5
+PORTVERSION= 0.6.9
CATEGORIES= databases haskell
MAINTAINER= haskell@FreeBSD.org
-COMMENT= Haskell API for Redis
+COMMENT= Client library for the Redis datastore
LICENSE= BSD3CLAUSE
-USE_CABAL= attoparsec>=0.10 BoundedChan>=1.0 bytestring-lexing>=0.4 \
- mtl>=2.0 network>=2.0 resource-pool>=0.2 vector>=0.9
+USE_CABAL= attoparsec>=0.12 BoundedChan>=1.0 bytestring-lexing>=0.5 \
+ mtl>=2 network>=2 resource-pool>=0.2 vector>=0.9
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/databases/hs-hedis/distinfo b/databases/hs-hedis/distinfo
index 24cfdf9b3253..07042c46f016 100644
--- a/databases/hs-hedis/distinfo
+++ b/databases/hs-hedis/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cabal/hedis-0.6.5.tar.gz) = 70fa3843b3d52203b831ec13bf7f29273ee6fd4695f8cbe55d41d7ee1389c8ce
-SIZE (cabal/hedis-0.6.5.tar.gz) = 27113
+SHA256 (cabal/hedis-0.6.9.tar.gz) = ead8c36dcb7093be9e414da900e2b6fa2f4bc8723a3a5346020d316c75e79179
+SIZE (cabal/hedis-0.6.9.tar.gz) = 27140
diff --git a/databases/hs-mysql/Makefile b/databases/hs-mysql/Makefile
index b1ba943230ce..f26a3249b529 100644
--- a/databases/hs-mysql/Makefile
+++ b/databases/hs-mysql/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= mysql
-PORTVERSION= 0.1.1.6
-PORTREVISION= 1
+PORTVERSION= 0.1.1.8
CATEGORIES= databases haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/databases/hs-mysql/distinfo b/databases/hs-mysql/distinfo
index eeb934f2d10f..7fdc00902e05 100644
--- a/databases/hs-mysql/distinfo
+++ b/databases/hs-mysql/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cabal/mysql-0.1.1.6.tar.gz) = b2d6c47e3176ddb4e192133c5e2ecff7c4831cef44ce1a6dc0b06b4f5ce9bfeb
-SIZE (cabal/mysql-0.1.1.6.tar.gz) = 14071
+SHA256 (cabal/mysql-0.1.1.8.tar.gz) = 90f02af1c81e2189f65dcef0f78327eba4b0ef40bea5bde5cb74920727f9bd84
+SIZE (cabal/mysql-0.1.1.8.tar.gz) = 14092
diff --git a/databases/hs-mysql/pkg-descr b/databases/hs-mysql/pkg-descr
index fe3037d6855b..683488cf0fe9 100644
--- a/databases/hs-mysql/pkg-descr
+++ b/databases/hs-mysql/pkg-descr
@@ -1,4 +1,4 @@
-A low-level client library for the MySQL database, implemented as
-bindings to the C mysqlclient API.
+A low-level client library for the MySQL database, implemented as bindings to
+the C mysqlclient API.
WWW: https://github.com/bos/mysql
diff --git a/databases/hs-persistent-sqlite/Makefile b/databases/hs-persistent-sqlite/Makefile
index 722e6ec403b2..b13fb2fdcee8 100644
--- a/databases/hs-persistent-sqlite/Makefile
+++ b/databases/hs-persistent-sqlite/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= persistent-sqlite
-PORTVERSION= 1.3.0.5
-PORTREVISION= 1
+PORTVERSION= 2.2
CATEGORIES= databases haskell
MAINTAINER= haskell@FreeBSD.org
@@ -10,8 +9,9 @@ COMMENT= Backend for the persistent library using sqlite3
LICENSE= MIT
-USE_CABAL= aeson>=0.5 conduit>=0.5.3 monad-control>=0.2 \
- monad-logger>=0.2.4 persistent>=1.3 resourcet text>=0.7
+USE_CABAL= aeson>=0.6.2 conduit>=0.5.3 monad-control>=0.2 \
+ monad-logger>=0.2.4 persistent>=2.2 resourcet>=1.1 \
+ text>=0.7
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/databases/hs-persistent-sqlite/distinfo b/databases/hs-persistent-sqlite/distinfo
index cea8cc8b1791..362c952802bc 100644
--- a/databases/hs-persistent-sqlite/distinfo
+++ b/databases/hs-persistent-sqlite/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cabal/persistent-sqlite-1.3.0.5.tar.gz) = eb477f7f98d4af69aa5ef88750c0e62915378c554a480652b4b09e4f985f6715
-SIZE (cabal/persistent-sqlite-1.3.0.5.tar.gz) = 1353303
+SHA256 (cabal/persistent-sqlite-2.2.tar.gz) = f11005a23df9ad0740111e675aab42f40eda7e37f4996ebae15e1fe48692c794
+SIZE (cabal/persistent-sqlite-2.2.tar.gz) = 1460775
diff --git a/databases/hs-persistent-template/Makefile b/databases/hs-persistent-template/Makefile
index f43d846f1157..3bb0f65abebc 100644
--- a/databases/hs-persistent-template/Makefile
+++ b/databases/hs-persistent-template/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= persistent-template
-PORTVERSION= 1.3.1.4
-PORTREVISION= 1
+PORTVERSION= 2.1.3.4
CATEGORIES= databases haskell
MAINTAINER= haskell@FreeBSD.org
@@ -10,8 +9,8 @@ COMMENT= Type-safe, non-relational, multi-backend persistence
LICENSE= MIT
-USE_CABAL= aeson monad-control>=0.2 monad-logger persistent>=1.3 \
- text>=0.5 unordered-containers
+USE_CABAL= aeson>=0.7 monad-control>=0.2 monad-logger path-pieces \
+ persistent>=2.1.3 tagged text>=0.5 unordered-containers
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/databases/hs-persistent-template/distinfo b/databases/hs-persistent-template/distinfo
index 79fd83cdf79b..69211f2d05a3 100644
--- a/databases/hs-persistent-template/distinfo
+++ b/databases/hs-persistent-template/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cabal/persistent-template-1.3.1.4.tar.gz) = d3313840ef0258775b2ce0d37ba9be0948a11d97ef6f3ed3ce76f0b476d045fb
-SIZE (cabal/persistent-template-1.3.1.4.tar.gz) = 14384
+SHA256 (cabal/persistent-template-2.1.3.4.tar.gz) = 4f28c9ef478e3835de5bc0105907582b2e0229cecc84ffa895c67c1a59ae2172
+SIZE (cabal/persistent-template-2.1.3.4.tar.gz) = 19084
diff --git a/databases/hs-persistent/Makefile b/databases/hs-persistent/Makefile
index 8710af2892e4..0df540ba667b 100644
--- a/databases/hs-persistent/Makefile
+++ b/databases/hs-persistent/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= persistent
-PORTVERSION= 1.3.1.1
-PORTREVISION= 1
+PORTVERSION= 2.2
CATEGORIES= databases haskell
MAINTAINER= haskell@FreeBSD.org
@@ -11,9 +10,10 @@ COMMENT= Type-safe, multi-backend data serialization
LICENSE= MIT
USE_CABAL= aeson>=0.5 attoparsec base64-bytestring blaze-html>=0.5 \
- blaze-markup>=0.5.1 conduit>=1.0 exceptions lifted-base>=0.1 \
- monad-control>=0.3 monad-logger>=0.3 path-pieces>=0.1 \
- resource-pool resourcet>=0.4 scientific silently text>=0.8 \
+ blaze-markup>=0.5.1 conduit>=1.0 exceptions>=0.6 \
+ fast-logger>=2.1 lifted-base>=0.1 monad-control>=0.3 \
+ monad-logger>=0.3 mtl path-pieces>=0.1 resource-pool \
+ resourcet>=1.1 scientific silently tagged text>=0.8 \
transformers-base unordered-containers vector
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
diff --git a/databases/hs-persistent/distinfo b/databases/hs-persistent/distinfo
index efa853d3d514..d76c723c69a4 100644
--- a/databases/hs-persistent/distinfo
+++ b/databases/hs-persistent/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cabal/persistent-1.3.1.1.tar.gz) = 7db789abfdd485f6f8a5f27613115f53f0d9702b87e1d200d91fa27a22ab4159
-SIZE (cabal/persistent-1.3.1.1.tar.gz) = 37042
+SHA256 (cabal/persistent-2.2.tar.gz) = 174047d7f140571081459713fbdeeabbd4a52bbc02dbf35969a0daec491a8512
+SIZE (cabal/persistent-2.2.tar.gz) = 43419