aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-10 13:54:26 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-10 13:54:26 +0000
commit5005b67362a735dc18d3d85170eae34e1fb6feab (patch)
tree3a1e73b4128190b7ed7020b2113a1d94d76b0e93 /databases
parente4eefd3f1e344c567f932fef63a6f04a0bb4eba4 (diff)
Notes
Diffstat (limited to 'databases')
-rw-r--r--databases/db41/Makefile2
-rw-r--r--databases/gqlplus/Makefile3
-rw-r--r--databases/hsqldb/Makefile3
-rw-r--r--databases/mysql-connector-java/Makefile2
-rw-r--r--databases/postgresql-jdbc/Makefile2
-rw-r--r--databases/postgresql-odbc/Makefile3
-rw-r--r--databases/pure-sql3/Makefile2
-rw-r--r--databases/tablelog/Makefile2
8 files changed, 19 insertions, 0 deletions
diff --git a/databases/db41/Makefile b/databases/db41/Makefile
index 5edb9820b3ab..712118736681 100644
--- a/databases/db41/Makefile
+++ b/databases/db41/Makefile
@@ -31,6 +31,8 @@ CONFIGURE_ARGS= --enable-compat185 --enable-dump185 \
--includedir=${STAGEDIR}${PREFIX}/include/db41
USE_LDCONFIG= yes
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MDOCS}
diff --git a/databases/gqlplus/Makefile b/databases/gqlplus/Makefile
index 11476b6b340c..0ce722cbc387 100644
--- a/databases/gqlplus/Makefile
+++ b/databases/gqlplus/Makefile
@@ -18,6 +18,9 @@ USE_AUTOTOOLS= autoconf automake aclocal
AUTOMAKE_ARGS= --add-missing
NO_STAGE= yes
+
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
do-install:
diff --git a/databases/hsqldb/Makefile b/databases/hsqldb/Makefile
index 707eedd501b1..5a546b9113a0 100644
--- a/databases/hsqldb/Makefile
+++ b/databases/hsqldb/Makefile
@@ -20,6 +20,9 @@ BUILD_WRKSRC= ${WRKSRC}/build
ALL_TARGET= hsqldb hsqljdbc
NO_STAGE= yes
+
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
do-install:
diff --git a/databases/mysql-connector-java/Makefile b/databases/mysql-connector-java/Makefile
index 30521514ce6e..77265cbaebd9 100644
--- a/databases/mysql-connector-java/Makefile
+++ b/databases/mysql-connector-java/Makefile
@@ -28,6 +28,8 @@ JDCLASSPATH= ${SRCDIR}:${CLASSPATH}
PLIST_FILES= %%JAVAJARDIR%%/${DESTJARFILE}
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MDOCS}
diff --git a/databases/postgresql-jdbc/Makefile b/databases/postgresql-jdbc/Makefile
index 09e334819b0e..28ecc642b93c 100644
--- a/databases/postgresql-jdbc/Makefile
+++ b/databases/postgresql-jdbc/Makefile
@@ -27,6 +27,8 @@ NO_STAGE= yes
post-patch:
${REINPLACE_CMD} 's,/usr/local/pgsql/share/java,${JAVAJARDIR},' ${WRKSRC}/README
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
do-install:
diff --git a/databases/postgresql-odbc/Makefile b/databases/postgresql-odbc/Makefile
index e8dcd15d946b..4696f0524d2a 100644
--- a/databases/postgresql-odbc/Makefile
+++ b/databases/postgresql-odbc/Makefile
@@ -37,6 +37,9 @@ PKGNAMESUFFIX= -iodbc
.endif
NO_STAGE= yes
+
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
DATADIR_1= ${DATADIR}/odbc
diff --git a/databases/pure-sql3/Makefile b/databases/pure-sql3/Makefile
index 0ab2d5e469be..ae45301ff451 100644
--- a/databases/pure-sql3/Makefile
+++ b/databases/pure-sql3/Makefile
@@ -26,6 +26,8 @@ PORTDOCS= README
PORTEXAMPLES= *
+OPTIONS_DEFINE= DOCS EXAMPLES
+
.include <bsd.port.options.mk>
post-install:
diff --git a/databases/tablelog/Makefile b/databases/tablelog/Makefile
index 7ac65a8ef927..0bb6b8079a20 100644
--- a/databases/tablelog/Makefile
+++ b/databases/tablelog/Makefile
@@ -16,6 +16,8 @@ USES= gmake
USE_PGSQL= yes
MAKE_ARGS= USE_PGXS=1
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
do-install: