aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2010-08-16 06:20:56 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2010-08-16 06:20:56 +0000
commit87453ddfb8b018b68036795bddbe161f8ff0bc1f (patch)
treeb985bedcdffc9acd2c119ce6c816a997caa551b4 /databases
parentb1e133d7e0735dd78fb8481a8d7000116c01daeb (diff)
Notes
Diffstat (limited to 'databases')
-rw-r--r--databases/fastdb/Makefile2
-rw-r--r--databases/fastdb/distinfo6
-rw-r--r--databases/fastdb/files/patch-inc-sync_unix.h11
-rw-r--r--databases/fastdb/files/patch-makefile25
-rw-r--r--databases/fastdb/pkg-plist1
5 files changed, 30 insertions, 15 deletions
diff --git a/databases/fastdb/Makefile b/databases/fastdb/Makefile
index fcb6b1cbbb10..b1e4e6a27931 100644
--- a/databases/fastdb/Makefile
+++ b/databases/fastdb/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= fastdb
-PORTVERSION= 3.53
+PORTVERSION= 3.63
CATEGORIES= databases
MASTER_SITES= SF
diff --git a/databases/fastdb/distinfo b/databases/fastdb/distinfo
index 3906847d92cd..45725ae7bf8e 100644
--- a/databases/fastdb/distinfo
+++ b/databases/fastdb/distinfo
@@ -1,3 +1,3 @@
-MD5 (fastdb-3.53.tar.gz) = 666839686bcd467df3376078af916901
-SHA256 (fastdb-3.53.tar.gz) = 62b6decc2bcf8b580b005c3c97d3cdfa939b75cd760fe26549a4697e0ca6f9f3
-SIZE (fastdb-3.53.tar.gz) = 1028375
+MD5 (fastdb-3.63.tar.gz) = a5dd1090c40a6ad9d48cf56994d69dad
+SHA256 (fastdb-3.63.tar.gz) = 68c944d2fbd3ed4c3ae693f8f886a21fdc3101188f0a3914d945e0da33d12458
+SIZE (fastdb-3.63.tar.gz) = 1913077
diff --git a/databases/fastdb/files/patch-inc-sync_unix.h b/databases/fastdb/files/patch-inc-sync_unix.h
new file mode 100644
index 000000000000..03960aba9b51
--- /dev/null
+++ b/databases/fastdb/files/patch-inc-sync_unix.h
@@ -0,0 +1,11 @@
+--- inc/sync_unix.h.orig 2009-11-20 20:53:02.000000000 +0800
++++ inc/sync_unix.h 2010-08-16 13:56:02.000000000 +0800
+@@ -160,7 +160,7 @@
+ }
+
+ static int getCurrentThreadId() {
+- return (int)pthread_self();
++ return reinterpret_cast<unsigned long>(pthread_self());
+ }
+
+ static int numberOfProcessors();
diff --git a/databases/fastdb/files/patch-makefile b/databases/fastdb/files/patch-makefile
index 6036089e0f94..4d48060557ff 100644
--- a/databases/fastdb/files/patch-makefile
+++ b/databases/fastdb/files/patch-makefile
@@ -1,6 +1,6 @@
---- makefile.orig 2009-03-01 20:30:50.000000000 +0800
-+++ makefile 2009-05-20 15:47:02.000000000 +0800
-@@ -37,8 +37,8 @@
+--- makefile.orig 2009-12-15 00:07:00.000000000 +0800
++++ makefile 2010-08-16 13:53:31.000000000 +0800
+@@ -38,8 +38,8 @@
THRLIBS=
SUFF=
else
@@ -11,7 +11,7 @@
SUFF=_r
endif
-@@ -67,21 +67,21 @@
+@@ -65,23 +65,23 @@
WEB_EXAMPLES = cgistub bugdb clidb
@@ -21,10 +21,12 @@
# DEFS macro is deprecatred, edit config.h file instead
DEFS = -Wno-invalid-offsetof
- #CFLAGS = $(TFLAGS) -Iinc -c -Wall -O5 -g -fPIC $(DEFS)
+ ifeq ($(DEBUG), 1)
-CFLAGS = -c -Iinc -Wall -O0 -g -fPIC $(DEFS) $(TFLAGS)
+CFLAGS = -c -Iinc ${CXXFLAGS} -fPIC $(DEFS) $(TFLAGS)
- #CFLAGS = -c -Iinc -Wall -O0 -fPIC -DFASTDB_DEBUG=DEBUG_TRACE -g $(DEFS) $(TFLAGS)
+ else
+ CFLAGS = -c -Iinc -Wall -O5 -g -fPIC $(DEFS) $(TFLAGS)
+ endif
-#SHFLAGS=-shared -Wl,-soname,$@
-SHFLAGS=-shared
@@ -38,16 +40,17 @@
AR = ar
ARFLAGS = -cru
-@@ -389,24 +389,20 @@
+@@ -433,16 +433,15 @@
- install: subsql cleanupsem installlib
+ install: subsql cleanupsem inspectsem installlib
mkdir -p $(BINSPATH)
- cp subsql $(BINSPATH)
- strip $(BINSPATH)/subsql
- cp cleanupsem $(BINSPATH)
-- strip $(BINSPATH)/cleanupsem
+- cp inspectsem $(BINSPATH)
+ ${BSD_INSTALL_PROGRAM} subsql $(BINSPATH)
+ ${BSD_INSTALL_PROGRAM} cleanupsem $(BINSPATH)
++ ${BSD_INSTALL_PROGRAM} inspectsem $(BINSPATH)
installlib: $(FASTDB_LIB) $(CLI_LIB) $(FASTDB_SHARED) $(CLI_SHARED)
mkdir -p $(INCSPATH)
@@ -58,8 +61,8 @@
+ ${BSD_INSTALL_PROGRAM} $(FASTDB_LIB) $(CLI_LIB) $(FASTDB_SHARED) $(CLI_SHARED) $(LIBSPATH)
(cd $(LIBSPATH) && ln -f -s $(FASTDB_SHARED) libfastdb$(SUFF).so \
&& ln -f -s $(CLI_SHARED) libcli$(SUFF).so)
-- if [ -f $(JNI_LIB) ]; then cp $(JNI_LIB) $(LIBSPATH); \
-- cd $(LIBSPATH) && ln -f -s $(JNI_LIB) libjnicli.so; fi
+ if [ -f $(JNI_LIB) ]; then cp $(JNI_LIB) $(LIBSPATH); \
+@@ -450,7 +449,7 @@
uninstall:
rm -fr $(INCSPATH)
diff --git a/databases/fastdb/pkg-plist b/databases/fastdb/pkg-plist
index 245e835a5f1d..27e0015eeec6 100644
--- a/databases/fastdb/pkg-plist
+++ b/databases/fastdb/pkg-plist
@@ -1,4 +1,5 @@
bin/cleanupsem
+bin/inspectsem
bin/subsql
include/fastdb/array.h
include/fastdb/class.h