aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2015-06-20 08:02:19 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2015-06-20 08:02:19 +0000
commitaa9341c1e3070094d9e2892020ebb6ac00f792cd (patch)
tree42093fb9cd41ccc5a05a192508f7531f7cb9e139 /databases
parent8678f6ce418c58bd3c2a0870e52935564c5d930b (diff)
downloadports-aa9341c1e3070094d9e2892020ebb6ac00f792cd.tar.gz
ports-aa9341c1e3070094d9e2892020ebb6ac00f792cd.zip
Notes
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/cassandra-cpp-driver/Makefile30
-rw-r--r--databases/cassandra-cpp-driver/distinfo2
-rw-r--r--databases/cassandra-cpp-driver/pkg-descr5
4 files changed, 38 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 3df86bfd8d24..b0ea345b55be 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -26,6 +26,7 @@
SUBDIR += buzhug
SUBDIR += c3p0
SUBDIR += cassandra
+ SUBDIR += cassandra-cpp-driver
SUBDIR += cassandra2
SUBDIR += cdb
SUBDIR += cego
diff --git a/databases/cassandra-cpp-driver/Makefile b/databases/cassandra-cpp-driver/Makefile
new file mode 100644
index 000000000000..e57194481926
--- /dev/null
+++ b/databases/cassandra-cpp-driver/Makefile
@@ -0,0 +1,30 @@
+# Created by: gahr
+# $FreeBSD$
+
+PORTNAME= cassandra-cpp-driver
+PORTVERSION= 1.0.2
+CATEGORIES= databases
+
+MAINTAINER= gahr@FreeBSD.org
+COMMENT= DataStax C/C++ Driver for Apache Cassandra
+
+LICENSE= APACHE20
+
+LIB_DEPENDS= libuv.so:${PORTSDIR}/devel/libuv
+
+USE_GITHUB= nodefault
+GH_ACCOUNT= datastax
+GH_PROJECT= cpp-driver
+
+USES= cmake:outsource
+CMAKE_ARGS= -DCMAKE_INSTALL_LIBDIR:STRING=lib
+
+USE_LDCONFIG= yes
+USE_OPENSSL= yes
+
+PLIST_FILES= include/cassandra.h \
+ lib/libcassandra.so \
+ lib/libcassandra.so.1 \
+ lib/libcassandra.so.1.0.2
+
+.include <bsd.port.mk>
diff --git a/databases/cassandra-cpp-driver/distinfo b/databases/cassandra-cpp-driver/distinfo
new file mode 100644
index 000000000000..9dd922b82297
--- /dev/null
+++ b/databases/cassandra-cpp-driver/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cassandra-cpp-driver-1.0.2_GH0.tar.gz) = 69a80dc857d3de975827c6c165e7844c8044e32de47cd702ffd97e7577de2672
+SIZE (cassandra-cpp-driver-1.0.2_GH0.tar.gz) = 1036892
diff --git a/databases/cassandra-cpp-driver/pkg-descr b/databases/cassandra-cpp-driver/pkg-descr
new file mode 100644
index 000000000000..8fba9a83b616
--- /dev/null
+++ b/databases/cassandra-cpp-driver/pkg-descr
@@ -0,0 +1,5 @@
+DataStax Cpp Driver is modern, feature-rich, and highly tunable C/C++ client
+library for Apache Cassandra (1.2+) and DataStax Enterprise (3.1+) using
+exclusively Cassandra's native protocol and Cassandra Query Language v3.
+
+WWW: http://datastax.github.io/cpp-driver/