aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2009-11-15 10:13:21 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2009-11-15 10:13:21 +0000
commitb95981a575454de82d4534803a5af361eed87482 (patch)
treeafaa24d7963ffcc2f11a3a570c1d18da00cd736b /databases
parentd794abd839a4075b26d499b54ca2b03c6234bafe (diff)
downloadports-b95981a575454de82d4534803a5af361eed87482.tar.gz
ports-b95981a575454de82d4534803a5af361eed87482.zip
Notes
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/ruby-dbd-sqlite3/Makefile25
-rw-r--r--databases/ruby-dbd-sqlite3/distinfo3
-rw-r--r--databases/ruby-dbd-sqlite3/pkg-descr4
-rw-r--r--databases/ruby-dbd-sqlite3/pkg-plist5
5 files changed, 38 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 09c7058d6052..18c8d0409609 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -609,6 +609,7 @@
SUBDIR += ruby-bdb
SUBDIR += ruby-bdb1
SUBDIR += ruby-cdb
+ SUBDIR += ruby-dbd-sqlite3
SUBDIR += ruby-dbd_mysql
SUBDIR += ruby-dbd_odbc
SUBDIR += ruby-dbd_pg
diff --git a/databases/ruby-dbd-sqlite3/Makefile b/databases/ruby-dbd-sqlite3/Makefile
new file mode 100644
index 000000000000..88141c24869e
--- /dev/null
+++ b/databases/ruby-dbd-sqlite3/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: dbd-sqlite3 for DBD-for-Ruby
+# Date created: 10 August 2009
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= dbd-sqlite3
+PORTVERSION= 1.2.5
+CATEGORIES= databases ruby
+MASTER_SITES= RF
+MASTER_SITE_SUBDIR= ruby-dbi
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DIST_SUBDIR= ruby
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= SQLite3 driver for DBI-for-Ruby
+
+LIB_DEPENDS= sqlite3:${PORTSDIR}/databases/sqlite3
+RUN_DEPENDS= ${RUBY_SITELIBDIR}/dbi.rb:${PORTSDIR}/databases/ruby-dbi
+
+USE_RUBY= yes
+USE_RUBY_SETUP= yes
+
+.include <bsd.port.mk>
diff --git a/databases/ruby-dbd-sqlite3/distinfo b/databases/ruby-dbd-sqlite3/distinfo
new file mode 100644
index 000000000000..96344841f988
--- /dev/null
+++ b/databases/ruby-dbd-sqlite3/distinfo
@@ -0,0 +1,3 @@
+MD5 (ruby/dbd-sqlite3-1.2.5.tar.gz) = 2af3766bd696ed0899acb768da1d12fe
+SHA256 (ruby/dbd-sqlite3-1.2.5.tar.gz) = b831e8ce20d8dd957e4e35a56f558259fbe2f0297920fc448caa6f29226f03f7
+SIZE (ruby/dbd-sqlite3-1.2.5.tar.gz) = 52156
diff --git a/databases/ruby-dbd-sqlite3/pkg-descr b/databases/ruby-dbd-sqlite3/pkg-descr
new file mode 100644
index 000000000000..ab49f8dbf234
--- /dev/null
+++ b/databases/ruby-dbd-sqlite3/pkg-descr
@@ -0,0 +1,4 @@
+This is the SQLite3 driver for DBI-for-Ruby.
+
+Author: Erik Hollensben
+WWW: http://ruby-dbi.sourceforge.net
diff --git a/databases/ruby-dbd-sqlite3/pkg-plist b/databases/ruby-dbd-sqlite3/pkg-plist
new file mode 100644
index 000000000000..311961ac2a75
--- /dev/null
+++ b/databases/ruby-dbd-sqlite3/pkg-plist
@@ -0,0 +1,5 @@
+%%RUBY_SITELIBDIR%%/dbd/SQLite3.rb
+%%RUBY_SITELIBDIR%%/dbd/sqlite3/database.rb
+%%RUBY_SITELIBDIR%%/dbd/sqlite3/statement.rb
+@dirrm %%RUBY_SITELIBDIR%%/dbd/sqlite3
+@dirrmtry %%RUBY_SITELIBDIR%%/dbd