aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorJimmy Olgeni <olgeni@FreeBSD.org>2009-08-09 20:30:24 +0000
committerJimmy Olgeni <olgeni@FreeBSD.org>2009-08-09 20:30:24 +0000
commitf7f69852d61e1bee30293d1fb64072c2ffa659b0 (patch)
tree3656aa814dffff39a104d82a3a21a7f28bd09c26 /databases
parent8c51e19b84b21bbe35d8da09dbc8e872bea59bac (diff)
downloadports-f7f69852d61e1bee30293d1fb64072c2ffa659b0.tar.gz
ports-f7f69852d61e1bee30293d1fb64072c2ffa659b0.zip
Notes
Diffstat (limited to 'databases')
-rw-r--r--databases/slony1v2/Makefile18
-rw-r--r--databases/slony1v2/distinfo12
-rw-r--r--databases/slony1v2/pkg-descr6
-rw-r--r--databases/slony1v2/pkg-plist23
4 files changed, 28 insertions, 31 deletions
diff --git a/databases/slony1v2/Makefile b/databases/slony1v2/Makefile
index 1f68cc41285c..0e3c1d770c26 100644
--- a/databases/slony1v2/Makefile
+++ b/databases/slony1v2/Makefile
@@ -5,12 +5,13 @@
# $FreeBSD$
#
-PORTNAME= slony1
-PORTVERSION= 1.2.16
+PORTNAME= slony1v2
+PORTVERSION= 2.0.2
CATEGORIES= databases
-MASTER_SITES= http://main.slony.info/downloads/1.2/source/
-DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX} \
- ${PORTNAME}-${PORTVERSION}-docs${EXTRACT_SUFX}
+MASTER_SITES= http://main.slony.info/downloads/2.0/source/
+DISTNAME= slony1-${PORTVERSION}
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
+ ${DISTNAME}-docs${EXTRACT_SUFX}
MAINTAINER= vivek@khera.org
COMMENT= PostgreSQL master to multiple replicas replication system
@@ -28,9 +29,11 @@ SUB_LIST+= NAME=slon
OPTIONS= PERLTOOLS "Install perl configuration tools" Off
+CONFLICTS?= slony1-*
+
.include <bsd.port.pre.mk>
-IGNORE_WITH_PGSQL= 84
+IGNORE_WITH_PGSQL= 73 74 80 81 82 84
.if defined(WITH_PERLTOOLS)
USE_PERL5= yes
@@ -53,7 +56,7 @@ CONFIGURE_ARGS+=--with-pgconfigdir=${LOCALBASE}/bin \
--with-pgpkglibdir=${LOCALBASE}/lib/postgresql \
--with-pgsharedir=${LOCALBASE}/share/postgresql
-DEFAULT_PGSQL_VER?=80
+DEFAULT_PGSQL_VER?=83
# Setting/finding PostgreSQL version we want.
.if exists(${LOCALBASE}/bin/postmaster)
@@ -76,7 +79,6 @@ post-install:
${MKDIR} ${DOCSDIR}/adminguide
${MKDIR} ${DOCSDIR}/howto
${INSTALL_DATA} ${WRKSRC}/COPYRIGHT ${WRKSRC}/INSTALL ${WRKSRC}/SAMPLE ${WRKSRC}/README ${WRKSRC}/HISTORY-1.1 ${WRKSRC}/UPGRADING ${DOCSDIR}
-# ${INSTALL_DATA} ${WRKSRC}/doc/*/*.pdf ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/doc/howto/*.txt ${WRKSRC}/doc/howto/*.html ${DOCSDIR}/howto/
${INSTALL_DATA} ${WRKSRC}/doc/adminguide/*.html ${WRKSRC}/doc/adminguide/*.png ${DOCSDIR}/adminguide/
.endif
diff --git a/databases/slony1v2/distinfo b/databases/slony1v2/distinfo
index 751f931d8b9b..3c935e2316c4 100644
--- a/databases/slony1v2/distinfo
+++ b/databases/slony1v2/distinfo
@@ -1,6 +1,6 @@
-MD5 (slony1-1.2.16.tar.bz2) = 1b112918a152ce3b6396de17c437fc7e
-SHA256 (slony1-1.2.16.tar.bz2) = 8b6278859a999f38b6ae38e7d991e8988e9dfb86ad15e159e7f1f20ab35380cb
-SIZE (slony1-1.2.16.tar.bz2) = 881560
-MD5 (slony1-1.2.16-docs.tar.bz2) = 47414e8d1b0ad97f023f794d9677d33a
-SHA256 (slony1-1.2.16-docs.tar.bz2) = be9bf2c529164e6f8c5ea68bb9bed9bcdf9ddb9b0023c0fbd6a8376c37b9f90d
-SIZE (slony1-1.2.16-docs.tar.bz2) = 231348
+MD5 (slony1-2.0.2.tar.bz2) = bad7d73ab83ee87244df24de70ac319e
+SHA256 (slony1-2.0.2.tar.bz2) = 937ff0aad51cb4c7ef57d92431654c2d35ab22e0ff0f038f0a38e9c8af3b723f
+SIZE (slony1-2.0.2.tar.bz2) = 933793
+MD5 (slony1-2.0.2-docs.tar.bz2) = 19a42d920a6abe855d0e254cb24410c4
+SHA256 (slony1-2.0.2-docs.tar.bz2) = fde0954f65e102697890ad70d79b0928a41ab89d610500d01e8fd4424edb3d1b
+SIZE (slony1-2.0.2-docs.tar.bz2) = 242622
diff --git a/databases/slony1v2/pkg-descr b/databases/slony1v2/pkg-descr
index 4d9368491802..2c8cebff0488 100644
--- a/databases/slony1v2/pkg-descr
+++ b/databases/slony1v2/pkg-descr
@@ -10,4 +10,10 @@ Slony-I is developed as a system for data centers and backup
sites, where the normal mode of operation is that all nodes
are available.
+Differences from 1.2 stream
+
+- Removal of TABLE ADD KEY
+
+- It drops all support for databases prior to Postgres version 8.3.
+
WWW: http://www.slony.info/
diff --git a/databases/slony1v2/pkg-plist b/databases/slony1v2/pkg-plist
index e052a5d92e3f..2f5ed56aae82 100644
--- a/databases/slony1v2/pkg-plist
+++ b/databases/slony1v2/pkg-plist
@@ -2,21 +2,12 @@ bin/slon
bin/slonik
bin/slony_logshipper
lib/postgresql/slony1_funcs.so
-lib/postgresql/xxid.so
etc/slon.conf-sample
sbin/slon-mkservice
share/postgresql/slony1_base.sql
-share/postgresql/slony1_base.v74.sql
-share/postgresql/slony1_base.v80.sql
-share/postgresql/slony1_base.v81.sql
+share/postgresql/slony1_base.v83.sql
share/postgresql/slony1_funcs.sql
-share/postgresql/slony1_funcs.v74.sql
-share/postgresql/slony1_funcs.v80.sql
-share/postgresql/slony1_funcs.v81.sql
-share/postgresql/xxid.v74.sql
-share/postgresql/xxid.v80.sql
-share/postgresql/xxid.v81.sql
-%%PERLTOOLS%%sbin/show_configuration
+share/postgresql/slony1_funcs.v83.sql
%%PERLTOOLS%%sbin/slon_kill
%%PERLTOOLS%%sbin/slon_start
%%PERLTOOLS%%sbin/slon_watchdog
@@ -55,6 +46,7 @@ share/postgresql/xxid.v81.sql
%%PORTDOCS%%%%DOCSDIR%%/adminguide/cmds.html
%%PORTDOCS%%%%DOCSDIR%%/adminguide/commandreference.html
%%PORTDOCS%%%%DOCSDIR%%/adminguide/complexenv.png
+%%PORTDOCS%%%%DOCSDIR%%/adminguide/complexfail.png
%%PORTDOCS%%%%DOCSDIR%%/adminguide/concepts.html
%%PORTDOCS%%%%DOCSDIR%%/adminguide/ddlchanges.html
%%PORTDOCS%%%%DOCSDIR%%/adminguide/definingsets.html
@@ -62,7 +54,6 @@ share/postgresql/xxid.v81.sql
%%PORTDOCS%%%%DOCSDIR%%/adminguide/failover.html
%%PORTDOCS%%%%DOCSDIR%%/adminguide/faq.html
%%PORTDOCS%%%%DOCSDIR%%/adminguide/firstdb.html
-%%PORTDOCS%%%%DOCSDIR%%/adminguide/function.add-empty-table-to-replication-integer-integer-text-text-text-text.html
%%PORTDOCS%%%%DOCSDIR%%/adminguide/function.add-missing-table-field-text-text-text-text.html
%%PORTDOCS%%%%DOCSDIR%%/adminguide/function.addpartiallogindices.html
%%PORTDOCS%%%%DOCSDIR%%/adminguide/function.altertableforreplication-integer.html
@@ -107,7 +98,7 @@ share/postgresql/xxid.v81.sql
%%PORTDOCS%%%%DOCSDIR%%/adminguide/function.enablesubscription-integer-integer-integer.html
%%PORTDOCS%%%%DOCSDIR%%/adminguide/function.failednode-integer-integer.html
%%PORTDOCS%%%%DOCSDIR%%/adminguide/function.failednode2-integer-integer-integer-bigint-bigint.html
-%%PORTDOCS%%%%DOCSDIR%%/adminguide/function.failoverset-int-integer-integer-integer-bigint.html
+%%PORTDOCS%%%%DOCSDIR%%/adminguide/function.failoverset-int-integer-integer-integer.html
%%PORTDOCS%%%%DOCSDIR%%/adminguide/function.forwardconfirm-integer-integer-bigint-timestamp-without-time-zone.html
%%PORTDOCS%%%%DOCSDIR%%/adminguide/function.generate-sync-event-interval.html
%%PORTDOCS%%%%DOCSDIR%%/adminguide/function.getlocalnodeid-name.html
@@ -123,7 +114,7 @@ share/postgresql/xxid.v81.sql
%%PORTDOCS%%%%DOCSDIR%%/adminguide/function.logtrigger.html
%%PORTDOCS%%%%DOCSDIR%%/adminguide/function.mergeset-int-integer-integer.html
%%PORTDOCS%%%%DOCSDIR%%/adminguide/function.mergeset-integer-integer.html
-%%PORTDOCS%%%%DOCSDIR%%/adminguide/function.moveset-int-integer-integer-integer-bigint.html
+%%PORTDOCS%%%%DOCSDIR%%/adminguide/function.moveset-int-integer-integer-integer.html
%%PORTDOCS%%%%DOCSDIR%%/adminguide/function.moveset-integer-integer.html
%%PORTDOCS%%%%DOCSDIR%%/adminguide/function.reachablefromnode-integer-integerarray.html
%%PORTDOCS%%%%DOCSDIR%%/adminguide/function.rebuildlistenentries.html
@@ -134,7 +125,6 @@ share/postgresql/xxid.v81.sql
%%PORTDOCS%%%%DOCSDIR%%/adminguide/function.registry-set-int4-text-integer.html
%%PORTDOCS%%%%DOCSDIR%%/adminguide/function.registry-set-text-text-text.html
%%PORTDOCS%%%%DOCSDIR%%/adminguide/function.registry-set-timestamp-text-timestamp-without-time-zone.html
-%%PORTDOCS%%%%DOCSDIR%%/adminguide/function.replicate-partition-integer-text-text-text-text.html
%%PORTDOCS%%%%DOCSDIR%%/adminguide/function.sequencelastvalue-text.html
%%PORTDOCS%%%%DOCSDIR%%/adminguide/function.sequencesetvalue-integer-integer-bigint-bigint.html
%%PORTDOCS%%%%DOCSDIR%%/adminguide/function.setaddsequence-int-integer-integer-text-text.html
@@ -181,7 +171,7 @@ share/postgresql/xxid.v81.sql
%%PORTDOCS%%%%DOCSDIR%%/adminguide/function.upgradeschema-text.html
%%PORTDOCS%%%%DOCSDIR%%/adminguide/hdrcmds.html
%%PORTDOCS%%%%DOCSDIR%%/adminguide/help.html
-%%PORTDOCS%%%%DOCSDIR%%/adminguide/i13365.html
+%%PORTDOCS%%%%DOCSDIR%%/adminguide/i13318.html
%%PORTDOCS%%%%DOCSDIR%%/adminguide/index.html
%%PORTDOCS%%%%DOCSDIR%%/adminguide/installation.html
%%PORTDOCS%%%%DOCSDIR%%/adminguide/listenpaths.html
@@ -253,7 +243,6 @@ share/postgresql/xxid.v81.sql
%%PORTDOCS%%%%DOCSDIR%%/adminguide/stmtwaitevent.html
%%PORTDOCS%%%%DOCSDIR%%/adminguide/subscribenodes.html
%%PORTDOCS%%%%DOCSDIR%%/adminguide/supportedplatforms.html
-%%PORTDOCS%%%%DOCSDIR%%/adminguide/table.sl-config-lock.html
%%PORTDOCS%%%%DOCSDIR%%/adminguide/table.sl-confirm.html
%%PORTDOCS%%%%DOCSDIR%%/adminguide/table.sl-event.html
%%PORTDOCS%%%%DOCSDIR%%/adminguide/table.sl-listen.html