aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2014-07-26 12:04:07 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2014-07-26 12:04:07 +0000
commit5151244eafbb2425911570673a76995eca6087b2 (patch)
tree83703cb6f2e7f16a605437474207f50d4b8881a5 /databases
parentb5ef18588edf0ee54b9d9ebc96adac1d1a8d96e0 (diff)
downloadports-5151244eafbb2425911570673a76995eca6087b2.tar.gz
ports-5151244eafbb2425911570673a76995eca6087b2.zip
Notes
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/py-mysql-connector-python/Makefile20
-rw-r--r--databases/py-mysql-connector-python/distinfo2
-rw-r--r--databases/py-mysql-connector-python/pkg-descr4
4 files changed, 27 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index be5f012416ec..af2e7be71c67 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -737,6 +737,7 @@
SUBDIR += py-leveldb
SUBDIR += py-memcached
SUBDIR += py-mssql
+ SUBDIR += py-mysql-connector-python
SUBDIR += py-mysql2pgsql
SUBDIR += py-odbc
SUBDIR += py-oops
diff --git a/databases/py-mysql-connector-python/Makefile b/databases/py-mysql-connector-python/Makefile
new file mode 100644
index 000000000000..2cc0d48a8a14
--- /dev/null
+++ b/databases/py-mysql-connector-python/Makefile
@@ -0,0 +1,20 @@
+# $FreeBSD$
+
+PORTNAME= mysql-connector-python
+PORTVERSION= 1.2.2
+CATEGORIES= databases python
+MASTER_SITES= ${MASTER_SITE_MYSQL}
+MASTER_SITE_SUBDIR= Connector-Python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= arcade@bit.name
+COMMENT= MySQL driver written in Python
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+PYDISTUTILS_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/databases/py-mysql-connector-python/distinfo b/databases/py-mysql-connector-python/distinfo
new file mode 100644
index 000000000000..e890b47df67a
--- /dev/null
+++ b/databases/py-mysql-connector-python/distinfo
@@ -0,0 +1,2 @@
+SHA256 (mysql-connector-python-1.2.2.tar.gz) = f2500d4b99a991a2ee060c3df40387a86f41e60f12b76032f066a723ed2d18a6
+SIZE (mysql-connector-python-1.2.2.tar.gz) = 281753
diff --git a/databases/py-mysql-connector-python/pkg-descr b/databases/py-mysql-connector-python/pkg-descr
new file mode 100644
index 000000000000..aef91a9527b0
--- /dev/null
+++ b/databases/py-mysql-connector-python/pkg-descr
@@ -0,0 +1,4 @@
+MySQL driver written in Python which does not depend on MySQL C client
+libraries and implements the DB API v2.0 specification (PEP-249).
+
+WWW: http://dev.mysql.com/doc/connector-python/en