aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2006-01-06 06:16:54 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2006-01-06 06:16:54 +0000
commit5aa1d63af549b070e6af3962308e81ecd809f7b7 (patch)
treea369f00ee77ce7a3e7866cdbccee9db8f5cdefda /databases
parentc9867be4d9871c93db35989c316fded61daf60d0 (diff)
downloadports-5aa1d63af549b070e6af3962308e81ecd809f7b7.tar.gz
ports-5aa1d63af549b070e6af3962308e81ecd809f7b7.zip
Notes
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/p5-DBIx-Abstract/Makefile24
-rw-r--r--databases/p5-DBIx-Abstract/distinfo3
-rw-r--r--databases/p5-DBIx-Abstract/pkg-descr22
-rw-r--r--databases/p5-DBIx-Abstract/pkg-plist8
5 files changed, 58 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 0f5af104c03f..d889cfdc5b14 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -197,6 +197,7 @@
SUBDIR += p5-DBI-137
SUBDIR += p5-DBI-Shell
SUBDIR += p5-DBIWrapper
+ SUBDIR += p5-DBIx-Abstract
SUBDIR += p5-DBIx-AnyDBD
SUBDIR += p5-DBIx-Browse
SUBDIR += p5-DBIx-Class
diff --git a/databases/p5-DBIx-Abstract/Makefile b/databases/p5-DBIx-Abstract/Makefile
new file mode 100644
index 000000000000..685369fd2e64
--- /dev/null
+++ b/databases/p5-DBIx-Abstract/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: p5-DBIx-Abstract
+# Date created: 6 Jan 2006
+# Whom: Jon Nistor <nistor@snickers.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= DBIx-Abstract
+PORTVERSION= 1.006
+CATEGORIES= databases perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= DBIx
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= nistor@snickers.org
+COMMENT= DBIx::Abstract - DBI SQL abstraction
+
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+
+PERL_CONFIGURE= yes
+
+MAN3= DBIx::Abstract.3
+
+.include <bsd.port.mk>
diff --git a/databases/p5-DBIx-Abstract/distinfo b/databases/p5-DBIx-Abstract/distinfo
new file mode 100644
index 000000000000..93950b367fda
--- /dev/null
+++ b/databases/p5-DBIx-Abstract/distinfo
@@ -0,0 +1,3 @@
+MD5 (DBIx-Abstract-1.006.tar.gz) = 230009d2613d3ad84a38c8589384003d
+SHA256 (DBIx-Abstract-1.006.tar.gz) = 112749cc5fdaa8163e1db38b29d15965553805b13aac442e95ccf7af08d1577a
+SIZE (DBIx-Abstract-1.006.tar.gz) = 20351
diff --git a/databases/p5-DBIx-Abstract/pkg-descr b/databases/p5-DBIx-Abstract/pkg-descr
new file mode 100644
index 000000000000..2c17391e6fda
--- /dev/null
+++ b/databases/p5-DBIx-Abstract/pkg-descr
@@ -0,0 +1,22 @@
+DBIx::Abstract - DBI SQL abstraction.
+
+This module provides methods for doing manipulating database tables
+This module provides methods retrieving and storing data in SQL
+databases. It provides methods for all of the more important SQL
+commands (like SELECT, INSERT, REPLACE, UPDATE, DELETE).
+
+It endeavors to produce an interface that will be intuitive to those
+already familiar with SQL.
+
+Notable features include:
+
+ * data_source generation for some DBD drivers.
+ * Can check to make sure the connection is not stale and reconnect
+ if it is.
+ * Controls statement handles for you.
+ * Can delay writes.
+ * Generates complex where clauses from hashes and arrays.
+ * Shortcuts (convenience functions) for some common cases. (Like
+ select_all_to_hashref.)
+
+WWW: http://search.cpan.org/dist/DBIx-Abstract/
diff --git a/databases/p5-DBIx-Abstract/pkg-plist b/databases/p5-DBIx-Abstract/pkg-plist
new file mode 100644
index 000000000000..8353efbfc648
--- /dev/null
+++ b/databases/p5-DBIx-Abstract/pkg-plist
@@ -0,0 +1,8 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/DBIx/Abstract.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/DBIx/Abstract/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/DBIx/Abstract
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/DBIx/Abstract 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/DBIx 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/DBIx/Abstract 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/DBIx 2>/dev/null || true