aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-12-24 23:38:54 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-12-24 23:38:54 +0000
commitfc48231e28a9f17ed8d6c9c12bc377411858e734 (patch)
tree9ad07fe6b05b7393b986d7ed828cef8340743b41 /databases
parent9dd642663884210ca5cce041ea859fc1d7784c59 (diff)
downloadports-fc48231e28a9f17ed8d6c9c12bc377411858e734.tar.gz
ports-fc48231e28a9f17ed8d6c9c12bc377411858e734.zip
Notes
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/autobackupmysql/Makefile34
-rw-r--r--databases/autobackupmysql/distinfo3
-rw-r--r--databases/autobackupmysql/files/patch-autobackupmysql.sh20
-rw-r--r--databases/autobackupmysql/pkg-descr11
5 files changed, 69 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 639844a1d768..093bb85540d0 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -14,6 +14,7 @@
SUBDIR += animenfo-client-gtk
SUBDIR += aolserver-nsmysql
SUBDIR += aolserver-nspostgres
+ SUBDIR += autobackupmysql
SUBDIR += bbdb
SUBDIR += buzhug
SUBDIR += cassandra
diff --git a/databases/autobackupmysql/Makefile b/databases/autobackupmysql/Makefile
new file mode 100644
index 000000000000..876ae1989956
--- /dev/null
+++ b/databases/autobackupmysql/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: autobackupmysql
+# Date created: 2009-12-21
+# Whom: Frank Wall <fw@moov.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= autobackupmysql
+PORTVERSION= 1.1
+CATEGORIES= databases
+MASTER_SITES= SF/${PORTNAME}
+DISTNAME= ${PORTNAME}
+EXTRACT_SUFX= .sh
+
+MAINTAINER= fw@moov.de
+COMMENT= Make daily, weekly and monthly backups of your MySQL databases
+
+RUN_DEPENDS= ${LOCALBASE}/bin/bash:${PORTSDIR}/shells/bash
+
+.if defined(WITH_OLDBASH)
+RUN_DEPENDS= ${LOCALBASE}/bin/bash:${PORTSDIR}/shells/bash3
+.endif
+
+NO_BUILD= yes
+PLIST_FILES= sbin/autobackupmysql.sh
+
+do-extract:
+ ${MKDIR} ${WRKSRC}
+ ${CP} ${DISTDIR}/${DISTFILES} ${WRKSRC}
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.sh ${PREFIX}/sbin
+
+.include <bsd.port.mk>
diff --git a/databases/autobackupmysql/distinfo b/databases/autobackupmysql/distinfo
new file mode 100644
index 000000000000..d449e4c185b7
--- /dev/null
+++ b/databases/autobackupmysql/distinfo
@@ -0,0 +1,3 @@
+MD5 (autobackupmysql.sh) = 290cc0c7c1bf28d97ad2f29245f5c57d
+SHA256 (autobackupmysql.sh) = 986b5dad34f47a04e1ddb3d03eab3a830e27f3bfb7245ec2154d168a25f375ce
+SIZE (autobackupmysql.sh) = 22011
diff --git a/databases/autobackupmysql/files/patch-autobackupmysql.sh b/databases/autobackupmysql/files/patch-autobackupmysql.sh
new file mode 100644
index 000000000000..e9b2ba369219
--- /dev/null
+++ b/databases/autobackupmysql/files/patch-autobackupmysql.sh
@@ -0,0 +1,20 @@
+--- autobackupmysql.sh.orig 2009-12-21 15:25:29.000000000 +0100
++++ autobackupmysql.sh 2009-12-21 16:07:01.000000000 +0100
+@@ -1,4 +1,4 @@
+-#!/bin/bash
++#!/usr/local/bin/bash
+ #
+ # Automatic MySQL Backup Script
+ # VER. 1.1 - http://sourceforge.net/projects/autobackupmysql/
+@@ -30,8 +30,8 @@
+ # Check configuration files
+ if [ -f "autobackupmysql.conf" ] ; then
+ source "autobackupmysql.conf"
+-elif [ - f "/etc/autobackupmysql.conf" ] ; then
+- source "/etc/autobackupmysql.conf"
++elif [ -f "/usr/local/etc/autobackupmysql.conf" ] ; then
++ source "/usr/local/etc/autobackupmysql.conf"
+ else
+ # Username to access the MySQL server e.g. dbuser
+ USERNAME='dbuser'
+
diff --git a/databases/autobackupmysql/pkg-descr b/databases/autobackupmysql/pkg-descr
new file mode 100644
index 000000000000..679c86e7b293
--- /dev/null
+++ b/databases/autobackupmysql/pkg-descr
@@ -0,0 +1,11 @@
+A script to take daily, weekly and monthly backups of your MySQL
+databases using mysqldump.
+
+Features:
+- Backup mutiple databases
+- Single backup file or to a seperate file for each DB
+- Compress backup files
+- Backup remote servers
+- E-mail logs
+
+WWW: https://sourceforge.net/projects/autobackupmysql