aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2019-04-01 19:10:15 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2019-04-01 19:10:15 +0000
commit84cc7e992404f83eeb3a8b8c207cb74b1dde86a2 (patch)
tree1c5a75f751cdbe48258b4167dcf1b3bcfd06c652 /databases
parentb7c871a2db25918c6d73cf73240a036139976328 (diff)
Notes
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile5
-rw-r--r--databases/gomdb/Makefile39
-rw-r--r--databases/gomdb/distinfo2
-rw-r--r--databases/gomdb/pkg-descr3
-rw-r--r--databases/gomdb/pkg-plist18
-rw-r--r--databases/gosqlite3/Makefile28
-rw-r--r--databases/gosqlite3/distinfo2
-rw-r--r--databases/gosqlite3/pkg-descr3
-rw-r--r--databases/gosqlite3/pkg-plist17
-rw-r--r--databases/levigo/Makefile42
-rw-r--r--databases/levigo/distinfo2
-rw-r--r--databases/levigo/pkg-descr5
-rw-r--r--databases/levigo/pkg-plist16
-rw-r--r--databases/radix.v2/Makefile21
-rw-r--r--databases/radix.v2/distinfo3
-rw-r--r--databases/radix.v2/pkg-descr4
-rw-r--r--databases/radix.v2/pkg-plist29
-rw-r--r--databases/redigo/Makefile24
-rw-r--r--databases/redigo/distinfo3
-rw-r--r--databases/redigo/pkg-descr4
-rw-r--r--databases/redigo/pkg-plist18
21 files changed, 0 insertions, 288 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 3d8dfc82474e..1584b0c4f871 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -100,8 +100,6 @@
SUBDIR += gnatsweb4
SUBDIR += go-carbon
SUBDIR += gom
- SUBDIR += gomdb
- SUBDIR += gosqlite3
SUBDIR += gqlplus
SUBDIR += grass7
SUBDIR += gtksql
@@ -142,7 +140,6 @@
SUBDIR += leo_center
SUBDIR += leofs
SUBDIR += leveldb
- SUBDIR += levigo
SUBDIR += libcouchbase
SUBDIR += libdbi
SUBDIR += libdbi-drivers
@@ -876,9 +873,7 @@
SUBDIR += qt5-sqldrivers-sqlite2
SUBDIR += qt5-sqldrivers-sqlite3
SUBDIR += qt5-sqldrivers-tds
- SUBDIR += radix.v2
SUBDIR += recutils
- SUBDIR += redigo
SUBDIR += redis
SUBDIR += redis-devel
SUBDIR += redis_exporter
diff --git a/databases/gomdb/Makefile b/databases/gomdb/Makefile
deleted file mode 100644
index 54da4b291e6d..000000000000
--- a/databases/gomdb/Makefile
+++ /dev/null
@@ -1,39 +0,0 @@
-# $FreeBSD$
-
-PORTNAME= gomdb
-PORTVERSION= 20140824
-PORTREVISION= 5
-CATEGORIES= databases
-
-MAINTAINER= cheffo@freebsd-bg.org
-COMMENT= Go wrapper for LMDB - OpenLDAP Lightning Memory-Mapped Database
-
-LICENSE= BSD3CLAUSE
-
-DEPRECATED= Go libraries should not be packaged
-EXPIRATION_DATE= 2019-03-31
-
-BUILD_DEPENDS= go:lang/go
-
-ONLY_FOR_ARCHS= i386 amd64
-
-USES= compiler go
-
-USE_GITHUB= yes
-GH_ACCOUNT= szferi
-GH_TAGNAME= 6bcb5a
-
-.include <bsd.port.pre.mk>
-
-#Build fails on FreeBSD10+ if value of "CC" is not set to "clang" (checked by configure)
-
-.if ${COMPILER_TYPE} == clang
-CC= clang
-.else
-USE_GCC= yes
-.endif
-
-CONFIGURE_ENV+= CC=${CC}
-GO_ENV+= ${CONFIGURE_ENV}
-
-.include <bsd.port.post.mk>
diff --git a/databases/gomdb/distinfo b/databases/gomdb/distinfo
deleted file mode 100644
index c9c66bd606c5..000000000000
--- a/databases/gomdb/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (szferi-gomdb-20140824-6bcb5a_GH0.tar.gz) = 61067d3131b988f00fb01373e90fd71c27a417ab4d664dc19b5500d3a4953877
-SIZE (szferi-gomdb-20140824-6bcb5a_GH0.tar.gz) = 103059
diff --git a/databases/gomdb/pkg-descr b/databases/gomdb/pkg-descr
deleted file mode 100644
index 4d018341835b..000000000000
--- a/databases/gomdb/pkg-descr
+++ /dev/null
@@ -1,3 +0,0 @@
-Go wrapper for OpenLDAP Lightning Memory-Mapped Database, LMDB.
-
-WWW: https://github.com/szferi/gomdb
diff --git a/databases/gomdb/pkg-plist b/databases/gomdb/pkg-plist
deleted file mode 100644
index 101894e5fbc3..000000000000
--- a/databases/gomdb/pkg-plist
+++ /dev/null
@@ -1,18 +0,0 @@
-%%GO_LIBDIR%%/%%GO_PKGNAME%%.a
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/LICENSE
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/README.md
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/bench_test.go
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/cursor.go
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/env.go
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/env_test.go
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/error_test.go
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/example_test.go
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/lmdb.h
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/mdb.c
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/mdb.go
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/mdb_test.go
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/midl.c
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/midl.h
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/txn.go
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/val.go
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/val_test.go
diff --git a/databases/gosqlite3/Makefile b/databases/gosqlite3/Makefile
deleted file mode 100644
index a0f92bbcd6d6..000000000000
--- a/databases/gosqlite3/Makefile
+++ /dev/null
@@ -1,28 +0,0 @@
-# Created by: Zhihao Yuan <lichray@gmail.com>
-# $FreeBSD$
-
-PORTNAME= gosqlite3
-PORTVERSION= 20120330
-PORTREVISION= 2
-CATEGORIES= databases
-MASTER_SITES= LOCAL/jlaffaye
-
-MAINTAINER= lichray@gmail.com
-COMMENT= Go interface for SQLite3
-
-DEPRECATED= Go libraries should not be packaged
-EXPIRATION_DATE= 2019-03-31
-
-USES= compiler go
-
-LIB_DEPENDS+= libsqlite3.so:databases/sqlite3
-
-GO_PKGNAME= github.com/kuroneko/${PORTNAME}
-
-.include <bsd.port.pre.mk>
-
-.if ${COMPILER_TYPE} == clang && ${CC} == cc
-CC= clang
-.endif
-
-.include <bsd.port.post.mk>
diff --git a/databases/gosqlite3/distinfo b/databases/gosqlite3/distinfo
deleted file mode 100644
index c31e95512f99..000000000000
--- a/databases/gosqlite3/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (gosqlite3-20120330.tar.gz) = bb64dacbc61d3ea686ff60d039e7a795a99547ae4c991d544e3e9ef7dd6d64a3
-SIZE (gosqlite3-20120330.tar.gz) = 11079
diff --git a/databases/gosqlite3/pkg-descr b/databases/gosqlite3/pkg-descr
deleted file mode 100644
index 5dc3e81315fd..000000000000
--- a/databases/gosqlite3/pkg-descr
+++ /dev/null
@@ -1,3 +0,0 @@
-A Go interface for SQLite3, modelled after the C interface.
-
-WWW: http://kuroneko.github.com/gosqlite3/
diff --git a/databases/gosqlite3/pkg-plist b/databases/gosqlite3/pkg-plist
deleted file mode 100644
index 1ba1c847eef0..000000000000
--- a/databases/gosqlite3/pkg-plist
+++ /dev/null
@@ -1,17 +0,0 @@
-%%GO_LIBDIR%%/%%GO_PKGNAME%%.a
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/README
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/backup.go
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/database.go
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/database_test.go
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/errors.go
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/helpers_test.go
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/progress.go
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/query_parameter.go
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/query_parameter_test.go
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/result_column.go
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/result_column_test.go
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/sql_test.go
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/sqlite3.go
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/sqlite3_test.go
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/statement.go
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/table.go
diff --git a/databases/levigo/Makefile b/databases/levigo/Makefile
deleted file mode 100644
index ab0e07130687..000000000000
--- a/databases/levigo/Makefile
+++ /dev/null
@@ -1,42 +0,0 @@
-# $FreeBSD$
-
-PORTNAME= levigo
-PORTVERSION= 20150216
-PORTREVISION= 5
-CATEGORIES= databases
-
-MAINTAINER= cheffo@freebsd-bg.org
-COMMENT= Levigo is a Go wrapper for LevelDB
-
-LICENSE= MIT
-
-DEPRECATED= Go libraries should not be packaged
-EXPIRATION_DATE= 2019-03-31
-
-BUILD_DEPENDS= go:lang/go
-LIB_DEPENDS= libleveldb.so:databases/leveldb
-
-ONLY_FOR_ARCHS= i386 amd64
-
-USES= compiler go
-
-USE_GITHUB= yes
-GH_ACCOUNT= jmhodges
-GH_TAGNAME= 1ddad808d4
-
-.include <bsd.port.pre.mk>
-
-# Build fails on FreeBSD10+ if value of "CC" is not set to "clang"
-# (checked by configure)
-
-.if ${COMPILER_TYPE} == clang
-CC= clang
-.else
-USE_GCC= yes
-.endif
-
-CONFIGURE_ENV+= CC=${CC} \
- CXX=${CXX}
-GO_ENV+= ${CONFIGURE_ENV}
-
-.include <bsd.port.post.mk>
diff --git a/databases/levigo/distinfo b/databases/levigo/distinfo
deleted file mode 100644
index 29e182804012..000000000000
--- a/databases/levigo/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (jmhodges-levigo-20150216-1ddad808d4_GH0.tar.gz) = 0f5df795cb4ce7ad692bd70296343fb5bbbe1e67ca32b0e235cf0b7a2bc32959
-SIZE (jmhodges-levigo-20150216-1ddad808d4_GH0.tar.gz) = 12837
diff --git a/databases/levigo/pkg-descr b/databases/levigo/pkg-descr
deleted file mode 100644
index ffb2822c262b..000000000000
--- a/databases/levigo/pkg-descr
+++ /dev/null
@@ -1,5 +0,0 @@
-levigo is a Go wrapper for LevelDB.
-The API has been godoc'ed and is available on the web.
-Questions answered at golang-nuts@googlegroups.com.
-
-WWW: https://github.com/jmhodges/levigo
diff --git a/databases/levigo/pkg-plist b/databases/levigo/pkg-plist
deleted file mode 100644
index 6859d9428c1a..000000000000
--- a/databases/levigo/pkg-plist
+++ /dev/null
@@ -1,16 +0,0 @@
-%%GO_LIBDIR%%/%%GO_PKGNAME%%.a
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/LICENSE
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/README.md
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/batch.go
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/cache.go
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/comparator.go
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/conv.go
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/db.go
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/doc.go
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/env.go
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/examples/comparator_example.go
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/filterpolicy.go
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/iterator.go
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/leveldb_test.go
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/options.go
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/version.go
diff --git a/databases/radix.v2/Makefile b/databases/radix.v2/Makefile
deleted file mode 100644
index bc039a2b0ee0..000000000000
--- a/databases/radix.v2/Makefile
+++ /dev/null
@@ -1,21 +0,0 @@
-# $FreeBSD$
-
-PORTNAME= radix.v2
-PORTVERSION= 20160530
-CATEGORIES= databases
-
-MAINTAINER= cs@FreeBSD.org
-COMMENT= Redis client for Go
-
-LICENSE= MIT
-
-DEPRECATED= Go libraries should not be packaged
-EXPIRATION_DATE= 2019-03-31
-
-USE_GITHUB= yes
-GH_ACCOUNT= mediocregopher
-GH_TAGNAME= ae04b3eb3731f94789205d1268e0759371166605
-USES= go
-GO_PKGNAME= github.com/mediocregopher/${PORTNAME}
-
-.include <bsd.port.mk>
diff --git a/databases/radix.v2/distinfo b/databases/radix.v2/distinfo
deleted file mode 100644
index eb9919246e50..000000000000
--- a/databases/radix.v2/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-TIMESTAMP = 1468183124
-SHA256 (mediocregopher-radix.v2-20160530-ae04b3eb3731f94789205d1268e0759371166605_GH0.tar.gz) = f58f68024ee684ad57570d37c6018e777088fccb68104a4fb67494389f350ae7
-SIZE (mediocregopher-radix.v2-20160530-ae04b3eb3731f94789205d1268e0759371166605_GH0.tar.gz) = 34225
diff --git a/databases/radix.v2/pkg-descr b/databases/radix.v2/pkg-descr
deleted file mode 100644
index 6a1788807932..000000000000
--- a/databases/radix.v2/pkg-descr
+++ /dev/null
@@ -1,4 +0,0 @@
-Radix is a minimalistic Redis client for Go. It is broken up into small,
-single-purpose packages for ease of use.
-
-WWW: http://godoc.org/github.com/mediocregopher/radix.v2
diff --git a/databases/radix.v2/pkg-plist b/databases/radix.v2/pkg-plist
deleted file mode 100644
index b681a887c693..000000000000
--- a/databases/radix.v2/pkg-plist
+++ /dev/null
@@ -1,29 +0,0 @@
-%%GO_LIBDIR%%/%%GO_PKGNAME%%.a
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/CONTRIBUTING.md
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/LICENSE.txt
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/Makefile
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/README.md
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/cluster/cluster.go
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/cluster/cluster_test.go
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/cluster/crc16.go
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/cluster/crc16_test.go
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/cluster/loadtest/README.md
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/cluster/loadtest/loadtest.go
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/pool/doc.go
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/pool/pool.go
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/pool/pool_test.go
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/pubsub/sub.go
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/pubsub/sub_test.go
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/radix.go
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/redis/client.go
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/redis/client_test.go
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/redis/doc.go
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/redis/resp.go
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/redis/resp_test.go
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/sentinel/sentinel.go
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/sentinel/sentinel_test.go
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/util/lua.go
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/util/lua_test.go
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/util/scan.go
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/util/scan_test.go
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/util/util.go
diff --git a/databases/redigo/Makefile b/databases/redigo/Makefile
deleted file mode 100644
index 2b2de4a9c2c5..000000000000
--- a/databases/redigo/Makefile
+++ /dev/null
@@ -1,24 +0,0 @@
-# Created by: Grzegorz Blach <gblach@FreeBSD.org>
-# $FreeBSD$
-
-PORTNAME= redigo
-PORTVERSION= 1.0.0
-DISTVERSIONPREFIX= v
-PORTEPOCH= 1
-CATEGORIES= databases
-
-MAINTAINER= cs@FreeBSD.org
-COMMENT= Go client for the Redis database
-
-LICENSE= APACHE20
-
-DEPRECATED= Go libraries should not be packaged
-EXPIRATION_DATE= 2019-03-31
-
-USE_GITHUB= yes
-GH_ACCOUNT= garyburd
-USES= go
-GO_PKGNAME= github.com/garyburd/${PORTNAME}
-GO_TARGET= ${GO_PKGNAME}/redis \
-
-.include <bsd.port.mk>
diff --git a/databases/redigo/distinfo b/databases/redigo/distinfo
deleted file mode 100644
index 0f8ff022cdf8..000000000000
--- a/databases/redigo/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-TIMESTAMP = 1468848985
-SHA256 (garyburd-redigo-v1.0.0_GH0.tar.gz) = 5c8dcdb2b160adb4265f70faa9630ba0239caada6221d3dfefc8b79417145e1f
-SIZE (garyburd-redigo-v1.0.0_GH0.tar.gz) = 34024
diff --git a/databases/redigo/pkg-descr b/databases/redigo/pkg-descr
deleted file mode 100644
index e4add0deb660..000000000000
--- a/databases/redigo/pkg-descr
+++ /dev/null
@@ -1,4 +0,0 @@
-Redigo is a Go client for the Redis database. It supports all Redis commands,
-pipelining, publish/subscribe and connection pooling.
-
-WWW: https://github.com/garyburd/redigo
diff --git a/databases/redigo/pkg-plist b/databases/redigo/pkg-plist
deleted file mode 100644
index b8e23df2edd3..000000000000
--- a/databases/redigo/pkg-plist
+++ /dev/null
@@ -1,18 +0,0 @@
-%%GO_LIBDIR%%/%%GO_PKGNAME%%/redis.a
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/redis/conn.go
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/redis/conn_test.go
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/redis/doc.go
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/redis/log.go
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/redis/pool.go
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/redis/pool_test.go
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/redis/pubsub.go
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/redis/pubsub_test.go
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/redis/redis.go
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/redis/reply.go
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/redis/reply_test.go
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/redis/scan.go
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/redis/scan_test.go
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/redis/script.go
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/redis/script_test.go
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/redis/test_test.go
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/redis/zpop_example_test.go