aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2013-09-16 17:03:42 +0000
committerAndrej Zverev <az@FreeBSD.org>2013-09-16 17:03:42 +0000
commita5341091eb73a3b0935daf8915c7f79139235548 (patch)
tree9b94453d2ae9c02c16c1562358f70fdbdeba9e53 /databases
parentf56f112403e0108e4a1caa3b8bd8197282cda9a6 (diff)
Notes
Diffstat (limited to 'databases')
-rw-r--r--databases/mysql56-server/Makefile3
-rw-r--r--databases/mysqltuner/Makefile3
-rw-r--r--databases/p5-DBZ_File/Makefile3
-rw-r--r--databases/rrdtool10/Makefile3
-rw-r--r--databases/slony1v2/Makefile5
-rw-r--r--databases/tarantool/Makefile4
6 files changed, 10 insertions, 11 deletions
diff --git a/databases/mysql56-server/Makefile b/databases/mysql56-server/Makefile
index 6ad38cdc2a1c..4dd1fd1ae590 100644
--- a/databases/mysql56-server/Makefile
+++ b/databases/mysql56-server/Makefile
@@ -42,7 +42,8 @@ CMAKE_ARGS+= -DINSTALL_DOCDIR="share/doc/mysql" \
USE_MYSQL= yes
WANT_MYSQL_VER= 56
-USE_PERL5_RUN= yes
+USES+= perl5
+USE_PERL5= run
LATEST_LINK= mysql56-server
diff --git a/databases/mysqltuner/Makefile b/databases/mysqltuner/Makefile
index 6457c5d49b1d..729e78f4e62f 100644
--- a/databases/mysqltuner/Makefile
+++ b/databases/mysqltuner/Makefile
@@ -17,7 +17,8 @@ COMMENT= A Script Assist You with MySQL Configuration
LICENSE= GPLv3
FETCH_ARGS= -pRr
-USE_PERL5= yes
+
+USES= perl5
NO_BUILD= yes
PLIST_FILES= bin/${PORTNAME}.pl
diff --git a/databases/p5-DBZ_File/Makefile b/databases/p5-DBZ_File/Makefile
index 817aa1daa113..a32418446ea7 100644
--- a/databases/p5-DBZ_File/Makefile
+++ b/databases/p5-DBZ_File/Makefile
@@ -15,7 +15,8 @@ DISTNAME= ${PORTNAME}_${PORTVERSION}
MAINTAINER= leeym@FreeBSD.org
COMMENT= Perl module to access a DBZ database
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
CONFIGURE_ARGS= DEFINE="-I${FILESDIR}" POLLUTE=1
WRKSRC= ${WRKDIR}/DBZ_File
diff --git a/databases/rrdtool10/Makefile b/databases/rrdtool10/Makefile
index bfc728d928ce..4012961ad3a6 100644
--- a/databases/rrdtool10/Makefile
+++ b/databases/rrdtool10/Makefile
@@ -10,13 +10,12 @@ MASTER_SITES= http://oss.oetiker.ch/rrdtool/pub/rrdtool-1.0.x/
MAINTAINER= lth@FreeBSD.org
COMMENT= Round Robin Database Tools
-USE_PERL5= yes
MAKE_ENV= PERL=${PERL}
CONFLICTS= rrdtool-1.2*
LATEST_LINK= rrdtool10
-USES= pkgconfig
+USES= pkgconfig perl5
USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
CONFIGURE_ARGS= --enable-shared --enable-local-zlib \
diff --git a/databases/slony1v2/Makefile b/databases/slony1v2/Makefile
index 7460b917bc14..fae3e915d54f 100644
--- a/databases/slony1v2/Makefile
+++ b/databases/slony1v2/Makefile
@@ -16,9 +16,8 @@ BUILD_DEPENDS= ${LOCALBASE}/bin/flex:${PORTSDIR}/textproc/flex \
${LOCALBASE}/bin/postmaster:${PORTSDIR}/databases/postgresql${PGSQL_VER}-server
GNU_CONFIGURE= yes
-USES= bison
+USES= bison gmake
USE_PGSQL= yes
-USE_GMAKE= yes
USE_BZIP2= yes
USE_RC_SUBR= slon
@@ -35,7 +34,7 @@ CONFIGURE_ENV+= FLEX=${LOCALBASE}/bin/flex
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MPERLTOOLS}
-USE_PERL5= yes
+USES+= perl5
CONFIGURE_ARGS+=--with-perltools=${LOCALBASE}/sbin
RUN_DEPENDS+= p5-DBD-Pg>=0:${PORTSDIR}/databases/p5-DBD-Pg
BUILD_DEPENDS+= p5-DBD-Pg>=0:${PORTSDIR}/databases/p5-DBD-Pg
diff --git a/databases/tarantool/Makefile b/databases/tarantool/Makefile
index a2dbcb35ab50..52d69bb0bfca 100644
--- a/databases/tarantool/Makefile
+++ b/databases/tarantool/Makefile
@@ -13,11 +13,9 @@ COMMENT= High performance key/value storage server
LICENSE= BSD
TR_REV= 45-g2f7b3f9
-USES= cmake gettext:build
+USES= cmake gettext:build gmake perl5
USE_GCC= yes
-USE_GMAKE= yes
USE_LDCONFIG= yes
-USE_PERL5= yes
USE_RC_SUBR= ${PORTNAME}
SUB_FILES= pkg-message
MAN1= tarantool_box.1