aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2014-10-07 16:01:41 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2014-10-07 16:01:41 +0000
commitaeabbc16ff4e8bd0b42f7ceb76029654da653021 (patch)
tree8de050626415b61ee62419965e840f7d34d5f4e1 /databases
parentd5a258e45386cc0bbf97e267f0d89b189f1e0d66 (diff)
Notes
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/speedtables/Makefile42
-rw-r--r--databases/speedtables/distinfo2
-rw-r--r--databases/speedtables/pkg-descr10
-rw-r--r--databases/speedtables/pkg-plist42
5 files changed, 97 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 2479da16a524..04ab67afbdba 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -888,6 +888,7 @@
SUBDIR += soci
SUBDIR += spatialite
SUBDIR += spatialite_gui
+ SUBDIR += speedtables
SUBDIR += sqlbuddy
SUBDIR += sqlcached
SUBDIR += sqlcipher
diff --git a/databases/speedtables/Makefile b/databases/speedtables/Makefile
new file mode 100644
index 000000000000..78de882cc919
--- /dev/null
+++ b/databases/speedtables/Makefile
@@ -0,0 +1,42 @@
+# Created by: gahr
+# $FreeBSD$
+
+PORTNAME= speedtables
+PORTVERSION= 1.8.3
+CATEGORIES= databases
+
+MAINTAINER= gahr@FreeBSD.org
+COMMENT= High-performance memory-resident database
+
+LICENSE= BSD3CLAUSE
+
+LIB_DEPENDS= libtclx8.4.so:${PORTSDIR}/lang/tclX
+
+OPTIONS_DEFINE= DOCS PGSQL
+PGSQL_CONFIGURE_ON= --with-pgsql=${LOCALBASE}
+PGSQL_LIB_DEPENDS= libpgtcl2.0.0.so:${PORTSDIR}/databases/postgresql94-pgtcl
+
+PORTDOCS= *
+
+USES= tcl
+
+USE_AUTOTOOLS= autoconf
+USE_GITHUB= yes
+GH_ACCOUNT= flightaware
+GH_TAGNAME= v${PORTVERSION}
+GH_COMMIT= 09c623c
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+=--exec-prefix=${PREFIX} \
+ --with-tcl=${TCL_LIBDIR}
+
+pre-configure:
+ @cd ${WRKSRC} && ${AUTORECONF}
+
+post-install:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC}/ctables/docs/manual && \
+ ${COPYTREE_SHARE} \*.html ${STAGEDIR}${DOCSDIR} && \
+ ${COPYTREE_SHARE} \*.css ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/databases/speedtables/distinfo b/databases/speedtables/distinfo
new file mode 100644
index 000000000000..5e8b37f7b9f1
--- /dev/null
+++ b/databases/speedtables/distinfo
@@ -0,0 +1,2 @@
+SHA256 (speedtables-1.8.3.tar.gz) = 4a15af503a051c12e8866ec66325aa636ae71c0c8ce744d543526cf3defd6c5a
+SIZE (speedtables-1.8.3.tar.gz) = 696032
diff --git a/databases/speedtables/pkg-descr b/databases/speedtables/pkg-descr
new file mode 100644
index 000000000000..19c57f051af7
--- /dev/null
+++ b/databases/speedtables/pkg-descr
@@ -0,0 +1,10 @@
+Speed tables is a high-performance memory-resident database, currently oriented
+towards Tcl. Speed tables provides an interface for defining tables containing
+zero or more rows, with each row containing one or more fields. The speed table
+compiler reads the table definition and generates C code to create and manage
+corresponding structures, generating a custom C language Tcl extension to
+create, access and manipulate those tables and building a native code package
+in a shared library that is loadable on demand via Tcl's "package require"
+mechanism.
+
+WWW: http://flightaware.github.io/speedtables/
diff --git a/databases/speedtables/pkg-plist b/databases/speedtables/pkg-plist
new file mode 100644
index 000000000000..5c59d43ec1a1
--- /dev/null
+++ b/databases/speedtables/pkg-plist
@@ -0,0 +1,42 @@
+bin/sttp
+lib/ctable/boyer_moore.c
+lib/ctable/command-body.c-subst
+lib/ctable/config.tcl
+lib/ctable/ctable.h
+lib/ctable/ctable_batch.c
+lib/ctable/ctable_io.c
+lib/ctable/ctable_lists.c
+lib/ctable/ctable_qsort.c
+lib/ctable/ctable_search.c
+lib/ctable/exten-frag.c-subst
+lib/ctable/gentable.tcl
+lib/ctable/init-exten.c-subst
+lib/ctable/jsw_rand.c
+lib/ctable/jsw_rand.h
+lib/ctable/jsw_slib.c
+lib/ctable/jsw_slib.h
+lib/ctable/pkgIndex.tcl
+lib/ctable/shared.c
+lib/ctable/shared.h
+lib/ctable/speedtableHash.c
+lib/ctable/speedtables.h
+lib/ctable/sysconfig.tcl
+lib/ctable/template.c-subst
+lib/ctable_server/ctable_client.tcl
+lib/ctable_server/ctable_client_server.tcl
+lib/ctable_server/ctable_server.tcl
+lib/ctable_server/pkgIndex.tcl
+lib/ctable_server/sttp_buffer.tcl
+lib/stapi/client/client.tcl
+lib/stapi/client/extend.tcl
+lib/stapi/client/pgsql.tcl
+lib/stapi/client/shared.tcl
+lib/stapi/copy.tcl
+lib/stapi/debug.tcl
+lib/stapi/display/display.tcl
+lib/stapi/display/test.tcl
+lib/stapi/pgsql.tcl
+lib/stapi/pkgIndex.tcl
+lib/stapi/server/lock.tcl
+lib/stapi/server/server.tcl
+lib/stapi/stapi.tcl