aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2018-09-10 13:14:50 +0000
committerMathieu Arnold <mat@FreeBSD.org>2018-09-10 13:14:50 +0000
commite1bfdfbe5665c963621e06f6bbfbbc2c000a804e (patch)
treeeaf052562fa1ad9b232918eb5e617ac1df0dd725 /databases
parentf57bc4af665126de839ff734a08e57726e84da84 (diff)
Notes
Diffstat (limited to 'databases')
-rw-r--r--databases/akonadi/Makefile2
-rw-r--r--databases/arangodb32/Makefile2
-rw-r--r--databases/arangodb33/Makefile2
-rw-r--r--databases/c3p0/Makefile2
-rw-r--r--databases/couchdb/Makefile2
-rw-r--r--databases/elixir-calecto/Makefile2
-rw-r--r--databases/elixir-db_connection/Makefile2
-rw-r--r--databases/elixir-ecto/Makefile2
-rw-r--r--databases/elixir-exredis/Makefile2
-rw-r--r--databases/elixir-geo/Makefile2
-rw-r--r--databases/elixir-mariaex/Makefile2
-rw-r--r--databases/elixir-mongo/Makefile2
-rw-r--r--databases/elixir-postgrex/Makefile2
-rw-r--r--databases/elixir-timex_ecto/Makefile2
-rw-r--r--databases/erlang-couchbeam/Makefile2
-rw-r--r--databases/erlang-epgsql/Makefile2
-rw-r--r--databases/erlang-eredis/Makefile2
-rw-r--r--databases/iowow/Makefile2
-rw-r--r--databases/libodbc++/Makefile3
-rw-r--r--databases/libpbl/Makefile2
-rw-r--r--databases/linux-c6-sqlite3/Makefile2
-rw-r--r--databases/linux-c7-sqlite3/Makefile2
-rw-r--r--databases/mariadb100-server/Makefile3
-rw-r--r--databases/mariadb101-server/Makefile4
-rw-r--r--databases/mariadb102-server/Makefile4
-rw-r--r--databases/mariadb103-server/Makefile4
-rw-r--r--databases/mdcached/Makefile2
-rw-r--r--databases/memcacheq/Makefile2
-rw-r--r--databases/monetdb/Makefile2
-rw-r--r--databases/mongodb32-tools/Makefile2
-rw-r--r--databases/mongodb34-tools/Makefile2
-rw-r--r--databases/mongodb36-tools/Makefile2
-rw-r--r--databases/ora2pg/Makefile2
-rw-r--r--databases/pg_partman/Makefile2
-rw-r--r--databases/pgespresso/Makefile2
-rw-r--r--databases/postgresql10-contrib/Makefile2
-rw-r--r--databases/postgresql10-server/Makefile6
-rw-r--r--databases/postgresql95-contrib/Makefile2
-rw-r--r--databases/postgresql96-contrib/Makefile2
-rw-r--r--databases/py-PyGreSQL/Makefile2
-rw-r--r--databases/py-bsddb3/Makefile2
-rw-r--r--databases/py-sqlobject/Makefile2
-rw-r--r--databases/qdbm/Makefile2
-rw-r--r--databases/sqlcached/Makefile2
44 files changed, 83 insertions, 17 deletions
diff --git a/databases/akonadi/Makefile b/databases/akonadi/Makefile
index 995d0bf18a6b..eff73aebe307 100644
--- a/databases/akonadi/Makefile
+++ b/databases/akonadi/Makefile
@@ -52,6 +52,8 @@ SQLITE_CMAKE_OFF= -DAKONADI_BUILD_QSQLITE:BOOL=OFF
OPTIONS_DEFAULT= MYSQL
+OPTIONS_DEFINE= DOCS
+
post-patch:
# To avoid overflow, MySQL settings need to be lower than
# INT_MAX / kern.hz. This setting assumes kern.hz=2000, and
diff --git a/databases/arangodb32/Makefile b/databases/arangodb32/Makefile
index 9ca727ac66d5..26121b1f640e 100644
--- a/databases/arangodb32/Makefile
+++ b/databases/arangodb32/Makefile
@@ -28,6 +28,8 @@ USERS= arangodb
GROUPS= arangodb
USE_RC_SUBR= arangod
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1200057
diff --git a/databases/arangodb33/Makefile b/databases/arangodb33/Makefile
index 8200672a93a3..c392c15afbfe 100644
--- a/databases/arangodb33/Makefile
+++ b/databases/arangodb33/Makefile
@@ -31,6 +31,8 @@ USERS= arangodb
GROUPS= arangodb
USE_RC_SUBR= arangod
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1200057
diff --git a/databases/c3p0/Makefile b/databases/c3p0/Makefile
index f00123912a03..b265518290cb 100644
--- a/databases/c3p0/Makefile
+++ b/databases/c3p0/Makefile
@@ -18,6 +18,8 @@ NO_BUILD= yes
JAVA_VERSION= 1.6+
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+OPTIONS_DEFINE= DOCS
+
do-install:
${INSTALL_DATA} ${WRKSRC}/lib/${PORTNAME}-${PORTVERSION}.jar ${STAGEDIR}${JAVAJARDIR}/${PORTNAME}.jar
@${MKDIR} ${STAGEDIR}${DOCSDIR}
diff --git a/databases/couchdb/Makefile b/databases/couchdb/Makefile
index bd5bad3789af..2994c79d2b67 100644
--- a/databases/couchdb/Makefile
+++ b/databases/couchdb/Makefile
@@ -46,6 +46,8 @@ STRIP= #empty
INFO= CouchDB
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
post-patch:
diff --git a/databases/elixir-calecto/Makefile b/databases/elixir-calecto/Makefile
index cce3ecfbf716..361a2fa5b1cd 100644
--- a/databases/elixir-calecto/Makefile
+++ b/databases/elixir-calecto/Makefile
@@ -19,4 +19,6 @@ MIX_BUILD_DEPS= databases/elixir-ecto \
devel/elixir-calendar
MIX_RUN_DEPS:= ${MIX_BUILD_DEPS}
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/databases/elixir-db_connection/Makefile b/databases/elixir-db_connection/Makefile
index cd87ec4e1c6f..804d89b7bf0c 100644
--- a/databases/elixir-db_connection/Makefile
+++ b/databases/elixir-db_connection/Makefile
@@ -21,4 +21,6 @@ MIX_BUILD_DEPS= devel/elixir-connection \
MIX_RUN_DEPS:= ${MIX_BUILD_DEPS}
MIX_REWRITE= yes
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/databases/elixir-ecto/Makefile b/databases/elixir-ecto/Makefile
index 69148c6cc30d..fe7f2cb36bc4 100644
--- a/databases/elixir-ecto/Makefile
+++ b/databases/elixir-ecto/Makefile
@@ -15,7 +15,7 @@ USES= elixir
USE_GITHUB= yes
GH_ACCOUNT= elixir-ecto
-OPTIONS_DEFINE= POSTGREX MARIAEX
+OPTIONS_DEFINE= POSTGREX MARIAEX DOCS
OPTIONS_SUB= yes
POSTGREX_DESC= PostgreSQL adapter support
MARIAEX_DESC= MySQL adapter support
diff --git a/databases/elixir-exredis/Makefile b/databases/elixir-exredis/Makefile
index 89a002498612..067797193c1e 100644
--- a/databases/elixir-exredis/Makefile
+++ b/databases/elixir-exredis/Makefile
@@ -17,4 +17,6 @@ GH_ACCOUNT= artemeff
MIX_BUILD_DEPS= databases/erlang-eredis
MIX_RUN_DEPS:= ${MIX_BUILD_DEPS}
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/databases/elixir-geo/Makefile b/databases/elixir-geo/Makefile
index f0e370bfa52c..a3122a547c05 100644
--- a/databases/elixir-geo/Makefile
+++ b/databases/elixir-geo/Makefile
@@ -23,4 +23,6 @@ MIX_BUILD_DEPS= databases/elixir-ecto \
MIX_RUN_DEPS:= ${MIX_BUILD_DEPS}
MIX_REWRITE= yes
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/databases/elixir-mariaex/Makefile b/databases/elixir-mariaex/Makefile
index 1aed8da440f2..be40a64a963f 100644
--- a/databases/elixir-mariaex/Makefile
+++ b/databases/elixir-mariaex/Makefile
@@ -21,4 +21,6 @@ MIX_BUILD_DEPS= devel/elixir-connection \
MIX_RUN_DEPS:= ${MIX_BUILD_DEPS}
MIX_REWRITE= yes
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/databases/elixir-mongo/Makefile b/databases/elixir-mongo/Makefile
index 05129c3f390b..ba422a3362f3 100644
--- a/databases/elixir-mongo/Makefile
+++ b/databases/elixir-mongo/Makefile
@@ -18,4 +18,6 @@ ELIXIR_APP_NAME=mongo
MIX_BUILD_DEPS= devel/elixir-bson
MIX_RUN_DEPS:= ${MIX_BUILD_DEPS}
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/databases/elixir-postgrex/Makefile b/databases/elixir-postgrex/Makefile
index 00e2d4ba0134..2029a1d27bdc 100644
--- a/databases/elixir-postgrex/Makefile
+++ b/databases/elixir-postgrex/Makefile
@@ -21,4 +21,6 @@ MIX_BUILD_DEPS= databases/elixir-db_connection \
MIX_RUN_DEPS:= ${MIX_BUILD_DEPS}
MIX_REWRITE= yes
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/databases/elixir-timex_ecto/Makefile b/databases/elixir-timex_ecto/Makefile
index fbfd82dcd82b..11716c9d3796 100644
--- a/databases/elixir-timex_ecto/Makefile
+++ b/databases/elixir-timex_ecto/Makefile
@@ -19,4 +19,6 @@ MIX_BUILD_DEPS= databases/elixir-ecto \
MIX_RUN_DEPS:= ${MIX_BUILD_DEPS}
MIX_REWRITE= yes
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/databases/erlang-couchbeam/Makefile b/databases/erlang-couchbeam/Makefile
index a9cb8d4b837a..75baf5e61ba6 100644
--- a/databases/erlang-couchbeam/Makefile
+++ b/databases/erlang-couchbeam/Makefile
@@ -18,4 +18,6 @@ ERL_BUILD_DEPS= devel/erlang-jsx \
www/erlang-hackney
ERL_RUN_DEPS:= ${ERL_BUILD_DEPS}
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/databases/erlang-epgsql/Makefile b/databases/erlang-epgsql/Makefile
index 41b1eff9844e..2690f88cbd6d 100644
--- a/databases/erlang-epgsql/Makefile
+++ b/databases/erlang-epgsql/Makefile
@@ -13,4 +13,6 @@ LICENSE= BSD3CLAUSE
USES= erlang:rebar3
USE_GITHUB= yes
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/databases/erlang-eredis/Makefile b/databases/erlang-eredis/Makefile
index 864452dfa3f2..559d489ff314 100644
--- a/databases/erlang-eredis/Makefile
+++ b/databases/erlang-eredis/Makefile
@@ -15,4 +15,6 @@ USES= erlang:rebar
USE_GITHUB= yes
GH_ACCOUNT= wooga
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/databases/iowow/Makefile b/databases/iowow/Makefile
index b393ab89a665..95ee65416ada 100644
--- a/databases/iowow/Makefile
+++ b/databases/iowow/Makefile
@@ -18,4 +18,6 @@ USE_LDCONFIG= yes
PORTDOCS= Changelog README
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/databases/libodbc++/Makefile b/databases/libodbc++/Makefile
index 53ce61f353e2..f6d520915c5b 100644
--- a/databases/libodbc++/Makefile
+++ b/databases/libodbc++/Makefile
@@ -11,8 +11,9 @@ COMMENT= C++ class library and toolset for ODBC access to data sources
LICENSE= GPLv2
-OPTIONS_DEFINE= DOXYGEN
+OPTIONS_DEFINE= DOXYGEN DOCS
+DOXYGEN_IMPLIES= DOCS
DOXYGEN_BUILD_DEPENDS= doxygen:devel/doxygen
USES= gmake libtool ncurses pathfix pkgconfig readline tar:bzip2
diff --git a/databases/libpbl/Makefile b/databases/libpbl/Makefile
index 78ea6a67c35a..6f02b67aad77 100644
--- a/databases/libpbl/Makefile
+++ b/databases/libpbl/Makefile
@@ -25,6 +25,8 @@ PLIST_FILES= include/pbl.h \
lib/libpbl.a
PORTDOCS= *
+OPTIONS_DEFINE= DOCS
+
post-extract:
@${REINPLACE_CMD} -e 's/= -Wall -O3/+= -Wall -Werror/' \
-e 's/^CC=/CC?=/' -e '/^.rm -f/d' ${WRKSRC}/makefile
diff --git a/databases/linux-c6-sqlite3/Makefile b/databases/linux-c6-sqlite3/Makefile
index c73037de36c2..03fb7c4cc3eb 100644
--- a/databases/linux-c6-sqlite3/Makefile
+++ b/databases/linux-c6-sqlite3/Makefile
@@ -15,4 +15,6 @@ USES= linux:c6
USE_LDCONFIG= yes
USE_LINUX_RPM= yes
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/databases/linux-c7-sqlite3/Makefile b/databases/linux-c7-sqlite3/Makefile
index 9920df343b9c..6193cb9328b3 100644
--- a/databases/linux-c7-sqlite3/Makefile
+++ b/databases/linux-c7-sqlite3/Makefile
@@ -19,4 +19,6 @@ USES= linux:c7
USE_LDCONFIG= yes
USE_LINUX_RPM= yes
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/databases/mariadb100-server/Makefile b/databases/mariadb100-server/Makefile
index a5cc3110d615..ff1d645693ff 100644
--- a/databases/mariadb100-server/Makefile
+++ b/databases/mariadb100-server/Makefile
@@ -73,7 +73,7 @@ CONFLICTS_INSTALL= mariadb5*-${PKGNAMESUFFIX:C/^[0-9]*-//}-* \
.if !defined(CLIENT_ONLY)
# MySQL-Server options
-OPTIONS_DEFINE+= CONNECT_EXTRA MAXKEY
+OPTIONS_DEFINE+= CONNECT_EXTRA MAXKEY DOCS
OPTIONS_DEFAULT+= MAXKEY
OPTIONS_GROUP= ENGINES
OPTIONS_GROUP_ENGINES= INNOBASE MROONGA OQGRAPH SPHINX SPIDER TOKUDB
@@ -123,6 +123,7 @@ OQGRAPH_LIB_DEPENDS= libboost_system.so:devel/boost-libs \
TOKUDB_LIB_DEPENDS= libsnappy.so:archivers/snappy
TOKUDB_PORTDOCS= PATENTS README.md
TOKUDB_VARS= LICENSE+=PerconaFT LICENSE_COMB=multi
+TOKUDB_IMPLIES= DOCS
post-install:
# Remove programs to avoid conflict with mariadb100-client
diff --git a/databases/mariadb101-server/Makefile b/databases/mariadb101-server/Makefile
index 5af3ce63b04b..00d0176e3271 100644
--- a/databases/mariadb101-server/Makefile
+++ b/databases/mariadb101-server/Makefile
@@ -44,7 +44,7 @@ FASTMTX_DESC= Replace mutexes with spinlocks
.if !defined(CLIENT_ONLY)
# MySQL-Server options
-OPTIONS_DEFINE+= CONNECT_EXTRA MAXKEY
+OPTIONS_DEFINE+= CONNECT_EXTRA MAXKEY DOCS
OPTIONS_DEFAULT+= MAXKEY SPHINX SPIDER
OPTIONS_GROUP= COMPRESSION ENGINES GROONGA
OPTIONS_GROUP_COMPRESSION= LZ4 LZO SNAPPY
@@ -149,7 +149,7 @@ OQGRAPH_LIB_DEPENDS= libboost_system.so:devel/boost-libs \
SNAPPY_CMAKE_OFF= -DWITH_INNODB_SNAPPY=OFF
SNAPPY_CMAKE_ON= -DWITH_INNODB_SNAPPY=${LOCALBASE}/lib
SNAPPY_LIB_DEPENDS= libsnappy.so:archivers/snappy
-TOKUDB_IMPLIES= SNAPPY
+TOKUDB_IMPLIES= SNAPPY DOCS
TOKUDB_PORTDOCS= README.md
TOKUDB_VARS= LICENSE+=PerconaFT LICENSE_COMB=multi
ZMQ_LIB_DEPENDS= libzmq.so:net/libzmq4
diff --git a/databases/mariadb102-server/Makefile b/databases/mariadb102-server/Makefile
index 22d12d7cadc5..c551e97e4536 100644
--- a/databases/mariadb102-server/Makefile
+++ b/databases/mariadb102-server/Makefile
@@ -39,7 +39,7 @@ OPTIONS_DEFAULT= GSSAPI_BASE
# MySQL-Server options
OPTIONS_DEFAULT+= CONNECT_EXTRA INNOBASE SPHINX SPIDER
OPTIONS_GROUP= COMPRESSION ENGINES GROONGA
-OPTIONS_DEFINE= CONNECT_EXTRA
+OPTIONS_DEFINE= CONNECT_EXTRA DOCS
OPTIONS_GROUP_COMPRESSION= LZ4 LZO SNAPPY ZSTD
OPTIONS_GROUP_ENGINES= INNOBASE MROONGA OQGRAPH ROCKSDB SPHINX SPIDER TOKUDB XTRADB
OPTIONS_GROUP_GROONGA= ZMQ MSGPACK
@@ -156,7 +156,7 @@ ROCKSDB_USES= python
SNAPPY_CMAKE_OFF= -DWITH_INNODB_SNAPPY=OFF -DWITH_ROCKSDB_snappy=OFF
SNAPPY_CMAKE_ON= -DWITH_INNODB_SNAPPY=ON -DWITH_ROCKSDB_snappy=ON
SNAPPY_LIB_DEPENDS= libsnappy.so:archivers/snappy
-TOKUDB_IMPLIES= SNAPPY
+TOKUDB_IMPLIES= SNAPPY DOCS
TOKUDB_PORTDOCS= README.md
TOKUDB_VARS= LICENSE+=PerconaFT LICENSE_COMB=multi
ZMQ_LIB_DEPENDS= libzmq.so:net/libzmq4
diff --git a/databases/mariadb103-server/Makefile b/databases/mariadb103-server/Makefile
index e9e9fdbd56ff..37fc6d3dfdaa 100644
--- a/databases/mariadb103-server/Makefile
+++ b/databases/mariadb103-server/Makefile
@@ -41,7 +41,7 @@ OPTIONS_DEFAULT= GSSAPI_BASE
# MySQL-Server options
OPTIONS_DEFAULT+= CONNECT_EXTRA INNOBASE SPHINX SPIDER WSREP
OPTIONS_GROUP= COMPRESSION ENGINES GROONGA
-OPTIONS_DEFINE= CONNECT_EXTRA WSREP
+OPTIONS_DEFINE= CONNECT_EXTRA WSREP DOCS
OPTIONS_GROUP_COMPRESSION= LZ4 LZO SNAPPY ZSTD
OPTIONS_GROUP_ENGINES= INNOBASE MROONGA OQGRAPH ROCKSDB SPHINX SPIDER TOKUDB XTRADB
OPTIONS_GROUP_GROONGA= ZMQ MSGPACK
@@ -158,7 +158,7 @@ ROCKSDB_USES= python
SNAPPY_CMAKE_OFF= -DWITH_INNODB_SNAPPY=OFF -DWITH_ROCKSDB_snappy=OFF
SNAPPY_CMAKE_ON= -DWITH_INNODB_SNAPPY=ON -DWITH_ROCKSDB_snappy=ON
SNAPPY_LIB_DEPENDS= libsnappy.so:archivers/snappy
-TOKUDB_IMPLIES= SNAPPY
+TOKUDB_IMPLIES= SNAPPY DOCS
TOKUDB_PORTDOCS= README.md
TOKUDB_VARS= LICENSE+=PerconaFT LICENSE_COMB=multi
WSREP_CMAKE_OFF= -DWITH_WSREP=OFF
diff --git a/databases/mdcached/Makefile b/databases/mdcached/Makefile
index 9fbefc9327f2..af1e76b5ea73 100644
--- a/databases/mdcached/Makefile
+++ b/databases/mdcached/Makefile
@@ -18,6 +18,8 @@ USE_LDCONFIG= yes
PORTDOCS= UserGuide.txt mdcached.txt
+OPTIONS_DEFINE= DOCS
+
post-patch:
@${REINPLACE_CMD} 's|ADDCFLAGS = -Wall -g -O3 -march=native|ADDCFLAGS = ${CFLAGS}|' \
${WRKSRC}/Makefile
diff --git a/databases/memcacheq/Makefile b/databases/memcacheq/Makefile
index 0829e2225ac7..38ceee27da1a 100644
--- a/databases/memcacheq/Makefile
+++ b/databases/memcacheq/Makefile
@@ -28,6 +28,8 @@ PORTDOCS= README
MCQDIR?= /var/db/memcacheq
PLIST_SUB= MCQDIR=${MCQDIR}
+OPTIONS_DEFINE= DOCS
+
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
diff --git a/databases/monetdb/Makefile b/databases/monetdb/Makefile
index e2494f94db86..0df58e8152bd 100644
--- a/databases/monetdb/Makefile
+++ b/databases/monetdb/Makefile
@@ -35,7 +35,7 @@ CFLAGS+= -I${PREFIX}/include
INSTALL_TARGET= install-strip
OPTIONS_DEFINE= CONSOLE CURL DATACELL FITS GEOM JDBC MEROCONTROL ODBC \
- PERL RDF RUBYGEMS SPHINXCLIENT TESTING OPTIMIZE
+ PERL RDF RUBYGEMS SPHINXCLIENT TESTING OPTIMIZE DOCS
OPTIONS_RADIO= PYTHON
OPTIONS_RADIO_PYTHON= PYTHON2 PYTHON3
OPTIONS_SINGLE= PASSWD_HASH_ALGORITHM
diff --git a/databases/mongodb32-tools/Makefile b/databases/mongodb32-tools/Makefile
index 2dcb9fa4e82e..e3589291686a 100644
--- a/databases/mongodb32-tools/Makefile
+++ b/databases/mongodb32-tools/Makefile
@@ -22,7 +22,7 @@ USE_GITHUB= yes
GH_ACCOUNT= mongodb
GH_PROJECT= mongo-tools
-OPTIONS_DEFINE= SSL SASL
+OPTIONS_DEFINE= SSL SASL DOCS
OPTIONS_DEFAULT= SSL
SASL_USE= my_tags=sasl
diff --git a/databases/mongodb34-tools/Makefile b/databases/mongodb34-tools/Makefile
index d920a4514ac7..ad9a1a1dc314 100644
--- a/databases/mongodb34-tools/Makefile
+++ b/databases/mongodb34-tools/Makefile
@@ -23,7 +23,7 @@ USE_GITHUB= yes
GH_ACCOUNT= mongodb
GH_PROJECT= mongo-tools
-OPTIONS_DEFINE= SSL SASL
+OPTIONS_DEFINE= SSL SASL DOCS
OPTIONS_DEFAULT= SSL SASL
SASL_USE= my_tags=sasl
diff --git a/databases/mongodb36-tools/Makefile b/databases/mongodb36-tools/Makefile
index c37f5c0b6c65..7ac98f5e281d 100644
--- a/databases/mongodb36-tools/Makefile
+++ b/databases/mongodb36-tools/Makefile
@@ -27,7 +27,7 @@ USE_GITHUB= yes
GH_ACCOUNT= mongodb
GH_PROJECT= mongo-tools
-OPTIONS_DEFINE= SSL SASL
+OPTIONS_DEFINE= DOCS SSL SASL
OPTIONS_DEFAULT= SSL SASL
SASL_USE= my_tags=sasl
diff --git a/databases/ora2pg/Makefile b/databases/ora2pg/Makefile
index 0d9d359cb16d..a4318e0e50bb 100644
--- a/databases/ora2pg/Makefile
+++ b/databases/ora2pg/Makefile
@@ -22,6 +22,8 @@ USE_PERL5= configure
USE_GITHUB= yes
GH_ACCOUNT= darold
+OPTIONS_DEFINE= DOCS
+
do-patch:
${REINPLACE_CMD} -e '/install_all :/,/};/s=$$CONFDIR=${STAGEDIR}${ETCDIR}=g' \
-e '/install_all :/,/};/s=$$DOCDIR=${STAGEDIR}${DOCSDIR}=g' \
diff --git a/databases/pg_partman/Makefile b/databases/pg_partman/Makefile
index daa1960ebaf6..3f316d70957a 100644
--- a/databases/pg_partman/Makefile
+++ b/databases/pg_partman/Makefile
@@ -24,6 +24,8 @@ SHEBANG_GLOB= *.py
OPTIONS_DEFINE= DOCS
+OPTIONS_DEFINE= DOCS
+
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/postgresql/pg_partman_bgw.so
diff --git a/databases/pgespresso/Makefile b/databases/pgespresso/Makefile
index d12952220435..8de1d6507e79 100644
--- a/databases/pgespresso/Makefile
+++ b/databases/pgespresso/Makefile
@@ -28,6 +28,8 @@ PORTDOCS= README.asciidoc
INSTALL_TARGET= install-strip
MAKE_ARGS= INSTALL="${INSTALL} -c"
+OPTIONS_DEFINE= DOCS
+
post-install:
${MKDIR} ${STAGEDIR}${DOCSDIR}/
${INSTALL_MAN} ${WRKSRC}/${PORTDOCS} ${STAGEDIR}${DOCSDIR}/
diff --git a/databases/postgresql10-contrib/Makefile b/databases/postgresql10-contrib/Makefile
index 0f819e2cb4a9..d2d5002b6b2b 100644
--- a/databases/postgresql10-contrib/Makefile
+++ b/databases/postgresql10-contrib/Makefile
@@ -23,6 +23,8 @@ COMPONENT= -contrib
CONFIGURE_ARGS+=--with-libxslt --with-libxml --with-openssl --disable-nls --with-uuid=bsd
LDFLAGS+= -lpthread -L${PREFIX}/lib
+OPTIONS_DEFINE= DOCS
+
post-configure:
@cd ${WRKSRC}/src/backend && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} symlinks
diff --git a/databases/postgresql10-server/Makefile b/databases/postgresql10-server/Makefile
index fa72652dfcc5..02afe6cf0574 100644
--- a/databases/postgresql10-server/Makefile
+++ b/databases/postgresql10-server/Makefile
@@ -71,7 +71,7 @@ SUB_FILES+= 502.pgsql
.endif
.if defined(CLIENT_ONLY)
-OPTIONS_DEFINE+=LIBEDIT
+OPTIONS_DEFINE+=LIBEDIT DOCS
LIBEDIT_DESC= Use non-GPL libedit instead of readline
USES+= perl5
.else
@@ -80,7 +80,7 @@ CONFIGURE_ENV+= PATH=${PREFIX}/bin:${PATH}
.endif
.if defined(SERVER_ONLY)
-OPTIONS_DEFINE= DTRACE LDAP INTDATE TZDATA XML
+OPTIONS_DEFINE= DTRACE LDAP INTDATE TZDATA XML DOCS
LDAP_DESC= Build with LDAP authentication support
DTRACE_DESC= Build with DTrace probes
TZDATA_DESC= Use internal timezone database
@@ -104,7 +104,7 @@ OPTIONS_DEFAULT+= TZDATA INTDATE
.endif
.if !defined(SLAVE_ONLY)
-OPTIONS_DEFINE+= NLS PAM GSSAPI OPTIMIZED_CFLAGS DEBUG
+OPTIONS_DEFINE+= NLS PAM GSSAPI OPTIMIZED_CFLAGS DEBUG DOCS
. if ${DISTVERSION:R} == 9.2 || ${DISTVERSION:R} == 9.3
OPTIONS_RADIO= KRB5
OPTIONS_RADIO_KRB5= MIT_KRB5 HEIMDAL_KRB5
diff --git a/databases/postgresql95-contrib/Makefile b/databases/postgresql95-contrib/Makefile
index bb60cd3bbe57..760edb6a941d 100644
--- a/databases/postgresql95-contrib/Makefile
+++ b/databases/postgresql95-contrib/Makefile
@@ -23,6 +23,8 @@ COMPONENT= -contrib
CONFIGURE_ARGS+=--with-libxslt --with-libxml --with-openssl --disable-nls --with-uuid=bsd
LDFLAGS+= -lpthread -L${PREFIX}/lib
+OPTIONS_DEFINE= DOCS
+
post-install:
@- ${INSTALL_DATA} ${WRKSRC}/contrib/README ${STAGEDIR}${DOCSDIR}/extension/README
diff --git a/databases/postgresql96-contrib/Makefile b/databases/postgresql96-contrib/Makefile
index 55ed6d09223b..30313169e20b 100644
--- a/databases/postgresql96-contrib/Makefile
+++ b/databases/postgresql96-contrib/Makefile
@@ -23,6 +23,8 @@ COMPONENT= -contrib
CONFIGURE_ARGS+=--with-libxslt --with-libxml --with-openssl --disable-nls --with-uuid=bsd
LDFLAGS+= -lpthread -L${PREFIX}/lib
+OPTIONS_DEFINE= DOCS
+
post-configure:
@cd ${WRKSRC}/src/backend && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} symlinks
diff --git a/databases/py-PyGreSQL/Makefile b/databases/py-PyGreSQL/Makefile
index 491bfe2ddb20..e8246e3a5c6d 100644
--- a/databases/py-PyGreSQL/Makefile
+++ b/databases/py-PyGreSQL/Makefile
@@ -19,6 +19,8 @@ USE_PYTHON= autoplist distutils
PORTDOCS= *
+OPTIONS_DEFINE= DOCS
+
post-install:
${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/_pg.so
@${MKDIR} ${STAGEDIR}${DOCSDIR}
diff --git a/databases/py-bsddb3/Makefile b/databases/py-bsddb3/Makefile
index 5144d2e5b538..b833320e34d3 100644
--- a/databases/py-bsddb3/Makefile
+++ b/databases/py-bsddb3/Makefile
@@ -22,6 +22,8 @@ PYDISTUTILS_INSTALLARGS=-c -O1 --prefix=${PREFIX} --berkeley-db=${LOCALBASE}
PORTDOCS= *
DOCSDIR= ${PREFIX}/share/doc/${PYTHON_PKGNAMEPREFIX}${PORTNAME}
+OPTIONS_DEFINE= DOCS
+
post-patch:
@${REINPLACE_CMD} 's,%%DBVERSION%%,${BDB_LIB_NAME},g' ${WRKSRC}/setup2.py ${WRKSRC}/setup3.py
@${REINPLACE_CMD} 's,<db\.h>,<${BDB_INCLUDE_DIR}/db.h>,' ${WRKSRC}/Modules/bsddb.h
diff --git a/databases/py-sqlobject/Makefile b/databases/py-sqlobject/Makefile
index 1736b25e816b..131e1a8a6280 100644
--- a/databases/py-sqlobject/Makefile
+++ b/databases/py-sqlobject/Makefile
@@ -21,7 +21,7 @@ USES= python${PY_MYSQL}
USE_PYTHON= autoplist distutils
# currently MaxDB(SAP), ADODB are not supported
-OPTIONS_DEFINE= MYSQL PGSQL SQLITE MSSQL SYBASE
+OPTIONS_DEFINE= DOCS MYSQL PGSQL SQLITE MSSQL SYBASE
SYBASE_DESC= sybase support
PORTDOCS= *
diff --git a/databases/qdbm/Makefile b/databases/qdbm/Makefile
index ef61b24c306a..277949319505 100644
--- a/databases/qdbm/Makefile
+++ b/databases/qdbm/Makefile
@@ -29,6 +29,8 @@ MAKE_ARGS= MYDATADIR="${DOCSDIR}" MYDOCS="${PORTDOCS}" \
INSTALL_TARGET= install-strip
PORTDOCS= ChangeLog NEWS
+OPTIONS_DEFINE= DOCS
+
post-patch:
.if defined(WITH_DEBUG)
@${REINPLACE_CMD} 's/-DNDEBUG//' ${WRKSRC}/Makefile.in
diff --git a/databases/sqlcached/Makefile b/databases/sqlcached/Makefile
index e9e8c0a80210..a6fa2740d0d3 100644
--- a/databases/sqlcached/Makefile
+++ b/databases/sqlcached/Makefile
@@ -23,6 +23,8 @@ PORTDOCS= ${PORTNAME}.html ${PORTNAME}.txt
PLIST_FILES= bin/${PORTNAME} etc/rc.d/${PORTNAME} \
man/man1/${PORTNAME}.1.gz
+OPTIONS_DEFINE= DOCS
+
post-patch:
@${REINPLACE_CMD} -e 's|-lcurses|-lncurses|' ${WRKSRC}/Makefile
@${REINPLACE_CMD} 's|/usr/local|${PREFIX}|' \