aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorLoïc Bartoletti <lbartoletti@FreeBSD.org>2020-09-03 04:23:44 +0000
committerLoïc Bartoletti <lbartoletti@FreeBSD.org>2020-09-03 04:23:44 +0000
commit2f0cec94ef1b3aae681ffd5b47597df691e8d79e (patch)
treebcf38dd902d17520db03001f2342473d72f102f6 /databases
parentd47e1c8ea5ba8ccc1e4a3029a9c4fba5f59478c6 (diff)
downloadports-2f0cec94ef1b3aae681ffd5b47597df691e8d79e.tar.gz
ports-2f0cec94ef1b3aae681ffd5b47597df691e8d79e.zip
MFH: r546879
databases/grass7: fix build on 11i386 When I added the option for compiling with openmp, like other ports, I don't use compiler:openmp but directly the default compiler because it works just as well. However, on FreeBSD 11, grass only builds well with LLVM90. While I'm here I added with-proj-[includes|libs] to be more thorough Approved by: tcberner Differential Revision: https://reviews.freebsd.org/D25712 Approved by: ports-secteam (joneum)
Notes
Notes: svn path=/branches/2020Q3/; revision=547409
Diffstat (limited to 'databases')
-rw-r--r--databases/grass7/Makefile16
1 files changed, 11 insertions, 5 deletions
diff --git a/databases/grass7/Makefile b/databases/grass7/Makefile
index ea508efc3b1c..767105da5cad 100644
--- a/databases/grass7/Makefile
+++ b/databases/grass7/Makefile
@@ -39,7 +39,7 @@ LIB_DEPENDS= libgdal.so:graphics/gdal \
RUN_DEPENDS= ${PY_NUMPY} \
${PYTHON_SITELIBDIR}/six.py:devel/py-six@${PY_FLAVOR}
-USES= blaslapack compiler:c11 gl gmake gnome iconv \
+USES= blaslapack compiler:features gl gmake gnome iconv \
jpeg perl5 pkgconfig python:3.6+ readline shebangfix xorg
SHEBANG_GLOB= *.py
SHEBANG_LANG= nviz
@@ -65,6 +65,8 @@ CONFIGURE_ARGS= --with-includes=${LOCALBASE}/include \
--enable-largefile \
--with-wxwidgets=${WX_CONFIG} \
--with-proj-share=${LOCALBASE}/share/proj \
+ --with-proj-includes=${LOCALBASE}/include \
+ --with-proj-libs=${LOCALBASE}/lib \
--with-geos=${LOCALBASE}/bin/geos-config \
--with-gdal=${LOCALBASE}/bin/gdal-config \
--with-pthread=yes \
@@ -135,8 +137,16 @@ ZSTD_LIB_DEPENDS= libzstd.so:archivers/zstd
PLIST_SUB+= WOSBRK="@comment "
.else
PLIST_SUB+= WOSBRK=""
+.endif
+.if ${ARCH} == "i386" && ${OSVERSION} < 1200000
+# clang 7.x and 8.x do not build properly on 11i386
+CPP= clang-cpp${LLVM_DEFAULT}
+CC= clang${LLVM_DEFAULT}
+CXX= clang++${LLVM_DEFAULT}
+BUILD_DEPENDS+= clang${LLVM_DEFAULT}:devel/llvm${LLVM_DEFAULT}
.endif
+
.if !defined (GRASS_INST_DIR)
GRASS_INST_DIR= ${PORTNAME}${VER}
.endif
@@ -144,10 +154,6 @@ GRASS_INST_DIR= ${PORTNAME}${VER}
MANDIRS= ${PREFIX}/grass${VER}/docs/man/man1
post-patch:
-# ${REINPLACE_CMD} -e \
-# 's|-lblas|${BLASLIB}|g ; \
-# s|-llapack|${LAPACKLIB}|g ; \
-# s|g2c|f2c|g' ${WRKSRC}/configure
${REINPLACE_CMD} -e \
's|make -C|$$(MAKE) -C| ; \
/^BINDIR/s|=.*|= $${DESTDIR}$${UNIX_BIN}| ; \