aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-04-26 15:10:57 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-04-26 15:10:57 +0000
commit9dbc02d2c5d8b2c2c499e0e86015bc9505c69318 (patch)
treea82894e443e00d2d1e62c361da23f99b943f1351 /databases
parentab49cb5a84477145caac35e88ca5cfc76001c68f (diff)
downloadports-9dbc02d2c5d8b2c2c499e0e86015bc9505c69318.tar.gz
ports-9dbc02d2c5d8b2c2c499e0e86015bc9505c69318.zip
Notes
Diffstat (limited to 'databases')
-rw-r--r--databases/postgresql84-server/Makefile8
-rw-r--r--databases/postgresql91-server/Makefile8
-rw-r--r--databases/postgresql92-server/Makefile8
3 files changed, 9 insertions, 15 deletions
diff --git a/databases/postgresql84-server/Makefile b/databases/postgresql84-server/Makefile
index bb13db06c3d2..3e6d45f1ea0a 100644
--- a/databases/postgresql84-server/Makefile
+++ b/databases/postgresql84-server/Makefile
@@ -133,8 +133,6 @@ EXTRA_PATCHES+= ${FILESDIR}/extra-patch-icu4
. endif
.endif # !SLAVE_ONLY
-.include <bsd.port.pre.mk>
-
.if !defined(SLAVE_ONLY)
PATCH_DIST_STRIP=-p1
@@ -173,10 +171,10 @@ CONFIGURE_ARGS+=--enable-integer-datetimes
CONFIGURE_ARGS+=--disable-integer-datetimes
. endif
-. if ( defined(WITH_GETTEXT) || ${PORT_OPTIONS:MNLS} )
+. if ${PORT_OPTIONS:MNLS}
CONFIGURE_ARGS+=--enable-nls
PLIST_SUB+= GETTEXT=""
-USE_GETTEXT= yes
+USES+= gettext
. else
CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= GETTEXT="@comment "
@@ -371,4 +369,4 @@ check:
fi
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/databases/postgresql91-server/Makefile b/databases/postgresql91-server/Makefile
index c565e632fab1..5030637f9f88 100644
--- a/databases/postgresql91-server/Makefile
+++ b/databases/postgresql91-server/Makefile
@@ -140,8 +140,6 @@ PLIST_SUB+= OSSP=""
PLIST_SUB+= OSSP="@comment "
.endif
-.include <bsd.port.pre.mk>
-
.if !defined(SLAVE_ONLY)
PATCH_DIST_STRIP=-p1
@@ -181,10 +179,10 @@ PLIST_SUB+= TZDATA="@comment "
CONFIGURE_ARGS+=--disable-integer-datetimes
. endif
-. if ( defined(WITH_GETTEXT) || ${PORT_OPTIONS:MNLS} )
+. if ${PORT_OPTIONS:MNLS}
CONFIGURE_ARGS+=--enable-nls
PLIST_SUB+= GETTEXT=""
-USE_GETTEXT= yes
+USES+= gettext
. else
CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= GETTEXT="@comment "
@@ -390,4 +388,4 @@ check:
fi
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/databases/postgresql92-server/Makefile b/databases/postgresql92-server/Makefile
index e272ac2e0fb4..30a50db4c046 100644
--- a/databases/postgresql92-server/Makefile
+++ b/databases/postgresql92-server/Makefile
@@ -139,8 +139,6 @@ PLIST_SUB+= OSSP=""
PLIST_SUB+= OSSP="@comment "
.endif
-.include <bsd.port.pre.mk>
-
.if !defined(SLAVE_ONLY)
PATCH_DIST_STRIP=-p1
@@ -180,10 +178,10 @@ PLIST_SUB+= TZDATA="@comment "
CONFIGURE_ARGS+=--disable-integer-datetimes
. endif
-. if ( defined(WITH_GETTEXT) || ${PORT_OPTIONS:MNLS} )
+. if ${PORT_OPTIONS:MNLS}
CONFIGURE_ARGS+=--enable-nls
PLIST_SUB+= GETTEXT=""
-USE_GETTEXT= yes
+USES= gettext
. else
CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= GETTEXT="@comment "
@@ -392,4 +390,4 @@ check:
fi
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>