aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2010-03-26 03:00:34 +0000
committerWen Heping <wen@FreeBSD.org>2010-03-26 03:00:34 +0000
commit037fe5524f075b503d882c2a4d2918a10fe24431 (patch)
treec26acc886306aa54dc488a6d2f30787894fe9f48 /databases
parent774a50b6a4a5d2e6960e46275b2cb0eda3d3f24a (diff)
downloadports-037fe5524f075b503d882c2a4d2918a10fe24431.tar.gz
ports-037fe5524f075b503d882c2a4d2918a10fe24431.zip
Notes
Diffstat (limited to 'databases')
-rw-r--r--databases/postgis/Makefile8
-rw-r--r--databases/postgis/distinfo6
-rw-r--r--databases/postgis/files/patch-doc-Makefile.in25
-rw-r--r--databases/postgis/files/patch-doc-html-image_src-Makefile.in30
-rw-r--r--databases/postgis/files/patch-postgis-Makefile.in26
-rw-r--r--databases/postgis/pkg-plist24
6 files changed, 86 insertions, 33 deletions
diff --git a/databases/postgis/Makefile b/databases/postgis/Makefile
index 367bdb2f2b0f..8a06fd6ecfc9 100644
--- a/databases/postgis/Makefile
+++ b/databases/postgis/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= postgis
-PORTVERSION= 1.4.1
+PORTVERSION= 1.5.0
CATEGORIES= databases geography
MASTER_SITES= http://postgis.refractions.net/download/ \
http://www.postgis.org/download/
@@ -14,12 +14,13 @@ MASTER_SITES= http://postgis.refractions.net/download/ \
MAINTAINER= anderson@cnpm.embrapa.br
COMMENT= Adds support for geographic objects to PostgreSQL databases
-BUILD_DEPENDS= ${LOCALBASE}/bin/geos-config:${PORTSDIR}/graphics/geos
-LIB_DEPENDS= proj.6:${PORTSDIR}/graphics/proj
+LIB_DEPENDS= proj.6:${PORTSDIR}/graphics/proj \
+ geos.0:${PORTSDIR}/graphics/geos
RUN_DEPENDS= postmaster:${PORTSDIR}/databases/postgresql${PGSQL_VER}-server
USE_BISON= build
USE_PGSQL= yes
+DEFAULT_PGSQL_VER= 83
USE_GMAKE= yes
USE_ICONV= yes
USE_LDCONFIG= yes
@@ -28,6 +29,7 @@ USE_PERL5_BUILD= yes
INSTALL_TARGET= install
GNU_CONFIGURE= yes
+USE_GNOME= libxml2
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
MAKE_ENV= DATADIR=${DATADIR} DOCSDIR=${DOCSDIR}
diff --git a/databases/postgis/distinfo b/databases/postgis/distinfo
index ee0dca43dd20..788a1c91ba02 100644
--- a/databases/postgis/distinfo
+++ b/databases/postgis/distinfo
@@ -1,3 +1,3 @@
-MD5 (postgis-1.4.1.tar.gz) = 78d13c4294f3336502ad35c8a30e5583
-SHA256 (postgis-1.4.1.tar.gz) = 17d96c59e1653d7441c98ba0762b55cae3dc22f51e897294d3262dee22ba0a50
-SIZE (postgis-1.4.1.tar.gz) = 3273182
+MD5 (postgis-1.5.0.tar.gz) = 8c0d291296033deee4d7f545e5d8218f
+SHA256 (postgis-1.5.0.tar.gz) = f79e8f740d48367e5481183c33e09b860c2c4466b196ea99c5601db287e2d324
+SIZE (postgis-1.5.0.tar.gz) = 3752211
diff --git a/databases/postgis/files/patch-doc-Makefile.in b/databases/postgis/files/patch-doc-Makefile.in
index 955f8c0129a6..796fced2d04c 100644
--- a/databases/postgis/files/patch-doc-Makefile.in
+++ b/databases/postgis/files/patch-doc-Makefile.in
@@ -1,6 +1,24 @@
---- doc/Makefile.in.orig 2009-07-08 12:16:53.000000000 -0300
-+++ doc/Makefile.in 2009-09-20 10:12:53.000000000 -0300
-@@ -135,12 +135,12 @@
+--- doc/Makefile.in.orig 2010-01-11 23:00:56.000000000 -0200
++++ doc/Makefile.in 2010-02-28 17:04:05.000000000 -0300
+@@ -111,14 +111,14 @@
+ doxygen $<
+
+ images:
+- make -C html/image_src images
++
+
+ clean:
+- make -C html/image_src clean
++ gmake -C html/image_src clean
+ @rm -f postgis-out.xml postgis_aggs_mm.xml
+
+ maintainer-clean: clean
+- make -C html/image_src clean
++ gmake -C html/image_src clean
+ @rm -f html/*.html \
+ postgis-${POSTGIS_MAJOR_VERSION}.${POSTGIS_MINOR_VERSION}.${POSTGIS_MICRO_VERSION}.pdf
+
+@@ -131,12 +131,13 @@
rm -f $(PGSQL_SHAREDIR)/contrib/postgis_comments.sql
install: html/postgis.html man/shp2pgsql.1 man/pgsql2shp.1
@@ -16,6 +34,7 @@
+ cp ../README.postgis $(DOCSDIR)/README.postgis
+ cp man/pgsql2shp.1 $(PREFIX)/man/man1/pgsql2shp.1
+ cp man/shp2pgsql.1 $(PREFIX)/man/man1/shp2pgsql.1
++ gmake -C html/image_src install
uninstall:
rm -f $(PGSQL_DOCDIR)/postgis/postgis.html
diff --git a/databases/postgis/files/patch-doc-html-image_src-Makefile.in b/databases/postgis/files/patch-doc-html-image_src-Makefile.in
new file mode 100644
index 000000000000..cc66e6d3f6f9
--- /dev/null
+++ b/databases/postgis/files/patch-doc-html-image_src-Makefile.in
@@ -0,0 +1,30 @@
+--- doc/html/image_src/Makefile.in.orig 2010-01-12 01:31:49.000000000 +0800
++++ doc/html/image_src/Makefile.in 2010-03-26 10:15:25.000000000 +0800
+@@ -83,7 +83,18 @@
+ ../images/st_touches04.png \
+ ../images/st_touches05.png \
+ ../images/st_touches06.png \
+- ../images/st_within01.png
++ ../images/st_within01.png \
++ ../images/caution.png \
++ ../images/check.png \
++ ../images/important.png \
++ ../images/note.png \
++ ../images/tip.png \
++ ../images/warning.png \
++ ../images/matrix_autocast.png \
++ ../images/matrix_transform.png \
++ ../images/matrix_checkmark.png
++
++
+
+ # Images that are created with dimensions 100x100
+ IMAGES_RESIZED= \
+@@ -134,3 +145,7 @@
+ @rm -f generator
+ @rm -f tmp[0-9].png
+
++install:
++ @mkdir -p $(DOCSDIR)/images
++ cp $(IMAGES) $(DOCSDIR)/images
++
diff --git a/databases/postgis/files/patch-postgis-Makefile.in b/databases/postgis/files/patch-postgis-Makefile.in
index aecbcdae6065..6562c4cfda54 100644
--- a/databases/postgis/files/patch-postgis-Makefile.in
+++ b/databases/postgis/files/patch-postgis-Makefile.in
@@ -1,34 +1,34 @@
---- postgis/Makefile.in.orig 2009-11-14 06:26:00.000000000 +0800
-+++ postgis/Makefile.in 2010-01-22 11:41:18.000000000 +0800
-@@ -12,6 +12,10 @@
-
+--- postgis/Makefile.in.orig 2010-01-08 20:48:29.000000000 -0200
++++ postgis/Makefile.in 2010-02-28 14:18:37.000000000 -0300
+@@ -13,6 +13,10 @@
MODULE_big=postgis-@POSTGIS_MAJOR_VERSION@.@POSTGIS_MINOR_VERSION@
+ MODULEDIR=contrib/$(MODULE_big)
+override datadir := $(DATADIR)
+override bindir := $(PREFIX)/bin
+override pkglibdir := $(PREFIX)/lib/postgresql
+
# Files to be copied to the contrib/ directory
- DATA_built=postgis.sql uninstall_postgis.sql postgis_upgrade_14_minor.sql postgis_upgrade_13_to_14.sql postgis_upgrade_12_to_14.sql
+ DATA_built=postgis.sql uninstall_postgis.sql postgis_upgrade_15_minor.sql postgis_upgrade_14_to_15.sql postgis_upgrade_13_to_15.sql
DATA=../spatial_ref_sys.sql
-@@ -73,16 +77,16 @@
+@@ -103,16 +107,16 @@
# Borrow the $libdir substitution from PGXS but customise by adding the version number
%.sql: %.sql.in
-- sed 's,MODULE_PATHNAME,$$libdir/$*-@POSTGIS_MAJOR_VERSION@.@POSTGIS_MINOR_VERSION@,g' $< >$@
+- sed 's,MODULE_PATHNAME,$$libdir/postgis-@POSTGIS_MAJOR_VERSION@.@POSTGIS_MINOR_VERSION@,g' $< >$@
+ sed 's,MODULE_PATHNAME,$$libdir/$*,g' $< >$@
- postgis_upgrade_14_minor.sql: postgis.sql
+ postgis_upgrade_15_minor.sql: postgis.sql
+- $(PERL) ../utils/postgis_proc_upgrade.pl $< 1.5 > $@
++ %PERL% ../utils/postgis_proc_upgrade.pl $< 1.5 > $@
+
+ postgis_upgrade_14_to_15.sql: postgis.sql
- $(PERL) ../utils/postgis_proc_upgrade.pl $< 1.4 > $@
+ %PERL% ../utils/postgis_proc_upgrade.pl $< 1.4 > $@
- postgis_upgrade_13_to_14.sql: postgis.sql
+ postgis_upgrade_13_to_15.sql: postgis.sql
- $(PERL) ../utils/postgis_proc_upgrade.pl $< 1.3 > $@
+ %PERL% ../utils/postgis_proc_upgrade.pl $< 1.3 > $@
- postgis_upgrade_12_to_14.sql: postgis.sql
-- $(PERL) ../utils/postgis_proc_upgrade.pl $< 1.2 > $@
-+ %PERL% ../utils/postgis_proc_upgrade.pl $< 1.2 > $@
-
# Generate any .sql.in files from .sql.in.c files by running them through the C pre-processor
$(SQL_OBJS): %.in: %.in.c
diff --git a/databases/postgis/pkg-plist b/databases/postgis/pkg-plist
index 128d624d17f8..fb17a2cafde4 100644
--- a/databases/postgis/pkg-plist
+++ b/databases/postgis/pkg-plist
@@ -1,15 +1,15 @@
bin/pgsql2shp
bin/shp2pgsql
-lib/postgresql/postgis-1.4.so
-lib/postgresql/postgis.so
lib/postgresql/liblwgeom.so
lib/postgresql/liblwgeom.so.1
-%%DATADIR%%/contrib/postgis.sql
-%%DATADIR%%/contrib/postgis_upgrade_14_minor.sql
-%%DATADIR%%/contrib/postgis_upgrade_13_to_14.sql
-%%DATADIR%%/contrib/postgis_upgrade_12_to_14.sql
-%%DATADIR%%/contrib/spatial_ref_sys.sql
-%%DATADIR%%/contrib/uninstall_postgis.sql
+lib/postgresql/postgis-1.5.so
+lib/postgresql/postgis.so
+%%DATADIR%%/contrib/postgis-1.5/postgis.sql
+%%DATADIR%%/contrib/postgis-1.5/postgis_upgrade_13_to_15.sql
+%%DATADIR%%/contrib/postgis-1.5/postgis_upgrade_14_to_15.sql
+%%DATADIR%%/contrib/postgis-1.5/postgis_upgrade_15_minor.sql
+%%DATADIR%%/contrib/postgis-1.5/spatial_ref_sys.sql
+%%DATADIR%%/contrib/postgis-1.5/uninstall_postgis.sql
%%DATADIR%%/utils/create_undef.pl
%%DATADIR%%/utils/new_postgis_restore.pl
%%DATADIR%%/utils/postgis_proc_upgrade.pl
@@ -17,7 +17,9 @@ lib/postgresql/liblwgeom.so.1
%%DATADIR%%/utils/profile_intersects.pl
%%DATADIR%%/utils/test_estimation.pl
%%DATADIR%%/utils/test_joinestimation.pl
-@dirrm %%DATADIR%%/utils
-@dirrm %%DATADIR%%/contrib
-@dirrm %%DATADIR%%
+@dirrmtry %%DATADIR%%/utils
+@dirrmtry %%DATADIR%%/contrib/postgis-1.5
+@dirrmtry %%DATADIR%%/contrib
+@dirrmtry %%DATADIR%%
@dirrmtry lib/postgresql
+@dirrmtry lib