aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2013-09-10 12:14:21 +0000
committerAndrej Zverev <az@FreeBSD.org>2013-09-10 12:14:21 +0000
commit1a612a3da133de5a7102ce8bbcc7de3e412ad91b (patch)
tree9aeebeb9aec3579ec4feb99b00bee1dad3a4c734 /databases
parent7f9ec7d977869a069660c0a22ff7cb18d425bf50 (diff)
downloadports-1a612a3da133de5a7102ce8bbcc7de3e412ad91b.tar.gz
ports-1a612a3da133de5a7102ce8bbcc7de3e412ad91b.zip
Notes
Diffstat (limited to 'databases')
-rw-r--r--databases/mysql2pgsql/Makefile8
-rw-r--r--databases/p5-Amon2-DBI/Makefile3
-rw-r--r--databases/p5-AnyEvent-DBD-Pg/Makefile8
-rw-r--r--databases/p5-Cache-Memcached-libmemcached/Makefile9
-rw-r--r--databases/p5-Class-DBI-Plugin-Iterator/Makefile8
-rw-r--r--databases/p5-DBIx-Class-DeploymentHandler/Makefile3
-rw-r--r--databases/p5-DBIx-DBHResolver/Makefile8
-rw-r--r--databases/p5-DBIx-HA/Makefile9
-rw-r--r--databases/p5-DBIx-RetryOverDisconnects/Makefile3
-rw-r--r--databases/p5-DBIx-SearchBuilder/Makefile9
-rw-r--r--databases/p5-HTML-FormHandler-Model-DBIC/Makefile9
-rw-r--r--databases/p5-ORLite/Makefile3
-rw-r--r--databases/p5-Relations-Query/Makefile3
-rw-r--r--databases/p5-Rose-DBx-Object-MoreHelpers/Makefile3
-rw-r--r--databases/p5-Search-Namazu/Makefile9
-rw-r--r--databases/p5-Teng/Makefile3
-rw-r--r--databases/p5-Test-Fixture-DBI/Makefile8
-rw-r--r--databases/pgtop/Makefile9
-rw-r--r--databases/rrdman/Makefile2
19 files changed, 43 insertions, 74 deletions
diff --git a/databases/mysql2pgsql/Makefile b/databases/mysql2pgsql/Makefile
index 02367ea416e2..9ef5fa278bf9 100644
--- a/databases/mysql2pgsql/Makefile
+++ b/databases/mysql2pgsql/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: mysql2pgsql
-# Date Created: 27 May 2001
-# Whom: Pete Fritchman <petef@databits.net>
-#
+# Created by: Pete Fritchman <petef@databits.net>
# $FreeBSD$
-#
PORTNAME= mysql2pgsql
PORTVERSION= 1.2
@@ -17,7 +13,7 @@ MAINTAINER= klossalex@gmail.com
COMMENT= Convert a MySQL dump to a PostgreSQL dump
PLIST_FILES= bin/mysql2pgsql
-USE_PERL5= yes
+USES= perl5
NO_BUILD= yes
do-extract:
diff --git a/databases/p5-Amon2-DBI/Makefile b/databases/p5-Amon2-DBI/Makefile
index 79c23e3ea31c..cc6fd9c7c1d4 100644
--- a/databases/p5-Amon2-DBI/Makefile
+++ b/databases/p5-Amon2-DBI/Makefile
@@ -21,7 +21,8 @@ TEST_DEPENDS= \
p5-Amon2>0:${PORTSDIR}/www/p5-Amon2 \
p5-Test-Memory-Cycle>0:${PORTSDIR}/devel/p5-Test-Memory-Cycle
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Amon2::DBI.3
diff --git a/databases/p5-AnyEvent-DBD-Pg/Makefile b/databases/p5-AnyEvent-DBD-Pg/Makefile
index 43a3422aee49..6fe031da2675 100644
--- a/databases/p5-AnyEvent-DBD-Pg/Makefile
+++ b/databases/p5-AnyEvent-DBD-Pg/Makefile
@@ -1,9 +1,4 @@
-# New ports collection makefile for: AnyEvent::DBD::Pg
-# Date created: 02 Dec 2010
-# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
-#
# $FreeBSD$
-#
PORTNAME= AnyEvent-DBD-Pg
PORTVERSION= 0.03
@@ -24,7 +19,8 @@ RUN_DEPENDS= p5-AnyEvent>=5:${PORTSDIR}/devel/p5-AnyEvent \
p5-common-sense>=3:${PORTSDIR}/devel/p5-common-sense
TEST_DEPENDS= p5-lib-abs>=0.90:${PORTSDIR}/devel/p5-lib-abs
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= AnyEvent::DBD::Pg.3
diff --git a/databases/p5-Cache-Memcached-libmemcached/Makefile b/databases/p5-Cache-Memcached-libmemcached/Makefile
index f5f0a8570a69..f4625221c4c6 100644
--- a/databases/p5-Cache-Memcached-libmemcached/Makefile
+++ b/databases/p5-Cache-Memcached-libmemcached/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Cache-Memcached-libmemcached
-# Date created: Jun 06 2011
-# Whom: Dmitry Liakh <dliakh@ukr.net>
-#
+# Created by: Dmitry Liakh <dliakh@ukr.net>
# $FreeBSD$
-#
PORTNAME= Cache-Memcached-libmemcached
PORTVERSION= 0.02011
@@ -19,7 +15,8 @@ BUILD_DEPENDS= p5-Memcached-libmemcached>=0.42.01:${PORTSDIR}/databases/p5-Memca
p5-Task-Weaken>=0:${PORTSDIR}/devel/p5-Task-Weaken
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Cache::Memcached::libmemcached.3
diff --git a/databases/p5-Class-DBI-Plugin-Iterator/Makefile b/databases/p5-Class-DBI-Plugin-Iterator/Makefile
index 13112c7808d6..1905c942446e 100644
--- a/databases/p5-Class-DBI-Plugin-Iterator/Makefile
+++ b/databases/p5-Class-DBI-Plugin-Iterator/Makefile
@@ -1,9 +1,4 @@
-# New ports collection makefile for: Class-DBI-Plugin-Iterator
-# Date created: 26 Oct 2005
-# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
-#
# $FreeBSD$
-#
PORTNAME= Class-DBI-Plugin-Iterator
PORTVERSION= 0.13
@@ -18,7 +13,8 @@ BUILD_DEPENDS= p5-Class-DBI>=0:${PORTSDIR}/databases/p5-Class-DBI
TEST_DEPENDS= p5-DBD-SQLite>=1.27:${PORTSDIR}/databases/p5-DBD-SQLite \
p5-Class-DBI-Pager>=0:${PORTSDIR}/databases/p5-Class-DBI-Pager
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Class::DBI::Plugin::Iterator.3 \
Class::DBI::Plugin::Iterator::Nihongo.3
diff --git a/databases/p5-DBIx-Class-DeploymentHandler/Makefile b/databases/p5-DBIx-Class-DeploymentHandler/Makefile
index 917cf62ef8a1..e187aa55c569 100644
--- a/databases/p5-DBIx-Class-DeploymentHandler/Makefile
+++ b/databases/p5-DBIx-Class-DeploymentHandler/Makefile
@@ -31,7 +31,8 @@ TEST_DEPENDS= \
p5-Test-Requires>=0.06:${PORTSDIR}/devel/p5-Test-Requires \
p5-Test-Simple>0:${PORTSDIR}/devel/p5-Test-Simple
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= DBIx::Class::DeploymentHandler.3 \
DBIx::Class::DeploymentHandler::Cookbook::CustomResultSource.3 \
diff --git a/databases/p5-DBIx-DBHResolver/Makefile b/databases/p5-DBIx-DBHResolver/Makefile
index e2fe6eb5222f..ec92dbb6c3d1 100644
--- a/databases/p5-DBIx-DBHResolver/Makefile
+++ b/databases/p5-DBIx-DBHResolver/Makefile
@@ -1,9 +1,4 @@
-# New ports collection makefile for: DBIx::DBHResolver
-# Date created: 16 Oct 2010
-# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
-#
# $FreeBSD$
-#
PORTNAME= DBIx-DBHResolver
PORTVERSION= 0.17
@@ -29,7 +24,8 @@ TEST_DEPENDS= p5-List-MoreUtils>=0:${PORTSDIR}/lang/p5-List-MoreUtils \
p5-Sub-Uplevel>=0:${PORTSDIR}/devel/p5-Sub-Uplevel
# TODO: fix test.
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= DBIx::DBHResolver.3 \
DBIx::DBHResolver::Strategy.3 \
diff --git a/databases/p5-DBIx-HA/Makefile b/databases/p5-DBIx-HA/Makefile
index 8424b7b89915..0866d58d9ab4 100644
--- a/databases/p5-DBIx-HA/Makefile
+++ b/databases/p5-DBIx-HA/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-DBIx-HA
-# Date created: 2007-05-02
-# Whom: Gea-Suan Lin <gslin@gslin.org>
-#
+# Created by: Gea-Suan Lin <gslin@gslin.org>
# $FreeBSD$
-#
PORTNAME= DBIx-HA
PORTVERSION= 1.1
@@ -15,7 +11,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= miwi@FreeBSD.org
COMMENT= High Availability package for DBI
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= DBIx::HA.3
diff --git a/databases/p5-DBIx-RetryOverDisconnects/Makefile b/databases/p5-DBIx-RetryOverDisconnects/Makefile
index 729cab6fc331..c07b4a69688b 100644
--- a/databases/p5-DBIx-RetryOverDisconnects/Makefile
+++ b/databases/p5-DBIx-RetryOverDisconnects/Makefile
@@ -14,7 +14,8 @@ BUILD_DEPENDS= p5-DBI>0:${PORTSDIR}/databases/p5-DBI \
p5-Exception-Class>0:${PORTSDIR}/devel/p5-Exception-Class
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= DBIx::RetryOverDisconnects.3
diff --git a/databases/p5-DBIx-SearchBuilder/Makefile b/databases/p5-DBIx-SearchBuilder/Makefile
index d3a48d780049..18d81c28378c 100644
--- a/databases/p5-DBIx-SearchBuilder/Makefile
+++ b/databases/p5-DBIx-SearchBuilder/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: databases/p5-DBIx-SearchBuilder
-# Date created: 29 May 2001
-# Whom: Anton Berezin <tobez@tobez.org>
-#
+# Created by: Anton Berezin <tobez@tobez.org>
# $FreeBSD$
-#
PORTNAME= DBIx-SearchBuilder
PORTVERSION= 1.63
@@ -26,7 +22,8 @@ BUILD_DEPENDS= p5-Class-ReturnValue>=0:${PORTSDIR}/devel/p5-Class-ReturnValue \
RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-DBD-SQLite>=0:${PORTSDIR}/databases/p5-DBD-SQLite
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= DBIx::SearchBuilder.3 DBIx::SearchBuilder::Handle.3 \
DBIx::SearchBuilder::Handle::Informix.3 \
diff --git a/databases/p5-HTML-FormHandler-Model-DBIC/Makefile b/databases/p5-HTML-FormHandler-Model-DBIC/Makefile
index 85af088df3dd..28f110efddbc 100644
--- a/databases/p5-HTML-FormHandler-Model-DBIC/Makefile
+++ b/databases/p5-HTML-FormHandler-Model-DBIC/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-HTML-FormHandler-Model-DBIC
-# Date created: 2010-02-02
-# Whom: Vladimir Timofeev <vovkasm@gmail.com>
-#
+# Created by: Vladimir Timofeev <vovkasm@gmail.com>
# $FreeBSD$
-#
PORTNAME= HTML-FormHandler-Model-DBIC
PORTVERSION= 0.19
@@ -25,7 +21,8 @@ TEST_DEPENDS= p5-DateTime-Format-MySQL>0:${PORTSDIR}/devel/p5-DateTime-Format-My
p5-DateTime-Format-SQLite>0:${PORTSDIR}/devel/p5-DateTime-Format-SQLite \
p5-DateTime-Format-W3CDTF>0:${PORTSDIR}/devel/p5-DateTime-Format-W3CDTF
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN1= form_generator.pl.1
diff --git a/databases/p5-ORLite/Makefile b/databases/p5-ORLite/Makefile
index 3e0e181797d6..d42f0d6f668b 100644
--- a/databases/p5-ORLite/Makefile
+++ b/databases/p5-ORLite/Makefile
@@ -20,7 +20,8 @@ BUILD_DEPENDS+= p5-ExtUtils-MakeMaker>=6.59:${PORTSDIR}/devel/p5-ExtUtils-MakeMa
TEST_DEPENDS= p5-Test-Script>=1.06:${PORTSDIR}/devel/p5-Test-Script
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= ORLite.3
diff --git a/databases/p5-Relations-Query/Makefile b/databases/p5-Relations-Query/Makefile
index 729b60d168e3..df39db4e4192 100644
--- a/databases/p5-Relations-Query/Makefile
+++ b/databases/p5-Relations-Query/Makefile
@@ -13,7 +13,8 @@ COMMENT= Object for building queries with DBI/DBD::mysql
BUILD_DEPENDS= p5-Relations>=0:${PORTSDIR}/databases/p5-Relations
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Relations::Query.3
diff --git a/databases/p5-Rose-DBx-Object-MoreHelpers/Makefile b/databases/p5-Rose-DBx-Object-MoreHelpers/Makefile
index 5d992f209f56..7ba9b14d65fa 100644
--- a/databases/p5-Rose-DBx-Object-MoreHelpers/Makefile
+++ b/databases/p5-Rose-DBx-Object-MoreHelpers/Makefile
@@ -14,7 +14,8 @@ COMMENT= Perl 5 module to deploy a DBIx::Class schema
RUN_DEPENDS= p5-Rose-DB-Object>=0.7730,1:${PORTSDIR}/databases/p5-Rose-DB-Object \
p5-Data-Dump>=1.06:${PORTSDIR}/devel/p5-Data-Dump
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Rose::DBx::Object::MoreHelpers.3
diff --git a/databases/p5-Search-Namazu/Makefile b/databases/p5-Search-Namazu/Makefile
index 8839dc4f97b2..329f80a1bde1 100644
--- a/databases/p5-Search-Namazu/Makefile
+++ b/databases/p5-Search-Namazu/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Search::Namazu
-# Date created: 18 Jun 2002
-# Whom: kuriyama
-#
+# Created by: kuriyama
# $FreeBSD$
-#
PORTNAME= Search-Namazu
PORTVERSION= 0.96
@@ -17,7 +13,8 @@ COMMENT= Namazu library module for perl
LIB_DEPENDS= nmz.8:${PORTSDIR}/databases/namazu2
-PERL_CONFIGURE= YES
+USES= perl5
+USE_PERL5= configure
MAN3= Search::Namazu.3
diff --git a/databases/p5-Teng/Makefile b/databases/p5-Teng/Makefile
index 1e66b5e25709..a48853745881 100644
--- a/databases/p5-Teng/Makefile
+++ b/databases/p5-Teng/Makefile
@@ -28,7 +28,8 @@ TEST_DEPENDS= \
p5-Test-Simple>=0.96:${PORTSDIR}/devel/p5-Test-Simple \
p5-Class-Method-Modifiers>0:${PORTSDIR}/devel/p5-Class-Method-Modifiers
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Teng.3 \
Teng::Iterator.3 \
diff --git a/databases/p5-Test-Fixture-DBI/Makefile b/databases/p5-Test-Fixture-DBI/Makefile
index bb2d113516cf..0168ed51822e 100644
--- a/databases/p5-Test-Fixture-DBI/Makefile
+++ b/databases/p5-Test-Fixture-DBI/Makefile
@@ -1,9 +1,4 @@
-# New ports collection makefile for: Test::Fixture::DBI
-# Date created: 26 Dec 2010
-# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
-#
# $FreeBSD$
-#
PORTNAME= Test-Fixture-DBI
PORTVERSION= 0.07
@@ -24,7 +19,8 @@ BUILD_DEPENDS:= ${RUN_DEPENDS}
TEST_DEPENDS= p5-List-MoreUtils>=0:${PORTSDIR}/lang/p5-List-MoreUtils \
p5-Sub-Uplevel>=0:${PORTSDIR}/devel/p5-Sub-Uplevel
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN1= make_database_yaml.pl.1 \
make_fixture_yaml.pl.1
diff --git a/databases/pgtop/Makefile b/databases/pgtop/Makefile
index 635735f9fca8..1dae100b578a 100644
--- a/databases/pgtop/Makefile
+++ b/databases/pgtop/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: pgtop
-# Date created: 30 May 2006
-# Whom: Bartek Rutkowski <r@robakdesign.com>
-#
+# Created by: Bartek Rutkowski <r@robakdesign.com>
# $FreeBSD$
-#
PORTNAME= pgtop
PORTVERSION= 0.05
@@ -19,7 +15,8 @@ RUN_DEPENDS= p5-Term-ReadKey>=2.10:${PORTSDIR}/devel/p5-Term-ReadKey \
p5-DBD-Pg>=1.22:${PORTSDIR}/databases/p5-DBD-Pg \
p5-DBI>=1.16:${PORTSDIR}/databases/p5-DBI
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN1= pgtop.1
diff --git a/databases/rrdman/Makefile b/databases/rrdman/Makefile
index a553b4949d93..4b8ca4c51c32 100644
--- a/databases/rrdman/Makefile
+++ b/databases/rrdman/Makefile
@@ -14,7 +14,7 @@ BUILD_DEPENDS= rrdtool:${PORTSDIR}/databases/rrdtool
RUN_DEPENDS:= ${BUILD_DEPENDS}
GNU_CONFIGURE= YES
-USE_PERL5= YES
+USES= perl5
PLIST_FILES= bin/rrd_hwreapply
MAN1= rrd_hwreapply.1