aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2020-09-26 09:08:01 +0000
committerKurt Jaeger <pi@FreeBSD.org>2020-09-26 09:08:01 +0000
commita22198ffa09b529dd76071243848e45b2ff17448 (patch)
treede0c6a050ce22d572b0362b59159cdfc4d85ce7b /databases
parent104e766eb8c43718a5fc4fa27de8b7ec214db8cc (diff)
downloadports-a22198ffa09b529dd76071243848e45b2ff17448.tar.gz
ports-a22198ffa09b529dd76071243848e45b2ff17448.zip
New port: databases/mongodb-tools
According to https://docs.mongodb.com/database-tools/#versioning the versioning of mongodb-tools changed. One version of mongodb-tools for all future mongodb versions. - removed mongoreplay: it does not exist (anymore) - enabled all tools: I don't know the history why these were not enabled - builds and runs on aarch64 - Add WWW to official documentation -------- Useful utilities for managing a MongoDB instance written in Go. - bsondump - display BSON files in a human-readable format - mongoimport - Convert data from JSON, TSV or CSV and insert them into a collection - mongoexport - Write an existing collection to CSV or JSON format - mongodump/mongorestore - Dump MongoDB backups to disk in .BSON format, or restore them to a live database - mongostat - Monitor live MongoDB servers, replica sets, or sharded clusters - mongofiles - Read, write, delete, or update files in GridFS - mongotop - Monitor read/write activity on a mongo server WWW: https://github.com/mongodb/mongo-tools WWW: https://docs.mongodb.com/database-tools/ PR: 249426 Submitted by: Ronald Klop <ronald-lists@klop.ws>
Notes
Notes: svn path=/head/; revision=550139
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/mongodb-tools/Makefile64
-rw-r--r--databases/mongodb-tools/distinfo3
-rw-r--r--databases/mongodb-tools/pkg-descr15
-rw-r--r--databases/mongodb-tools/pkg-plist11
5 files changed, 94 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index cb6ba2719d8d..ef898d8f8fac 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -186,6 +186,7 @@
SUBDIR += mdbtools
SUBDIR += mdcached
SUBDIR += memcached
+ SUBDIR += mongodb-tools
SUBDIR += mongodb36
SUBDIR += mongodb36-tools
SUBDIR += mongodb40
diff --git a/databases/mongodb-tools/Makefile b/databases/mongodb-tools/Makefile
new file mode 100644
index 000000000000..3bf1080dae68
--- /dev/null
+++ b/databases/mongodb-tools/Makefile
@@ -0,0 +1,64 @@
+# $FreeBSD$
+
+PORTNAME= mongodb-tools
+DISTVERSION= 100.2.0
+CATEGORIES= databases
+
+MAINTAINER= ronald-lists@klop.ws
+COMMENT= Tools for MongoDB 4.4.x and up
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE.md
+
+ONLY_FOR_ARCHS= aarch64 amd64 armv7 i386
+ONLY_FOR_ARCHS_REASON= not yet ported to other architectures
+
+USES= compiler:c++14-lang go localbase
+USE_GITHUB= yes
+GH_ACCOUNT= mongodb
+GH_PROJECT= mongo-tools
+
+GO_BUILDFLAGS= -tags "${USE_MY_TAGS}"
+GO_PKGNAME= github.com/${GH_ACCOUNT}/${GH_PROJECT}
+
+CONFLICTS_INSTALL= mongodb36-tools mongodb4[02]-tools
+
+OPTIONS_DEFINE= DOCS
+OPTIONS_DEFAULT= BSONDUMP MONGODUMP MONGOEXPORT MONGOFILES MONGOIMPORT \
+ MONGORESTORE MONGOSTAT MONGOTOP \
+ SASL SSL
+OPTIONS_MULTI= SECURITY TOOLS
+OPTIONS_MULTI_TOOLS= BSONDUMP MONGODUMP MONGOEXPORT MONGOFILES MONGOIMPORT \
+ MONGORESTORE MONGOSTAT MONGOTOP
+OPTIONS_MULTI_SECURITY= SASL SSL
+OPTIONS_SUB= yes
+
+BSONDUMP_DESC= BSON files into human-readable formats
+MONGOSTAT_DESC= Status of a running mongod or mongos instance
+MONGOFILES_DESC= Interface to GridFS in a MongoDB instance
+MONGOEXPORT_DESC= JSON or CSV export of MongoDB instance data
+MONGOIMPORT_DESC= Importing JSON, CSV, or TSV into a MongoDB instance
+MONGORESTORE_DESC= BSON data to a MongoDB instance
+MONGODUMP_DESC= BSON data from the contents of a MongoDB instance
+MONGOTOP_DESC= Track the amount of data I/O time
+
+BSONDUMP_VARS= go_target+=./bsondump/main:bsondump
+MONGOSTAT_VARS= go_target+=./mongostat/main:mongostat
+MONGOFILES_VARS= go_target+=./mongofiles/main:mongofiles
+MONGOEXPORT_VARS= go_target+=./mongoexport/main:mongoexport
+MONGOIMPORT_VARS= go_target+=./mongoimport/main:mongoimport
+MONGORESTORE_VARS= go_target+=./mongorestore/main:mongorestore
+MONGODUMP_VARS= go_target+=./mongodump/main:mongodump
+MONGOTOP_VARS= go_target+=./mongotop/main:mongotop
+SASL_LIB_DEPENDS= libsasl2.so:security/cyrus-sasl2
+SASL_USE= my_tags=sasl
+SSL_USES= ssl
+SSL_USE= my_tags=ssl
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+.for doc in README.md CONTRIBUTING.md THIRD-PARTY-NOTICES
+ ${INSTALL_MAN} ${WRKSRC}/${doc} ${STAGEDIR}${DOCSDIR}
+.endfor
+
+.include <bsd.port.mk>
diff --git a/databases/mongodb-tools/distinfo b/databases/mongodb-tools/distinfo
new file mode 100644
index 000000000000..3cc073acc47b
--- /dev/null
+++ b/databases/mongodb-tools/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1601054275
+SHA256 (mongodb-mongo-tools-100.2.0_GH0.tar.gz) = f6f92b11f9e714ed2eb6a17d823a71537ca6736237262110ebce210326fd4346
+SIZE (mongodb-mongo-tools-100.2.0_GH0.tar.gz) = 27400186
diff --git a/databases/mongodb-tools/pkg-descr b/databases/mongodb-tools/pkg-descr
new file mode 100644
index 000000000000..d08897727372
--- /dev/null
+++ b/databases/mongodb-tools/pkg-descr
@@ -0,0 +1,15 @@
+Useful utilities for managing a MongoDB instance written in Go.
+
+- bsondump - display BSON files in a human-readable format
+- mongoimport - Convert data from JSON, TSV or CSV and insert them
+ into a collection
+- mongoexport - Write an existing collection to CSV or JSON format
+- mongodump/mongorestore - Dump MongoDB backups to disk in .BSON
+ format, or restore them to a live database
+- mongostat - Monitor live MongoDB servers, replica sets, or sharded
+ clusters
+- mongofiles - Read, write, delete, or update files in GridFS
+- mongotop - Monitor read/write activity on a mongo server
+
+WWW: https://github.com/mongodb/mongo-tools
+WWW: https://docs.mongodb.com/database-tools/
diff --git a/databases/mongodb-tools/pkg-plist b/databases/mongodb-tools/pkg-plist
new file mode 100644
index 000000000000..25bedf0601db
--- /dev/null
+++ b/databases/mongodb-tools/pkg-plist
@@ -0,0 +1,11 @@
+%%BSONDUMP%%bin/bsondump
+%%MONGODUMP%%bin/mongodump
+%%MONGOEXPORT%%bin/mongoexport
+%%MONGOFILES%%bin/mongofiles
+%%MONGOIMPORT%%bin/mongoimport
+%%MONGORESTORE%%bin/mongorestore
+%%MONGOSTAT%%bin/mongostat
+%%MONGOTOP%%bin/mongotop
+%%PORTDOCS%%%%DOCSDIR%%/README.md
+%%PORTDOCS%%%%DOCSDIR%%/CONTRIBUTING.md
+%%PORTDOCS%%%%DOCSDIR%%/THIRD-PARTY-NOTICES