aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-02-12 19:26:43 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-02-12 19:26:43 +0000
commitc9fa3470640d11aefe6f94e2fe859701f01f9d42 (patch)
tree9141311f5d0e9917d83a997715cfee677c2f24a4 /databases
parent115f6521a7a83697efc16e5d607dd0d5d59b18a7 (diff)
downloadports-c9fa3470640d11aefe6f94e2fe859701f01f9d42.tar.gz
ports-c9fa3470640d11aefe6f94e2fe859701f01f9d42.zip
Notes
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/pgsphere/Makefile41
-rw-r--r--databases/pgsphere/distinfo3
-rw-r--r--databases/pgsphere/pkg-descr3
4 files changed, 48 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 4ae808a4e12b..d036e9277537 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -470,6 +470,7 @@
SUBDIR += pgpool-II
SUBDIR += pgpool-II-22
SUBDIR += pgpoolAdmin
+ SUBDIR += pgsphere
SUBDIR += pgtcl
SUBDIR += pgtop
SUBDIR += pgtune
diff --git a/databases/pgsphere/Makefile b/databases/pgsphere/Makefile
new file mode 100644
index 000000000000..34fa0264b131
--- /dev/null
+++ b/databases/pgsphere/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: pgsphere
+# Date created: 2010-02-09
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@sunpoet.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pgsphere
+PORTVERSION= 1.1.1
+CATEGORIES= databases geography
+MASTER_SITES= http://pgfoundry.org/frs/download.php/2558/ \
+ http://sunpoet.net/distfiles/
+
+MAINTAINER= sunpoet@sunpoet.net
+COMMENT= Spherical data types, functions, and operators for PostgreSQL
+
+DATADIR= ${PREFIX}/share/postgresql
+DOCSDIR?= ${PREFIX}/share/doc/postgresql
+
+USE_GMAKE= yes
+USE_LDCONFIG= yes
+USE_PGSQL= yes
+
+MAKE_ARGS+= PG_CONFIG=${LOCALBASE}/bin/pg_config USE_PGXS=1 docdir=${DOCSDIR}
+.if defined(NOPORTDOCS)
+MAKE_ARGS+= DOCS=""
+.endif
+
+PLIST_FILES= lib/postgresql/pg_sphere.so \
+ %%DATADIR%%/contrib/pg_sphere.sql \
+ %%DOCSDIR%%/contrib/README.pg_sphere \
+ %%DOCSDIR%%/contrib/COPYRIGHT.pg_sphere
+
+PLIST_DIRS= %%DOCSDIR%%/contrib \
+ %%DATADIR%%/contrib
+
+#regression-test:
+# @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_ARGS} installcheck
+
+.include <bsd.port.mk>
+
diff --git a/databases/pgsphere/distinfo b/databases/pgsphere/distinfo
new file mode 100644
index 000000000000..d8fbcadfead2
--- /dev/null
+++ b/databases/pgsphere/distinfo
@@ -0,0 +1,3 @@
+MD5 (pgsphere-1.1.1.tar.gz) = 5920835ef432c5b8925d16957121f940
+SHA256 (pgsphere-1.1.1.tar.gz) = 524225536e75e3c6ec48890502a7bdc8023563dc6eb320f3ef26f995bd90ab10
+SIZE (pgsphere-1.1.1.tar.gz) = 449970
diff --git a/databases/pgsphere/pkg-descr b/databases/pgsphere/pkg-descr
new file mode 100644
index 000000000000..5df29c27368f
--- /dev/null
+++ b/databases/pgsphere/pkg-descr
@@ -0,0 +1,3 @@
+pgSphere provides spherical data types, functions, and operators for PostgreSQL.
+
+WWW: http://pgsphere.projects.postgresql.org/