aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-04-23 14:20:25 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-04-23 14:20:25 +0000
commit992586fa0863f8346a19cbcdfbba376c5c4dfd43 (patch)
tree87b239f8431cee200969f89da8739806496b7dad /databases
parentdc0ce8f5839343b4c972ae818337189b1b55d447 (diff)
downloadports-992586fa0863f8346a19cbcdfbba376c5c4dfd43.tar.gz
ports-992586fa0863f8346a19cbcdfbba376c5c4dfd43.zip
Notes
Diffstat (limited to 'databases')
-rw-r--r--databases/mydumper/Makefile3
-rw-r--r--databases/mysqlcppapi/Makefile9
-rw-r--r--databases/rrdtool10/Makefile2
-rw-r--r--databases/sqlite2/Makefile2
-rw-r--r--databases/sqlite3/Makefile2
-rw-r--r--databases/tdb/Makefile2
6 files changed, 7 insertions, 13 deletions
diff --git a/databases/mydumper/Makefile b/databases/mydumper/Makefile
index c4428b0cb80e..595f7c5917c5 100644
--- a/databases/mydumper/Makefile
+++ b/databases/mydumper/Makefile
@@ -19,9 +19,8 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:S/a//}
FETCH_ARGS?= -pRr
PLIST_FILES= sbin/mydumper sbin/myloader
USE_GNOME= glib20
-USE_PKGCONFIG= build
USE_MYSQL= yes
-USES= cmake
+USES= cmake pkgconfig
post-patch:
@${REINPLACE_CMD} -e 's|-Werror||' ${WRKSRC}/CMakeLists.txt
diff --git a/databases/mysqlcppapi/Makefile b/databases/mysqlcppapi/Makefile
index 92980147642f..7bf86a8d78db 100644
--- a/databases/mysqlcppapi/Makefile
+++ b/databases/mysqlcppapi/Makefile
@@ -1,9 +1,5 @@
-# ports collection makefile for: mysqlcppapi
-# Date created: 4 August 2004
-# Whom: Jie Gao <gaoj@cpsc.ucalgary.ca>
-#
+# Created by: Jie Gao <gaoj@cpsc.ucalgary.ca>
# $FreeBSD$
-#
PORTNAME= mysqlcppapi
PORTVERSION= 1.9.3
@@ -16,8 +12,7 @@ COMMENT= A fork of mysql++ C++ API for MySQL
USE_AUTOTOOLS= libtool
USE_MYSQL= yes
-USES= pathfix
-USE_PKGCONFIG= yes
+USES= pathfix pkgconfig
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/databases/rrdtool10/Makefile b/databases/rrdtool10/Makefile
index 110adb441505..81bc812a2b24 100644
--- a/databases/rrdtool10/Makefile
+++ b/databases/rrdtool10/Makefile
@@ -16,7 +16,7 @@ MAKE_ENV= PERL=${PERL}
CONFLICTS= rrdtool-1.2*
LATEST_LINK= rrdtool10
-USE_PKGCONFIG= build
+USES= pkgconfig
USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
CONFIGURE_ARGS= --enable-shared --enable-local-zlib \
diff --git a/databases/sqlite2/Makefile b/databases/sqlite2/Makefile
index c649c9bdd24b..49da7d0de48a 100644
--- a/databases/sqlite2/Makefile
+++ b/databases/sqlite2/Makefile
@@ -10,10 +10,10 @@ MASTER_SITES= http://www.sqlite.org/
MAINTAINER= ports@FreeBSD.org
COMMENT= An SQL database engine in a C library
+USES= pkgconfig
USE_GMAKE= YES
USE_AUTOTOOLS= libtool
USE_LDCONFIG= YES
-USE_PKGCONFIG= yes
CONFIGURE_ARGS= --prefix=${PREFIX} --with-hints=freebsd.hints
diff --git a/databases/sqlite3/Makefile b/databases/sqlite3/Makefile
index 64096bb8f62e..b0e770bd79a8 100644
--- a/databases/sqlite3/Makefile
+++ b/databases/sqlite3/Makefile
@@ -17,7 +17,7 @@ LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
CONFLICTS= sqlite34-[0-9]* sqlcipher-[0-9]*
-USE_PKGCONFIG= build
+USES= pkgconfig
USE_LDCONFIG= YES
GNU_CONFIGURE= YES
diff --git a/databases/tdb/Makefile b/databases/tdb/Makefile
index a58bf916bc13..4422d8496fe1 100644
--- a/databases/tdb/Makefile
+++ b/databases/tdb/Makefile
@@ -20,7 +20,7 @@ USE_LDCONFIG= yes
HAS_CONFIGURE= yes
WAF_TOOL= buildtools/bin/waf
CONFIGURE_SCRIPT= ${WAF_TOOL} configure
-USE_PKGCONFIG= build
+USES= pkgconfig
MAKE_JOBS_SAFE= yes