aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2018-12-31 13:37:58 +0000
committerRene Ladan <rene@FreeBSD.org>2018-12-31 13:37:58 +0000
commitd1a5353b9cccb568b52fb525175941ad0b8a0345 (patch)
tree25abb8f5b9cdfd31fb9d446791a87606bf77ff0b /databases
parentd460c1a711a6e1319160cba021ecc281f1e4fc70 (diff)
downloadports-d1a5353b9cccb568b52fb525175941ad0b8a0345.tar.gz
ports-d1a5353b9cccb568b52fb525175941ad0b8a0345.zip
Notes
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile2
-rw-r--r--databases/mongodb32-tools/Makefile71
-rw-r--r--databases/mongodb32-tools/distinfo3
-rw-r--r--databases/mongodb32-tools/files/patch-vendor_src_github.com_spacemonkeygo_openssl_build.go9
-rw-r--r--databases/mongodb32-tools/files/patch-vendor_src_github.com_spacemonkeygo_openssl_init__posix.go11
-rw-r--r--databases/mongodb32-tools/pkg-descr6
-rw-r--r--databases/mongodb32-tools/pkg-plist12
-rw-r--r--databases/mongodb32/Makefile96
-rw-r--r--databases/mongodb32/distinfo3
-rw-r--r--databases/mongodb32/files/mongod.in63
-rw-r--r--databases/mongodb32/files/patch-SConstruct15
-rw-r--r--databases/mongodb32/files/patch-pcre311
-rw-r--r--databases/mongodb32/files/patch-rpm_mongod.conf31
-rw-r--r--databases/mongodb32/pkg-descr5
-rw-r--r--databases/mongodb32/pkg-plist6
15 files changed, 0 insertions, 644 deletions
diff --git a/databases/Makefile b/databases/Makefile
index d48a483c7781..ff2c49249d0b 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -200,8 +200,6 @@
SUBDIR += memcacheq
SUBDIR += metakit
SUBDIR += monetdb
- SUBDIR += mongodb32
- SUBDIR += mongodb32-tools
SUBDIR += mongodb34
SUBDIR += mongodb34-tools
SUBDIR += mongodb36
diff --git a/databases/mongodb32-tools/Makefile b/databases/mongodb32-tools/Makefile
deleted file mode 100644
index 0add98e2266e..000000000000
--- a/databases/mongodb32-tools/Makefile
+++ /dev/null
@@ -1,71 +0,0 @@
-# Created by: Brendan Molloy <brendan+freebsd@bbqsrc.net>
-# $FreeBSD$
-
-PORTNAME= mongodb32-tools
-PORTVERSION= 3.2.11
-DISTVERSIONPREFIX= r
-CATEGORIES= databases net
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Tools for MongoDB
-
-LICENSE= APACHE20
-
-DEPRECATED= EOL upstream since September 2018
-EXPIRATION_DATE=2018-12-31
-
-BROKEN_SSL= openssl111 libressl libressl-devel
-BROKEN_SSL_REASON_openssl111= variable has incomplete type 'BIO_METHOD' (aka 'struct bio_method_st')
-BROKEN_SSL_REASON_libressl= could not determine kind of name for C.EVP_sha
-BROKEN_SSL_REASON_libressl-devel= ${BROKEN_SSL_REASON_libressl}
-
-BUILD_DEPENDS= go>0:lang/go
-
-USE_GITHUB= yes
-GH_ACCOUNT= mongodb
-GH_PROJECT= mongo-tools
-
-OPTIONS_DEFINE= SSL SASL DOCS
-OPTIONS_DEFAULT= SSL
-
-SASL_USE= my_tags=sasl
-SASL_LIB_DEPENDS= libsasl2.so:security/cyrus-sasl2
-
-SSL_USES= ssl
-SSL_USE= my_tags=ssl
-
-ONLY_FOR_ARCHS= i386 amd64
-ONLY_FOR_ARCHS_REASON= "not yet ported to anything other than i386 and amd64"
-
-# Go is not our friend. Without below, ignores user-supplied flags.
-MAKE_CMD= ${LOCALBASE}/bin/go build
-MAKE_ENV= GOPATH="${WRKSRC}/.gopath:${WRKSRC}/vendor" \
- CGO_CFLAGS="${CFLAGS}" CGO_CPPFLAGS="${CPPFLAGS}" \
- CGO_CXXFLAGS="${CXXFLAGS}" CGO_LDFLAGS="${LDFLAGS}"
-
-USES= localbase
-MY_TAGS= -tags "${USE_MY_TAGS}"
-
-post-patch:
- @cd ${WRKSRC} ; ${MKDIR} ${WRKSRC}/.gopath/src/github.com/${GH_ACCOUNT} ; \
- ${LN} -sf ${WRKSRC} ${WRKSRC}/.gopath/src/github.com/${GH_ACCOUNT}/${GH_PROJECT}
-
-do-build:
-.for x in bsondump mongostat mongofiles mongoexport mongoimport mongorestore mongodump mongotop mongooplog
- ${SETENV} ${MAKE_ENV} ${MAKE_CMD} \
- -o ${WRKSRC}/bin/${x} ${MY_TAGS}\
- -ldflags "-X github.com/${GH_ACCOUNT}/${GH_PROJECT}/common/options.Gitspec=${GH_TAGNAME}"\
- ${WRKSRC}/${x}/main/${x}.go
-.endfor
-
-do-install:
-.for x in bsondump mongostat mongofiles mongoexport mongoimport mongorestore mongodump mongotop mongooplog
- ${INSTALL_PROGRAM} ${WRKSRC}/bin/${x} ${STAGEDIR}${PREFIX}/bin/
-.endfor
-
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
-.for x in LICENSE.md README.md THIRD-PARTY-NOTICES
- ${INSTALL_MAN} ${WRKSRC}/${x} ${STAGEDIR}${DOCSDIR}
-.endfor
-
-.include <bsd.port.mk>
diff --git a/databases/mongodb32-tools/distinfo b/databases/mongodb32-tools/distinfo
deleted file mode 100644
index ff48e9affd4e..000000000000
--- a/databases/mongodb32-tools/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-TIMESTAMP = 1480077778
-SHA256 (mongodb-mongo-tools-r3.2.11_GH0.tar.gz) = 992e9fb94df6bed49e68684afee096f1193dc9cfca8ce8bcc4c912996bba365c
-SIZE (mongodb-mongo-tools-r3.2.11_GH0.tar.gz) = 2712014
diff --git a/databases/mongodb32-tools/files/patch-vendor_src_github.com_spacemonkeygo_openssl_build.go b/databases/mongodb32-tools/files/patch-vendor_src_github.com_spacemonkeygo_openssl_build.go
deleted file mode 100644
index 6e35a6a6149f..000000000000
--- a/databases/mongodb32-tools/files/patch-vendor_src_github.com_spacemonkeygo_openssl_build.go
+++ /dev/null
@@ -1,9 +0,0 @@
---- vendor/src/github.com/spacemonkeygo/openssl/build.go.orig 2016-08-30 17:14:55 UTC
-+++ vendor/src/github.com/spacemonkeygo/openssl/build.go
-@@ -19,5 +19,6 @@ package openssl
- // #cgo linux pkg-config: openssl
- // #cgo windows CFLAGS: -DWIN32_LEAN_AND_MEAN
- // #cgo darwin CFLAGS: -Wno-deprecated-declarations
-+// #cgo freebsd LDFLAGS: -lssl -lcrypto
- // #cgo darwin LDFLAGS: -lssl -lcrypto
- import "C"
diff --git a/databases/mongodb32-tools/files/patch-vendor_src_github.com_spacemonkeygo_openssl_init__posix.go b/databases/mongodb32-tools/files/patch-vendor_src_github.com_spacemonkeygo_openssl_init__posix.go
deleted file mode 100644
index 17dc773143bf..000000000000
--- a/databases/mongodb32-tools/files/patch-vendor_src_github.com_spacemonkeygo_openssl_init__posix.go
+++ /dev/null
@@ -1,11 +0,0 @@
---- vendor/src/github.com/spacemonkeygo/openssl/init_posix.go.orig 2016-01-03 17:52:58 UTC
-+++ vendor/src/github.com/spacemonkeygo/openssl/init_posix.go
-@@ -12,7 +12,7 @@
- // See the License for the specific language governing permissions and
- // limitations under the License.
-
--// +build linux darwin cgo
-+// +build linux darwin freebsd cgo
- // +build !windows
-
- package openssl
diff --git a/databases/mongodb32-tools/pkg-descr b/databases/mongodb32-tools/pkg-descr
deleted file mode 100644
index 0894b03e17d7..000000000000
--- a/databases/mongodb32-tools/pkg-descr
+++ /dev/null
@@ -1,6 +0,0 @@
-Since MongoDB 3.2, the tools bsondump, mongoimport, mongoexport, mongodump,
-mongorestore, mongostat, mongofiles, mongooplog and mongotop have been placed
-in a separate package and rewritten in Go. These are useful utilities for
-managing a MongoDB instance.
-
-WWW: https://github.com/mongodb/mongo-tools
diff --git a/databases/mongodb32-tools/pkg-plist b/databases/mongodb32-tools/pkg-plist
deleted file mode 100644
index 07389cef6136..000000000000
--- a/databases/mongodb32-tools/pkg-plist
+++ /dev/null
@@ -1,12 +0,0 @@
-bin/bsondump
-bin/mongodump
-bin/mongoexport
-bin/mongofiles
-bin/mongoimport
-bin/mongooplog
-bin/mongorestore
-bin/mongostat
-bin/mongotop
-%%PORTDOCS%%%%DOCSDIR%%/LICENSE.md
-%%PORTDOCS%%%%DOCSDIR%%/README.md
-%%PORTDOCS%%%%DOCSDIR%%/THIRD-PARTY-NOTICES
diff --git a/databases/mongodb32/Makefile b/databases/mongodb32/Makefile
deleted file mode 100644
index a6729d306853..000000000000
--- a/databases/mongodb32/Makefile
+++ /dev/null
@@ -1,96 +0,0 @@
-# Created by: Brendan Molloy <brendan+freebsd@bbqsrc.net>
-# $FreeBSD$
-
-PORTNAME= mongodb32
-PORTVERSION= 3.2.11
-PORTREVISION= 2
-DISTVERSIONPREFIX= r
-CATEGORIES= databases net
-MASTER_SITES= https://fastdl.mongodb.org/src/ \
- http://fastdl.mongodb.org/src/ \
- http://download.mongodb.org/src/
-DISTNAME= mongodb-src-${DISTVERSIONPREFIX}${PORTVERSION}
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Distributed document-oriented "NoSQL" database
-
-# mongodb is AGPLv3, C++ driver is APACHE20
-LICENSE= AGPLv3 APACHE20
-LICENSE_COMB= multi
-
-DEPRECATED= EOL upstream since September 2018
-EXPIRATION_DATE=2018-12-31
-
-BROKEN_SSL= openssl111
-BROKEN_SSL_REASON_openssl111= variable has incomplete type 'EVP_MD_CTX' (aka 'evp_md_ctx_st')
-LIB_DEPENDS= libpcre.so:devel/pcre \
- libsnappy.so:archivers/snappy
-TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}yaml>=3.11:devel/py-yaml@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pymongo>=3.0:databases/pymongo@${PY_FLAVOR}
-
-CHOSEN_COMPILER_TYPE= clang
-
-ONLY_FOR_ARCHS= amd64
-ONLY_FOR_ARCHS_REASON= "Only supported on amd64 (i386 deprecated in v3)"
-
-CONFLICTS_BUILD= mongo-cxx-driver
-OPTIONS_DEFINE= SASL SSL
-OPTIONS_DEFAULT= SASL SSL
-
-SASL_LIB_DEPENDS= libsasl2.so:security/cyrus-sasl2
-SASL_MAKE_ARGS= --use-sasl-client
-
-SSL_USE= yes
-SSL_MAKE_ARGS= --ssl
-
-USES= compiler cpe python:build scons
-
-MAKE_ARGS= --prefix=${STAGEDIR}${PREFIX} \
- --use-system-pcre --use-system-snappy \
- --release
-
-USERS= mongodb
-GROUPS= mongodb
-
-USE_RC_SUBR= mongod
-
-.include <bsd.port.options.mk>
-
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1200057
-SUB_LIST+= LEGACY_LIMITS="@comment " MODERN_LIMITS=""
-.else
-SUB_LIST+= LEGACY_LIMITS="" MODERN_LIMITS="@comment "
-.endif
-
-ALL_TARGET= core
-TEST_TARGET= unittests
-
-.include <bsd.port.pre.mk>
-
-# Bugs when compiled with < Clang 3.7
-# - https://jira.mongodb.org/browse/SERVER-21217
-# - https://jira.mongodb.org/browse/SERVER-22740
-.if ${COMPILER_TYPE} == clang && ${COMPILER_VERSION} < 37
-BUILD_DEPENDS+= ${LOCALBASE}/bin/clang40:devel/llvm40
-CPP= ${LOCALBASE}/bin/clang-cpp40
-CC= ${LOCALBASE}/bin/clang40
-CXX= ${LOCALBASE}/bin/clang++40
-.endif
-
-post-install:
-.for f in mongo mongod mongoperf mongos mongosniff
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${f}
-.endfor
- ${CP} ${WRKSRC}/rpm/mongod.conf ${STAGEDIR}${PREFIX}/etc/mongodb.conf.sample
-
-do-test:
- @cd ${BUILD_WRKSRC} && ${SETENV} ${MAKE_ENV} \
- ${MAKE_CMD} ${_MAKE_JOBS} ${MAKE_ARGS} ${TEST_TARGET} &&\
- ${PYTHON_CMD} ${BUILD_WRKSRC}/buildscripts/resmoke.py\
- --suites=unittests --jobs=${MAKE_JOBS_NUMBER}
-
-PORTSCOUT= limitw:1,even
-
-CPE_PRODUCT= mongodb
-
-.include <bsd.port.post.mk>
diff --git a/databases/mongodb32/distinfo b/databases/mongodb32/distinfo
deleted file mode 100644
index 1164d458bf01..000000000000
--- a/databases/mongodb32/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-TIMESTAMP = 1480077698
-SHA256 (mongodb-src-r3.2.11.tar.gz) = 625eb28fd47b2af63b30343a064de7f42e5265f4c642874ec766ba3643fd80d7
-SIZE (mongodb-src-r3.2.11.tar.gz) = 29113706
diff --git a/databases/mongodb32/files/mongod.in b/databases/mongodb32/files/mongod.in
deleted file mode 100644
index 94a538b46668..000000000000
--- a/databases/mongodb32/files/mongod.in
+++ /dev/null
@@ -1,63 +0,0 @@
-#!/bin/sh
-
-# PROVIDE: mongod
-# REQUIRE: NETWORK ldconfig
-# KEYWORD: shutdown
-#
-# Add the following lines to /etc/rc.conf.local or /etc/rc.conf
-# to enable this service:
-#
-# mongod_enable (bool): Set to "NO" by default.
-# Set it to "YES" to enable mongod.
-%%LEGACY_LIMITS%%# mongod_limits (bool): Set to "NO" by default.
-%%LEGACY_LIMITS%%# Set it to yes to run `limits -e -U mongodb`
-%%LEGACY_LIMITS%%# just before mongod starts.
-# mongod_dbpath (str): Default to "/var/db/mongodb"
-# Base database directory.
-# mongod_flags (str): Custom additional arguments to be passed to mongod.
-# Default to "--logpath ${mongod_dbpath}/mongod.log --logappend".
-# mongod_config (str): Default to "%%PREFIX%%/etc/mongodb.conf"
-# Path to config file
-#
-
-. /etc/rc.subr
-
-name="mongod"
-rcvar=mongod_enable
-
-load_rc_config $name
-
-: ${mongod_enable="NO"}
-%%LEGACY_LIMITS%%: ${mongod_limits="NO"}
-: ${mongod_dbpath="/var/db/mongodb"}
-: ${mongod_flags="--logpath ${mongod_dbpath}/mongod.log --logappend"}
-: ${mongod_user="mongodb"}
-: ${mongod_group="mongodb"}
-: ${mongod_config="%%PREFIX%%/etc/mongodb.conf"}
-
-pidfile="${mongod_dbpath}/mongod.lock"
-command=%%PREFIX%%/bin/${name}
-command_args="--config $mongod_config --dbpath $mongod_dbpath --fork >/dev/null 2>/dev/null"
-start_precmd="${name}_prestart"
-
-mongod_create_dbpath()
-{
- mkdir ${mongod_dbpath} >/dev/null 2>/dev/null
- [ $? -eq 0 ] && chown -R ${mongod_user}:${mongod_group} ${mongod_dbpath}
-}
-
-
-mongod_prestart()
-{
- if [ ! -d ${mongod_dbpath} ]; then
- mongod_create_dbpath || return 1
- fi
-%%LEGACY_LIMITS%% if checkyesno mongod_limits; then
-%%LEGACY_LIMITS%% eval `/usr/bin/limits -e -U ${mongod_user}` 2>/dev/null
-%%LEGACY_LIMITS%% else
-%%LEGACY_LIMITS%% return 0
-%%LEGACY_LIMITS%% fi
-%%MODERN_LIMITS%% return 0
-}
-
-run_rc_command "$1"
diff --git a/databases/mongodb32/files/patch-SConstruct b/databases/mongodb32/files/patch-SConstruct
deleted file mode 100644
index 0fcfc03ac7de..000000000000
--- a/databases/mongodb32/files/patch-SConstruct
+++ /dev/null
@@ -1,15 +0,0 @@
---- SConstruct.orig 2015-12-02 19:01:34 UTC
-+++ SConstruct
-@@ -840,9 +840,9 @@ if has_option('variables-help'):
- print env_vars.GenerateHelpText(env)
- Exit(0)
-
--unknown_vars = env_vars.UnknownVariables()
--if unknown_vars:
-- env.FatalError("Unknown variables specified: {0}", ", ".join(unknown_vars.keys()))
-+#unknown_vars = env_vars.UnknownVariables()
-+#if unknown_vars:
-+# env.FatalError("Unknown variables specified: {0}", ", ".join(unknown_vars.keys()))
-
- def set_config_header_define(env, varname, varval = 1):
- env['CONFIG_HEADER_DEFINES'][varname] = varval
diff --git a/databases/mongodb32/files/patch-pcre b/databases/mongodb32/files/patch-pcre
deleted file mode 100644
index c0b79532f490..000000000000
--- a/databases/mongodb32/files/patch-pcre
+++ /dev/null
@@ -1,311 +0,0 @@
-From 18f4c63869a32426bd33235a8cf51f06809a1b6b Mon Sep 17 00:00:00 2001
-From: Steven Green <steven@greenius.co.uk>
-Date: Tue, 22 Aug 2017 13:08:48 -0400
-Subject: [PATCH] SERVER-30166 Replace string with explicit std::string.
- Enables compulation when using --use-system-pcre which presusably used to do
- 'using std::string' in an earlier version of pcre
-
-Closes #1167
-
-Signed-off-by: Mark Benvenuto <mark.benvenuto@mongodb.com>
-(cherry picked from commit b7cebf82bc5e5572308cc3a3fb958a825db91498)
----
- src/mongo/db/dbwebserver.cpp | 1 +
- src/mongo/db/matcher/expression_leaf.cpp | 4 +-
- src/mongo/db/repl/master_slave.cpp | 41 ++--
- .../sharding_catalog_create_database_test.cpp | 216 +++++++++++++++++++++
- src/mongo/shell/bench.cpp | 14 +-
- src/mongo/util/net/miniwebserver.cpp | 1 +
- 6 files changed, 248 insertions(+), 29 deletions(-)
- create mode 100644 src/mongo/s/catalog/sharding_catalog_create_database_test.cpp
-
-diff --git a/src/mongo/db/dbwebserver.cpp b/src/mongo/db/dbwebserver.cpp
-index bee10b95a5b..055ce27aacf 100644
---- src/mongo/db/dbwebserver.cpp
-+++ src/mongo/db/dbwebserver.cpp
-@@ -67,6 +67,7 @@
- namespace mongo {
-
- using std::map;
-+using std::string;
- using std::stringstream;
- using std::vector;
-
-diff --git a/src/mongo/db/matcher/expression_leaf.cpp b/src/mongo/db/matcher/expression_leaf.cpp
-index cfcd3d03591..5b658640578 100644
---- src/mongo/db/matcher/expression_leaf.cpp
-+++ src/mongo/db/matcher/expression_leaf.cpp
-@@ -200,7 +200,7 @@ void ComparisonMatchExpression::debugString(StringBuilder& debug, int level) con
- }
-
- void ComparisonMatchExpression::toBSON(BSONObjBuilder* out) const {
-- string opString = "";
-+ std::string opString = "";
- switch (matchType()) {
- case LT:
- opString = "$lt";
-@@ -880,7 +880,7 @@ void BitTestMatchExpression::debugString(StringBuilder& debug, int level) const
- }
-
- void BitTestMatchExpression::toBSON(BSONObjBuilder* out) const {
-- string opString = "";
-+ std::string opString = "";
-
- switch (matchType()) {
- case BITS_ALL_SET:
-diff --git a/src/mongo/shell/bench.cpp b/src/mongo/shell/bench.cpp
-index d7503c4d689..3a60f351758 100644
---- src/mongo/shell/bench.cpp
-+++ src/mongo/shell/bench.cpp
-@@ -674,7 +674,7 @@ void BenchRunWorker::generateLoadOnConnection(DBClientBase* conn) {
- invariant(bsonTemplateEvaluator.setId(_id) == BsonTemplateEvaluator::StatusSuccess);
-
- if (_config->username != "") {
-- string errmsg;
-+ std::string errmsg;
- if (!conn->auth("admin", _config->username, _config->password, errmsg)) {
- uasserted(15931, "Authenticating to connection for _benchThread failed: " + errmsg);
- }
-@@ -920,7 +920,7 @@ void BenchRunWorker::generateLoadOnConnection(DBClientBase* conn) {
-
- if (!result["err"].eoo() && result["err"].type() == String &&
- (_config->throwGLE || op.throwGLE))
-- throw DBException((string) "From benchRun GLE" +
-+ throw DBException((std::string) "From benchRun GLE" +
- causedBy(result["err"].String()),
- result["code"].eoo() ? 0 : result["code"].Int());
- }
-@@ -987,7 +987,7 @@ void BenchRunWorker::generateLoadOnConnection(DBClientBase* conn) {
-
- if (!result["err"].eoo() && result["err"].type() == String &&
- (_config->throwGLE || op.throwGLE))
-- throw DBException((string) "From benchRun GLE" +
-+ throw DBException((std::string) "From benchRun GLE" +
- causedBy(result["err"].String()),
- result["code"].eoo() ? 0 : result["code"].Int());
- }
-@@ -1035,7 +1035,7 @@ void BenchRunWorker::generateLoadOnConnection(DBClientBase* conn) {
-
- if (!result["err"].eoo() && result["err"].type() == String &&
- (_config->throwGLE || op.throwGLE))
-- throw DBException((string) "From benchRun GLE " +
-+ throw DBException((std::string) "From benchRun GLE " +
- causedBy(result["err"].String()),
- result["code"].eoo() ? 0 : result["code"].Int());
- }
-@@ -1136,7 +1136,7 @@ void BenchRunWorker::run() {
- try {
- std::unique_ptr<DBClientBase> conn(_config->createConnection());
- if (!_config->username.empty()) {
-- string errmsg;
-+ std::string errmsg;
- if (!conn->auth("admin", _config->username, _config->password, errmsg)) {
- uasserted(15932, "Authenticating to connection for benchThread failed: " + errmsg);
- }
-@@ -1168,7 +1168,7 @@ void BenchRunner::start() {
- std::unique_ptr<DBClientBase> conn(_config->createConnection());
- // Must authenticate to admin db in order to run serverStatus command
- if (_config->username != "") {
-- string errmsg;
-+ std::string errmsg;
- if (!conn->auth("admin", _config->username, _config->password, errmsg)) {
- uasserted(16704,
- str::stream()
-@@ -1204,7 +1204,7 @@ void BenchRunner::stop() {
- {
- std::unique_ptr<DBClientBase> conn(_config->createConnection());
- if (_config->username != "") {
-- string errmsg;
-+ std::string errmsg;
- // this can only fail if admin access was revoked since start of run
- if (!conn->auth("admin", _config->username, _config->password, errmsg)) {
- uasserted(16705,
-diff --git a/src/mongo/util/net/miniwebserver.cpp b/src/mongo/util/net/miniwebserver.cpp
-index fc86f95b24f..369f23f136a 100644
---- src/mongo/util/net/miniwebserver.cpp
-+++ src/mongo/util/net/miniwebserver.cpp
-@@ -43,6 +43,7 @@ namespace mongo {
-
- using std::shared_ptr;
- using std::endl;
-+using std::string;
- using std::stringstream;
- using std::vector;
-
---- src/mongo/db/repl/master_slave.cpp.orig
-+++ src/mongo/db/repl/master_slave.cpp
-@@ -161,7 +161,7 @@
-
- BSONObjBuilder dbsNextPassBuilder;
- int n = 0;
-- for (set<string>::iterator i = addDbNextPass.begin(); i != addDbNextPass.end(); i++) {
-+ for (set<std::string>::iterator i = addDbNextPass.begin(); i != addDbNextPass.end(); i++) {
- n++;
- dbsNextPassBuilder.appendBool(*i, 1);
- }
-@@ -170,7 +170,8 @@
-
- BSONObjBuilder incompleteCloneDbsBuilder;
- n = 0;
-- for (set<string>::iterator i = incompleteCloneDbs.begin(); i != incompleteCloneDbs.end(); i++) {
-+ for (set<std::string>::iterator i = incompleteCloneDbs.begin(); i != incompleteCloneDbs.end();
-+ i++) {
- n++;
- incompleteCloneDbsBuilder.appendBool(*i, 1);
- }
-@@ -181,7 +182,7 @@
- }
-
- void ReplSource::ensureMe(OperationContext* txn) {
-- string myname = getHostName();
-+ std::string myname = getHostName();
-
- // local.me is an identifier for a server for getLastError w:2+
- bool exists = Helpers::getSingleton(txn, "local.me", _me);
-@@ -373,10 +374,10 @@
- }
-
- virtual bool run(OperationContext* txn,
-- const string& ns,
-+ const std::string& ns,
- BSONObj& cmdObj,
- int options,
-- string& errmsg,
-+ std::string& errmsg,
- BSONObjBuilder& result) {
- HandshakeArgs handshake;
- Status status = handshake.initialize(cmdObj);
-@@ -393,7 +394,7 @@
- } handshakeCmd;
-
- bool replHandshake(DBClientConnection* conn, const OID& myRID) {
-- string myname = getHostName();
-+ std::string myname = getHostName();
-
- BSONObjBuilder cmd;
- cmd.append("handshake", myRID);
-@@ -445,7 +446,7 @@
- BSONElement e = i.next();
- if (e.eoo())
- break;
-- string name = e.embeddedObject().getField("name").valuestr();
-+ std::string name = e.embeddedObject().getField("name").valuestr();
- if (!e.embeddedObject().getBoolField("empty")) {
- if (name != "local") {
- if (only.empty() || only == name) {
-@@ -459,7 +460,7 @@
- save(txn);
- }
-
--void ReplSource::resyncDrop(OperationContext* txn, const string& db) {
-+void ReplSource::resyncDrop(OperationContext* txn, const std::string& db) {
- log() << "resync: dropping database " << db;
- OldClientContext ctx(txn, db);
- dropDatabase(txn, ctx.db());
-@@ -502,13 +503,13 @@
-
- static DatabaseIgnorer ___databaseIgnorer;
-
--void DatabaseIgnorer::doIgnoreUntilAfter(const string& db, const Timestamp& futureOplogTime) {
-+void DatabaseIgnorer::doIgnoreUntilAfter(const std::string& db, const Timestamp& futureOplogTime) {
- if (futureOplogTime > _ignores[db]) {
- _ignores[db] = futureOplogTime;
- }
- }
-
--bool DatabaseIgnorer::ignoreAt(const string& db, const Timestamp& currentOplogTime) {
-+bool DatabaseIgnorer::ignoreAt(const std::string& db, const Timestamp& currentOplogTime) {
- if (_ignores[db].isNull()) {
- return false;
- }
-@@ -594,12 +595,12 @@
- }
-
- // Check for duplicates again, since we released the lock above.
-- set<string> duplicates;
-+ set<std::string> duplicates;
- Database::duplicateUncasedName(db, &duplicates);
-
- // The database is present on the master and no conflicting databases
- // are present on the master. Drop any local conflicts.
-- for (set<string>::const_iterator i = duplicates.begin(); i != duplicates.end(); ++i) {
-+ for (set<std::string>::const_iterator i = duplicates.begin(); i != duplicates.end(); ++i) {
- ___databaseIgnorer.doIgnoreUntilAfter(*i, lastTime);
- incompleteCloneDbs.erase(*i);
- addDbNextPass.erase(*i);
-@@ -794,10 +795,10 @@
- }
-
- void ReplSource::syncToTailOfRemoteLog() {
-- string _ns = ns();
-+ std::string _ns = ns();
- BSONObjBuilder b;
- if (!only.empty()) {
-- b.appendRegex("ns", string("^") + pcrecpp::RE::QuoteMeta(only));
-+ b.appendRegex("ns", std::string("^") + pcrecpp::RE::QuoteMeta(only));
- }
- BSONObj last = oplogReader.findOne(_ns.c_str(), Query(b.done()).sort(BSON("$natural" << -1)));
- if (!last.isEmpty()) {
-@@ -845,7 +846,7 @@
- */
- int ReplSource::_sync_pullOpLog(OperationContext* txn, int& nApplied) {
- int okResultCode = 1;
-- string ns = string("local.oplog.$") + sourceName();
-+ std::string ns = std::string("local.oplog.$") + sourceName();
- LOG(2) << "sync_pullOpLog " << ns << " syncedTo:" << syncedTo.toStringLong() << '\n';
-
- bool tailing = true;
-@@ -865,7 +866,7 @@
- BSONElement e = i.next();
- if (e.eoo())
- break;
-- string name = e.embeddedObject().getField("name").valuestr();
-+ std::string name = e.embeddedObject().getField("name").valuestr();
- if (!e.embeddedObject().getBoolField("empty")) {
- if (name != "local") {
- if (only.empty() || only == name) {
-@@ -889,7 +890,7 @@
- if (!only.empty()) {
- // note we may here skip a LOT of data table scanning, a lot of work for the master.
- // maybe append "\\." here?
-- query.appendRegex("ns", string("^") + pcrecpp::RE::QuoteMeta(only));
-+ query.appendRegex("ns", std::string("^") + pcrecpp::RE::QuoteMeta(only));
- }
- BSONObj queryObj = query.done();
- // e.g. queryObj = { ts: { $gte: syncedTo } }
-@@ -908,7 +909,7 @@
-
- // show any deferred database creates from a previous pass
- {
-- set<string>::iterator i = addDbNextPass.begin();
-+ set<std::string>::iterator i = addDbNextPass.begin();
- if (i != addDbNextPass.end()) {
- BSONObjBuilder b;
- b.append("ns", *i + '.');
-@@ -939,7 +940,7 @@
- BSONObj op = oplogReader.next();
- BSONElement ts = op.getField("ts");
- if (ts.type() != Date && ts.type() != bsonTimestamp) {
-- string err = op.getStringField("$err");
-+ std::string err = op.getStringField("$err");
- if (!err.empty()) {
- // 13051 is "tailable cursor requested on non capped collection"
- if (op.getIntField("code") == 13051) {
-@@ -1107,7 +1108,7 @@
-
- // FIXME Handle cases where this db isn't on default port, or default port is spec'd in
- // hostName.
-- if ((string("localhost") == hostName || string("127.0.0.1") == hostName) &&
-+ if ((std::string("localhost") == hostName || std::string("127.0.0.1") == hostName) &&
- serverGlobalParams.port == ServerGlobalParams::DefaultDBPort) {
- log() << "can't sync from self (localhost). sources configuration may be wrong." << endl;
- sleepsecs(5);
-@@ -1252,7 +1253,7 @@
- if (s) {
- stringstream ss;
- ss << "sleep " << s << " sec before next pass";
-- string msg = ss.str();
-+ std::string msg = ss.str();
- if (!serverGlobalParams.quiet)
- log() << msg << endl;
- ReplInfo r(msg.c_str());
diff --git a/databases/mongodb32/files/patch-rpm_mongod.conf b/databases/mongodb32/files/patch-rpm_mongod.conf
deleted file mode 100644
index 52159af5fb27..000000000000
--- a/databases/mongodb32/files/patch-rpm_mongod.conf
+++ /dev/null
@@ -1,31 +0,0 @@
---- rpm/mongod.conf.orig 2016-03-01 04:38:06 UTC
-+++ rpm/mongod.conf
-@@ -1,4 +1,4 @@
--# mongod.conf
-+# mongodb.conf
-
- # for documentation of all options, see:
- # http://docs.mongodb.org/manual/reference/configuration-options/
-@@ -7,11 +7,11 @@
- systemLog:
- destination: file
- logAppend: true
-- path: /var/log/mongodb/mongod.log
-+ path: /var/log/mongodb/log
-
- # Where and how to store data.
- storage:
-- dbPath: /var/lib/mongo
-+ dbPath: /var/db/mongo
- journal:
- enabled: true
- # engine:
-@@ -21,7 +21,7 @@ storage:
- # how the process runs
- processManagement:
- fork: true # fork and run in background
-- pidFilePath: /var/run/mongodb/mongod.pid # location of pidfile
-+ pidFilePath: /var/run/mongodb/pid # location of pidfile
-
- # network interfaces
- net:
diff --git a/databases/mongodb32/pkg-descr b/databases/mongodb32/pkg-descr
deleted file mode 100644
index 24f53e80363b..000000000000
--- a/databases/mongodb32/pkg-descr
+++ /dev/null
@@ -1,5 +0,0 @@
-Mongo (from "humongous") is a high-performance, open source,
-schema-free, document-oriented database. A common name in the
-"NOSQL" community.
-
-WWW: http://www.mongodb.org/
diff --git a/databases/mongodb32/pkg-plist b/databases/mongodb32/pkg-plist
deleted file mode 100644
index fbc480c26786..000000000000
--- a/databases/mongodb32/pkg-plist
+++ /dev/null
@@ -1,6 +0,0 @@
-@sample etc/mongodb.conf.sample
-bin/mongo
-bin/mongod
-bin/mongoperf
-bin/mongos
-bin/mongosniff