aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2010-11-12 04:13:08 +0000
committerBeech Rintoul <beech@FreeBSD.org>2010-11-12 04:13:08 +0000
commit0f5bcec2aabc8a89ebcee942698ad6138d754f08 (patch)
tree4a529d25343984c29c203d323824479a471f8c08 /databases
parentb9a070e69ab6787f67ae9e36770df3023d362dcb (diff)
downloadports-0f5bcec2aabc8a89ebcee942698ad6138d754f08.tar.gz
ports-0f5bcec2aabc8a89ebcee942698ad6138d754f08.zip
Notes
Diffstat (limited to 'databases')
-rw-r--r--databases/sqlite3/Makefile15
1 files changed, 13 insertions, 2 deletions
diff --git a/databases/sqlite3/Makefile b/databases/sqlite3/Makefile
index 2b78281d1169..7aa1b3e79549 100644
--- a/databases/sqlite3/Makefile
+++ b/databases/sqlite3/Makefile
@@ -7,6 +7,7 @@
PORTNAME= sqlite3
PORTVERSION= 3.7.3
+PORTREVISION= 1
CATEGORIES= databases
MASTER_SITES= http://www.sqlite.org/ http://www2.sqlite.org/
DISTNAME= sqlite-${PORTVERSION}
@@ -25,6 +26,7 @@ USE_GMAKE= YES
USE_GNOME= pkgconfig gnomehack
USE_LDCONFIG= YES
GNU_CONFIGURE= YES
+
USE_TCL_BUILD= 84+
CONFIGURE_ENV+= TCLSH_CMD="${TCLSH}" \
TCLLIBDIR="${PREFIX}/lib/${PORTNAME}" \
@@ -125,7 +127,7 @@ CFLAGS+= -DSQLITE_ENABLE_UNLOCK_NOTIFY=1
.if defined(WITH_TCLWRAPPER)
CATEGORIES+= lang tcl
COMMENT+= with TCL Wrapper
-USE_TCL_RUN= 84+
+USE_TCL_RUN= yes
ALL_TARGET= all tclsqlite3
INSTALL_TARGET= install tcl_install
CONFIGURE_ARGS+= --with-tcl=${TCL_LIBDIR}
@@ -156,6 +158,15 @@ CONFIGURE_ARGS+= --disable-load-extension
CONFIGURE_ENV+= CPPFLAGS="-I. -I./src ${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
MAKE_ENV+= CPPFLAGS="-I. -I./src ${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+.include <bsd.port.pre.mk>
+
+.if ${TCL_VER} > 8.4
+BUILD_DEPENDS+= ${LOCALBASE}/lib/tcl8/8.5/msgcat-1.4.3.tm:${PORTSDIR}/lang/tcl-modules
+.if defined(WITH_TCLWRAPPER)
+RUN_DEPENDS+= ${LOCALBASE}/lib/tcl8/8.5/msgcat-1.4.3.tm:${PORTSDIR}/lang/tcl-modules
+.endif
+.endif
+
post-install:
.if defined(WITH_TCLWRAPPER)
@${INSTALL_PROGRAM} ${WRKSRC}/.libs/tclsqlite3 ${PREFIX}/bin
@@ -178,4 +189,4 @@ post-install:
.endif
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>