aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2009-08-16 11:12:53 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2009-08-16 11:12:53 +0000
commit1119248aa86342d5ecca3f123a5066b6b9cbf50b (patch)
tree2c0d5d9eb498d5abfdcbd10d6aaf69eb5255edc8 /databases
parent10865dba7e605d87be8ad22a494951affc877799 (diff)
downloadports-1119248aa86342d5ecca3f123a5066b6b9cbf50b.tar.gz
ports-1119248aa86342d5ecca3f123a5066b6b9cbf50b.zip
Notes
Diffstat (limited to 'databases')
-rw-r--r--databases/p5-DBIx-Class/Makefile13
-rw-r--r--databases/p5-DBIx-Class/pkg-descr4
2 files changed, 9 insertions, 8 deletions
diff --git a/databases/p5-DBIx-Class/Makefile b/databases/p5-DBIx-Class/Makefile
index 463036cbff49..cc91ded51cd8 100644
--- a/databases/p5-DBIx-Class/Makefile
+++ b/databases/p5-DBIx-Class/Makefile
@@ -15,20 +15,21 @@ MAINTAINER= perl@FreeBSD.org
COMMENT= Extensible and flexible object <-> relational mapper
BUILD_DEPENDS= p5-Data-Page>=2.00:${PORTSDIR}/databases/p5-Data-Page \
- p5-SQL-Abstract>=1.51:${PORTSDIR}/databases/p5-SQL-Abstract \
+ p5-SQL-Abstract>=1.56:${PORTSDIR}/databases/p5-SQL-Abstract \
p5-SQL-Abstract-Limit>=0.141:${PORTSDIR}/databases/p5-SQL-Abstract-Limit \
p5-Class-C3-Componentised>=1.0005:${PORTSDIR}/devel/p5-Class-C3-Componentised \
- p5-Carp-Clan>=0:${PORTSDIR}/devel/p5-Carp-Clan \
+ p5-Carp-Clan>=6.00:${PORTSDIR}/devel/p5-Carp-Clan \
p5-DBI>=1.40:${PORTSDIR}/databases/p5-DBI \
- p5-Module-Find>=0:${PORTSDIR}/devel/p5-Module-Find \
- p5-Class-Inspector>=0:${PORTSDIR}/devel/p5-Class-Inspector \
+ p5-Module-Find>=0.06:${PORTSDIR}/devel/p5-Module-Find \
+ p5-Class-Inspector>=1.24:${PORTSDIR}/devel/p5-Class-Inspector \
p5-Class-Accessor-Grouped>=0.08003:${PORTSDIR}/devel/p5-Class-Accessor-Grouped \
p5-JSON-Any>=1.17:${PORTSDIR}/converters/p5-JSON-Any \
p5-Scope-Guard>=0.03:${PORTSDIR}/devel/p5-Scope-Guard \
p5-Path-Class>0:${PORTSDIR}/devel/p5-Path-Class \
p5-Scalar-List-Utils>=1.19:${PORTSDIR}/lang/p5-Scalar-List-Utils \
p5-Sub-Name>=0.04:${PORTSDIR}/devel/p5-Sub-Name \
- p5-MRO-Compat>=0.09:${PORTSDIR}/devel/p5-MRO-Compat
+ p5-MRO-Compat>=0.09:${PORTSDIR}/devel/p5-MRO-Compat \
+ p5-DBD-SQLite>=1.25:${PORTSDIR}/databases/p5-DBD-SQLite
RUN_DEPENDS= ${BUILD_DEPENDS}
OPTIONS= SQLT "SQL::Translator (generate DDL from schema)" Off
@@ -134,7 +135,7 @@ post-extract:
.include <bsd.port.pre.mk>
.ifdef(WITH_SQLT)
-RUN_DEPENDS+= p5-SQL-Translator>=0.09004:${PORTSDIR}/databases/p5-SQL-Translator
+RUN_DEPENDS+= p5-SQL-Translator>=0.09.004:${PORTSDIR}/databases/p5-SQL-Translator
.endif
.include <bsd.port.post.mk>
diff --git a/databases/p5-DBIx-Class/pkg-descr b/databases/p5-DBIx-Class/pkg-descr
index b2ed2161b21a..4f1b29efaddd 100644
--- a/databases/p5-DBIx-Class/pkg-descr
+++ b/databases/p5-DBIx-Class/pkg-descr
@@ -1,10 +1,10 @@
-This is an SQL to OO mapper with an object API inspired by Class::DBI (and a
+This is an SQL to OO mapper with an object API inspired by Class::DBI (with a
compatibility layer as a springboard for porting) and a resultset API that
allows abstract encapsulation of database operations. It aims to make
representing queries in your code as perl-ish as possible while still providing
access to as many of the capabilities of the database as possible, including
retrieving related records from multiple tables in a single query, JOIN, LEFT
-JOIN, COUNT, DISTINCT, GROUP BY and HAVING support.
+JOIN, COUNT, DISTINCT, GROUP BY, ORDER BY and HAVING support.
DBIx::Class can handle multi-column primary and foreign keys, complex queries
and database-level paging, and does its best to only query the database in