aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorTorsten Zuehlsdorff <tz@FreeBSD.org>2017-05-16 10:19:06 +0000
committerTorsten Zuehlsdorff <tz@FreeBSD.org>2017-05-16 10:19:06 +0000
commit6ef69822b0b61160debe7fe8259ed905a262d6ee (patch)
treed0043d37d2eface6282150ba94e2056ea9d09e4a /databases
parent2c1b1531efb81a8c167a0dd8f2243ccf2a36848f (diff)
downloadports-6ef69822b0b61160debe7fe8259ed905a262d6ee.tar.gz
ports-6ef69822b0b61160debe7fe8259ed905a262d6ee.zip
Notes
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/pgpool-II-35/Makefile46
-rw-r--r--databases/pgpool-II-35/distinfo3
-rw-r--r--databases/pgpool-II-35/files/pgpool.in36
-rw-r--r--databases/pgpool-II-35/pkg-descr8
-rw-r--r--databases/pgpool-II-35/pkg-message9
-rw-r--r--databases/pgpool-II-35/pkg-plist31
7 files changed, 134 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 7102bbf61c84..2eaec00fa0da 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -579,6 +579,7 @@
SUBDIR += pgpool-II
SUBDIR += pgpool-II-30
SUBDIR += pgpool-II-33
+ SUBDIR += pgpool-II-35
SUBDIR += pgpoolAdmin
SUBDIR += pgreplay
SUBDIR += pgrouting
diff --git a/databases/pgpool-II-35/Makefile b/databases/pgpool-II-35/Makefile
new file mode 100644
index 000000000000..88e3df6740e3
--- /dev/null
+++ b/databases/pgpool-II-35/Makefile
@@ -0,0 +1,46 @@
+# Created by: Choe, Cheng-Dae <whitekid@gmail.com>
+# $FreeBSD$
+
+PORTNAME= pgpool
+PORTVERSION= 3.5.8
+CATEGORIES= databases
+MASTER_SITES= http://www.pgpool.net/mediawiki/images/
+DISTNAME= ${PORTNAME}-II-${PORTVERSION}
+
+MAINTAINER= tz@FreeBSD.org
+COMMENT= Connection pool server for PostgreSQL
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+PORTSCOUT= limit:^3.5.[0-9]*
+
+USES= gmake libtool pgsql:9.3+
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+
+DATADIR= ${PREFIX}/share/${PORTNAME}-II
+
+USE_RC_SUBR= pgpool
+CONFLICTS= pgpool-II-[0-9]*
+
+PORTDOCS= *
+
+OPTIONS_DEFINE= DOCS SSL
+OPTIONS_DEFAULT= SSL
+
+SSL_CONFIGURE_WITH= openssl
+SSL_USES= ssl
+
+post-install:
+ @${MKDIR} ${STAGEDIR}/var/run/pgpool
+ ${INSTALL_LIB} ${WRKSRC}/src/libs/pcp/.libs/libpcp.so.1.0.0 ${STAGEDIR}${PREFIX}/lib
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC} && ${COPYTREE_SHARE} doc ${STAGEDIR}${DOCSDIR} "-not -name Makefile.\*"
+.for f in AUTHORS ChangeLog NEWS TODO
+ ${INSTALL_DATA} ${WRKSRC}/$f ${STAGEDIR}${DOCSDIR}
+.endfor
+
+.include <bsd.port.mk>
diff --git a/databases/pgpool-II-35/distinfo b/databases/pgpool-II-35/distinfo
new file mode 100644
index 000000000000..7ff16089750b
--- /dev/null
+++ b/databases/pgpool-II-35/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1494929811
+SHA256 (pgpool-II-3.5.8.tar.gz) = 49d509c4cbfc2e4b8105c56e9955f91fe8b6e008cb4cfb8a39ece32a9251f7f6
+SIZE (pgpool-II-3.5.8.tar.gz) = 2254981
diff --git a/databases/pgpool-II-35/files/pgpool.in b/databases/pgpool-II-35/files/pgpool.in
new file mode 100644
index 000000000000..5d39db2f108d
--- /dev/null
+++ b/databases/pgpool-II-35/files/pgpool.in
@@ -0,0 +1,36 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+# PROVIDE: pgpool
+# REQUIRE: LOGIN
+# KEYWORD: shutdown
+#
+# Add the following lines to /etc/rc.conf.local or /etc/rc.conf
+# to enable this service:
+#
+# pgpool_enable (bool): Set to NO by default.
+# Set it to YES to enable pgpool.
+# pgpool_conf (file): Set location of your config.
+# Default is "%%PREFIX%%/etc/pgpool.conf"
+# pgpool_user (uid): User ID to run as (default nobody)
+#
+
+. /etc/rc.subr
+
+name=pgpool
+rcvar=pgpool_enable
+
+load_rc_config $name
+
+: ${pgpool_enable="NO"}
+: ${pgpool_conf="%%PREFIX%%/etc/pgpool.conf"}
+: ${pgpool_user="nobody"}
+
+command="%%PREFIX%%/bin/pgpool"
+command_args="-f ${pgpool_conf}"
+stop_cmd="${command} ${command_args} stop"
+
+required_files="${pgpool_conf}"
+
+run_rc_command "$1"
diff --git a/databases/pgpool-II-35/pkg-descr b/databases/pgpool-II-35/pkg-descr
new file mode 100644
index 000000000000..6aa062adf911
--- /dev/null
+++ b/databases/pgpool-II-35/pkg-descr
@@ -0,0 +1,8 @@
+pgpool is a connection pool server for PostgreSQL. pgpool runs between
+PostgreSQL's clients(front ends) and servers(back ends). A PostgreSQL client can
+connect to pgpool as if it were a standard PostgreSQL server.
+
+pgpool caches the connection to PostgreSQL server to reduce the overhead to
+establish the connection to it.
+
+WWW: http://pgpool.net/
diff --git a/databases/pgpool-II-35/pkg-message b/databases/pgpool-II-35/pkg-message
new file mode 100644
index 000000000000..b1a7385436a6
--- /dev/null
+++ b/databases/pgpool-II-35/pkg-message
@@ -0,0 +1,9 @@
+In order to start pgpool you need some more configuration:
+
+# sysrc -f /etc/rc.conf pgpool_enable="YES"
+# sysrc -f /etc/rc.conf pgpool_user="root"
+
+Please consider the usage of another user. The user is
+required to have read/write access to /var/run/pgpool.
+
+Using the root user is - as always - an security issue.
diff --git a/databases/pgpool-II-35/pkg-plist b/databases/pgpool-II-35/pkg-plist
new file mode 100644
index 000000000000..7f1ed316c744
--- /dev/null
+++ b/databases/pgpool-II-35/pkg-plist
@@ -0,0 +1,31 @@
+bin/pcp_attach_node
+bin/pcp_detach_node
+bin/pcp_node_count
+bin/pcp_node_info
+bin/pcp_pool_status
+bin/pcp_proc_count
+bin/pcp_proc_info
+bin/pcp_promote_node
+bin/pcp_recovery_node
+bin/pcp_stop_pgpool
+bin/pcp_watchdog_info
+bin/pg_md5
+bin/pgpool
+@sample etc/pcp.conf.sample
+@sample etc/pgpool.conf.sample
+etc/pgpool.conf.sample-master-slave
+etc/pgpool.conf.sample-replication
+etc/pgpool.conf.sample-stream
+@sample etc/pool_hba.conf.sample
+include/libpcp_ext.h
+include/pcp.h
+include/pool_process_reporting.h
+include/pool_type.h
+lib/libpcp.a
+lib/libpcp.so
+lib/libpcp.so.1
+lib/libpcp.so.1.0.0
+man/man8/pgpool.8.gz
+%%DATADIR%%/insert_lock.sql
+%%DATADIR%%/pgpool.pam
+@dir /var/run/pgpool