aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2015-10-20 14:47:12 +0000
committerMathieu Arnold <mat@FreeBSD.org>2015-10-20 14:47:12 +0000
commit89226726da7540c762ffb63d6efb4a194a19030e (patch)
tree405c181b876f07b52700e82f1ad6bdd917cf0607 /databases
parentb625a1346aa9099b4172f3633f67f4890316aed7 (diff)
downloadports-89226726da7540c762ffb63d6efb4a194a19030e.tar.gz
ports-89226726da7540c762ffb63d6efb4a194a19030e.zip
Notes
Diffstat (limited to 'databases')
-rw-r--r--databases/sqlite3/Makefile28
-rw-r--r--databases/sqlite3/distinfo4
-rw-r--r--databases/sqlite3/files/patch-Makefile.am6
-rw-r--r--databases/sqlite3/files/patch-Makefile.in8
4 files changed, 31 insertions, 15 deletions
diff --git a/databases/sqlite3/Makefile b/databases/sqlite3/Makefile
index 38e324e51255..b621a16324bf 100644
--- a/databases/sqlite3/Makefile
+++ b/databases/sqlite3/Makefile
@@ -2,11 +2,10 @@
# $FreeBSD$
PORTNAME= sqlite3
-PORTVERSION= 3.8.11.1
-PORTREVISION= 1
+PORTVERSION= 3.9.1
CATEGORIES= databases
MASTER_SITES= https://www.sqlite.org/2015/ http://www2.sqlite.org/2015/ http://www3.sqlite.org/2015/
-DISTNAME= sqlite-autoconf-${PORTVERSION:S|8.|8|:S|.|0|g}
+DISTNAME= sqlite-autoconf-${PORTVERSION:C/\.([[:digit:]])[[:>:]]/0\1/g:S/.//g}00
MAINTAINER= pavelivolkov@gmail.com
COMMENT= SQL database engine in a C library
@@ -16,7 +15,7 @@ LICENSE_NAME= Public Domain
LICENSE_TEXT= Description of the license can be obtained from the following URL: http://www.sqlite.org/copyright.html
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
-CONFLICTS= sqlite34-[0-9]* sqlcipher-[0-9]*
+CONFLICTS= sqlcipher-[0-9]*
USES= libtool ncurses pathfix
USE_LDCONFIG= yes
@@ -29,12 +28,11 @@ MAKE_JOBS_UNSAFE= yes
# Compilation Options For SQLite http://www.sqlite.org/compile.html
OPTIONS_DEFINE= FTS4 UPD_DEL_LIMIT URI URI_AUTHORITY SOUNDEX METADATA \
DIRECT_READ MEMMAN SECURE_DELETE UNLOCK_NOTIFY THREADS \
- EXTENSION READLINE ARMOR STMT DBSTAT
+ EXTENSION READLINE ARMOR STMT DBSTAT FTS5 JSON1 RBU
OPTIONS_SINGLE= RAMT
OPTIONS_RADIO= STAT
OPTIONS_GROUP= UNICODE RTREEG
-FTS4_DESC= Enable FTS3/4 (Full Text Search) module
UPD_DEL_LIMIT_DESC= ORDER BY and LIMIT on UPDATE and DELETE
URI_DESC= Enable use the URI filename
URI_AUTHORITY_DESC= Allow convert URL into a UNC
@@ -49,6 +47,18 @@ EXTENSION_DESC= Allow loadable extensions
# http://www.sqlite.org/compile.html#enable_api_armor
ARMOR_DESC= Detect misuse of the API
+# http://www.sqlite.org/fts3.html
+FTS4_DESC= Enable FTS3/4 (Full Text Search) module
+
+# http://www.sqlite.org/fts5.html
+FTS5_DESC= Enable version 5 full-text search engine
+
+# http://www.sqlite.org/json1.html
+JSON1_DESC= Enable the JSON1 extension
+
+# http://www.sqlite.org/rbu.html
+RBU_DESC= Enable the Resumable Bulk Update
+
# http://www.sqlite.org/c3ref/stmt_scanstatus.html
STMT_DESC= Prepared Statement Scan Status
@@ -143,6 +153,12 @@ UNICODE61_CPPFLAGS_OFF= -DSQLITE_DISABLE_FTS3_UNICODE=1
READLINE_CONFIGURE_ENABLE= readline
READLINE_USES= readline
+FTS5_CONFIGURE_ENABLE= fts5
+
+JSON1_CONFIGURE_ENABLE= json1
+
+RBU_CPPFLAGS= -DSQLITE_ENABLE_RBU=1
+
.include <bsd.port.options.mk>
post-configure:
diff --git a/databases/sqlite3/distinfo b/databases/sqlite3/distinfo
index a73d370af0fb..84cd9fb00183 100644
--- a/databases/sqlite3/distinfo
+++ b/databases/sqlite3/distinfo
@@ -1,2 +1,2 @@
-SHA256 (sqlite-autoconf-3081101.tar.gz) = fb99b0ac038c4a7e48b44b61836cb41d4eeba36b4d0ee757beeab59031a1d3b6
-SIZE (sqlite-autoconf-3081101.tar.gz) = 2101885
+SHA256 (sqlite-autoconf-3090100.tar.gz) = d89d0e1d93deafebd0aa067d20d9029d9914ccde244920d9dd09ea51944e1c6c
+SIZE (sqlite-autoconf-3090100.tar.gz) = 2284128
diff --git a/databases/sqlite3/files/patch-Makefile.am b/databases/sqlite3/files/patch-Makefile.am
index eb8bd527ac15..0825564c19cf 100644
--- a/databases/sqlite3/files/patch-Makefile.am
+++ b/databases/sqlite3/files/patch-Makefile.am
@@ -1,9 +1,9 @@
---- Makefile.am.orig 2015-05-09 12:23:20 UTC
+--- Makefile.am.orig 2015-10-20 07:35:33 UTC
+++ Makefile.am
@@ -1,5 +1,5 @@
--AM_CFLAGS = @THREADSAFE_FLAGS@ @DYNAMIC_EXTENSION_FLAGS@ -DSQLITE_ENABLE_FTS3 -DSQLITE_ENABLE_RTREE
-+AM_CFLAGS = @THREADSAFE_FLAGS@ @DYNAMIC_EXTENSION_FLAGS@
+-AM_CFLAGS = @THREADSAFE_FLAGS@ @DYNAMIC_EXTENSION_FLAGS@ @FTS5_FLAGS@ @JSON1_FLAGS@ -DSQLITE_ENABLE_FTS3 -DSQLITE_ENABLE_RTREE
++AM_CFLAGS = @THREADSAFE_FLAGS@ @DYNAMIC_EXTENSION_FLAGS@ @FTS5_FLAGS@ @JSON1_FLAGS@
lib_LTLIBRARIES = libsqlite3.la
libsqlite3_la_SOURCES = sqlite3.c
diff --git a/databases/sqlite3/files/patch-Makefile.in b/databases/sqlite3/files/patch-Makefile.in
index 335e1fee327c..b4357abf8ee9 100644
--- a/databases/sqlite3/files/patch-Makefile.in
+++ b/databases/sqlite3/files/patch-Makefile.in
@@ -1,11 +1,11 @@
---- Makefile.in.orig 2015-05-12 14:38:01 UTC
+--- Makefile.in.orig 2015-10-20 07:35:55 UTC
+++ Makefile.in
-@@ -269,7 +269,7 @@ target_alias = @target_alias@
+@@ -274,7 +274,7 @@ target_alias = @target_alias@
top_build_prefix = @top_build_prefix@
top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
--AM_CFLAGS = @THREADSAFE_FLAGS@ @DYNAMIC_EXTENSION_FLAGS@ -DSQLITE_ENABLE_FTS3 -DSQLITE_ENABLE_RTREE
-+AM_CFLAGS = @THREADSAFE_FLAGS@ @DYNAMIC_EXTENSION_FLAGS@
+-AM_CFLAGS = @THREADSAFE_FLAGS@ @DYNAMIC_EXTENSION_FLAGS@ @FTS5_FLAGS@ @JSON1_FLAGS@ -DSQLITE_ENABLE_FTS3 -DSQLITE_ENABLE_RTREE
++AM_CFLAGS = @THREADSAFE_FLAGS@ @DYNAMIC_EXTENSION_FLAGS@ @FTS5_FLAGS@ @JSON1_FLAGS@
lib_LTLIBRARIES = libsqlite3.la
libsqlite3_la_SOURCES = sqlite3.c
libsqlite3_la_LDFLAGS = -no-undefined -version-info 8:6:8