aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorMatthias Fechner <mfechner@FreeBSD.org>2021-10-05 07:38:10 +0000
committerMatthias Fechner <mfechner@FreeBSD.org>2021-10-05 07:51:06 +0000
commit9b6b71faaa6942e54e77dec0d603807ef8964c1f (patch)
treee4cdf5f7318e78fb60607affb862f0e2fc4ad83e /databases
parent1cc165530a199a5cffad3e004980c0712d8dc74b (diff)
downloadports-9b6b71faaa6942e54e77dec0d603807ef8964c1f.tar.gz
ports-9b6b71faaa6942e54e77dec0d603807ef8964c1f.zip
*/*: Make rails 6.1.3 available
The upgrade of rails to 6.1.4 broke www/gitlab-ce. PR: 258855 (cherry picked from commit f4511dc4a7c439b30c898b75246d314a574f01cb)
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile2
-rw-r--r--databases/rubygem-activemodel613/Makefile24
-rw-r--r--databases/rubygem-activemodel613/distinfo3
-rw-r--r--databases/rubygem-activemodel613/pkg-descr10
-rw-r--r--databases/rubygem-activerecord613/Makefile25
-rw-r--r--databases/rubygem-activerecord613/distinfo3
-rw-r--r--databases/rubygem-activerecord613/pkg-descr14
7 files changed, 81 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index ab4e0546e798..fef6a340f5f1 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -879,6 +879,7 @@
SUBDIR += rubygem-activemodel52
SUBDIR += rubygem-activemodel60
SUBDIR += rubygem-activemodel61
+ SUBDIR += rubygem-activemodel613
SUBDIR += rubygem-activerecord-explain-analyze
SUBDIR += rubygem-activerecord-import
SUBDIR += rubygem-activerecord-jdbc-adapter
@@ -890,6 +891,7 @@
SUBDIR += rubygem-activerecord52
SUBDIR += rubygem-activerecord60
SUBDIR += rubygem-activerecord61
+ SUBDIR += rubygem-activerecord613
SUBDIR += rubygem-after_commit_queue
SUBDIR += rubygem-amalgalite
SUBDIR += rubygem-arel
diff --git a/databases/rubygem-activemodel613/Makefile b/databases/rubygem-activemodel613/Makefile
new file mode 100644
index 000000000000..4b30d701cce7
--- /dev/null
+++ b/databases/rubygem-activemodel613/Makefile
@@ -0,0 +1,24 @@
+# Created by: Johannes Meixner <johannes@perceivon.net>
+
+PORTNAME= activemodel
+PORTVERSION= 6.1.3.2
+CATEGORIES= databases rubygems
+MASTER_SITES= RG
+PKGNAMESUFFIX= 613
+
+MAINTAINER= mfechner@FreeBSD.org
+COMMENT= Toolkit for building modeling frameworks
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/MIT-LICENSE
+
+RUN_DEPENDS= rubygem-activesupport613>=${PORTVERSION}:devel/rubygem-activesupport613
+
+USES= gem
+USE_RUBY= yes
+
+NO_ARCH= yes
+
+PORTSCOUT= limit:^6\.1\.
+
+.include <bsd.port.mk>
diff --git a/databases/rubygem-activemodel613/distinfo b/databases/rubygem-activemodel613/distinfo
new file mode 100644
index 000000000000..d4eb52d930f2
--- /dev/null
+++ b/databases/rubygem-activemodel613/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1633413586
+SHA256 (rubygem/activemodel-6.1.3.2.gem) = 5459410a49855d18b89ecf2d509cb74924e37559a01a991b41d9fb4c201cedbe
+SIZE (rubygem/activemodel-6.1.3.2.gem) = 61952
diff --git a/databases/rubygem-activemodel613/pkg-descr b/databases/rubygem-activemodel613/pkg-descr
new file mode 100644
index 000000000000..5eee67fa991a
--- /dev/null
+++ b/databases/rubygem-activemodel613/pkg-descr
@@ -0,0 +1,10 @@
+Active Model provides a known set of interfaces for usage in model classes. They
+allow for Action Pack helpers to interact with non-Active Record models, for
+example. Active Model also helps with building custom ORMs for use outside of
+the Rails framework.
+
+Active Model provides a default module that implements the basic API required to
+integrate with Action Pack out of the box: ActiveModel::Model.
+
+WWW: https://rubyonrails.org/
+WWW: https://github.com/rails/rails/tree/master/activemodel
diff --git a/databases/rubygem-activerecord613/Makefile b/databases/rubygem-activerecord613/Makefile
new file mode 100644
index 000000000000..fef2f3dc8544
--- /dev/null
+++ b/databases/rubygem-activerecord613/Makefile
@@ -0,0 +1,25 @@
+# Created by: Johannes Meixner <johannes@perceivon.net>
+
+PORTNAME= activerecord
+PORTVERSION= 6.1.3.2
+CATEGORIES= databases rubygems
+MASTER_SITES= RG
+PKGNAMESUFFIX= 613
+
+MAINTAINER= mfechner@FreeBSD.org
+COMMENT= Object-relational mapping layer for Rails MVC Framework
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/MIT-LICENSE
+
+RUN_DEPENDS= rubygem-activemodel613>=${PORTVERSION}:databases/rubygem-activemodel613 \
+ rubygem-activesupport613>=${PORTVERSION}:devel/rubygem-activesupport613
+
+USES= gem
+USE_RUBY= yes
+
+NO_ARCH= yes
+
+PORTSCOUT= limit:^6\.1\.
+
+.include <bsd.port.mk>
diff --git a/databases/rubygem-activerecord613/distinfo b/databases/rubygem-activerecord613/distinfo
new file mode 100644
index 000000000000..0fa7a8f225f0
--- /dev/null
+++ b/databases/rubygem-activerecord613/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1633413635
+SHA256 (rubygem/activerecord-6.1.3.2.gem) = c8400e75c1caa43aefcc6dd1d21c427030f4190ee606931ff8f97da12a46e539
+SIZE (rubygem/activerecord-6.1.3.2.gem) = 429056
diff --git a/databases/rubygem-activerecord613/pkg-descr b/databases/rubygem-activerecord613/pkg-descr
new file mode 100644
index 000000000000..29c7987b2296
--- /dev/null
+++ b/databases/rubygem-activerecord613/pkg-descr
@@ -0,0 +1,14 @@
+Active Record connects classes to relational database tables to establish an
+almost zero-configuration persistence layer for applications. The library
+provides a base class that, when subclassed, sets up a mapping between the new
+class and an existing table in the database. In the context of an application,
+these classes are commonly referred to as models. Models can also be connected
+to other models; this is done by defining associations.
+
+Active Record relies heavily on naming in that it uses class and association
+names to establish mappings between respective database tables and foreign key
+columns. Although these mappings can be defined explicitly, it's recommended to
+follow naming conventions, especially when getting started with the library.
+
+WWW: https://rubyonrails.org/
+WWW: https://github.com/rails/rails/tree/master/activerecord