aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2013-05-30 16:44:50 +0000
committerMartin Wilke <miwi@FreeBSD.org>2013-05-30 16:44:50 +0000
commitceeb795c43040b1a35bdad6a9a8e1e0e02dc07bf (patch)
tree457dacf34e29c0fb9e4e764d05e58ad610c78285 /databases
parent01744dd6bc689880293f584008b40f4ad4b59c39 (diff)
downloadports-ceeb795c43040b1a35bdad6a9a8e1e0e02dc07bf.tar.gz
ports-ceeb795c43040b1a35bdad6a9a8e1e0e02dc07bf.zip
Notes
Diffstat (limited to 'databases')
-rw-r--r--databases/pecl-mongo/Makefile2
-rw-r--r--databases/pecl-mongo/files/patch-mcon_types.h10
2 files changed, 11 insertions, 1 deletions
diff --git a/databases/pecl-mongo/Makefile b/databases/pecl-mongo/Makefile
index bcdc713a32a5..c72a9fc58b89 100644
--- a/databases/pecl-mongo/Makefile
+++ b/databases/pecl-mongo/Makefile
@@ -17,7 +17,7 @@ USE_PHP= yes
USE_PHP_BUILD= spl
USE_PHPIZE= yes
USE_PHPEXT= yes
-
+CONFIGURE_ARGS= --enable-mongo=${LOCALBASE}
SUB_FILES= pkg-message
post-install:
diff --git a/databases/pecl-mongo/files/patch-mcon_types.h b/databases/pecl-mongo/files/patch-mcon_types.h
new file mode 100644
index 000000000000..035f96ca7c39
--- /dev/null
+++ b/databases/pecl-mongo/files/patch-mcon_types.h
@@ -0,0 +1,10 @@
+--- mcon/types.h.orgi 2013-05-31 00:39:17.000000000 +0800
++++ mcon/types.h 2013-05-31 00:40:39.000000000 +0800
+@@ -36,6 +36,7 @@
+ # define va_copy(d,s) ((void)((d) = (s)))
+ #endif
+ #else
++# include <sys/types.h>
+ # include <stdint.h>
+ # include <netinet/in.h>
+ # include <netinet/tcp.h>