aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2021-10-30 18:08:16 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2021-12-11 13:50:53 +0000
commit45526ecbeec33dbb87f0b678d4c04988aab9b657 (patch)
treeb77614b463af0ed929512fcc838ff5cb20c96275 /databases
parenta148ebec4e0afe980f949de0dea5ef4931cb7e86 (diff)
downloadports-45526ecbeec33dbb87f0b678d4c04988aab9b657.tar.gz
ports-45526ecbeec33dbb87f0b678d4c04988aab9b657.zip
Diffstat (limited to 'databases')
-rw-r--r--databases/opendbviewer/Makefile4
-rw-r--r--databases/virtuoso/Makefile2
2 files changed, 2 insertions, 4 deletions
diff --git a/databases/opendbviewer/Makefile b/databases/opendbviewer/Makefile
index a89512df01f3..4d7987782786 100644
--- a/databases/opendbviewer/Makefile
+++ b/databases/opendbviewer/Makefile
@@ -9,9 +9,7 @@ COMMENT= Simple database explorer
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
-BUILD_DEPENDS= convert:graphics/ImageMagick6
-
-USES= cmake compiler:c++11-lang qt:5
+USES= cmake compiler:c++11-lang magick:6,build qt:5
USE_GITHUB= yes
GH_ACCOUNT= Jet1oeil
USE_QT= core gui network sql sql-sqlite3 testlib widgets \
diff --git a/databases/virtuoso/Makefile b/databases/virtuoso/Makefile
index 0dcaa0eb5ca7..61fec3050978 100644
--- a/databases/virtuoso/Makefile
+++ b/databases/virtuoso/Makefile
@@ -74,7 +74,7 @@ BROKEN_FreeBSD_14= OpenSSL version 1.1.0 or greater is currently not supported
.if ${PORT_OPTIONS:MIMAGEMAGICK}
CONFIGURE_ARGS+=--enable-imagemagick=${LOCALBASE}
-LIB_DEPENDS+= libMagickWand-6.so:graphics/ImageMagick6
+USES+= magick:6
PLIST_SUB+= WITH_IMAGEMAGICK=""
.else
CONFIGURE_ARGS+=--disable-imagemagick