aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2021-12-28 01:27:04 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2021-12-28 01:27:04 +0000
commit9afad415443b91904c5499a0acebc94e9d1116d3 (patch)
tree2a5c0d8c4c10d1647be38f62ed0c25dd86d78322 /databases
parent1b3c44d137ce39914901457a7f5d4bdc21cb4e1c (diff)
downloadports-9afad415443b91904c5499a0acebc94e9d1116d3.tar.gz
ports-9afad415443b91904c5499a0acebc94e9d1116d3.zip
databases/pgpool-II-43: New Port
Connection pool server for PostgreSQL (4.3.X branch) pgpool is a connection pool server for PostgreSQL. pgpool runs between PostgreSQL's clients(front ends) and servers(back ends). A PostgreSQL client can connect to pgpool as if it were a standard PostgreSQL server. pgpool caches the connection to PostgreSQL server to reduce the overhead to establish the connection to it. WWW: https://pgpool.net/ Relnotes: https://www.pgpool.net/docs/43/en/html/release-4-3-0.html Sponsored by: Bounce Experts
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/pgpool-II-43/Makefile49
-rw-r--r--databases/pgpool-II-43/distinfo3
-rw-r--r--databases/pgpool-II-43/files/pgpool.in48
-rw-r--r--databases/pgpool-II-43/pkg-descr8
-rw-r--r--databases/pgpool-II-43/pkg-message15
-rw-r--r--databases/pgpool-II-43/pkg-plist41
7 files changed, 165 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index b854b262223b..a2f7c0fb2374 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -599,6 +599,7 @@
SUBDIR += pgpool-II-40
SUBDIR += pgpool-II-41
SUBDIR += pgpool-II-42
+ SUBDIR += pgpool-II-43
SUBDIR += pgreplay
SUBDIR += pgroonga
SUBDIR += pgrouting
diff --git a/databases/pgpool-II-43/Makefile b/databases/pgpool-II-43/Makefile
new file mode 100644
index 000000000000..32dd9b160856
--- /dev/null
+++ b/databases/pgpool-II-43/Makefile
@@ -0,0 +1,49 @@
+PORTNAME= pgpool-II
+PORTVERSION= 4.3.0
+CATEGORIES= databases
+MASTER_SITES= http://www.pgpool.net/mediawiki/images/
+PKGNAMESUFFIX= -43
+
+MAINTAINER= bofh@FreeBSD.org
+COMMENT= Connection pool server for PostgreSQL (4.3.X branch)
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USES= gmake libtool pgsql:9.6+
+USE_LDCONFIG= yes
+USE_RC_SUBR= pgpool
+
+GNU_CONFIGURE= yes
+
+CONFLICTS= pgpool-II
+
+PORTSCOUT= limit:^4.3.[0-9]*
+
+PORTDOCS= *
+
+OPTIONS_DEFINE= DOCS MEMCACHED PAM SSL
+OPTIONS_DEFAULT= SSL
+
+MEMCACHED_DESC= Use memcached for in memory query cache
+PAM_DESC= Build with PAM support
+SSL_DESC= Build with OpenSSL support
+
+MEMCACHED_LIB_DEPENDS= libmemcached.so:databases/libmemcached
+MEMCACHED_CONFIGURE_ON= --with-memcached=${LOCALBASE}/include
+PAM_CONFIGURE_ON= --with-pam
+SSL_USES= ssl
+SSL_CONFIGURE_WITH= openssl
+
+post-install:
+ @${MKDIR} ${STAGEDIR}/var/run/pgpool
+ ${INSTALL_LIB} ${WRKSRC}/src/libs/pcp/.libs/libpcp.so.2.0.0 ${STAGEDIR}${PREFIX}/lib
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC} && ${COPYTREE_SHARE} doc ${STAGEDIR}${DOCSDIR} "-not -name Makefile.\*"
+.for f in AUTHORS ChangeLog NEWS TODO
+ ${INSTALL_DATA} ${WRKSRC}/$f ${STAGEDIR}${DOCSDIR}
+.endfor
+
+.include <bsd.port.mk>
diff --git a/databases/pgpool-II-43/distinfo b/databases/pgpool-II-43/distinfo
new file mode 100644
index 000000000000..2d3782f33c5c
--- /dev/null
+++ b/databases/pgpool-II-43/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1640294175
+SHA256 (pgpool-II-4.3.0.tar.gz) = 1650cb7db960c83386dade17372f2306c427d05f42e2a94559abc183576dd213
+SIZE (pgpool-II-4.3.0.tar.gz) = 5995138
diff --git a/databases/pgpool-II-43/files/pgpool.in b/databases/pgpool-II-43/files/pgpool.in
new file mode 100644
index 000000000000..cb76557e2e57
--- /dev/null
+++ b/databases/pgpool-II-43/files/pgpool.in
@@ -0,0 +1,48 @@
+#!/bin/sh
+
+# PROVIDE: pgpool
+# REQUIRE: LOGIN
+# KEYWORD: shutdown
+#
+# Add the following lines to /etc/rc.conf.local or /etc/rc.conf
+# to enable this service:
+#
+# pgpool_enable (bool): Set to NO by default.
+# Set it to YES to enable pgpool.
+# pgpool_conf (file): Set location of your config.
+# Default is "%%PREFIX%%/etc/pgpool.conf"
+# pgpool_hba (file): Set location of your pool hba file.
+# Default is "%%PREFIX%%/etc/pool_hba.conf"
+# pgpool_pcp (file): Set location of your pcp conf file.
+# Default is "%%PREFIX%%/etc/pcp.conf"
+# pgpool_user (uid): User ID to run as (default nobody)
+# pgpool_stop_mode (string): Shutdown mode
+# Default is "smart"
+# Possibilities are "smart", "fast", or "immediate"
+#
+
+. /etc/rc.subr
+
+name=pgpool
+rcvar=pgpool_enable
+
+load_rc_config $name
+
+: ${pgpool_enable="NO"}
+: ${pgpool_conf="%%PREFIX%%/etc/pgpool.conf"}
+: ${pgpool_hba="%%PREFIX%%/etc/pool_hba.conf"}
+: ${pgpool_pcp="%%PREFIX%%/etc/pcp.conf"}
+: ${pgpool_user="nobody"}
+: ${pgpool_stop_mode="smart"}
+
+command="%%PREFIX%%/bin/pgpool"
+command_args="-f ${pgpool_conf} -a ${pgpool_hba} -F ${pgpool_pcp}"
+stop_cmd="${command} -m ${pgpool_stop_mode} ${command_args} stop"
+reload_cmd="${command} ${command_args} reload"
+extra_commands="reload"
+
+required_files="${pgpool_conf}"
+
+
+run_rc_command "$1"
+
diff --git a/databases/pgpool-II-43/pkg-descr b/databases/pgpool-II-43/pkg-descr
new file mode 100644
index 000000000000..474bcbe9a30e
--- /dev/null
+++ b/databases/pgpool-II-43/pkg-descr
@@ -0,0 +1,8 @@
+pgpool is a connection pool server for PostgreSQL. pgpool runs between
+PostgreSQL's clients(front ends) and servers(back ends). A PostgreSQL client can
+connect to pgpool as if it were a standard PostgreSQL server.
+
+pgpool caches the connection to PostgreSQL server to reduce the overhead to
+establish the connection to it.
+
+WWW: https://pgpool.net/
diff --git a/databases/pgpool-II-43/pkg-message b/databases/pgpool-II-43/pkg-message
new file mode 100644
index 000000000000..1df287cd433a
--- /dev/null
+++ b/databases/pgpool-II-43/pkg-message
@@ -0,0 +1,15 @@
+[
+{ type: install
+ message: <<EOM
+In order to start pgpool you need some more configuration:
+
+# sysrc -f /etc/rc.conf pgpool_enable="YES"
+# sysrc -f /etc/rc.conf pgpool_user="root"
+
+Please consider the usage of another user. The user is
+required to have read/write access to /var/run/pgpool.
+
+Using the root user is - as always - an security issue.
+EOM
+}
+]
diff --git a/databases/pgpool-II-43/pkg-plist b/databases/pgpool-II-43/pkg-plist
new file mode 100644
index 000000000000..435e4c2729fd
--- /dev/null
+++ b/databases/pgpool-II-43/pkg-plist
@@ -0,0 +1,41 @@
+bin/pcp_attach_node
+bin/pcp_detach_node
+bin/pcp_health_check_stats
+bin/pcp_node_count
+bin/pcp_node_info
+bin/pcp_pool_status
+bin/pcp_proc_count
+bin/pcp_proc_info
+bin/pcp_promote_node
+bin/pcp_recovery_node
+bin/pcp_reload_config
+bin/pcp_stop_pgpool
+bin/pcp_watchdog_info
+bin/pg_enc
+bin/pg_md5
+bin/pgpool
+bin/pgpool_setup
+bin/pgproto
+bin/watchdog_setup
+bin/wd_cli
+@sample etc/escalation.sh.sample
+@sample etc/failover.sh.sample
+@sample etc/follow_primary.sh.sample
+@sample etc/pcp.conf.sample
+@sample etc/pgpool.conf.sample
+@sample etc/pgpool_remote_start.sample
+@sample etc/pool_hba.conf.sample
+@sample etc/replication_mode_recovery_1st_stage.sample
+@sample etc/replication_mode_recovery_2nd_stage.sample
+etc/recovery_1st_stage.sample
+include/libpcp_ext.h
+include/pcp.h
+include/pool_process_reporting.h
+include/pool_type.h
+lib/libpcp.a
+lib/libpcp.so
+lib/libpcp.so.2
+lib/libpcp.so.2.0.0
+%%DATADIR%%/insert_lock.sql
+%%DATADIR%%/pgpool.pam
+@dir /var/run/pgpool