aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorDanilo Egea Gondolfo <danilo@FreeBSD.org>2014-01-17 15:59:52 +0000
committerDanilo Egea Gondolfo <danilo@FreeBSD.org>2014-01-17 15:59:52 +0000
commit13294346c7f4483cb45f706828b7d35da885f0e5 (patch)
treea4882752dbe130cc0adfaf28f29c90c2958105d8 /databases
parentfe35afe04631099acc3bf94481ec0f18ff3c6f52 (diff)
downloadports-13294346c7f4483cb45f706828b7d35da885f0e5.tar.gz
ports-13294346c7f4483cb45f706828b7d35da885f0e5.zip
Notes
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/pgrouting/Makefile52
-rw-r--r--databases/pgrouting/distinfo2
-rw-r--r--databases/pgrouting/pkg-descr4
-rw-r--r--databases/pgrouting/pkg-plist17
5 files changed, 76 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 5dd00f3abb41..367d9f9adf01 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -572,6 +572,7 @@
SUBDIR += pgpool-II-23
SUBDIR += pgpool-II-30
SUBDIR += pgpoolAdmin
+ SUBDIR += pgrouting
SUBDIR += pgsphere
SUBDIR += pgtcl
SUBDIR += pgtop
diff --git a/databases/pgrouting/Makefile b/databases/pgrouting/Makefile
new file mode 100644
index 000000000000..8c8dc14b554f
--- /dev/null
+++ b/databases/pgrouting/Makefile
@@ -0,0 +1,52 @@
+# Created by: lbartoletti <coder@tuxfamily.org>
+# $FreeBSD$
+
+PORTNAME= pgrouting
+PORTVERSION= 2.0.0
+CATEGORIES= databases geography
+MASTER_SITES= https://github.com/pgRouting/${PORTNAME}/archive/
+DISTFILES= v${PORTVERSION}${EXTRACT_SUFX}
+
+MAINTAINER= coder@tuxfamily.org
+COMMENT= Extension to PostGIS to provide geospatial routing functionality
+
+LICENSE= GPLv2
+
+LIB_DEPENDS= libboost_system.so:${PORTSDIR}/devel/boost-libs\
+ libCGAL.so:${PORTSDIR}/math/cgal \
+ libgmp.so:${PORTSDIR}/math/gmp
+RUN_DEPENDS= ${LOCALBASE}/share/postgresql/contrib/postgis-2.1/postgis.sql:${PORTSDIR}/databases/postgis21
+
+USES= cmake pkgconfig
+USE_PGSQL= yes
+USE_LDCONFIG= yes
+
+FETCH_ARGS= -Fpr
+
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+PGSQL_VER= ${DEFAULT_PGSQL_VER}
+
+.if ${PGSQL_VER} >= 91
+EXT_FILES= pgrouting--2.0.0.sql \
+ pgrouting.control \
+ pgrouting_dd_legacy.sql \
+ pgrouting--2.0.0.sql.in \
+ pgrouting.sql \
+ pgrouting_legacy.sql
+PLIST_DIRSTRY+= share/postgresql/extension
+.for f in ${EXT_FILES}
+PLIST_FILES+= share/postgresql/extension/${f}
+.endfor
+.endif
+
+post-install:
+.if ${PGSQL_VER} >= 91
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/postgresql/extension
+.for f in ${EXT_FILES}
+ ${INSTALL_DATA} ${WRKSRC}/lib/${f} ${STAGEDIR}${PREFIX}/share/postgresql/extension/
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/databases/pgrouting/distinfo b/databases/pgrouting/distinfo
new file mode 100644
index 000000000000..fc240e336b39
--- /dev/null
+++ b/databases/pgrouting/distinfo
@@ -0,0 +1,2 @@
+SHA256 (v2.0.0.tar.gz) = 606309e8ece04abec062522374b48179c16bddb30dd4c5080b89a4298e8d163b
+SIZE (v2.0.0.tar.gz) = 3765933
diff --git a/databases/pgrouting/pkg-descr b/databases/pgrouting/pkg-descr
new file mode 100644
index 000000000000..a62d6ae85cdb
--- /dev/null
+++ b/databases/pgrouting/pkg-descr
@@ -0,0 +1,4 @@
+pgRouting extends the PostGIS / PostgreSQL geospatial database to provide
+geospatial routing functionality.
+
+WWW: http://pgrouting.org/
diff --git a/databases/pgrouting/pkg-plist b/databases/pgrouting/pkg-plist
new file mode 100644
index 000000000000..388f4c3f6e24
--- /dev/null
+++ b/databases/pgrouting/pkg-plist
@@ -0,0 +1,17 @@
+lib/postgresql/librouting.so
+lib/postgresql/librouting_bd.so
+lib/postgresql/librouting_dd.so
+lib/postgresql/librouting_ksp.so
+lib/postgresql/librouting_tsp.so
+share/postgresql/contrib/pgrouting-2.0/pgrouting.control
+share/postgresql/contrib/pgrouting-2.0/pgrouting.sql
+share/postgresql/contrib/pgrouting-2.0/pgrouting_dd_legacy.sql
+share/postgresql/contrib/pgrouting-2.0/pgrouting_legacy.sql
+share/postgresql/pgrouting--2.0.0.sql
+share/postgresql/pgrouting.control
+share/postgresql/pgrouting_dd_legacy.sql
+share/postgresql/pgrouting_legacy.sql
+@dirrmtry share/postgresql/contrib/pgrouting-2.0
+@dirrmtry share/postgresql/contrib
+@dirrmtry share/postgresql
+@dirrmtry lib/postgresql