aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorAlexander Botero-Lowry <alexbl@FreeBSD.org>2007-07-30 09:42:28 +0000
committerAlexander Botero-Lowry <alexbl@FreeBSD.org>2007-07-30 09:42:28 +0000
commit4942ce5a7d8a3d0cbebaf4d202011850d1f7569f (patch)
treedb1f21912f461000d609ddcd5d130946bcfe9e09 /databases
parentb4be9b354e86bd790925c5a9a2e67df8ba20bc00 (diff)
downloadports-4942ce5a7d8a3d0cbebaf4d202011850d1f7569f.tar.gz
ports-4942ce5a7d8a3d0cbebaf4d202011850d1f7569f.zip
Notes
Diffstat (limited to 'databases')
-rw-r--r--databases/glom/files/patch-glom-libglom-python_embed-py_glom_record.cc20
-rw-r--r--databases/hk_classes/Makefile3
-rw-r--r--databases/pgworksheet/Makefile1
-rw-r--r--databases/py-Elixir/Makefile1
-rw-r--r--databases/py-MySQL/Makefile4
-rw-r--r--databases/py-MySQL/files/Makefile.pre.in2
-rw-r--r--databases/py-MySQLdb-devel/Makefile2
-rw-r--r--databases/py-MySQLdb/Makefile2
-rw-r--r--databases/py-PyGreSQL/Makefile1
-rw-r--r--databases/py-PySQLite10/Makefile1
-rw-r--r--databases/py-PySQLite11/Makefile1
-rw-r--r--databases/py-axiom/Makefile1
-rw-r--r--databases/py-bsddb/Makefile2
-rw-r--r--databases/py-cdb/Makefile1
-rw-r--r--databases/py-dbutils/Makefile1
-rw-r--r--databases/py-forgetsql/Makefile1
-rw-r--r--databases/py-gdbm/Makefile1
-rw-r--r--databases/py-memcached/Makefile1
-rw-r--r--databases/py-mssql/Makefile1
-rw-r--r--databases/py-rrdtool_lgpl/Makefile1
-rw-r--r--databases/py-sqlalchemy/Makefile2
-rw-r--r--databases/py-sqlalchemy06/Makefile2
-rw-r--r--databases/py-sqlite3/Makefile4
-rw-r--r--databases/py-sqlobject/Makefile2
-rw-r--r--databases/py-sqlrelay/Makefile2
-rw-r--r--databases/py25-bsddb/Makefile2
-rw-r--r--databases/zodb3/Makefile1
27 files changed, 59 insertions, 4 deletions
diff --git a/databases/glom/files/patch-glom-libglom-python_embed-py_glom_record.cc b/databases/glom/files/patch-glom-libglom-python_embed-py_glom_record.cc
new file mode 100644
index 000000000000..a83ec8738c29
--- /dev/null
+++ b/databases/glom/files/patch-glom-libglom-python_embed-py_glom_record.cc
@@ -0,0 +1,20 @@
+--- glom/libglom/python_embed/py_glom_record.cc.orig Sun Jul 15 13:34:18 2007
++++ glom/libglom/python_embed/py_glom_record.cc Sun Jul 15 13:34:44 2007
+@@ -122,7 +122,7 @@
+
+
+
+-static int
++static Py_ssize_t
+ Record_tp_as_mapping_length(PyGlomRecord *self)
+ {
+ return self->m_pMap_field_values->size();
+@@ -146,7 +146,7 @@
+ }
+ else
+ {
+- g_warning("Record_tp_as_mapping_getitem(): item not found in m_pMap_field_values. size=%d, item=%s", self->m_pMap_field_values->size(), pchKey);
++ g_warning("Record_tp_as_mapping_getitem(): item not found in m_pMap_field_values. size=%d, item=%s", (int)self->m_pMap_field_values->size(), pchKey);
+ }
+ }
+ else
diff --git a/databases/hk_classes/Makefile b/databases/hk_classes/Makefile
index da78e85c6945..ed09ef6471fc 100644
--- a/databases/hk_classes/Makefile
+++ b/databases/hk_classes/Makefile
@@ -34,6 +34,9 @@ CONFIGURE_ARGS+=--with-python-libdir=${PYTHON_LIBDIR} \
INSTALLS_SHLIB= yes
LDCONFIG_DIRS+= ${PREFIX}/lib/hk_classes/
+INSTALLS_EGGINFO= yes
+PYDISTUTILS_PKGVERSION= 1.1
+
NOT_FOR_ARCHS= ia64
NOT_FOR_ARCHS_REASON_ia64= Does not build
diff --git a/databases/pgworksheet/Makefile b/databases/pgworksheet/Makefile
index 855cc92d8778..9e0f569970c1 100644
--- a/databases/pgworksheet/Makefile
+++ b/databases/pgworksheet/Makefile
@@ -22,6 +22,7 @@ USE_BZIP2= yes
USE_GNOME= pygtk2
USE_PYTHON= yes
USE_PYDISTUTILS=yes
+PYDISTUTILS_PKGVERSION= 1.8
post-patch:
${REINPLACE_CMD} -e \
diff --git a/databases/py-Elixir/Makefile b/databases/py-Elixir/Makefile
index 0c0a57dfa264..48137b5bd816 100644
--- a/databases/py-Elixir/Makefile
+++ b/databases/py-Elixir/Makefile
@@ -23,6 +23,7 @@ RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/${PYALCHEMY_EGG}:${PORTSDIR}/databases/py-sql
USE_PYTHON= yes
USE_PYDISTUTILS= yes
+PYDISTUTILS_NOEGGINFO= yes # XXX convert easy_install support to bsd.python.mk's
PYDISTUTILS_BUILD_TARGET= bdist_egg
PYDISTUTILS_INSTALL_TARGET= easy_install
PYDISTUTILS_INSTALLARGS= -O 1 -N -S ${PYTHON_SITELIBDIR} ${WRKSRC}/dist/${PYELIXIR_EGG}
diff --git a/databases/py-MySQL/Makefile b/databases/py-MySQL/Makefile
index 4eace29262e0..443ac95fdab7 100644
--- a/databases/py-MySQL/Makefile
+++ b/databases/py-MySQL/Makefile
@@ -17,7 +17,9 @@ COMMENT= Access a MySQL database through Python
LIB_DEPENDS= mysqlclient.10:${PORTSDIR}/databases/mysql323-client
PLIST_FILES= lib/%%PYTHON_VERSION%%/site-packages/MySQLmodule.so
-USE_PYTHON= yes
+USE_PYTHON= -2.4
+CONFIGURE_ENV= PYTHON=${PYTHON_CMD}
+MAKE_ENV= ${CONFIGURE_ENV}
.include <bsd.port.pre.mk>
diff --git a/databases/py-MySQL/files/Makefile.pre.in b/databases/py-MySQL/files/Makefile.pre.in
index 2d14294054a0..d8f763d8d6c6 100644
--- a/databases/py-MySQL/files/Makefile.pre.in
+++ b/databases/py-MySQL/files/Makefile.pre.in
@@ -92,7 +92,7 @@ VPATH= .
TARGET= python
# Installed python binary (used only by boot target)
-PYTHON= python
+PYTHON?= python
# Add more -I and -D options here
CFLAGS= $(OPT) -I$(INCLUDEPY) -I$(EXECINCLUDEPY) $(DEFS)
diff --git a/databases/py-MySQLdb-devel/Makefile b/databases/py-MySQLdb-devel/Makefile
index 426db1f3bd39..674c9a69ea42 100644
--- a/databases/py-MySQLdb-devel/Makefile
+++ b/databases/py-MySQLdb-devel/Makefile
@@ -21,6 +21,8 @@ COMMENT= Access a MySQL database through Python
USE_PYTHON= 2.3+
USE_PYDISTUTILS= yes
USE_MYSQL= yes
+PYDISTUTILS_PKGNAME= MySQL-python${PYTHON_VER}
+PYDISTUTILS_PKGVERSION= 1.2.2b2
CONFLICTS= py*-MySQLdb-[0-9]*
diff --git a/databases/py-MySQLdb/Makefile b/databases/py-MySQLdb/Makefile
index b6d59a0b5a43..4387929f326e 100644
--- a/databases/py-MySQLdb/Makefile
+++ b/databases/py-MySQLdb/Makefile
@@ -19,6 +19,8 @@ COMMENT= Access a MySQL database through Python
USE_PYTHON= yes
USE_PYDISTUTILS= yes
USE_MYSQL= yes
+PYDISTUTILS_PKGNAME= MySQL-python
+PYDISTUTILS_PKGVERSION= 1.2.2
CONFLICTS= py*-MySQLdb-devel-[0-9]*
diff --git a/databases/py-PyGreSQL/Makefile b/databases/py-PyGreSQL/Makefile
index 990b58b5facc..1cca9402ce20 100644
--- a/databases/py-PyGreSQL/Makefile
+++ b/databases/py-PyGreSQL/Makefile
@@ -22,6 +22,7 @@ RUN_DEPENDS= ${DATETIME_DEP}:${PORTSDIR}/lang/py-mx-base
USE_PGSQL= yes
USE_PYTHON= yes
DATETIME_DEP= ${PYTHON_SITELIBDIR}/mx/DateTime/__init__.py
+INSTALLS_EGGINFO= yes
pre-build:
@ cd ${WRKSRC} ; ${REINPLACE_CMD} -e 's,%%LOCALBASE%%,${LOCALBASE},g' setup.py
diff --git a/databases/py-PySQLite10/Makefile b/databases/py-PySQLite10/Makefile
index ba7d09daaf20..b29bdb9d7011 100644
--- a/databases/py-PySQLite10/Makefile
+++ b/databases/py-PySQLite10/Makefile
@@ -25,6 +25,7 @@ CONFLICTS= py*-PySQLite-1.1.*
WRKSRC= ${WRKDIR}/pysqlite
USE_PYTHON= yes
USE_PYDISTUTILS=yes
+PYDISTUTILS_PKGNAME= pysqlite
MAKE_ENV= LOCALBASE="${LOCALBASE}"
PORTDOCS= *
diff --git a/databases/py-PySQLite11/Makefile b/databases/py-PySQLite11/Makefile
index 2532e0163776..5ef8052f89d9 100644
--- a/databases/py-PySQLite11/Makefile
+++ b/databases/py-PySQLite11/Makefile
@@ -23,6 +23,7 @@ NO_LATEST_LINK= yes
USE_PYTHON= yes
USE_PYDISTUTILS= yes
+PYDISTUTILS_PKGNAME= pysqlite
MAKE_ENV= LOCALBASE="${LOCALBASE}"
PORTDOCS= *
diff --git a/databases/py-axiom/Makefile b/databases/py-axiom/Makefile
index 34f763333e7a..8362aa42e2f8 100644
--- a/databases/py-axiom/Makefile
+++ b/databases/py-axiom/Makefile
@@ -24,5 +24,6 @@ USE_PYTHON= yes
USE_PYDISTUTILS= yes
USE_TWISTED= yes
NO_BUILD= yes
+PYDISTUTILS_PKGNAME= Axiom
.include <bsd.port.mk>
diff --git a/databases/py-bsddb/Makefile b/databases/py-bsddb/Makefile
index 915e241a4492..048d14d08530 100644
--- a/databases/py-bsddb/Makefile
+++ b/databases/py-bsddb/Makefile
@@ -20,6 +20,8 @@ COMMENT= Python bindings to the Berkeley DB library
USE_BDB= yes
USE_PYTHON= 2.3+
USE_PYDISTUTILS=yes
+PYDISTUTILS_PKGNAME= _bsddb
+PYDISTUTILS_PKGVERSION= 0.0.0
DIST_SUBDIR= python
WRKSRC= ${PYTHON_WRKSRC}/Modules
MD5_FILE= ${PORTSDIR}/lang/python/distinfo
diff --git a/databases/py-cdb/Makefile b/databases/py-cdb/Makefile
index 4ad80a96df86..f5b2d7fb3f2d 100644
--- a/databases/py-cdb/Makefile
+++ b/databases/py-cdb/Makefile
@@ -18,6 +18,7 @@ COMMENT= Python interface to DJB's constant database library
USE_PYTHON= yes
USE_PYDISTUTILS= yes
+PYDISTUTILS_PKGNAME= python-cdb
DOCSDIR= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
EXAMPLESDIR= ${PREFIX}/share/examples/${PKGNAMEPREFIX}${PORTNAME}
diff --git a/databases/py-dbutils/Makefile b/databases/py-dbutils/Makefile
index 61363d036b76..0c57f22d5156 100644
--- a/databases/py-dbutils/Makefile
+++ b/databases/py-dbutils/Makefile
@@ -18,6 +18,7 @@ COMMENT= Providing solid, persistent and pooled connections to a database
USE_PYTHON= yes
USE_PYDISTUTILS=yes
+PYDISTUTILS_PKGNAME= DBUtils
DOCSDIR= ${TARGETDIR}/share/doc/py-${PORTNAME}
diff --git a/databases/py-forgetsql/Makefile b/databases/py-forgetsql/Makefile
index 250c838889d3..8e2a4d9b6486 100644
--- a/databases/py-forgetsql/Makefile
+++ b/databases/py-forgetsql/Makefile
@@ -25,6 +25,7 @@ RUN_DEPENDS= ${PYTHON_SITELIBDIR}/MySQLdb/__init__.py:${PORTSDIR}/databases/py-M
USE_PYTHON= yes
USE_PYDISTUTILS= yes
+PYDISTUTILS_PKGNAME= forgetSQL
DOCS= BUGS README TODO
diff --git a/databases/py-gdbm/Makefile b/databases/py-gdbm/Makefile
index 2ec16f13bed8..26272084da7e 100644
--- a/databases/py-gdbm/Makefile
+++ b/databases/py-gdbm/Makefile
@@ -22,6 +22,7 @@ PLIST_FILES= lib/%%PYTHON_VERSION%%/site-packages/gdbm.so
DIST_SUBDIR= python
USE_PYTHON= yes
USE_PYDISTUTILS=yes
+PYDISTUTILS_PKGVERSION= 0.0.0
WRKSRC= ${PYTHON_WRKSRC}/Modules
MD5_FILE= ${PORTSDIR}/lang/python/distinfo
diff --git a/databases/py-memcached/Makefile b/databases/py-memcached/Makefile
index 844c144f47bb..d1ef61141596 100644
--- a/databases/py-memcached/Makefile
+++ b/databases/py-memcached/Makefile
@@ -18,5 +18,6 @@ COMMENT= Python API for memcached, a distributed memory cache daemon
USE_PYTHON= yes
USE_PYDISTUTILS=yes
+PYDISTUTILS_PKGNAME= python-memcached
.include <bsd.port.mk>
diff --git a/databases/py-mssql/Makefile b/databases/py-mssql/Makefile
index 648c5e34a05e..43ebe5da8295 100644
--- a/databases/py-mssql/Makefile
+++ b/databases/py-mssql/Makefile
@@ -20,6 +20,7 @@ LIB_DEPENDS= sybdb.5:${PORTSDIR}/databases/freetds-msdblib
USE_PYTHON= 2.4+
USE_PYDISTUTILS=yes
+PYDISTUTILS_PKGNAME= pymssql
post-patch:
${REINPLACE_CMD} -e 's,/usr/local,${LOCALBASE},g' \
diff --git a/databases/py-rrdtool_lgpl/Makefile b/databases/py-rrdtool_lgpl/Makefile
index 900f9b7ac9dc..15f258244d57 100644
--- a/databases/py-rrdtool_lgpl/Makefile
+++ b/databases/py-rrdtool_lgpl/Makefile
@@ -20,6 +20,7 @@ LIB_DEPENDS= rrd:${PORTSDIR}/databases/rrdtool
USE_PYTHON= yes
USE_PYDISTUTILS=yes
+PYDISTUTILS_PKGNAME= py-rrdtool
LIBDIR?= ${LOCALBASE}/lib # directory where librrd.so lives
diff --git a/databases/py-sqlalchemy/Makefile b/databases/py-sqlalchemy/Makefile
index 27a6a8abb18e..2b920ad5718d 100644
--- a/databases/py-sqlalchemy/Makefile
+++ b/databases/py-sqlalchemy/Makefile
@@ -24,6 +24,8 @@ PLIST_SUB+= PORTVERSION=${PORTVERSION} \
EGG="SQLAlchemy==${PORTVERSION}" \
EXAMPLEDIR=share/examples/${PORTNAME}
USE_PYDISTUTILS= yes
+PYDISTUTILS_PKGNAME= SQLAlchemy
+PYDISTUTILS_NOEGGINFO= yes
BUILD_DEPENDS+= easy_install:${PORTSDIR}/devel/py-setuptools
# make sure we have it @deinstall time to remove the egg
diff --git a/databases/py-sqlalchemy06/Makefile b/databases/py-sqlalchemy06/Makefile
index 27a6a8abb18e..2b920ad5718d 100644
--- a/databases/py-sqlalchemy06/Makefile
+++ b/databases/py-sqlalchemy06/Makefile
@@ -24,6 +24,8 @@ PLIST_SUB+= PORTVERSION=${PORTVERSION} \
EGG="SQLAlchemy==${PORTVERSION}" \
EXAMPLEDIR=share/examples/${PORTNAME}
USE_PYDISTUTILS= yes
+PYDISTUTILS_PKGNAME= SQLAlchemy
+PYDISTUTILS_NOEGGINFO= yes
BUILD_DEPENDS+= easy_install:${PORTSDIR}/devel/py-setuptools
# make sure we have it @deinstall time to remove the egg
diff --git a/databases/py-sqlite3/Makefile b/databases/py-sqlite3/Makefile
index a7232d5c0775..d33ff720d869 100644
--- a/databases/py-sqlite3/Makefile
+++ b/databases/py-sqlite3/Makefile
@@ -14,7 +14,7 @@ MASTER_SITE_SUBDIR= ${PYTHON_MASTER_SITE_SUBDIR}
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTFILES= ${PYTHON_DISTFILE}
-MAINTAINER= perky@FreeBSD.org
+MAINTAINER= python@FreeBSD.org
COMMENT= Standard Python binding to the SQLite3 library
LIB_DEPENDS= sqlite3.8:${PORTSDIR}/databases/sqlite3
@@ -26,6 +26,8 @@ USE_PYDISTUTILS=yes
WRKSRC= ${PYTHON_WRKSRC}/Modules
MD5_FILE= ${PORTSDIR}/lang/python/distinfo
+PYDISTUTILS_NOEGGINFO= yes
+
pre-extract:
@${CAT} ${PKGMESSAGE}
diff --git a/databases/py-sqlobject/Makefile b/databases/py-sqlobject/Makefile
index 222b81281eda..063756123649 100644
--- a/databases/py-sqlobject/Makefile
+++ b/databases/py-sqlobject/Makefile
@@ -23,9 +23,11 @@ RUN_DEPENDS+= ${BUILD_DEPENDS}
USE_PYTHON= yes
USE_PYDISTUTILS= yes
+PYDISTUTILS_PKGNAME= SQLObject
SQLOBJECTVER?= ${PORTVERSION}
PYTHONVER?= ${PYTHON_VERSION:S/^python//}
PLIST_SUB= PYSQLOBJECT_EGG=${PYSQLOBJECT_EGG}
+PYDISTUTILS_NOEGGINFO= yes # XXX convert easy_install support to bsd.python.mk's
SUB_FILES+= pkg-deinstall pkg-install
SUB_LIST+= EGG="SQLObject==${SQLOBJECTVER}" \
diff --git a/databases/py-sqlrelay/Makefile b/databases/py-sqlrelay/Makefile
index 3a05677e10d2..e7517cfd634d 100644
--- a/databases/py-sqlrelay/Makefile
+++ b/databases/py-sqlrelay/Makefile
@@ -43,7 +43,7 @@ do-extract:
post-patch:
${PERL} -i -p \
- -e 's,"2\.1" "2\.0" "1\.6" "1\.5",${PYTHON_VERSION:S/^python//},g;' \
+ -e 's,"2\.4" "2\.3" "2\.2" "2\.1",${PYTHON_VERSION:S/^python//},g;' \
${WRKSRC}/configure
${CP} ${TEMPLATES}/config.sub ${WRKSRC}
${CP} ${TEMPLATES}/config.guess ${WRKSRC}
diff --git a/databases/py25-bsddb/Makefile b/databases/py25-bsddb/Makefile
index 915e241a4492..048d14d08530 100644
--- a/databases/py25-bsddb/Makefile
+++ b/databases/py25-bsddb/Makefile
@@ -20,6 +20,8 @@ COMMENT= Python bindings to the Berkeley DB library
USE_BDB= yes
USE_PYTHON= 2.3+
USE_PYDISTUTILS=yes
+PYDISTUTILS_PKGNAME= _bsddb
+PYDISTUTILS_PKGVERSION= 0.0.0
DIST_SUBDIR= python
WRKSRC= ${PYTHON_WRKSRC}/Modules
MD5_FILE= ${PORTSDIR}/lang/python/distinfo
diff --git a/databases/zodb3/Makefile b/databases/zodb3/Makefile
index 82bc5c36f6c9..dca3dba9c116 100644
--- a/databases/zodb3/Makefile
+++ b/databases/zodb3/Makefile
@@ -18,5 +18,6 @@ COMMENT= The Z - Object Database for python
USE_PYTHON= 2.3+
USE_PYDISTUTILS= yes
+PYDISTUTILS_PKGNAME= ZODB3
.include <bsd.port.mk>