aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2006-06-10 10:46:49 +0000
committerErwin Lansing <erwin@FreeBSD.org>2006-06-10 10:46:49 +0000
commitcf69935f05a4e5e41806fc896169a535939303ee (patch)
treeefbf12c5cd86bf41a7062ed43aeb1a60c5cc222c /databases
parent083858b3259dd06b20b3b7fb4f65cc8aa838651b (diff)
downloadports-cf69935f05a4e5e41806fc896169a535939303ee.tar.gz
ports-cf69935f05a4e5e41806fc896169a535939303ee.zip
Notes
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/p5-Rose-DB/Makefile45
-rw-r--r--databases/p5-Rose-DB/distinfo3
-rw-r--r--databases/p5-Rose-DB/pkg-descr3
-rw-r--r--databases/p5-Rose-DB/pkg-plist17
5 files changed, 69 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 22b1455b7f23..6520682c18f4 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -261,6 +261,7 @@
SUBDIR += p5-POE-Component-LaDBI
SUBDIR += p5-Pg
SUBDIR += p5-ResourcePool-Resource-DBI
+ SUBDIR += p5-Rose-DB
SUBDIR += p5-SQL-Abstract
SUBDIR += p5-SQL-Abstract-Limit
SUBDIR += p5-SQL-Statement
diff --git a/databases/p5-Rose-DB/Makefile b/databases/p5-Rose-DB/Makefile
new file mode 100644
index 000000000000..a729c5a489aa
--- /dev/null
+++ b/databases/p5-Rose-DB/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: databases/p5-Rose-DB
+# Date created: 09 June 2006
+# Whom: Zach Thompson <hideo@lastamericanempire.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Rose-DB
+PORTVERSION= 0.673
+CATEGORIES= databases perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Rose
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= hideo@lastamericanempire.com
+COMMENT= A DBI wrapper and abstraction layer
+
+BUILD_DEPENDS= ${SITE_PERL}/Rose/DateTime/Util.pm:${PORTSDIR}/devel/p5-Rose-DateTime \
+ ${SITE_PERL}/${PERL_ARCH}/Bit/Vector/Overload.pm:${PORTSDIR}/math/p5-Bit-Vector \
+ ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI \
+ ${SITE_PERL}/DateTime/Format/MySQL.pm:${PORTSDIR}/devel/p5-DateTime-Format-MySQL \
+ ${SITE_PERL}/DateTime/Format/Pg.pm:${PORTSDIR}/devel/p5-DateTime-Format-Pg
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Rose::DB.3 \
+ Rose::DB::Constants.3 \
+ Rose::DB::Generic.3 \
+ Rose::DB::Informix.3 \
+ Rose::DB::MySQL.3 \
+ Rose::DB::Oracle.3 \
+ Rose::DB::Pg.3 \
+ Rose::DB::Registry.3 \
+ Rose::DB::Registry::Entry.3 \
+ Rose::DB::SQLite.3 \
+ Rose::DB::Tutorial.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl 5.6 or later. Install lang/perl5 then try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/databases/p5-Rose-DB/distinfo b/databases/p5-Rose-DB/distinfo
new file mode 100644
index 000000000000..3ee278e84d97
--- /dev/null
+++ b/databases/p5-Rose-DB/distinfo
@@ -0,0 +1,3 @@
+MD5 (Rose-DB-0.673.tar.gz) = 910625bc6cfff0ed6b82ec3fa2f46e78
+SHA256 (Rose-DB-0.673.tar.gz) = c0d514688fce23b487d1d8ade14ffc33b98c54404b2cb39f80023d1c184c33e6
+SIZE (Rose-DB-0.673.tar.gz) = 65478
diff --git a/databases/p5-Rose-DB/pkg-descr b/databases/p5-Rose-DB/pkg-descr
new file mode 100644
index 000000000000..38029a4a07bc
--- /dev/null
+++ b/databases/p5-Rose-DB/pkg-descr
@@ -0,0 +1,3 @@
+Rose::DB is a wrapper and abstraction layer for DBI-related functionality.
+
+WWW: http://search.cpan.org/dist/Rose-DB/
diff --git a/databases/p5-Rose-DB/pkg-plist b/databases/p5-Rose-DB/pkg-plist
new file mode 100644
index 000000000000..350551f3eb43
--- /dev/null
+++ b/databases/p5-Rose-DB/pkg-plist
@@ -0,0 +1,17 @@
+%%SITE_PERL%%/Rose/DB.pm
+%%SITE_PERL%%/Rose/DB/Constants.pm
+%%SITE_PERL%%/Rose/DB/Generic.pm
+%%SITE_PERL%%/Rose/DB/Informix.pm
+%%SITE_PERL%%/Rose/DB/MySQL.pm
+%%SITE_PERL%%/Rose/DB/Oracle.pm
+%%SITE_PERL%%/Rose/DB/Pg.pm
+%%SITE_PERL%%/Rose/DB/Registry.pm
+%%SITE_PERL%%/Rose/DB/Registry/Entry.pm
+%%SITE_PERL%%/Rose/DB/SQLite.pm
+%%SITE_PERL%%/Rose/DB/Tutorial.pod
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Rose/DB/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Rose/DB
+@dirrmtry %%SITE_PERL%%/Rose/DB/Registry
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Rose
+@dirrmtry %%SITE_PERL%%/Rose/DB
+@dirrmtry %%SITE_PERL%%/Rose