aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2006-10-06 02:48:31 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2006-10-06 02:48:31 +0000
commit0a95ed3134930e5bce059f0c8c606f7852d0af31 (patch)
tree1de458949335b21f943a74ea354593f9d2eda308 /databases
parentd4507b50addd3e919a56abc9344b81f6f7467fff (diff)
downloadports-0a95ed3134930e5bce059f0c8c606f7852d0af31.tar.gz
ports-0a95ed3134930e5bce059f0c8c606f7852d0af31.zip
Notes
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/php-sqlite3/Makefile28
-rw-r--r--databases/php-sqlite3/distinfo3
-rw-r--r--databases/php-sqlite3/pkg-descr16
4 files changed, 48 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index ccc7329ac569..1809854071a3 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -328,6 +328,7 @@
SUBDIR += pgpool
SUBDIR += pgtop
SUBDIR += pgworksheet
+ SUBDIR += php-sqlite3
SUBDIR += php-sqlrelay
SUBDIR += php4-dba
SUBDIR += php4-dbase
diff --git a/databases/php-sqlite3/Makefile b/databases/php-sqlite3/Makefile
new file mode 100644
index 000000000000..a89c5a719e15
--- /dev/null
+++ b/databases/php-sqlite3/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: php-sqlite3
+# Date created: 26 Sep 2006
+# Whom: Simon Cornelius P. Umacob <simoncpu@infoweapons.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sqlite3
+PORTVERSION= 0.4
+CATEGORIES= databases
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= php-sqlite3
+PKGNAMEPREFIX= php-
+EXTRACT_SUFX= .tgz
+#DISTFILES= sqlite3-0.4.tgz
+
+MAINTAINER= simoncpu@infoweapons.com
+COMMENT= A port for the PHP sqlite3 extension
+
+BUILD_DEPENDS= sqlite>=3.0:${PORTSDIR}/databases/sqlite3
+
+CONFIGURE_ARGS= --with-sqlite3=${LOCALBASE}
+USE_PHP= yes
+USE_PHPIZE= yes
+USE_PHPEXT= yes
+USE_PHP_BUILD= yes
+
+.include <bsd.port.mk>
diff --git a/databases/php-sqlite3/distinfo b/databases/php-sqlite3/distinfo
new file mode 100644
index 000000000000..0299b43c5176
--- /dev/null
+++ b/databases/php-sqlite3/distinfo
@@ -0,0 +1,3 @@
+MD5 (sqlite3-0.4.tgz) = fc15ace3f5fd0aac0186745d6cff8a70
+SHA256 (sqlite3-0.4.tgz) = e5a14bc18d29aff39e8b831f30aa28384ca60f0df3edae9ce3173dc69c27ab8d
+SIZE (sqlite3-0.4.tgz) = 14005
diff --git a/databases/php-sqlite3/pkg-descr b/databases/php-sqlite3/pkg-descr
new file mode 100644
index 000000000000..3c70609d3967
--- /dev/null
+++ b/databases/php-sqlite3/pkg-descr
@@ -0,0 +1,16 @@
+php-sqlite3 is a PHP extension that lets you access SQLite3 databases
+within your scripts. PHP4 and PHP5 have already built-in support for this
+RDBM, but this is limited to the 2.x releases. This extension adds support
+for SQLite 3.x release.
+
+Please note that this project is still alpha-quality. Please test and report
+if it works for you and if you have ideas on how it can be enhanced.
+
+Current (or planned) features include:
+
+ * In-memory databases support
+ * UTF-16 encoding
+ * User-level SQL functions
+ * PEAR::DB driver class
+
+WWW: http://php-sqlite3.sourceforge.net/