aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2002-06-16 15:03:10 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2002-06-16 15:03:10 +0000
commit3209d0ed2cc143797c8daed23af744fac7bae88f (patch)
tree860c1e7d1aa2270dd945fbd7842cb80ebf687386 /databases
parentc00b0f53f4a755b319b5a5939106cfe959913672 (diff)
downloadports-3209d0ed2cc143797c8daed23af744fac7bae88f.tar.gz
ports-3209d0ed2cc143797c8daed23af744fac7bae88f.zip
Notes
Diffstat (limited to 'databases')
-rw-r--r--databases/metakit/Makefile18
1 files changed, 13 insertions, 5 deletions
diff --git a/databases/metakit/Makefile b/databases/metakit/Makefile
index ca02d4f360c1..d1b29157dffd 100644
--- a/databases/metakit/Makefile
+++ b/databases/metakit/Makefile
@@ -60,12 +60,20 @@ PLIST_SUB+= WITH_TCL="@comment "
.include <bsd.port.pre.mk>
pre-patch:
- @${PERL5} -pi -e "s/= tclsh/=tclsh${TCL_V}/" \
- ${WRKSRC}/../unix/Makefile.in
- @${PERL5} -pi -e "s=doc/==" ${WRKSRC}/../MetaKit.html
+ @${MV} ${WRKSRC}/../MetaKit.html ${WRKSRC}/../MetaKit.html.sed
+ ${SED} -e "s=doc/==" \
+ ${WRKSRC}/../MetaKit.html.sed > ${WRKSRC}/../MetaKit.html
+.if defined(METAKIT_WITH_TCL83) || defined(METAKIT_WITH_TCL84)
+ @${MV} ${WRKSRC}/../unix/Makefile.in ${WRKSRC}/../unix/Makefile.in.sed
+ ${SED} -e "s/= tclsh/=tclsh${TCL_V}/" \
+ ${WRKSRC}/../unix/Makefile.in.sed \
+ > ${WRKSRC}/../unix/Makefile.in
+.endif
.if defined(METAKIT_WITH_PYTHON)
- ${PERL5} -pi -e "s=python2.2=${PYTHON_VERSION}=" \
- ${WRKSRC}/../unix/Makefile.in
+ @${MV} ${WRKSRC}/../unix/Makefile.in ${WRKSRC}/../unix/Makefile.in.sed
+ ${SED} -e "s=python2.2=${PYTHON_VERSION}=" \
+ ${WRKSRC}/../unix/Makefile.in.sed \
+ > ${WRKSRC}/../unix/Makefile.in
.endif
post-install: