aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2003-01-18 14:39:52 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2003-01-18 14:39:52 +0000
commit88e8ecb26b8c4f4292d906441d4666d95e88f4a4 (patch)
tree9320f0e71c8965197d5337a6d74088bea2d04836 /databases
parent05f1053b345358cc3d480b23271bd182c1287173 (diff)
downloadports-88e8ecb26b8c4f4292d906441d4666d95e88f4a4.tar.gz
ports-88e8ecb26b8c4f4292d906441d4666d95e88f4a4.zip
Notes
Diffstat (limited to 'databases')
-rw-r--r--databases/fastdb/Makefile2
-rw-r--r--databases/fastdb/distinfo2
-rw-r--r--databases/fastdb/files/patch-cliproto.h14
-rw-r--r--databases/fastdb/files/patch-makefile17
-rw-r--r--databases/fastdb/files/patch-sync.cpp16
5 files changed, 25 insertions, 26 deletions
diff --git a/databases/fastdb/Makefile b/databases/fastdb/Makefile
index 26416296f4a2..5553ff754b63 100644
--- a/databases/fastdb/Makefile
+++ b/databases/fastdb/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= fastdb
-PORTVERSION= 2.54
+PORTVERSION= 2.55
CATEGORIES= databases
MASTER_SITES= http://www.garret.ru/~knizhnik/
diff --git a/databases/fastdb/distinfo b/databases/fastdb/distinfo
index 8b7cc9c221f1..4562734d97a1 100644
--- a/databases/fastdb/distinfo
+++ b/databases/fastdb/distinfo
@@ -1 +1 @@
-MD5 (fastdb-2.54.tar.gz) = 16c554c204e6fcc1e5fc95db7cc8e0cd
+MD5 (fastdb-2.55.tar.gz) = c3507a6447f292f08480395ac95e896e
diff --git a/databases/fastdb/files/patch-cliproto.h b/databases/fastdb/files/patch-cliproto.h
new file mode 100644
index 000000000000..b8a3f3accc21
--- /dev/null
+++ b/databases/fastdb/files/patch-cliproto.h
@@ -0,0 +1,14 @@
+--- cliproto.h.orig Thu Nov 21 20:43:08 2002
++++ cliproto.h Wed Dec 18 05:27:43 2002
+@@ -70,10 +70,7 @@
+ cli_oid
+ };
+
+-#if defined(__FreeBSD__)
+-#include <sys/param.h>
+-#define USE_HTON_NTOH
+-#elif defined(__linux__)
++#if defined(__linux__) || defined(__FreeBSD__)
+ //
+ // At Linux inline assembly declarations of ntohl, htonl... are available
+ //
diff --git a/databases/fastdb/files/patch-makefile b/databases/fastdb/files/patch-makefile
index 30d2e0b627e8..37b74abe629a 100644
--- a/databases/fastdb/files/patch-makefile
+++ b/databases/fastdb/files/patch-makefile
@@ -1,5 +1,5 @@
---- makefile.orig Fri Nov 22 00:41:30 2002
-+++ makefile Sun Dec 1 07:54:01 2002
+--- makefile.orig Tue Dec 10 00:22:22 2002
++++ makefile Tue Jan 14 18:57:13 2003
@@ -32,8 +32,8 @@
SUFF=
else
@@ -11,21 +11,22 @@
else
TFLAGS=-D_REENTRANT -D_THREAD_SAFE
THRLIBS=-lpthread
-@@ -65,7 +65,6 @@
+@@ -65,7 +65,7 @@
WEB_EXAMPLES = cgistub bugdb clidb
-CC = g++
++CC = ${CXX}
# Possible FastDB compile time parameters (-Dxxx should be added to DEFS macro):
- # 1. USE_LOCALE_SETTING - use C locale for string comparison operations
-@@ -101,13 +100,13 @@
+ # 1. USE_LOCALE_SETTINGS - use C locale for string comparison operations
+@@ -101,13 +101,13 @@
DEFS = -DUSE_QUEUE_MANAGER -DUSE_LOCALE_SETTINGS
#CFLAGS = $(TFLAGS) -c -Wall -O5 -g $(DEFS)
-CFLAGS = -c -Wall -O0 -g $(DEFS) $(TFLAGS)
-+CFLAGS += -c $(DEFS) $(TFLAGS)
- #CFLAGS = -c -Wall -O0 -DDEBUG=DEBUG_TRACE -g $(DEFS) $(TFLAGS)
++CFLAGS = -c ${CXXFLAGS} $(DEFS) $(TFLAGS)
+ #CFLAGS = -c -Wall -O0 -DFASTDB_DEBUG=DEBUG_TRACE -g $(DEFS) $(TFLAGS)
-SHFLAGS=-shared
+SHFLAGS=-shared -Wl,-soname,$@
@@ -36,7 +37,7 @@
AR = ar
ARFLAGS = -cru
-@@ -326,14 +325,13 @@
+@@ -326,14 +326,13 @@
install: subsql installlib
mkdir -p $(BINSPATH)
diff --git a/databases/fastdb/files/patch-sync.cpp b/databases/fastdb/files/patch-sync.cpp
deleted file mode 100644
index 2416fb7edc8e..000000000000
--- a/databases/fastdb/files/patch-sync.cpp
+++ /dev/null
@@ -1,16 +0,0 @@
---- sync.cpp.orig Fri Mar 2 17:01:17 2001
-+++ sync.cpp Fri Mar 2 17:03:08 2001
-@@ -160,11 +160,11 @@
- #if defined(__GNU_LIBRARY__) && !defined(_SEM_SEMUN_UNDEFINED)
- /* union semun is defined by including <sys/sem.h> */
- #else
--union semun {
-+/*union semun {
- int val;
- struct semid_ds* buf;
- unsigned short* array;
--};
-+};*/
- #endif
- static union semun u;
-