aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2010-02-22 11:21:18 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2010-02-22 11:21:18 +0000
commita404809c84bb39dcd547dac33ed823f926803e62 (patch)
tree1e3d1627466fc3fef773cb5639a34c338d446787 /databases
parentb036602676f95b559f0238af38f3a85c5e047365 (diff)
downloadports-a404809c84bb39dcd547dac33ed823f926803e62.tar.gz
ports-a404809c84bb39dcd547dac33ed823f926803e62.zip
Notes
Diffstat (limited to 'databases')
-rw-r--r--databases/couchdb/Makefile5
-rw-r--r--databases/couchdb/distinfo6
-rw-r--r--databases/couchdb/files/couchdb.in5
-rw-r--r--databases/couchdb/pkg-plist389
4 files changed, 229 insertions, 176 deletions
diff --git a/databases/couchdb/Makefile b/databases/couchdb/Makefile
index 0dd629f88c5a..fe2d877a201e 100644
--- a/databases/couchdb/Makefile
+++ b/databases/couchdb/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= couchdb
-PORTVERSION= 0.9.0
-PORTREVISION= 1
+PORTVERSION= 0.10.1
PORTEPOCH= 1
CATEGORIES= databases
MASTER_SITES= ${MASTER_SITE_APACHE}
@@ -37,6 +36,7 @@ CONFIGURE_ARGS= --with-erlang=${LOCALBASE}/lib/erlang/usr/include \
--disable-init \
--with-js-include=${LOCALBASE}/include \
--with-js-lib=${LOCALBASE}/lib
+PLIST_SUB+= PORTVERSION="${PORTVERSION}"
MAN1= couchdb.1 couchjs.1
@@ -46,6 +46,7 @@ pre-fetch:
@${ECHO_MSG} ""
post-patch:
+ ${REINPLACE_CMD} -e '117s|@INSTALL_PROGRAM@|@INSTALL_SCRIPT@|' ${WRKSRC}/src/couchdb/priv/Makefile.in
.if defined(NOPORTDOCS)
@${REINPLACE_CMD} -e 's/install-data-am$$//' ${WRKSRC}/Makefile.in
.endif
diff --git a/databases/couchdb/distinfo b/databases/couchdb/distinfo
index 1df369ca9589..2f036edaadb8 100644
--- a/databases/couchdb/distinfo
+++ b/databases/couchdb/distinfo
@@ -1,3 +1,3 @@
-MD5 (apache-couchdb-0.9.0.tar.gz) = 16526c807ae8a455a0a4feb50d0357eb
-SHA256 (apache-couchdb-0.9.0.tar.gz) = 8e18416179860f893dc31e81948869195a07cbd69a81966bb9631a0d3ab9f99c
-SIZE (apache-couchdb-0.9.0.tar.gz) = 737185
+MD5 (apache-couchdb-0.10.1.tar.gz) = a34dae8bf402299e378d7e8c13b7ba46
+SHA256 (apache-couchdb-0.10.1.tar.gz) = 2c6af7216537d0e399674a83e4505dc04a02abe1bdd966f69074564c3521c66b
+SIZE (apache-couchdb-0.10.1.tar.gz) = 883259
diff --git a/databases/couchdb/files/couchdb.in b/databases/couchdb/files/couchdb.in
index b6b1c53f78c0..f1e21a1af04f 100644
--- a/databases/couchdb/files/couchdb.in
+++ b/databases/couchdb/files/couchdb.in
@@ -31,7 +31,7 @@ rcvar=${name}_enable
load_rc_config $name
command="%%PREFIX%%/bin/${name}"
-pidfile="/var/run/${name}.pid"
+pidfile="/var/run/${name}/${name}.pid"
etcdir="%%PREFIX%%/etc/${name}"
respawn=""
@@ -50,10 +50,11 @@ if [ "$couchdb_enablelogs" = "YES" ]
fi
: ${couchdb_enable="NO"}
-: ${couchdb_flags="-b -c ${etcdir}/default.ini -c ${etcdir}/local.ini ${respawn}-o ${logfile} -e ${errfile} -p ${pidfile}"}
+: ${couchdb_flags="-b -a ${etcdir}/default.ini -a ${etcdir}/local.ini ${respawn}-o ${logfile} -e ${errfile} -p ${pidfile}"}
start_precmd=pid_touch
stop_cmd="${command} -d && rm -f ${pidfile}"
+status_cmd="${command} -s"
pid_touch ()
{
diff --git a/databases/couchdb/pkg-plist b/databases/couchdb/pkg-plist
index c2f20302c66a..99538d248a72 100644
--- a/databases/couchdb/pkg-plist
+++ b/databases/couchdb/pkg-plist
@@ -4,55 +4,84 @@ etc/couchdb/default.ini
etc/couchdb/local.ini
etc/logrotate.d/couchdb
lib/couchdb/bin/couchjs
-lib/couchdb/erlang/lib/ibrowse-1.4.1/ebin/ibrowse_sup.beam
-lib/couchdb/erlang/lib/ibrowse-1.4.1/ebin/ibrowse_app.beam
-lib/couchdb/erlang/lib/ibrowse-1.4.1/ebin/ibrowse_test.beam
-lib/couchdb/erlang/lib/ibrowse-1.4.1/ebin/ibrowse_lib.beam
-lib/couchdb/erlang/lib/ibrowse-1.4.1/ebin/ibrowse_lb.beam
-lib/couchdb/erlang/lib/ibrowse-1.4.1/ebin/ibrowse_http_client.beam
-lib/couchdb/erlang/lib/ibrowse-1.4.1/ebin/ibrowse.app
-lib/couchdb/erlang/lib/ibrowse-1.4.1/ebin/ibrowse.beam
-lib/couchdb/erlang/lib/couch-0.9.0/include/couch_db.hrl
-lib/couchdb/erlang/lib/couch-0.9.0/priv/lib/couch_erl_driver.la
-lib/couchdb/erlang/lib/couch-0.9.0/priv/lib/couch_erl_driver.so
-lib/couchdb/erlang/lib/couch-0.9.0/priv/lib/couch_erl_driver.a
-lib/couchdb/erlang/lib/couch-0.9.0/ebin/couch_os_process.beam
-lib/couchdb/erlang/lib/couch-0.9.0/ebin/couch_server.beam
-lib/couchdb/erlang/lib/couch-0.9.0/ebin/couch_httpd.beam
-lib/couchdb/erlang/lib/couch-0.9.0/ebin/couch_stream.beam
-lib/couchdb/erlang/lib/couch-0.9.0/ebin/couch_db_updater.beam
-lib/couchdb/erlang/lib/couch-0.9.0/ebin/couch_rep.beam
-lib/couchdb/erlang/lib/couch-0.9.0/ebin/couch_log.beam
-lib/couchdb/erlang/lib/couch-0.9.0/ebin/couch_db_update_notifier_sup.beam
-lib/couchdb/erlang/lib/couch-0.9.0/ebin/couch_event_sup.beam
-lib/couchdb/erlang/lib/couch-0.9.0/ebin/couch_config_writer.beam
-lib/couchdb/erlang/lib/couch-0.9.0/ebin/couch_httpd_stats_handlers.beam
-lib/couchdb/erlang/lib/couch-0.9.0/ebin/couch.app
-lib/couchdb/erlang/lib/couch-0.9.0/ebin/couch_db.beam
-lib/couchdb/erlang/lib/couch-0.9.0/ebin/couch_util.beam
-lib/couchdb/erlang/lib/couch-0.9.0/ebin/couch_task_status.beam
-lib/couchdb/erlang/lib/couch-0.9.0/ebin/couch_db_update_notifier.beam
-lib/couchdb/erlang/lib/couch-0.9.0/ebin/couch_config.beam
-lib/couchdb/erlang/lib/couch-0.9.0/ebin/couch_file.beam
-lib/couchdb/erlang/lib/couch-0.9.0/ebin/couch_httpd_view.beam
-lib/couchdb/erlang/lib/couch-0.9.0/ebin/couch_httpd_db.beam
-lib/couchdb/erlang/lib/couch-0.9.0/ebin/couch_btree.beam
-lib/couchdb/erlang/lib/couch-0.9.0/ebin/couch_rep_sup.beam
-lib/couchdb/erlang/lib/couch-0.9.0/ebin/couch_view.beam
-lib/couchdb/erlang/lib/couch-0.9.0/ebin/couch_view_group.beam
-lib/couchdb/erlang/lib/couch-0.9.0/ebin/couch_external_server.beam
-lib/couchdb/erlang/lib/couch-0.9.0/ebin/couch_stats_aggregator.beam
-lib/couchdb/erlang/lib/couch-0.9.0/ebin/couch_stats_collector.beam
-lib/couchdb/erlang/lib/couch-0.9.0/ebin/couch_ref_counter.beam
-lib/couchdb/erlang/lib/couch-0.9.0/ebin/couch_query_servers.beam
-lib/couchdb/erlang/lib/couch-0.9.0/ebin/couch_doc.beam
-lib/couchdb/erlang/lib/couch-0.9.0/ebin/couch_server_sup.beam
-lib/couchdb/erlang/lib/couch-0.9.0/ebin/couch_httpd_misc_handlers.beam
-lib/couchdb/erlang/lib/couch-0.9.0/ebin/couch_httpd_external.beam
-lib/couchdb/erlang/lib/couch-0.9.0/ebin/couch_httpd_show.beam
-lib/couchdb/erlang/lib/couch-0.9.0/ebin/couch_external_manager.beam
-lib/couchdb/erlang/lib/couch-0.9.0/ebin/couch_view_updater.beam
-lib/couchdb/erlang/lib/couch-0.9.0/ebin/couch_key_tree.beam
+lib/couchdb/erlang/lib/couch-%%PORTVERSION%%/ebin/couch.app
+lib/couchdb/erlang/lib/couch-%%PORTVERSION%%/ebin/couch_batch_save.beam
+lib/couchdb/erlang/lib/couch-%%PORTVERSION%%/ebin/couch_batch_save_sup.beam
+lib/couchdb/erlang/lib/couch-%%PORTVERSION%%/ebin/couch_btree.beam
+lib/couchdb/erlang/lib/couch-%%PORTVERSION%%/ebin/couch_config.beam
+lib/couchdb/erlang/lib/couch-%%PORTVERSION%%/ebin/couch_config_writer.beam
+lib/couchdb/erlang/lib/couch-%%PORTVERSION%%/ebin/couch_db.beam
+lib/couchdb/erlang/lib/couch-%%PORTVERSION%%/ebin/couch_db_update_notifier.beam
+lib/couchdb/erlang/lib/couch-%%PORTVERSION%%/ebin/couch_db_update_notifier_sup.beam
+lib/couchdb/erlang/lib/couch-%%PORTVERSION%%/ebin/couch_db_updater.beam
+lib/couchdb/erlang/lib/couch-%%PORTVERSION%%/ebin/couch_doc.beam
+lib/couchdb/erlang/lib/couch-%%PORTVERSION%%/ebin/couch_event_sup.beam
+lib/couchdb/erlang/lib/couch-%%PORTVERSION%%/ebin/couch_external_manager.beam
+lib/couchdb/erlang/lib/couch-%%PORTVERSION%%/ebin/couch_external_server.beam
+lib/couchdb/erlang/lib/couch-%%PORTVERSION%%/ebin/couch_file.beam
+lib/couchdb/erlang/lib/couch-%%PORTVERSION%%/ebin/couch_httpd.beam
+lib/couchdb/erlang/lib/couch-%%PORTVERSION%%/ebin/couch_httpd_auth.beam
+lib/couchdb/erlang/lib/couch-%%PORTVERSION%%/ebin/couch_httpd_db.beam
+lib/couchdb/erlang/lib/couch-%%PORTVERSION%%/ebin/couch_httpd_external.beam
+lib/couchdb/erlang/lib/couch-%%PORTVERSION%%/ebin/couch_httpd_misc_handlers.beam
+lib/couchdb/erlang/lib/couch-%%PORTVERSION%%/ebin/couch_httpd_oauth.beam
+lib/couchdb/erlang/lib/couch-%%PORTVERSION%%/ebin/couch_httpd_show.beam
+lib/couchdb/erlang/lib/couch-%%PORTVERSION%%/ebin/couch_httpd_stats_handlers.beam
+lib/couchdb/erlang/lib/couch-%%PORTVERSION%%/ebin/couch_httpd_view.beam
+lib/couchdb/erlang/lib/couch-%%PORTVERSION%%/ebin/couch_key_tree.beam
+lib/couchdb/erlang/lib/couch-%%PORTVERSION%%/ebin/couch_log.beam
+lib/couchdb/erlang/lib/couch-%%PORTVERSION%%/ebin/couch_native_process.beam
+lib/couchdb/erlang/lib/couch-%%PORTVERSION%%/ebin/couch_os_process.beam
+lib/couchdb/erlang/lib/couch-%%PORTVERSION%%/ebin/couch_query_servers.beam
+lib/couchdb/erlang/lib/couch-%%PORTVERSION%%/ebin/couch_ref_counter.beam
+lib/couchdb/erlang/lib/couch-%%PORTVERSION%%/ebin/couch_rep.beam
+lib/couchdb/erlang/lib/couch-%%PORTVERSION%%/ebin/couch_rep_att.beam
+lib/couchdb/erlang/lib/couch-%%PORTVERSION%%/ebin/couch_rep_changes_feed.beam
+lib/couchdb/erlang/lib/couch-%%PORTVERSION%%/ebin/couch_rep_httpc.beam
+lib/couchdb/erlang/lib/couch-%%PORTVERSION%%/ebin/couch_rep_missing_revs.beam
+lib/couchdb/erlang/lib/couch-%%PORTVERSION%%/ebin/couch_rep_reader.beam
+lib/couchdb/erlang/lib/couch-%%PORTVERSION%%/ebin/couch_rep_sup.beam
+lib/couchdb/erlang/lib/couch-%%PORTVERSION%%/ebin/couch_rep_writer.beam
+lib/couchdb/erlang/lib/couch-%%PORTVERSION%%/ebin/couch_server.beam
+lib/couchdb/erlang/lib/couch-%%PORTVERSION%%/ebin/couch_server_sup.beam
+lib/couchdb/erlang/lib/couch-%%PORTVERSION%%/ebin/couch_stats_aggregator.beam
+lib/couchdb/erlang/lib/couch-%%PORTVERSION%%/ebin/couch_stats_collector.beam
+lib/couchdb/erlang/lib/couch-%%PORTVERSION%%/ebin/couch_stream.beam
+lib/couchdb/erlang/lib/couch-%%PORTVERSION%%/ebin/couch_task_status.beam
+lib/couchdb/erlang/lib/couch-%%PORTVERSION%%/ebin/couch_util.beam
+lib/couchdb/erlang/lib/couch-%%PORTVERSION%%/ebin/couch_view.beam
+lib/couchdb/erlang/lib/couch-%%PORTVERSION%%/ebin/couch_view_compactor.beam
+lib/couchdb/erlang/lib/couch-%%PORTVERSION%%/ebin/couch_view_group.beam
+lib/couchdb/erlang/lib/couch-%%PORTVERSION%%/ebin/couch_view_updater.beam
+lib/couchdb/erlang/lib/couch-%%PORTVERSION%%/include/couch_db.hrl
+lib/couchdb/erlang/lib/couch-%%PORTVERSION%%/priv/couchspawnkillable
+lib/couchdb/erlang/lib/couch-%%PORTVERSION%%/priv/lib/couch_erl_driver.a
+lib/couchdb/erlang/lib/couch-%%PORTVERSION%%/priv/lib/couch_erl_driver.la
+lib/couchdb/erlang/lib/couch-%%PORTVERSION%%/priv/lib/couch_erl_driver.so
+lib/couchdb/erlang/lib/erlang-oauth/ebin/oauth.app
+lib/couchdb/erlang/lib/erlang-oauth/ebin/oauth.beam
+lib/couchdb/erlang/lib/erlang-oauth/ebin/oauth_hmac_sha1.beam
+lib/couchdb/erlang/lib/erlang-oauth/ebin/oauth_http.beam
+lib/couchdb/erlang/lib/erlang-oauth/ebin/oauth_plaintext.beam
+lib/couchdb/erlang/lib/erlang-oauth/ebin/oauth_unix.beam
+lib/couchdb/erlang/lib/erlang-oauth/ebin/oauth_uri.beam
+lib/couchdb/erlang/lib/etap/ebin/etap.beam
+lib/couchdb/erlang/lib/etap/ebin/etap_application.beam
+lib/couchdb/erlang/lib/etap/ebin/etap_can.beam
+lib/couchdb/erlang/lib/etap/ebin/etap_exception.beam
+lib/couchdb/erlang/lib/etap/ebin/etap_process.beam
+lib/couchdb/erlang/lib/etap/ebin/etap_report.beam
+lib/couchdb/erlang/lib/etap/ebin/etap_request.beam
+lib/couchdb/erlang/lib/etap/ebin/etap_string.beam
+lib/couchdb/erlang/lib/etap/ebin/etap_web.beam
+lib/couchdb/erlang/lib/ibrowse-1.5.2/ebin/ibrowse.app
+lib/couchdb/erlang/lib/ibrowse-1.5.2/ebin/ibrowse.beam
+lib/couchdb/erlang/lib/ibrowse-1.5.2/ebin/ibrowse_app.beam
+lib/couchdb/erlang/lib/ibrowse-1.5.2/ebin/ibrowse_http_client.beam
+lib/couchdb/erlang/lib/ibrowse-1.5.2/ebin/ibrowse_lb.beam
+lib/couchdb/erlang/lib/ibrowse-1.5.2/ebin/ibrowse_lib.beam
+lib/couchdb/erlang/lib/ibrowse-1.5.2/ebin/ibrowse_sup.beam
+lib/couchdb/erlang/lib/ibrowse-1.5.2/ebin/ibrowse_test.beam
lib/couchdb/erlang/lib/mochiweb-r97/ebin/mochifmt.beam
lib/couchdb/erlang/lib/mochiweb-r97/ebin/mochifmt_records.beam
lib/couchdb/erlang/lib/mochiweb-r97/ebin/mochifmt_std.beam
@@ -77,111 +106,127 @@ lib/couchdb/erlang/lib/mochiweb-r97/ebin/mochiweb_socket_server.beam
lib/couchdb/erlang/lib/mochiweb-r97/ebin/mochiweb_sup.beam
lib/couchdb/erlang/lib/mochiweb-r97/ebin/mochiweb_util.beam
lib/couchdb/erlang/lib/mochiweb-r97/ebin/reloader.beam
-share/couchdb/server/main.js
-share/couchdb/www/_sidebar.html
-share/couchdb/www/config.html
-share/couchdb/www/couch_tests.html
-share/couchdb/www/database.html
-share/couchdb/www/dialog/_compact_database.html
-share/couchdb/www/dialog/_create_database.html
-share/couchdb/www/dialog/_create_document.html
-share/couchdb/www/dialog/_delete_database.html
-share/couchdb/www/dialog/_delete_document.html
-share/couchdb/www/dialog/_save_view_as.html
-share/couchdb/www/dialog/_upload_attachment.html
-share/couchdb/www/document.html
-share/couchdb/www/favicon.ico
-share/couchdb/www/image/add.png
-share/couchdb/www/image/apply.gif
-share/couchdb/www/image/bg.png
-share/couchdb/www/image/cancel.gif
-share/couchdb/www/image/compact.png
-share/couchdb/www/image/delete-mini.png
-share/couchdb/www/image/delete.png
-share/couchdb/www/image/grippie.gif
-share/couchdb/www/image/hgrad.gif
-share/couchdb/www/image/load.png
-share/couchdb/www/image/logo.png
-share/couchdb/www/image/order-asc.gif
-share/couchdb/www/image/order-desc.gif
-share/couchdb/www/image/path.gif
-share/couchdb/www/image/progress.gif
-share/couchdb/www/image/rarrow.png
-share/couchdb/www/image/run-mini.png
-share/couchdb/www/image/run.png
-share/couchdb/www/image/running.png
-share/couchdb/www/image/save.png
-share/couchdb/www/image/spinner.gif
-share/couchdb/www/image/test_failure.gif
-share/couchdb/www/image/test_success.gif
-share/couchdb/www/image/thead-key.gif
-share/couchdb/www/image/thead.gif
-share/couchdb/www/image/toggle-collapse.gif
-share/couchdb/www/image/toggle-expand.gif
-share/couchdb/www/image/twisty.gif
-share/couchdb/www/index.html
-share/couchdb/www/replicator.html
-share/couchdb/www/script/couch.js
-share/couchdb/www/script/couch_test_runner.js
-share/couchdb/www/script/couch_tests.js
-share/couchdb/www/script/futon.browse.js
-share/couchdb/www/script/futon.format.js
-share/couchdb/www/script/futon.js
-share/couchdb/www/script/jquery.cookies.js
-share/couchdb/www/script/jquery.couch.js
-share/couchdb/www/script/jquery.dialog.js
-share/couchdb/www/script/jquery.editinline.js
-share/couchdb/www/script/jquery.form.js
-share/couchdb/www/script/jquery.js
-share/couchdb/www/script/jquery.resizer.js
-share/couchdb/www/script/jquery.suggest.js
-share/couchdb/www/script/json2.js
-share/couchdb/www/script/test/view_include_docs.js
-share/couchdb/www/script/test/conflicts.js
-share/couchdb/www/script/test/show_documents.js
-share/couchdb/www/script/test/view_collation.js
-share/couchdb/www/script/test/utf8.js
-share/couchdb/www/script/test/design_docs.js
-share/couchdb/www/script/test/view_xml.js
-share/couchdb/www/script/test/design_options.js
-share/couchdb/www/script/test/uuids.js
-share/couchdb/www/script/test/etags_views.js
-share/couchdb/www/script/test/multiple_rows.js
-share/couchdb/www/script/test/design_paths.js
-share/couchdb/www/script/test/copy_doc.js
-share/couchdb/www/script/test/large_docs.js
-share/couchdb/www/script/test/recreate_doc.js
-share/couchdb/www/script/test/all_docs.js
-share/couchdb/www/script/test/config.js
-share/couchdb/www/script/test/attachment_views.js
-share/couchdb/www/script/test/lots_of_docs.js
-share/couchdb/www/script/test/view_sandboxing.js
-share/couchdb/www/script/test/etags_head.js
-share/couchdb/www/script/test/reduce.js
-share/couchdb/www/script/test/replication.js
-share/couchdb/www/script/test/stats.js
-share/couchdb/www/script/test/security_validation.js
-share/couchdb/www/script/test/compact.js
-share/couchdb/www/script/test/view_offsets.js
-share/couchdb/www/script/test/list_views.js
-share/couchdb/www/script/test/view_errors.js
-share/couchdb/www/script/test/attachments.js
-share/couchdb/www/script/test/reduce_false.js
-share/couchdb/www/script/test/attachment_paths.js
-share/couchdb/www/script/test/bulk_docs.js
-share/couchdb/www/script/test/rev_stemming.js
-share/couchdb/www/script/test/purge.js
-share/couchdb/www/script/test/invalid_docids.js
-share/couchdb/www/script/test/view_pagination.js
-share/couchdb/www/script/test/delayed_commits.js
-share/couchdb/www/script/test/view_conflicts.js
-share/couchdb/www/script/test/view_multi_key_all_docs.js
-share/couchdb/www/script/test/view_multi_key_temp.js
-share/couchdb/www/script/test/view_multi_key_design.js
-share/couchdb/www/script/test/basics.js
-share/couchdb/www/script/test/content_negotiation.js
-share/couchdb/www/status.html
-share/couchdb/www/style/layout.css
+%%DATADIR%%/server/main.js
+%%DATADIR%%/www/_sidebar.html
+%%DATADIR%%/www/config.html
+%%DATADIR%%/www/couch_tests.html
+%%DATADIR%%/www/custom_test.html
+%%DATADIR%%/www/database.html
+%%DATADIR%%/www/dialog/_compact_database.html
+%%DATADIR%%/www/dialog/_create_database.html
+%%DATADIR%%/www/dialog/_delete_database.html
+%%DATADIR%%/www/dialog/_delete_document.html
+%%DATADIR%%/www/dialog/_save_view_as.html
+%%DATADIR%%/www/dialog/_upload_attachment.html
+%%DATADIR%%/www/document.html
+%%DATADIR%%/www/favicon.ico
+%%DATADIR%%/www/image/add.png
+%%DATADIR%%/www/image/apply.gif
+%%DATADIR%%/www/image/bg.png
+%%DATADIR%%/www/image/cancel.gif
+%%DATADIR%%/www/image/compact.png
+%%DATADIR%%/www/image/delete-mini.png
+%%DATADIR%%/www/image/delete.png
+%%DATADIR%%/www/image/grippie.gif
+%%DATADIR%%/www/image/hgrad.gif
+%%DATADIR%%/www/image/load.png
+%%DATADIR%%/www/image/logo.png
+%%DATADIR%%/www/image/order-asc.gif
+%%DATADIR%%/www/image/order-desc.gif
+%%DATADIR%%/www/image/path.gif
+%%DATADIR%%/www/image/progress.gif
+%%DATADIR%%/www/image/rarrow.png
+%%DATADIR%%/www/image/run-mini.png
+%%DATADIR%%/www/image/run.png
+%%DATADIR%%/www/image/running.png
+%%DATADIR%%/www/image/save.png
+%%DATADIR%%/www/image/sidebar-toggle.png
+%%DATADIR%%/www/image/spinner.gif
+%%DATADIR%%/www/image/test_failure.gif
+%%DATADIR%%/www/image/test_success.gif
+%%DATADIR%%/www/image/thead-key.gif
+%%DATADIR%%/www/image/thead.gif
+%%DATADIR%%/www/image/toggle-collapse.gif
+%%DATADIR%%/www/image/toggle-expand.gif
+%%DATADIR%%/www/image/twisty.gif
+%%DATADIR%%/www/index.html
+%%DATADIR%%/www/replicator.html
+%%DATADIR%%/www/script/couch.js
+%%DATADIR%%/www/script/couch_test_runner.js
+%%DATADIR%%/www/script/couch_tests.js
+%%DATADIR%%/www/script/futon.browse.js
+%%DATADIR%%/www/script/futon.format.js
+%%DATADIR%%/www/script/futon.js
+%%DATADIR%%/www/script/jquery.cookies.js
+%%DATADIR%%/www/script/jquery.couch.js
+%%DATADIR%%/www/script/jquery.dialog.js
+%%DATADIR%%/www/script/jquery.editinline.js
+%%DATADIR%%/www/script/jquery.form.js
+%%DATADIR%%/www/script/jquery.js
+%%DATADIR%%/www/script/jquery.resizer.js
+%%DATADIR%%/www/script/jquery.suggest.js
+%%DATADIR%%/www/script/json2.js
+%%DATADIR%%/www/script/oauth.js
+%%DATADIR%%/www/script/sha1.js
+%%DATADIR%%/www/script/test/all_docs.js
+%%DATADIR%%/www/script/test/attachment_names.js
+%%DATADIR%%/www/script/test/attachment_paths.js
+%%DATADIR%%/www/script/test/attachment_views.js
+%%DATADIR%%/www/script/test/attachments.js
+%%DATADIR%%/www/script/test/basics.js
+%%DATADIR%%/www/script/test/batch_save.js
+%%DATADIR%%/www/script/test/bulk_docs.js
+%%DATADIR%%/www/script/test/changes.js
+%%DATADIR%%/www/script/test/compact.js
+%%DATADIR%%/www/script/test/config.js
+%%DATADIR%%/www/script/test/conflicts.js
+%%DATADIR%%/www/script/test/content_negotiation.js
+%%DATADIR%%/www/script/test/cookie_auth.js
+%%DATADIR%%/www/script/test/copy_doc.js
+%%DATADIR%%/www/script/test/delayed_commits.js
+%%DATADIR%%/www/script/test/design_docs.js
+%%DATADIR%%/www/script/test/design_options.js
+%%DATADIR%%/www/script/test/design_paths.js
+%%DATADIR%%/www/script/test/erlang_views.js
+%%DATADIR%%/www/script/test/etags_head.js
+%%DATADIR%%/www/script/test/etags_views.js
+%%DATADIR%%/www/script/test/form_submit.js
+%%DATADIR%%/www/script/test/http.js
+%%DATADIR%%/www/script/test/invalid_docids.js
+%%DATADIR%%/www/script/test/jsonp.js
+%%DATADIR%%/www/script/test/large_docs.js
+%%DATADIR%%/www/script/test/list_views.js
+%%DATADIR%%/www/script/test/lorem.txt
+%%DATADIR%%/www/script/test/lorem_b64.txt
+%%DATADIR%%/www/script/test/lots_of_docs.js
+%%DATADIR%%/www/script/test/multiple_rows.js
+%%DATADIR%%/www/script/test/oauth.js
+%%DATADIR%%/www/script/test/purge.js
+%%DATADIR%%/www/script/test/recreate_doc.js
+%%DATADIR%%/www/script/test/reduce.js
+%%DATADIR%%/www/script/test/reduce_builtin.js
+%%DATADIR%%/www/script/test/reduce_false.js
+%%DATADIR%%/www/script/test/replication.js
+%%DATADIR%%/www/script/test/rev_stemming.js
+%%DATADIR%%/www/script/test/security_validation.js
+%%DATADIR%%/www/script/test/show_documents.js
+%%DATADIR%%/www/script/test/stats.js
+%%DATADIR%%/www/script/test/update_documents.js
+%%DATADIR%%/www/script/test/utf8.js
+%%DATADIR%%/www/script/test/uuids.js
+%%DATADIR%%/www/script/test/view_collation.js
+%%DATADIR%%/www/script/test/view_conflicts.js
+%%DATADIR%%/www/script/test/view_errors.js
+%%DATADIR%%/www/script/test/view_include_docs.js
+%%DATADIR%%/www/script/test/view_multi_key_all_docs.js
+%%DATADIR%%/www/script/test/view_multi_key_design.js
+%%DATADIR%%/www/script/test/view_multi_key_temp.js
+%%DATADIR%%/www/script/test/view_offsets.js
+%%DATADIR%%/www/script/test/view_pagination.js
+%%DATADIR%%/www/script/test/view_sandboxing.js
+%%DATADIR%%/www/script/test/view_xml.js
+%%DATADIR%%/www/status.html
+%%DATADIR%%/www/style/layout.css
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS.gz
%%PORTDOCS%%%%DOCSDIR%%/BUGS.gz
%%PORTDOCS%%%%DOCSDIR%%/CHANGES.gz
@@ -189,26 +234,32 @@ share/couchdb/www/style/layout.css
%%PORTDOCS%%%%DOCSDIR%%/README.gz
%%PORTDOCS%%%%DOCSDIR%%/THANKS.gz
%%PORTDOCS%%@dirrm %%DOCSDIR%%
-@dirrm share/couchdb/www/style
-@dirrm share/couchdb/www/script/test
-@dirrm share/couchdb/www/script
-@dirrm share/couchdb/www/image
-@dirrm share/couchdb/www/dialog
-@dirrm share/couchdb/www
-@dirrm share/couchdb/server
-@dirrm share/couchdb
-@dirrm lib/couchdb/erlang/lib/couch-0.9.0/ebin
-@dirrm lib/couchdb/erlang/lib/couch-0.9.0/include
-@dirrm lib/couchdb/erlang/lib/couch-0.9.0/priv/lib
-@dirrm lib/couchdb/erlang/lib/couch-0.9.0/priv
-@dirrm lib/couchdb/erlang/lib/couch-0.9.0
-@dirrm lib/couchdb/erlang/lib/ibrowse-1.4.1/ebin
-@dirrm lib/couchdb/erlang/lib/ibrowse-1.4.1
@dirrm lib/couchdb/erlang/lib/mochiweb-r97/ebin
@dirrm lib/couchdb/erlang/lib/mochiweb-r97
+@dirrm lib/couchdb/erlang/lib/ibrowse-1.5.2/ebin
+@dirrm lib/couchdb/erlang/lib/ibrowse-1.5.2
+@dirrm lib/couchdb/erlang/lib/etap/ebin
+@dirrm lib/couchdb/erlang/lib/etap
+@dirrm lib/couchdb/erlang/lib/erlang-oauth/ebin
+@dirrm lib/couchdb/erlang/lib/erlang-oauth
+@dirrm lib/couchdb/erlang/lib/couch-%%PORTVERSION%%/priv/lib
+@dirrm lib/couchdb/erlang/lib/couch-%%PORTVERSION%%/priv
+@dirrm lib/couchdb/erlang/lib/couch-%%PORTVERSION%%/include
+@dirrm lib/couchdb/erlang/lib/couch-%%PORTVERSION%%/ebin
+@dirrm lib/couchdb/erlang/lib/couch-%%PORTVERSION%%
@dirrm lib/couchdb/erlang/lib
@dirrm lib/couchdb/erlang
@dirrm lib/couchdb/bin
@dirrm lib/couchdb
@dirrm etc/logrotate.d
+@dirrm etc/couchdb/default.d
+@dirrm etc/couchdb/local.d
@dirrm etc/couchdb
+@dirrm %%DATADIR%%/www/style
+@dirrm %%DATADIR%%/www/script/test
+@dirrm %%DATADIR%%/www/script
+@dirrm %%DATADIR%%/www/image
+@dirrm %%DATADIR%%/www/dialog
+@dirrm %%DATADIR%%/www
+@dirrm %%DATADIR%%/server
+@dirrm %%DATADIR%%