aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-05-12 16:29:52 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-05-12 16:29:52 +0000
commitb132d22e3a13941d7b3d3d36da0aea72f962f667 (patch)
tree51538c8652f87bbe2c85bd7b8301c64c4f745af8 /databases
parente353c059a5006646ca81c19547b42542c7cbe1bd (diff)
Notes
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/py-tiledb/Makefile25
-rw-r--r--databases/py-tiledb/distinfo3
-rw-r--r--databases/py-tiledb/pkg-descr9
4 files changed, 38 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 38917a88cbce..532dcc684a3d 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -844,6 +844,7 @@
SUBDIR += py-sybase
SUBDIR += py-tableschema
SUBDIR += py-tarantool
+ SUBDIR += py-tiledb
SUBDIR += py-umemcache
SUBDIR += py-unqlite
SUBDIR += py-varstack
diff --git a/databases/py-tiledb/Makefile b/databases/py-tiledb/Makefile
new file mode 100644
index 000000000000..c0c19041cb27
--- /dev/null
+++ b/databases/py-tiledb/Makefile
@@ -0,0 +1,25 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= tiledb
+PORTVERSION= 0.4.1
+CATEGORIES= databases python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Python interface to the TileDB array storage manager
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>=1.5.4:devel/py-setuptools_scm@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0.30:devel/py-wheel@${PY_FLAVOR} \
+ ${RUN_DEPENDS}
+LIB_DEPENDS= libtiledb.so:databases/tiledb
+RUN_DEPENDS= ${PYNUMPY}
+
+USES= compiler:c++11-lang localbase python
+USE_PYTHON= autoplist concurrent cython distutils
+
+.include <bsd.port.mk>
diff --git a/databases/py-tiledb/distinfo b/databases/py-tiledb/distinfo
new file mode 100644
index 000000000000..789b33ef0124
--- /dev/null
+++ b/databases/py-tiledb/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1557542559
+SHA256 (tiledb-0.4.1.tar.gz) = 6b97d45a00cc12366a599a2196489fcbdd4c1fad17b198cbeec7a2754d44ad31
+SIZE (tiledb-0.4.1.tar.gz) = 73597
diff --git a/databases/py-tiledb/pkg-descr b/databases/py-tiledb/pkg-descr
new file mode 100644
index 000000000000..066fb205fb44
--- /dev/null
+++ b/databases/py-tiledb/pkg-descr
@@ -0,0 +1,9 @@
+TileDB is an efficient multi-dimensional array management system which
+introduces a novel format that can effectively store dense and sparse array data
+with support for fast updates and reads. It features excellent compression, an
+efficient parallel I/O system for high scalability, and high-level APIs
+including Python, R, Golang and more.
+
+TileDB-Py is the official Python interface to TileDB.
+
+WWW: https://github.com/TileDB-Inc/TileDB-Py