aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorPalle Girgensohn <girgen@FreeBSD.org>2010-11-21 20:57:15 +0000
committerPalle Girgensohn <girgen@FreeBSD.org>2010-11-21 20:57:15 +0000
commitd65b6815506967ded0cd3af9cabca64ec83e91c1 (patch)
tree8ffca41d91f01d27f272311de0dacb2079b08526 /databases
parent1a85e5452067ef80c734fce836ff3fd7a5c9f0b5 (diff)
downloadports-d65b6815506967ded0cd3af9cabca64ec83e91c1.tar.gz
ports-d65b6815506967ded0cd3af9cabca64ec83e91c1.zip
Notes
Diffstat (limited to 'databases')
-rw-r--r--databases/postgresql-tcltk/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/databases/postgresql-tcltk/Makefile b/databases/postgresql-tcltk/Makefile
index b16fb2693ecb..eadb50f7adaf 100644
--- a/databases/postgresql-tcltk/Makefile
+++ b/databases/postgresql-tcltk/Makefile
@@ -20,19 +20,18 @@ LIB_DEPENDS= tcl${TCLVERSION:S/.//}:${TCLPORTDIR}${TCLVERSION:C/[^0-9]//g}
USE_PGSQL= yes
MASTERDIR= ${.CURDIR}/../../databases/postgresql74-server
-BROKEN= does not compile
-
CONFLICTS= ${PORTNAME}${PKGNAMESUFFIX}-7.[0-3]*
LATEST_LINK= ${PKGNAMEPREFIX}${PORTNAME}${PKGNAMESUFFIX}
# you can use "make TCLVERSION=8.4" or similar for your favourite tcl version
-TCLVERSION?= 8.4
+TCLVERSION?= 8.5
PLIST_SUB+= TCLVERSION=${TCLVERSION}
CONFIGURE_ARGS= --with-tcl \
--with-tclconfig=${TCLCONFIG} \
--with-includes=${INCDIRS}
+INCLUDES+= -I${TCL_INCDIR}
TCL_INCDIR= ${LOCALBASE}/include/tcl${TCLVERSION}
TCLCONFIG= ${LOCALBASE}/lib/tcl${TCLVERSION}
MAKE_ENV+= TCL_INCDIR=${TCL_INCDIR}
@@ -57,6 +56,7 @@ CONFIGURE_ENV+= WISH=${LOCALBASE}/bin/wish${TCLVERSION}
LIB_DEPENDS+= tk${TCLVERSION:S/.//}:${TKPORTDIR}${TCLVERSION:C/[^0-9]//g}
TKCONFIG= ${LOCALBASE}/lib/tk${TCLVERSION}
INCDIRS= ${TCL_INCDIR}:${TK_INCDIR}
+INCLUDES+= -I${TK_INCDIR}
PLIST_SUB+= TK=""
CATEGORIES+= tk
.endif