aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorJimmy Olgeni <olgeni@FreeBSD.org>2009-08-04 12:28:36 +0000
committerJimmy Olgeni <olgeni@FreeBSD.org>2009-08-04 12:28:36 +0000
commit4e3ba2bc314f0b9955a5cd1c6bccd8742c7db45d (patch)
treeb3cd7d41c67d6dcba784b4fc3e3c7c04f0232427 /databases
parent61c1a77b38f2e14cd6bdfea14ebffccaeb7f07ae (diff)
downloadports-4e3ba2bc314f0b9955a5cd1c6bccd8742c7db45d.tar.gz
ports-4e3ba2bc314f0b9955a5cd1c6bccd8742c7db45d.zip
Notes
Diffstat (limited to 'databases')
-rw-r--r--databases/slony1/Makefile7
-rw-r--r--databases/slony1v2/Makefile7
2 files changed, 8 insertions, 6 deletions
diff --git a/databases/slony1/Makefile b/databases/slony1/Makefile
index 6de4d7a80805..1f68cc41285c 100644
--- a/databases/slony1/Makefile
+++ b/databases/slony1/Makefile
@@ -15,11 +15,10 @@ DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX} \
MAINTAINER= vivek@khera.org
COMMENT= PostgreSQL master to multiple replicas replication system
-PGSQL_PORT= ${PORTSDIR}/databases/postgresql${PGSQL_VER}-server
-RUN_DEPENDS= ${LOCALBASE}/bin/postmaster:${PGSQL_PORT}
-BUILD_DEPENDS= ${LOCALBASE}/bin/postmaster:${PGSQL_PORT}
+BUILD_DEPENDS= ${LOCALBASE}/bin/postmaster:${PORTSDIR}/databases/postgresql${PGSQL_VER}-server
GNU_CONFIGURE= yes
+USE_PGSQL= yes
USE_GMAKE= yes
USE_BZIP2= yes
USE_RC_SUBR= slon.sh
@@ -31,6 +30,8 @@ OPTIONS= PERLTOOLS "Install perl configuration tools" Off
.include <bsd.port.pre.mk>
+IGNORE_WITH_PGSQL= 84
+
.if defined(WITH_PERLTOOLS)
USE_PERL5= yes
CONFIGURE_ARGS+= --with-perltools=${LOCALBASE}/sbin
diff --git a/databases/slony1v2/Makefile b/databases/slony1v2/Makefile
index 6de4d7a80805..1f68cc41285c 100644
--- a/databases/slony1v2/Makefile
+++ b/databases/slony1v2/Makefile
@@ -15,11 +15,10 @@ DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX} \
MAINTAINER= vivek@khera.org
COMMENT= PostgreSQL master to multiple replicas replication system
-PGSQL_PORT= ${PORTSDIR}/databases/postgresql${PGSQL_VER}-server
-RUN_DEPENDS= ${LOCALBASE}/bin/postmaster:${PGSQL_PORT}
-BUILD_DEPENDS= ${LOCALBASE}/bin/postmaster:${PGSQL_PORT}
+BUILD_DEPENDS= ${LOCALBASE}/bin/postmaster:${PORTSDIR}/databases/postgresql${PGSQL_VER}-server
GNU_CONFIGURE= yes
+USE_PGSQL= yes
USE_GMAKE= yes
USE_BZIP2= yes
USE_RC_SUBR= slon.sh
@@ -31,6 +30,8 @@ OPTIONS= PERLTOOLS "Install perl configuration tools" Off
.include <bsd.port.pre.mk>
+IGNORE_WITH_PGSQL= 84
+
.if defined(WITH_PERLTOOLS)
USE_PERL5= yes
CONFIGURE_ARGS+= --with-perltools=${LOCALBASE}/sbin