aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorTorsten Zuehlsdorff <tz@FreeBSD.org>2017-06-23 09:02:17 +0000
committerTorsten Zuehlsdorff <tz@FreeBSD.org>2017-06-23 09:02:17 +0000
commitc97630de3bf159a1cf067580aaed0fe6da923be5 (patch)
tree0ccbbc0dca9bdcfa1289c8ee69eb5110c76f4136 /databases
parent609eedc42b0f8191d899923657eb3d134debb7e4 (diff)
downloadports-c97630de3bf159a1cf067580aaed0fe6da923be5.tar.gz
ports-c97630de3bf159a1cf067580aaed0fe6da923be5.zip
New port: databases/postgresql-mysql_fdw
This PostgreSQL extension implements a Foreign Data Wrapper (FDW) for MySQL. The following enhancements are added to the mysql_fdw: Write-able FDW Connection Pooling Where clause push-down Column push-down Prepared Statment Please note that this version of mysql_fdw works with PostgreSQL 9.3, 9.4, 9.5 and 9.6. WWW: https://github.com/EnterpriseDB/mysql_fdw PR: 219636 Submitted by: Jov <amutu@amutu.com>
Notes
Notes: svn path=/head/; revision=444170
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/postgresql-mysql_fdw/Makefile30
-rw-r--r--databases/postgresql-mysql_fdw/distinfo3
-rw-r--r--databases/postgresql-mysql_fdw/pkg-descr11
4 files changed, 45 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 10ad2821a6f9..b17860e6e372 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -661,6 +661,7 @@
SUBDIR += postgresql-libpgeasy
SUBDIR += postgresql-libpqxx
SUBDIR += postgresql-libpqxx3
+ SUBDIR += postgresql-mysql_fdw
SUBDIR += postgresql-odbc
SUBDIR += postgresql-plproxy
SUBDIR += postgresql-plruby
diff --git a/databases/postgresql-mysql_fdw/Makefile b/databases/postgresql-mysql_fdw/Makefile
new file mode 100644
index 000000000000..4dba1526df14
--- /dev/null
+++ b/databases/postgresql-mysql_fdw/Makefile
@@ -0,0 +1,30 @@
+# Created by: Jov <amutu@amutu.com>
+# $FreeBSD$
+
+PORTNAME= mysql_fdw
+PORTVERSION= 2.2.0
+CATEGORIES= databases
+PKGNAMEPREFIX= postgresql${PGSQL_VER:S/.//}-
+
+MAINTAINER= amutu@amutu.com
+COMMENT= PostgreSQL foreign data wrapper for MySQL
+
+LICENSE= PostgreSQL
+
+USES= gmake pgsql:9.3+ mysql
+USE_GITHUB= yes
+GH_ACCOUNT= EnterpriseDB
+GH_TAGNAME= c14ee1d
+
+MAKE_ENV= USE_PGXS=1
+
+WANT_PGSQL= server
+
+PLIST_FILES= lib/postgresql/mysql_fdw.so \
+ share/postgresql/extension/mysql_fdw--1.0.sql \
+ share/postgresql/extension/mysql_fdw.control
+
+do-patch:
+ ${SED} -i '.orig' 's/#if defined(__APPLE__)/& || defined(__FreeBSD__)/' ${WRKSRC}/mysql_fdw.c
+
+.include <bsd.port.mk>
diff --git a/databases/postgresql-mysql_fdw/distinfo b/databases/postgresql-mysql_fdw/distinfo
new file mode 100644
index 000000000000..9263ffe4fd9b
--- /dev/null
+++ b/databases/postgresql-mysql_fdw/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1496048192
+SHA256 (EnterpriseDB-mysql_fdw-2.2.0-c14ee1d_GH0.tar.gz) = 531f065a5827ba4f19f222e502b9b224031574845adb5d001d6527a0a601b55f
+SIZE (EnterpriseDB-mysql_fdw-2.2.0-c14ee1d_GH0.tar.gz) = 39601
diff --git a/databases/postgresql-mysql_fdw/pkg-descr b/databases/postgresql-mysql_fdw/pkg-descr
new file mode 100644
index 000000000000..efc33da8435f
--- /dev/null
+++ b/databases/postgresql-mysql_fdw/pkg-descr
@@ -0,0 +1,11 @@
+This PostgreSQL extension implements a Foreign Data Wrapper (FDW) for MySQL.
+The following enhancements are added to the mysql_fdw:
+ Write-able FDW
+ Connection Pooling
+ Where clause push-down
+ Column push-down
+ Prepared Statment
+Please note that this version of mysql_fdw works with PostgreSQL 9.3, 9.4, 9.5
+and 9.6.
+
+WWW: https://github.com/EnterpriseDB/mysql_fdw