aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2012-03-05 21:18:50 +0000
committerChris Rees <crees@FreeBSD.org>2012-03-05 21:18:50 +0000
commitea1723d3ac9af3787f2fb283fe10d92a6c7ee243 (patch)
tree5323f00292f3f573f25fbbb171e147a6c7848f40 /databases
parent9183ac23aaa9505a29ef7b26658fa5f75dac7bb5 (diff)
downloadports-ea1723d3ac9af3787f2fb283fe10d92a6c7ee243.tar.gz
ports-ea1723d3ac9af3787f2fb283fe10d92a6c7ee243.zip
Notes
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile5
-rw-r--r--databases/postgresql-pltcl/pkg-descr6
-rw-r--r--databases/postgresql83-pltcl/Makefile10
-rw-r--r--databases/postgresql84-pltcl/Makefile10
-rw-r--r--databases/postgresql90-pltcl/Makefile10
-rw-r--r--databases/postgresql91-pltcl/Makefile (renamed from databases/postgresql-pltcl/Makefile)22
-rw-r--r--databases/postgresql91-server/pkg-plist-pltcl9
-rw-r--r--databases/postgresql92-server/pkg-plist-pltcl9
8 files changed, 54 insertions, 27 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 5295f84db0e9..c5f3dde769a3 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -619,7 +619,6 @@
SUBDIR += postgresql-plproxy
SUBDIR += postgresql-plpython
SUBDIR += postgresql-plruby
- SUBDIR += postgresql-pltcl
SUBDIR += postgresql-relay
SUBDIR += postgresql-repmgr
SUBDIR += postgresql-tcltk
@@ -630,21 +629,25 @@
SUBDIR += postgresql83-contrib
SUBDIR += postgresql83-docs
SUBDIR += postgresql83-plperl
+ SUBDIR += postgresql83-pltcl
SUBDIR += postgresql83-server
SUBDIR += postgresql84-client
SUBDIR += postgresql84-contrib
SUBDIR += postgresql84-docs
SUBDIR += postgresql84-plperl
+ SUBDIR += postgresql84-pltcl
SUBDIR += postgresql84-server
SUBDIR += postgresql90-client
SUBDIR += postgresql90-contrib
SUBDIR += postgresql90-docs
SUBDIR += postgresql90-plperl
+ SUBDIR += postgresql90-pltcl
SUBDIR += postgresql90-server
SUBDIR += postgresql91-client
SUBDIR += postgresql91-contrib
SUBDIR += postgresql91-docs
SUBDIR += postgresql91-plperl
+ SUBDIR += postgresql91-pltcl
SUBDIR += postgresql91-server
SUBDIR += postgresql_autodoc
SUBDIR += powerarchitect
diff --git a/databases/postgresql-pltcl/pkg-descr b/databases/postgresql-pltcl/pkg-descr
deleted file mode 100644
index dbd49eb69164..000000000000
--- a/databases/postgresql-pltcl/pkg-descr
+++ /dev/null
@@ -1,6 +0,0 @@
-PL/Tcl allows you to write PostgreSQL stored functions and procedures
-in Tcl.
-
-This software is part of the standard PostgreSQL distribution.
-
-WWW: http://www.postgresql.org/
diff --git a/databases/postgresql83-pltcl/Makefile b/databases/postgresql83-pltcl/Makefile
new file mode 100644
index 000000000000..1b38ab2616b5
--- /dev/null
+++ b/databases/postgresql83-pltcl/Makefile
@@ -0,0 +1,10 @@
+# New ports collection makefile for: PostgreSQL PL/Tcl
+# Date created: January 14, 2002
+# Whom: Palle Girgensohn <girgen@partitur.se>
+#
+# $FreeBSD$
+#
+
+WANT_PGSQL_VER?=83
+
+.include "${.CURDIR}/../postgresql91-pltcl/Makefile"
diff --git a/databases/postgresql84-pltcl/Makefile b/databases/postgresql84-pltcl/Makefile
new file mode 100644
index 000000000000..e51df6048822
--- /dev/null
+++ b/databases/postgresql84-pltcl/Makefile
@@ -0,0 +1,10 @@
+# New ports collection makefile for: PostgreSQL PL/Tcl
+# Date created: January 14, 2002
+# Whom: Palle Girgensohn <girgen@partitur.se>
+#
+# $FreeBSD$
+#
+
+WANT_PGSQL_VER?=84
+
+.include "${.CURDIR}/../postgresql91-pltcl/Makefile"
diff --git a/databases/postgresql90-pltcl/Makefile b/databases/postgresql90-pltcl/Makefile
new file mode 100644
index 000000000000..b574bb1eb84b
--- /dev/null
+++ b/databases/postgresql90-pltcl/Makefile
@@ -0,0 +1,10 @@
+# New ports collection makefile for: PostgreSQL PL/Tcl
+# Date created: January 14, 2002
+# Whom: Palle Girgensohn <girgen@partitur.se>
+#
+# $FreeBSD$
+#
+
+WANT_PGSQL_VER?=90
+
+.include "${.CURDIR}/../postgresql91-pltcl/Makefile"
diff --git a/databases/postgresql-pltcl/Makefile b/databases/postgresql91-pltcl/Makefile
index 04506154dbcb..674c1790ceaf 100644
--- a/databases/postgresql-pltcl/Makefile
+++ b/databases/postgresql91-pltcl/Makefile
@@ -13,27 +13,13 @@ PKGNAMESUFFIX= -pltcl
MAINTAINER= pgsql@FreeBSD.org
COMMENT= A module for using Tcl to write SQL functions
-MASTERDIR= ${.CURDIR}/../../databases/postgresql${PGSQL_VER}-server
+MASTERDIR= ${.CURDIR}/../../databases/postgresql${WANT_PGSQL_VER}-server
BUILD_DEPENDS= postgres:${POSTGRESQL_PORT}
RUN_DEPENDS= postgres:${POSTGRESQL_PORT}
-POSTGRESQL_PORT?=${PORTSDIR}/databases/postgresql${PGSQL_VER}-server
-
-DEFAULT_PGSQL_VER?=82
-
-# can't include <bsd.port.pre.mk> in a slave port
-# so set these instead:
-LOCALBASE?= /usr/local
-SED?= /usr/bin/sed
-
-# Setting/finding PostgreSQL version we want.
-.if exists(${LOCALBASE}/bin/postmaster)
-PGSQL_VER!= ${LOCALBASE}/bin/postmaster -V | ${SED} -n 's/.*PostgreSQL[^0-9]*\([0-9][0-9]*\)\.\([0-9][0-9]*\)[^0-9].*/\1\2/p'
-.elif exists(${LOCALBASE}/bin/pg_config)
-PGSQL_VER!= ${LOCALBASE}/bin/pg_config --version | ${SED} -n 's/PostgreSQL[^0-9]*\([0-9][0-9]*\)\.\([0-9][0-9]*\)[^0-9].*/\1\2/p'
-.else
-PGSQL_VER= ${DEFAULT_PGSQL_VER}
-.endif
+POSTGRESQL_PORT?=${PORTSDIR}/databases/postgresql${WANT_PGSQL_VER}-server
+
+WANT_PGSQL_VER?=91
# you can use "make WITH_TCL_VER=84" or similar for your favourite tcl version
USE_TCL= 84+
diff --git a/databases/postgresql91-server/pkg-plist-pltcl b/databases/postgresql91-server/pkg-plist-pltcl
index 47036c2a4e2a..66cc153320be 100644
--- a/databases/postgresql91-server/pkg-plist-pltcl
+++ b/databases/postgresql91-server/pkg-plist-pltcl
@@ -1,3 +1,9 @@
+%%DATADIR%%/extension/pltcl--1.0.sql
+%%DATADIR%%/extension/pltcl.control
+%%DATADIR%%/extension/pltclu.control
+%%DATADIR%%/extension/pltclu--1.0.sql
+%%DATADIR%%/extension/pltcl--unpackaged--1.0.sql
+%%DATADIR%%/extension/pltclu--unpackaged--1.0.sql
%%DOCSDIR%%/README-pltcl
lib/postgresql/pltcl.so
@dirrmtry lib/postgresql
@@ -5,5 +11,6 @@ bin/pltcl_loadmod
bin/pltcl_delmod
bin/pltcl_listmod
share/postgresql/unknown.pltcl
-@dirrmtry share/postgresql
+@dirrmtry %%DATADIR%%/extension
+@dirrmtry %%DATADIR%%
@dirrmtry %%DOCSDIR%%
diff --git a/databases/postgresql92-server/pkg-plist-pltcl b/databases/postgresql92-server/pkg-plist-pltcl
index 47036c2a4e2a..66cc153320be 100644
--- a/databases/postgresql92-server/pkg-plist-pltcl
+++ b/databases/postgresql92-server/pkg-plist-pltcl
@@ -1,3 +1,9 @@
+%%DATADIR%%/extension/pltcl--1.0.sql
+%%DATADIR%%/extension/pltcl.control
+%%DATADIR%%/extension/pltclu.control
+%%DATADIR%%/extension/pltclu--1.0.sql
+%%DATADIR%%/extension/pltcl--unpackaged--1.0.sql
+%%DATADIR%%/extension/pltclu--unpackaged--1.0.sql
%%DOCSDIR%%/README-pltcl
lib/postgresql/pltcl.so
@dirrmtry lib/postgresql
@@ -5,5 +11,6 @@ bin/pltcl_loadmod
bin/pltcl_delmod
bin/pltcl_listmod
share/postgresql/unknown.pltcl
-@dirrmtry share/postgresql
+@dirrmtry %%DATADIR%%/extension
+@dirrmtry %%DATADIR%%
@dirrmtry %%DOCSDIR%%