aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2019-03-15 08:33:17 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2019-03-15 08:33:17 +0000
commit244f0f94fada54a69bedb7994c6d8366fdb16a19 (patch)
treef9041f4e830d32d2bf50f529aae8b4b322008c77 /databases
parent8c32f150ba3b68117fad2b361fd45705c111ae50 (diff)
downloadports-244f0f94fada54a69bedb7994c6d8366fdb16a19.tar.gz
ports-244f0f94fada54a69bedb7994c6d8366fdb16a19.zip
databases/virtuoso: Replace IODBC_CPPFLAGS and append directly to CPPFLAGS
The result is identical and having a variable that looks like an options helper (IODBC_CPPFLAGS) after bsd.port.options.mk would be an error if D19553 is accepted. Reported by: tobik (in D19553)
Notes
Notes: svn path=/head/; revision=495774
Diffstat (limited to 'databases')
-rw-r--r--databases/virtuoso/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/databases/virtuoso/Makefile b/databases/virtuoso/Makefile
index 7ef15da0b413..e3cc831457a5 100644
--- a/databases/virtuoso/Makefile
+++ b/databases/virtuoso/Makefile
@@ -41,7 +41,7 @@ CONFIGURE_ARGS= --with-readline\
--datadir="${PREFIX}"\
--localstatedir="${PREFIX}"
CONFIGURE_ENV= ac_cv_header_sys_timeb_h=no
-CPPFLAGS+= -std=gnu89 ${IODBC_CPPFLAGS}
+CPPFLAGS+= -std=gnu89
LDFLAGS+= -lexecinfo
MAKE_ENV= PATH=${LOCALBASE}/bin:${PATH}\
ISQL=isql-vt
@@ -79,10 +79,10 @@ PLIST_SUB+= WITH_IMAGEMAGICK="@comment "
.if ${PORT_OPTIONS:MIODBC}
CONFIGURE_ARGS+=--with-iodbc=${LOCALBASE}
LIB_DEPENDS+= libiodbc.so:databases/libiodbc
-IODBC_CPPFLAGS= -I${LOCALBASE}/include/libiodbc
+CPPFLAGS+= -I${LOCALBASE}/include/libiodbc
PLIST_SUB+= WITH_IODBC=""
.else
-IODBC_CPPFLAGS= -I../../libsrc/odbcsdk/include
+CPPFLAGS+= -I../../libsrc/odbcsdk/include
PLIST_SUB+= WITH_IODBC="@comment "
.endif