aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-09-13 22:55:32 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-09-13 22:55:32 +0000
commit88de2365f1cd740079ee082465d82d58df2618e2 (patch)
tree29bfc0b510b87cf797ba96b991be5afe7be739a3 /databases
parentb7f28c64b201282bff99894ea04664553c3a5a94 (diff)
downloadports-88de2365f1cd740079ee082465d82d58df2618e2.tar.gz
ports-88de2365f1cd740079ee082465d82d58df2618e2.zip
Notes
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/pecl-PDO_PGSQL/Makefile32
-rw-r--r--databases/pecl-PDO_PGSQL/distinfo2
-rw-r--r--databases/pecl-PDO_PGSQL/pkg-descr3
4 files changed, 38 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index bb547a7b9ee8..d40ea41c788e 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -248,6 +248,7 @@
SUBDIR += pear-MDB_QueryTool
SUBDIR += pecl-PDO
SUBDIR += pecl-PDO_MYSQL
+ SUBDIR += pecl-PDO_PGSQL
SUBDIR += pecl-memcache
SUBDIR += pecl-sqlite
SUBDIR += pgaccess
diff --git a/databases/pecl-PDO_PGSQL/Makefile b/databases/pecl-PDO_PGSQL/Makefile
new file mode 100644
index 000000000000..30e133f889a3
--- /dev/null
+++ b/databases/pecl-PDO_PGSQL/Makefile
@@ -0,0 +1,32 @@
+# Ports collection makefile for: pecl-PDO_PGSQL
+# Date created: 2005-09-10
+# Whom: Alexander Zhuravlev <zaa@zaa.pp.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= PDO_PGSQL
+DISTVERSION= 1.0RC1
+CATEGORIES= databases www
+MASTER_SITES= http://pecl.php.net/get/
+PKGNAMEPREFIX= pecl-
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= PECL
+
+MAINTAINER= zaa@zaa.pp.ru
+COMMENT= PostgreSQL driver for PDO
+
+BUILD_DEPENDS+= ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/pdo.so:${PORTSDIR}/databases/pecl-PDO
+RUN_DEPENDS+= ${BUILD_DEPENDS}
+
+USE_PHP= yes
+USE_PHPIZE= yes
+USE_PHPEXT= yes
+DEFAULT_PHP_VER=5
+PHP_MODNAME= pdo_pgsql
+
+CONFIGURE_ARGS+=--with-pdo-pgsql=${LOCALBASE}
+
+USE_PGSQL= yes
+
+.include <bsd.port.mk>
diff --git a/databases/pecl-PDO_PGSQL/distinfo b/databases/pecl-PDO_PGSQL/distinfo
new file mode 100644
index 000000000000..9c0dd20468dc
--- /dev/null
+++ b/databases/pecl-PDO_PGSQL/distinfo
@@ -0,0 +1,2 @@
+MD5 (PECL/PDO_PGSQL-1.0RC1.tgz) = cd5088efa9157eceed8efb79060cc519
+SIZE (PECL/PDO_PGSQL-1.0RC1.tgz) = 11468
diff --git a/databases/pecl-PDO_PGSQL/pkg-descr b/databases/pecl-PDO_PGSQL/pkg-descr
new file mode 100644
index 000000000000..818a8075eb18
--- /dev/null
+++ b/databases/pecl-PDO_PGSQL/pkg-descr
@@ -0,0 +1,3 @@
+This is PHP extension which provides an PostgreSQL driver for PDO.
+
+WWW: http://pecl.php.net/package/PDO_PGSQL