aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2012-12-20 02:23:04 +0000
committerGabor Pali <pgj@FreeBSD.org>2012-12-20 02:23:04 +0000
commitf6f83c9efc2c46d2970746758e2c682bb8a518ec (patch)
tree290f2ea61305744bf0f477895c56b92acaeb361f /databases
parentaf071cfdc1f8578bd1523b823e683074a3139a34 (diff)
downloadports-f6f83c9efc2c46d2970746758e2c682bb8a518ec.tar.gz
ports-f6f83c9efc2c46d2970746758e2c682bb8a518ec.zip
Notes
Diffstat (limited to 'databases')
-rw-r--r--databases/hs-mysql/Makefile8
-rw-r--r--databases/hs-mysql/pkg-descr2
-rw-r--r--databases/hs-persistent-sqlite/Makefile10
-rw-r--r--databases/hs-persistent-sqlite/distinfo4
-rw-r--r--databases/hs-persistent-sqlite/pkg-descr2
-rw-r--r--databases/hs-persistent-template/Makefile10
-rw-r--r--databases/hs-persistent-template/distinfo4
-rw-r--r--databases/hs-persistent-template/pkg-descr2
-rw-r--r--databases/hs-persistent/Makefile20
-rw-r--r--databases/hs-persistent/distinfo4
-rw-r--r--databases/hs-persistent/pkg-descr2
11 files changed, 23 insertions, 45 deletions
diff --git a/databases/hs-mysql/Makefile b/databases/hs-mysql/Makefile
index 10e40f79c59c..0576c0613715 100644
--- a/databases/hs-mysql/Makefile
+++ b/databases/hs-mysql/Makefile
@@ -1,13 +1,9 @@
-# New ports collection makefile for: hs-mysql
-# Date created: 2011-05-23
-# Whom: jyyou@cs.nctu.edu.tw
-#
+# Created by: jyyou@cs.nctu.edu.tw
# $FreeBSD$
-#
PORTNAME= mysql
PORTVERSION= 0.1.1.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= databases haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/databases/hs-mysql/pkg-descr b/databases/hs-mysql/pkg-descr
index 9f59b1861d20..34558cf33d08 100644
--- a/databases/hs-mysql/pkg-descr
+++ b/databases/hs-mysql/pkg-descr
@@ -2,4 +2,4 @@ This library is a Haskell binding to the MySQL mysqlclient client library.
It is a fairly faithful, low level library that implements
most of the MySQL client API.
-WWW: https://github.com/bos/mysql
+WWW: https://github.com/bos/mysql
diff --git a/databases/hs-persistent-sqlite/Makefile b/databases/hs-persistent-sqlite/Makefile
index a6b88542aa11..b4e84385a2e4 100644
--- a/databases/hs-persistent-sqlite/Makefile
+++ b/databases/hs-persistent-sqlite/Makefile
@@ -1,13 +1,7 @@
-# New ports collection makefile for: hs-persistent-sqlite
-# Date created: June 10, 2012
-# Whom: haskell@FreeBSD.org
-#
# $FreeBSD$
-#
PORTNAME= persistent-sqlite
-PORTVERSION= 0.9.0.2
-PORTREVISION= 1
+PORTVERSION= 1.0.1
CATEGORIES= databases haskell
MAINTAINER= haskell@FreeBSD.org
@@ -15,7 +9,7 @@ COMMENT= Backend for the persistent library using sqlite3
LICENSE= MIT
-USE_CABAL= aeson>=0.5 conduit>=0.4 monad-control>=0.2 persistent>=0.9 \
+USE_CABAL= aeson>=0.5 conduit>=0.5 monad-control>=0.2 persistent>=1.0 \
text>=0.7 transformers>=0.2.1
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
diff --git a/databases/hs-persistent-sqlite/distinfo b/databases/hs-persistent-sqlite/distinfo
index 076d0c946a02..356b8fc53034 100644
--- a/databases/hs-persistent-sqlite/distinfo
+++ b/databases/hs-persistent-sqlite/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cabal/persistent-sqlite-0.9.0.2.tar.gz) = eb8fa320475f28b48d1f3f9e4bb84744aac7d4fb6cfaa8455577e13147f895a7
-SIZE (cabal/persistent-sqlite-0.9.0.2.tar.gz) = 1108691
+SHA256 (cabal/persistent-sqlite-1.0.1.tar.gz) = f52c2117e0f55576c6840e707ae5cd42574827fbc3d7ec001e3e9ee1ebee7ee3
+SIZE (cabal/persistent-sqlite-1.0.1.tar.gz) = 1285112
diff --git a/databases/hs-persistent-sqlite/pkg-descr b/databases/hs-persistent-sqlite/pkg-descr
index 05b30f8ce623..aa47ae6bf968 100644
--- a/databases/hs-persistent-sqlite/pkg-descr
+++ b/databases/hs-persistent-sqlite/pkg-descr
@@ -2,4 +2,4 @@ This package includes a thin sqlite3 wrapper based on the direct-sqlite
package, as well as the entire C library, so there are no system
dependencies.
-WWW: http://www.yesodweb.com/book/persistent
+WWW: http://www.yesodweb.com/book/persistent
diff --git a/databases/hs-persistent-template/Makefile b/databases/hs-persistent-template/Makefile
index 724ac37aeea8..dcafa19268e8 100644
--- a/databases/hs-persistent-template/Makefile
+++ b/databases/hs-persistent-template/Makefile
@@ -1,13 +1,7 @@
-# New ports collection makefile for: hs-persistent-template
-# Date created: December 26, 2011
-# Whom: haskell@FreeBSD.org
-#
# $FreeBSD$
-#
PORTNAME= persistent-template
-PORTVERSION= 0.9.0.2
-PORTREVISION= 1
+PORTVERSION= 1.0.0.2
CATEGORIES= databases haskell
MAINTAINER= haskell@FreeBSD.org
@@ -15,7 +9,7 @@ COMMENT= Type-safe, non-relational, multi-backend persistence
LICENSE= MIT
-USE_CABAL= aeson monad-control>=0.2 persistent>=0.9 text>=0.5 \
+USE_CABAL= aeson monad-control>=0.2 persistent>=1.0 text>=0.5 \
transformers>=0.2
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
diff --git a/databases/hs-persistent-template/distinfo b/databases/hs-persistent-template/distinfo
index 95bca25a1100..5e580612997b 100644
--- a/databases/hs-persistent-template/distinfo
+++ b/databases/hs-persistent-template/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cabal/persistent-template-0.9.0.2.tar.gz) = 7c29ae335dfda30eccdcccbc4c209823336a08d03a66b09a5a3090dd5bb17df4
-SIZE (cabal/persistent-template-0.9.0.2.tar.gz) = 9595
+SHA256 (cabal/persistent-template-1.0.0.2.tar.gz) = e8c7c47482daccd38c93be37818b629ff03f90e56299f284ba15e19edd0b6d6a
+SIZE (cabal/persistent-template-1.0.0.2.tar.gz) = 10208
diff --git a/databases/hs-persistent-template/pkg-descr b/databases/hs-persistent-template/pkg-descr
index fe71a91f78e6..670d67a81ebd 100644
--- a/databases/hs-persistent-template/pkg-descr
+++ b/databases/hs-persistent-template/pkg-descr
@@ -1,4 +1,4 @@
This library provides just the general interface and helper functions.
You must use a specific backend in order to make this useful.
-WWW: http://www.yesodweb.com/book/persistent
+WWW: http://www.yesodweb.com/book/persistent
diff --git a/databases/hs-persistent/Makefile b/databases/hs-persistent/Makefile
index 4435bbeb003a..e8f39f774b8b 100644
--- a/databases/hs-persistent/Makefile
+++ b/databases/hs-persistent/Makefile
@@ -1,25 +1,19 @@
-# New ports collection makefile for: hs-persistent
-# Date created: December 26, 2011
-# Whom: haskell@FreeBSD.org
-#
# $FreeBSD$
-#
PORTNAME= persistent
-PORTVERSION= 0.9.0.4
-PORTREVISION= 1
+PORTVERSION= 1.0.2.2
CATEGORIES= databases haskell
MAINTAINER= haskell@FreeBSD.org
COMMENT= Type-safe, multi-backend data serialization
-LICENSE= BSD
+LICENSE= MIT
-USE_CABAL= aeson>=0.5 attoparsec base64-bytestring blaze-html>=0.4 \
- blaze-markup>=0.5.1 conduit>=0.4 lifted-base>=0.1 \
- monad-control>=0.3 path-pieces>=0.1 pool-conduit>=0.1 \
- resourcet>=0.3 text>=0.8 transformers>=0.2.1 transformers-base \
- unordered-containers vector
+USE_CABAL= aeson>=0.5 attoparsec base64-bytestring blaze-html>=0.5 \
+ blaze-markup>=0.5.1 conduit>=0.5 lifted-base>=0.1 \
+ monad-control>=0.3 monad-logger>=0.2.1 path-pieces>=0.1 \
+ pool-conduit>=0.1 resourcet>=0.3 text>=0.8 transformers>=0.2.1 \
+ transformers-base unordered-containers vector
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/databases/hs-persistent/distinfo b/databases/hs-persistent/distinfo
index 0f6217a963de..701618fa77fb 100644
--- a/databases/hs-persistent/distinfo
+++ b/databases/hs-persistent/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cabal/persistent-0.9.0.4.tar.gz) = 59a6c6f188ec883524229a0dfae8de6918bf71af04bb160e4aea2156a1a0f5c5
-SIZE (cabal/persistent-0.9.0.4.tar.gz) = 27921
+SHA256 (cabal/persistent-1.0.2.2.tar.gz) = d6a05aefa9ae1a3903009dd9ec89f8b249c7a4a2f7aa914ad7013000b64c5a69
+SIZE (cabal/persistent-1.0.2.2.tar.gz) = 29083
diff --git a/databases/hs-persistent/pkg-descr b/databases/hs-persistent/pkg-descr
index 2fb730da959e..8814d00f5b17 100644
--- a/databases/hs-persistent/pkg-descr
+++ b/databases/hs-persistent/pkg-descr
@@ -1,4 +1,4 @@
Type-safe, data serialization. You must use a specific backend in order
to make this useful.
-WWW: http://www.yesodweb.com/book/persistent
+WWW: http://www.yesodweb.com/book/persistent