aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2013-10-10 00:09:35 +0000
committerJason Helfman <jgh@FreeBSD.org>2013-10-10 00:09:35 +0000
commit284d8b86830ae0392efe8ea2fd65a3ccdf952a42 (patch)
tree70cdf6e4ee0fea6e38e7defbc7e3ce9db69ed0ef /databases
parent0ee5bfde1c3d2376c79e35486246423618b4f0cf (diff)
downloadports-284d8b86830ae0392efe8ea2fd65a3ccdf952a42.tar.gz
ports-284d8b86830ae0392efe8ea2fd65a3ccdf952a42.zip
Notes
Diffstat (limited to 'databases')
-rw-r--r--databases/postgresql84-client/Makefile4
-rw-r--r--databases/postgresql84-contrib/Makefile4
-rw-r--r--databases/postgresql84-docs/Makefile4
-rw-r--r--databases/postgresql84-server/Makefile29
-rw-r--r--databases/postgresql90-client/Makefile4
-rw-r--r--databases/postgresql90-contrib/Makefile4
-rw-r--r--databases/postgresql90-docs/Makefile1
-rw-r--r--databases/postgresql90-plperl/Makefile4
-rw-r--r--databases/postgresql90-plpython/Makefile4
-rw-r--r--databases/postgresql90-server/Makefile4
-rw-r--r--databases/postgresql91-client/Makefile4
-rw-r--r--databases/postgresql91-contrib/Makefile1
-rw-r--r--databases/postgresql91-docs/Makefile4
-rw-r--r--databases/postgresql91-plperl/Makefile1
-rw-r--r--databases/postgresql91-pltcl/Makefile5
-rw-r--r--databases/postgresql91-server/Makefile30
-rw-r--r--databases/postgresql92-client/Makefile4
-rw-r--r--databases/postgresql92-contrib/Makefile4
-rw-r--r--databases/postgresql92-docs/Makefile1
-rw-r--r--databases/postgresql92-server/Makefile30
-rw-r--r--databases/postgresql93-client/Makefile4
-rw-r--r--databases/postgresql93-contrib/Makefile4
-rw-r--r--databases/postgresql93-server/Makefile3
23 files changed, 96 insertions, 61 deletions
diff --git a/databases/postgresql84-client/Makefile b/databases/postgresql84-client/Makefile
index 1c1f0f215849..7737e2d5ff2e 100644
--- a/databases/postgresql84-client/Makefile
+++ b/databases/postgresql84-client/Makefile
@@ -3,7 +3,8 @@
PORTNAME= postgresql
PORTREVISION= 0
-PKGNAMESUFFIX= -client
+PKGNAMESUFFIX?= ${DISTV:S/.//}-client
+DISTV= ${DISTVERSION:R}
COMMENT= PostgreSQL database (client)
@@ -13,6 +14,7 @@ BUILD_DIRS= config src/include src/interfaces src/port \
src/bin/pg_dump src/bin/psql src/bin/scripts src/bin/pg_config \
doc src/makefiles
CLIENT_ONLY= yes
+COMPONENT= -client
USE_LDCONFIG= yes
NO_STAGE= yes
diff --git a/databases/postgresql84-contrib/Makefile b/databases/postgresql84-contrib/Makefile
index 492125af795c..e6f938214adb 100644
--- a/databases/postgresql84-contrib/Makefile
+++ b/databases/postgresql84-contrib/Makefile
@@ -4,7 +4,8 @@
PORTNAME= postgresql
PORTREVISION= 0
CATEGORIES= databases
-PKGNAMESUFFIX= -contrib
+PKGNAMESUFFIX?= ${DISTV:S/.//}-contrib
+DISTV= ${DISTVERSION:R}
MAINTAINER= pgsql@FreeBSD.org
COMMENT= The contrib utilities from the PostgreSQL distribution
@@ -21,6 +22,7 @@ BUILD_DIRS= src/port contrib
INSTALL_DIRS= contrib
SLAVE_ONLY= yes
+COMPONENT= -contrib
CONFIGURE_ARGS+=--with-libxslt --with-libxml --with-openssl
NO_STAGE= yes
diff --git a/databases/postgresql84-docs/Makefile b/databases/postgresql84-docs/Makefile
index 7f07bc78e719..829e134ce410 100644
--- a/databases/postgresql84-docs/Makefile
+++ b/databases/postgresql84-docs/Makefile
@@ -3,7 +3,8 @@
PORTNAME= postgresql
PORTREVISION= 0
-PKGNAMESUFFIX= -docs
+PKGNAMESUFFIX?= ${DISTV:S/.//}-docs
+DISTV= ${DISTVERSION:R}
MAINTAINER= pgsql@FreeBSD.org
COMMENT= The PostgreSQL documentation set
@@ -15,6 +16,7 @@ WANT_PGSQL_VER?=84
NO_BUILD= YES
SLAVE_ONLY= YES
+COMPONENT= -docs
PATCHDIR= mustnotexist
PGDOCSDIR?= ${DOCSDIR}/release-${PGSQL_VER}
diff --git a/databases/postgresql84-server/Makefile b/databases/postgresql84-server/Makefile
index d774953ed381..8ad0c74a3dcf 100644
--- a/databases/postgresql84-server/Makefile
+++ b/databases/postgresql84-server/Makefile
@@ -7,15 +7,16 @@ PORTREVISION?= 1
CATEGORIES?= databases
MASTER_SITES= PGSQL
MASTER_SITE_SUBDIR= source/v${DISTVERSION}
-PKGNAMESUFFIX?= -server
+PKGNAMESUFFIX?= ${DISTV:S/.//}-server
+DISTV= ${DISTVERSION:R}
MAINTAINER?= pgsql@FreeBSD.org
COMMENT?= The most advanced open-source database available anywhere
-CONFLICTS?= ${PORTNAME}-client-[^${PORTVERSION:R:R}].* \
- ${PORTNAME}${PKGNAMESUFFIX}-[^${PORTVERSION:R:R}].* \
- ${PORTNAME}-client-8.[^${PORTVERSION:R:E}].* \
- ${PORTNAME}${PKGNAMESUFFIX}-8.[^${PORTVERSION:R:E}].*
+CONFLICTS?= ${PORTNAME}[^${PORTVERSION:R:R}].*-client.* \
+ ${PORTNAME}${COMPONENT}[^${PORTVERSION:R:R}].* \
+ ${PORTNAME}8.[^${PORTVERSION:R:E}].*-client.* \
+ ${PORTNAME}${COMPONENT}8.[^${PORTVERSION:R:E}].*
WRKSRC= ${WRKDIR}/postgresql-${DISTVERSION}
DIST_SUBDIR= postgresql
@@ -23,9 +24,8 @@ DIST_SUBDIR= postgresql
ICU_PATCHFILE?= pg-840-icu-2009-09-15.diff.gz
UNIQUENAME?= ${PORTNAME}${DISTVERSION:R:S/.//}
-LATEST_LINK?= ${PKGNAMEPREFIX}${UNIQUENAME}${PKGNAMESUFFIX}
-PKGINSTALL?= ${PKGDIR}/pkg-install${PKGNAMESUFFIX}
+PKGINSTALL?= ${PKGDIR}/pkg-install${COMPONENT}
USE_BZIP2= yes
.if !defined(NO_BUILD)
USES+= gmake
@@ -46,7 +46,7 @@ CONFIGURE_ENV+= INCLUDES="${INCLUDES}" \
PTHREAD_LIBS="${PTHREAD_LIBS}" \
LDFLAGS_SL="${LDFLAGS_SL}"
-PLIST= ${PKGDIR}/pkg-plist${PKGNAMESUFFIX}
+PLIST= ${PKGDIR}/pkg-plist${COMPONENT}
BUILD_DIRS?= src/timezone src/backend src/backend/utils/mb/conversion_procs \
src/backend/snowball src/bin/initdb src/bin/pg_ctl \
@@ -56,6 +56,7 @@ INSTALL_DIRS?= ${BUILD_DIRS}
.if !defined(CLIENT_ONLY) && !defined(SLAVE_ONLY)
SERVER_ONLY= yes
+COMPONENT= -server
USE_RC_SUBR= postgresql
USE_PGSQL= yes
WANT_PGSQL_VER= ${DISTVERSION:C/([0-9][0-9]*)\.([0-9][0-9]*).*/\1\2/g}
@@ -320,12 +321,12 @@ do-build:
cd ${WRKSRC}/$${dir} && ${SETENV} ${MAKE_ENV} ${GMAKE}; \
done
-. if exists(${FILESDIR}/pkg-message${PKGNAMESUFFIX}.in)
-SUB_FILES+= pkg-message${PKGNAMESUFFIX}
-PKGMESSAGE= ${WRKSRC}/pkg-message${PKGNAMESUFFIX}
+. if exists(${FILESDIR}/pkg-message${COMPONENT}.in)
+SUB_FILES+= pkg-message${COMPONENT}
+PKGMESSAGE= ${WRKSRC}/pkg-message${COMPONENT}
. endif
-. if exists(${FILESDIR}/pkg-install${PKGNAMESUFFIX}.in)
-SUB_FILES+= pkg-install${PKGNAMESUFFIX}
+. if exists(${FILESDIR}/pkg-install${COMPONENT}.in)
+SUB_FILES+= pkg-install${COMPONENT}
PLIST_SUB+= PG_USER=${PG_USER}
. endif
.endif
@@ -355,7 +356,7 @@ do-install:
. endif
@ if [ -r ${PKGMESSAGE} ]; then \
${MKDIR} ${DOCSDIR} ;\
- ${INSTALL_DATA} ${PKGMESSAGE} ${DOCSDIR}/README${PKGNAMESUFFIX} ;\
+ ${INSTALL_DATA} ${PKGMESSAGE} ${DOCSDIR}/README${COMPONENT} ;\
${CAT} ${PKGMESSAGE} ;\
fi
.endif # !NO_BUILD
diff --git a/databases/postgresql90-client/Makefile b/databases/postgresql90-client/Makefile
index 7562647fee5f..717da0f556cb 100644
--- a/databases/postgresql90-client/Makefile
+++ b/databases/postgresql90-client/Makefile
@@ -3,7 +3,8 @@
PORTNAME= postgresql
PORTREVISION= 0
-PKGNAMESUFFIX= -client
+PKGNAMESUFFIX?= ${DISTV:S/.//}-client
+DISTV= ${DISTVERSION:R}
COMMENT= PostgreSQL database (client)
@@ -14,6 +15,7 @@ BUILD_DIRS= config src/include src/interfaces src/port \
doc src/makefiles
INSTALL_DIRS= ${BUILD_DIRS}
CLIENT_ONLY= yes
+COMPONENT= -client
USE_LDCONFIG= yes
NO_STAGE= yes
diff --git a/databases/postgresql90-contrib/Makefile b/databases/postgresql90-contrib/Makefile
index 5cff5cada007..6015c6a5cadb 100644
--- a/databases/postgresql90-contrib/Makefile
+++ b/databases/postgresql90-contrib/Makefile
@@ -4,7 +4,8 @@
PORTNAME= postgresql
PORTREVISION= 0
CATEGORIES= databases
-PKGNAMESUFFIX= -contrib
+PKGNAMESUFFIX?= ${DISTV:S/.//}-contrib
+DISTV= ${DISTVERSION:R}
MAINTAINER= pgsql@FreeBSD.org
COMMENT= The contrib utilities from the PostgreSQL distribution
@@ -22,6 +23,7 @@ BUILD_DIRS= src/port contrib
INSTALL_DIRS= contrib
SLAVE_ONLY= yes
+COMPONENT= -contrib
CONFIGURE_ARGS+=--with-libxslt --with-libxml --with-openssl
LDFLAGS+= ${PTHREAD_LIBS} -L${PREFIX}/lib
diff --git a/databases/postgresql90-docs/Makefile b/databases/postgresql90-docs/Makefile
index fb4b95c5d689..ee14bf256176 100644
--- a/databases/postgresql90-docs/Makefile
+++ b/databases/postgresql90-docs/Makefile
@@ -2,6 +2,7 @@
# $FreeBSD$
WANT_PGSQL_VER=90
+COMPONENT= -docs
NO_STAGE= yes
.include "${.CURDIR}/../postgresql91-docs/Makefile"
diff --git a/databases/postgresql90-plperl/Makefile b/databases/postgresql90-plperl/Makefile
index 6fc45b719255..9654550f3351 100644
--- a/databases/postgresql90-plperl/Makefile
+++ b/databases/postgresql90-plperl/Makefile
@@ -3,7 +3,8 @@
PORTNAME= postgresql
CATEGORIES= databases perl5
-PKGNAMESUFFIX= -plperl
+PKGNAMESUFFIX?= ${DISTV:S/.//}-plperl
+DISTV= ${DISTVERSION:R}
MAINTAINER= pgsql@FreeBSD.org
COMMENT= Write SQL functions for PostgreSQL using Perl5
@@ -20,6 +21,7 @@ CONFIGURE_ARGS= --with-perl
BUILD_DIRS= src/backend src/pl/plperl
INSTALL_DIRS= src/pl/plperl
SLAVE_ONLY= yes
+COMPONENT= -plperl
NO_STAGE= yes
.include "${MASTERDIR}/Makefile"
diff --git a/databases/postgresql90-plpython/Makefile b/databases/postgresql90-plpython/Makefile
index 183d860c16bd..fc313cad4b44 100644
--- a/databases/postgresql90-plpython/Makefile
+++ b/databases/postgresql90-plpython/Makefile
@@ -2,7 +2,8 @@
PORTNAME= postgresql
CATEGORIES= databases python
-PKGNAMESUFFIX= -plpython
+PKGNAMESUFFIX?= ${DISTV:S/.//}-plpython
+DISTV= ${DISTVERSION:R}
MAINTAINER= pgsql@FreeBSD.org
COMMENT= Module for using Python to write SQL functions
@@ -17,6 +18,7 @@ USE_PYTHON?= yes
PYTHON_MAJOR_VER= ${PYTHON_VER:R}
CONFIGURE_ARGS= --with-python
PLIST_SUB= PYTHON_MAJOR_VER=${PYTHON_MAJOR_VER}
+COMPONENT= -plpython
.if ${PYTHON_MAJOR_VER} == 3
PLIST_SUB+= PYTHON3=""
diff --git a/databases/postgresql90-server/Makefile b/databases/postgresql90-server/Makefile
index 75b5932a942f..1039404859b5 100644
--- a/databases/postgresql90-server/Makefile
+++ b/databases/postgresql90-server/Makefile
@@ -3,7 +3,8 @@
DISTVERSION?= 9.0.13
PORTREVISION= 0
-PKGNAMESUFFIX?= -server
+PKGNAMESUFFIX?= ${DISTV:S/.//}-server
+DISTV= ${DISTVERSION:R}
MAINTAINER?= pgsql@FreeBSD.org
@@ -14,6 +15,7 @@ BUILD_DIRS?= src/timezone src/backend src/backend/utils/mb/conversion_procs \
src/bin/initdb src/bin/pg_ctl \
src/bin/pg_controldata src/bin/pg_resetxlog src/pl
INSTALL_DIRS?= ${BUILD_DIRS}
+COMPONENT?= -server
.if defined(CLIENT_ONLY)
MAN1= # no MAN1 for 9.0 only
diff --git a/databases/postgresql91-client/Makefile b/databases/postgresql91-client/Makefile
index 00977c164637..42bea30cb02a 100644
--- a/databases/postgresql91-client/Makefile
+++ b/databases/postgresql91-client/Makefile
@@ -2,7 +2,8 @@
# $FreeBSD$
PORTNAME= postgresql
-PKGNAMESUFFIX= -client
+PKGNAMESUFFIX?= ${DISTV:S/.//}-client
+DISTV= ${DISTVERSION:R}
COMMENT= PostgreSQL database (client)
@@ -14,6 +15,7 @@ BUILD_DIRS= config src/include src/interfaces src/port \
INSTALL_DIRS= ${BUILD_DIRS}
CLIENT_ONLY= yes
+COMPONENT= -client
USE_LDCONFIG= yes
NO_STAGE= yes
diff --git a/databases/postgresql91-contrib/Makefile b/databases/postgresql91-contrib/Makefile
index 7f02e9a79ed4..7b95d08d0b02 100644
--- a/databases/postgresql91-contrib/Makefile
+++ b/databases/postgresql91-contrib/Makefile
@@ -22,6 +22,7 @@ BUILD_DIRS= src/port contrib
INSTALL_DIRS= contrib
SLAVE_ONLY= yes
+COMPONENT= -contrib
CONFIGURE_ARGS+=--with-libxslt --with-libxml --with-openssl
LDFLAGS+= ${PTHREAD_LIBS} -L${PREFIX}/lib
diff --git a/databases/postgresql91-docs/Makefile b/databases/postgresql91-docs/Makefile
index 8a8c62fef5dc..d5b356d0c043 100644
--- a/databases/postgresql91-docs/Makefile
+++ b/databases/postgresql91-docs/Makefile
@@ -3,7 +3,8 @@
PORTNAME= postgresql
PORTREVISION= 0
-PKGNAMESUFFIX= -docs
+PKGNAMESUFFIX?= ${DISTV:S/.//}-docs
+DISTV= ${DISTVERSION:R}
MAINTAINER= pgsql@FreeBSD.org
COMMENT= The PostgreSQL documentation set
@@ -14,6 +15,7 @@ USE_PGSQL= YES
WANT_PGSQL_VER?=91
SLAVE_ONLY= YES
+COMPONENT= -docs
PGDOCSREL?= ${DOCSDIR_REL}/release-${PGSQL_VER}
PGDOCSDIR?= ${PREFIX}/${PGDOCSREL}
diff --git a/databases/postgresql91-plperl/Makefile b/databases/postgresql91-plperl/Makefile
index 964b73725fae..ce17bb06e8cd 100644
--- a/databases/postgresql91-plperl/Makefile
+++ b/databases/postgresql91-plperl/Makefile
@@ -2,6 +2,7 @@
# $FreeBSD$
WANT_PGSQL_VER= 91
+COMPONENT= -plperl
NO_STAGE= yes
.include "${.CURDIR}/../postgresql90-plperl/Makefile"
diff --git a/databases/postgresql91-pltcl/Makefile b/databases/postgresql91-pltcl/Makefile
index 30521adb5902..8fdb90546902 100644
--- a/databases/postgresql91-pltcl/Makefile
+++ b/databases/postgresql91-pltcl/Makefile
@@ -4,10 +4,10 @@
PORTNAME= postgresql
PORTREVISION= 3
CATEGORIES= databases tcl
-PKGNAMESUFFIX= -pltcl
+PKGNAMESUFFIX?= ${DISTV:S/.//}-pltcl
MAINTAINER= pgsql@FreeBSD.org
-COMMENT= A module for using Tcl to write SQL functions
+COMMENT= Module for using Tcl to write SQL functions
MASTERDIR= ${.CURDIR}/../../databases/postgresql${WANT_PGSQL_VER}-server
@@ -29,6 +29,7 @@ MAKE_ENV+= TCL_INCDIR="${TCL_INCLUDEDIR}"
BUILD_DIRS= src/backend src/pl/tcl
INSTALL_DIRS= src/pl/tcl
SLAVE_ONLY= yes
+COMPONENT= -pltcl
NO_STAGE= yes
.include "${MASTERDIR}/Makefile"
diff --git a/databases/postgresql91-server/Makefile b/databases/postgresql91-server/Makefile
index c5356f8edf1a..f08853c3694c 100644
--- a/databases/postgresql91-server/Makefile
+++ b/databases/postgresql91-server/Makefile
@@ -7,15 +7,16 @@ PORTREVISION?= 0
CATEGORIES?= databases
MASTER_SITES= PGSQL
MASTER_SITE_SUBDIR= source/v${DISTVERSION}
-PKGNAMESUFFIX?= -server
+PKGNAMESUFFIX?= ${DISTV:S/.//}-server
+DISTV= ${DISTVERSION:R}
MAINTAINER?= pgsql@FreeBSD.org
COMMENT?= The most advanced open-source database available anywhere
-CONFLICTS?= ${PORTNAME}-client-[^${PORTVERSION:R:R}].* \
- ${PORTNAME}${PKGNAMESUFFIX}-[^${PORTVERSION:R:R}].* \
- ${PORTNAME}-client-9.[^${PORTVERSION:R:E}].* \
- ${PORTNAME}${PKGNAMESUFFIX}-9.[^${PORTVERSION:R:E}].*
+CONFLICTS?= ${PORTNAME}[^${PORTVERSION:R:R}]-client.* \
+ ${PORTNAME}${COMPONENT}[^${PORTVERSION:R:R}].* \
+ ${PORTNAME}9.[^${PORTVERSION:R:E}].*-client.* \
+ ${PORTNAME}${COMPONENT}9.[^${PORTVERSION:R:E}].*
WRKSRC= ${WRKDIR}/postgresql-${DISTVERSION}
DIST_SUBDIR= postgresql
@@ -24,13 +25,11 @@ ICU_PATCHFILE?= pg-910-icu-2012-12-19.diff.gz
.if !defined(SLAVE_ONLY)
UNIQUENAME?= ${PORTNAME}${DISTVERSION:R:S/.//}
-LATEST_LINK?= ${PKGNAMEPREFIX}${UNIQUENAME}${PKGNAMESUFFIX}
.else # Contrib has different options from -client/-server
UNIQUENAME?= ${PORTNAME}${DISTVERSION:R:S/.//}${PKGNAMESUFFIX}
-LATEST_LINK?= ${PKGNAMEPREFIX}${UNIQUENAME}
.endif
-PKGINSTALL?= ${PKGDIR}/pkg-install${PKGNAMESUFFIX}
+PKGINSTALL?= ${PKGDIR}/pkg-install${COMPONENT}
USE_BZIP2= yes
.if !defined(NO_BUILD)
USES+= gmake
@@ -51,7 +50,7 @@ CONFIGURE_ENV+= INCLUDES="${INCLUDES}" \
PTHREAD_LIBS="${PTHREAD_LIBS}" \
LDFLAGS_SL="${LDFLAGS_SL}"
-PLIST= ${PKGDIR}/pkg-plist${PKGNAMESUFFIX}
+PLIST= ${PKGDIR}/pkg-plist${COMPONENT}
INSTALL_DIRS?= src/timezone src/backend \
src/backend/utils/mb/conversion_procs \
@@ -62,6 +61,7 @@ INSTALL_DIRS?= src/timezone src/backend \
BUILD_DIRS?= src/port ${INSTALL_DIRS}
.if !defined(CLIENT_ONLY) && !defined(SLAVE_ONLY)
+COMPONENT= -server
SERVER_ONLY= yes
USE_RC_SUBR= postgresql
USE_PGSQL= yes
@@ -341,12 +341,12 @@ do-build:
cd ${WRKSRC}/$${dir} && ${SETENV} ${MAKE_ENV} ${GMAKE}; \
done
-. if exists(${FILESDIR}/pkg-message${PKGNAMESUFFIX}.in)
-SUB_FILES+= pkg-message${PKGNAMESUFFIX}
-PKGMESSAGE= ${WRKSRC}/pkg-message${PKGNAMESUFFIX}
+. if exists(${FILESDIR}/pkg-message${COMPONENT}.in)
+SUB_FILES+= pkg-message${COMPONENT}
+PKGMESSAGE= ${WRKSRC}/pkg-message${COMPONENT}
. endif
-. if exists(${FILESDIR}/pkg-install${PKGNAMESUFFIX}.in)
-SUB_FILES+= pkg-install${PKGNAMESUFFIX}
+. if exists(${FILESDIR}/pkg-install${COMPONENT}.in)
+SUB_FILES+= pkg-install${COMPONENT}
PLIST_SUB+= PG_USER=${PG_USER}
. endif
@@ -374,7 +374,7 @@ do-install:
. endif
@ if [ -r ${PKGMESSAGE} ]; then \
${MKDIR} ${DOCSDIR} ;\
- ${INSTALL_DATA} ${PKGMESSAGE} ${DOCSDIR}/README${PKGNAMESUFFIX} ;\
+ ${INSTALL_DATA} ${PKGMESSAGE} ${DOCSDIR}/README${COMPONENT} ;\
${CAT} ${PKGMESSAGE} ;\
fi
.endif # !NO_BUILD
diff --git a/databases/postgresql92-client/Makefile b/databases/postgresql92-client/Makefile
index 55b98e32b26e..0e69b4623d6f 100644
--- a/databases/postgresql92-client/Makefile
+++ b/databases/postgresql92-client/Makefile
@@ -2,7 +2,8 @@
# $FreeBSD$
PORTNAME= postgresql
-PKGNAMESUFFIX= -client
+PKGNAMESUFFIX?= ${DISTV:S/.//}-client
+DISTV= ${DISTVERSION:R}
COMMENT= PostgreSQL database (client)
@@ -14,6 +15,7 @@ BUILD_DIRS= config src/include src/interfaces src/port \
INSTALL_DIRS= ${BUILD_DIRS}
CLIENT_ONLY= yes
+COMPONENT= -client
USE_LDCONFIG= yes
NO_STAGE= yes
diff --git a/databases/postgresql92-contrib/Makefile b/databases/postgresql92-contrib/Makefile
index d614f3a48605..c3548774d873 100644
--- a/databases/postgresql92-contrib/Makefile
+++ b/databases/postgresql92-contrib/Makefile
@@ -3,7 +3,8 @@
PORTNAME= postgresql
CATEGORIES= databases
-PKGNAMESUFFIX= -contrib
+PKGNAMESUFFIX?= ${DISTV:S/.//}-contrib
+DISTV= ${DISTVERSION:R}
MAINTAINER= pgsql@FreeBSD.org
COMMENT= The contrib utilities from the PostgreSQL distribution
@@ -21,6 +22,7 @@ BUILD_DIRS= src/port contrib
INSTALL_DIRS= contrib
SLAVE_ONLY= yes
+COMPONENT= -contrib
CONFIGURE_ARGS+=--with-libxslt --with-libxml --with-openssl
LDFLAGS+= ${PTHREAD_LIBS} -L${PREFIX}/lib
diff --git a/databases/postgresql92-docs/Makefile b/databases/postgresql92-docs/Makefile
index 68ce1dfdface..cb020e28a41c 100644
--- a/databases/postgresql92-docs/Makefile
+++ b/databases/postgresql92-docs/Makefile
@@ -2,6 +2,7 @@
# $FreeBSD$
WANT_PGSQL_VER=92
+COMPONENT= -docs
NO_STAGE= yes
.include "${.CURDIR}/../postgresql91-docs/Makefile"
diff --git a/databases/postgresql92-server/Makefile b/databases/postgresql92-server/Makefile
index 832377b62c35..e225aac27cc2 100644
--- a/databases/postgresql92-server/Makefile
+++ b/databases/postgresql92-server/Makefile
@@ -7,15 +7,16 @@ PORTREVISION?= 0
CATEGORIES?= databases
MASTER_SITES= PGSQL
MASTER_SITE_SUBDIR= source/v${DISTVERSION}
-PKGNAMESUFFIX?= -server
+PKGNAMESUFFIX?= ${DISTV:S/.//}-server
+DISTV= ${DISTVERSION:R}
MAINTAINER?= pgsql@FreeBSD.org
COMMENT?= The most advanced open-source database available anywhere
-CONFLICTS?= ${PORTNAME}-client-[^${PORTVERSION:R:R}].* \
- ${PORTNAME}${PKGNAMESUFFIX}-[^${PORTVERSION:R:R}].* \
- ${PORTNAME}-client-9.[^${PORTVERSION:R:E}].* \
- ${PORTNAME}${PKGNAMESUFFIX}-9.[^${PORTVERSION:R:E}].*
+CONFLICTS?= ${PORTNAME}[^${PORTVERSION:R:R}].*-client-[^${PORTVERSION:R:R}].* \
+ ${PORTNAME}[^${PORTVERSION:R:R}].*${COMPONENT} \
+ ${PORTNAME}9[^${PORTVERSION:R:E}].*-client-9.[^${PORTVERSION:R:E}].* \
+ ${PORTNAME}9[^${PORTVERSION:R:E}]${COMPONENT}.*
WRKSRC= ${WRKDIR}/postgresql-${DISTVERSION}
DIST_SUBDIR= postgresql
@@ -24,13 +25,11 @@ ICU_PATCHFILE?= pg-910-icu-2012-12-19.diff.gz
.if !defined(SLAVE_ONLY)
UNIQUENAME?= ${PORTNAME}${DISTVERSION:R:S/.//}
-LATEST_LINK?= ${PKGNAMEPREFIX}${UNIQUENAME}${PKGNAMESUFFIX}
.else # Contrib has different options from -client/-server
UNIQUENAME?= ${PORTNAME}${DISTVERSION:R:S/.//}${PKGNAMESUFFIX}
-LATEST_LINK?= ${PKGNAMEPREFIX}${UNIQUENAME}
.endif
-PKGINSTALL?= ${PKGDIR}/pkg-install${PKGNAMESUFFIX}
+PKGINSTALL?= ${PKGDIR}/pkg-install${COMPONENT}
USE_BZIP2= yes
.if !defined(NO_BUILD)
USES+= gmake
@@ -51,7 +50,7 @@ CONFIGURE_ENV+= INCLUDES="${INCLUDES}" \
PTHREAD_LIBS="${PTHREAD_LIBS}" \
LDFLAGS_SL="${LDFLAGS_SL}"
-PLIST= ${PKGDIR}/pkg-plist${PKGNAMESUFFIX}
+PLIST= ${PKGDIR}/pkg-plist${COMPONENT}
INSTALL_DIRS?= src/timezone src/backend \
src/backend/utils/mb/conversion_procs \
@@ -63,6 +62,7 @@ BUILD_DIRS?= src/port ${INSTALL_DIRS}
.if !defined(CLIENT_ONLY) && !defined(SLAVE_ONLY)
SERVER_ONLY= yes
+COMPONENT= -server
USE_RC_SUBR= postgresql
USE_PGSQL= yes
WANT_PGSQL_VER= ${DISTVERSION:C/([0-9][0-9]*)\.([0-9][0-9]*).*/\1\2/g}
@@ -343,12 +343,12 @@ do-build:
cd ${WRKSRC}/$${dir} && ${SETENV} ${MAKE_ENV} ${GMAKE}; \
done
-. if exists(${FILESDIR}/pkg-message${PKGNAMESUFFIX}.in)
-SUB_FILES+= pkg-message${PKGNAMESUFFIX}
-PKGMESSAGE= ${WRKSRC}/pkg-message${PKGNAMESUFFIX}
+. if exists(${FILESDIR}/pkg-message${COMPONENT}.in)
+SUB_FILES+= pkg-message${COMPONENT}
+PKGMESSAGE= ${WRKSRC}/pkg-message${COMPONENT}
. endif
-. if exists(${FILESDIR}/pkg-install${PKGNAMESUFFIX}.in)
-SUB_FILES+= pkg-install${PKGNAMESUFFIX}
+. if exists(${FILESDIR}/pkg-install${COMPONENT}.in)
+SUB_FILES+= pkg-install${COMPONENT}
PLIST_SUB+= PG_USER=${PG_USER}
. endif
@@ -376,7 +376,7 @@ do-install:
. endif
@ if [ -r ${PKGMESSAGE} ]; then \
${MKDIR} ${DOCSDIR} ;\
- ${INSTALL_DATA} ${PKGMESSAGE} ${DOCSDIR}/README${PKGNAMESUFFIX} ;\
+ ${INSTALL_DATA} ${PKGMESSAGE} ${DOCSDIR}/README${COMPONENT} ;\
${CAT} ${PKGMESSAGE} ;\
fi
.endif # !NO_BUILD
diff --git a/databases/postgresql93-client/Makefile b/databases/postgresql93-client/Makefile
index cacadac97219..ba318ae41afb 100644
--- a/databases/postgresql93-client/Makefile
+++ b/databases/postgresql93-client/Makefile
@@ -3,7 +3,8 @@
PORTNAME= postgresql
PORTREVISION= 0
-PKGNAMESUFFIX= -client
+PKGNAMESUFFIX?= ${DISTV:S/.//}-client
+DISTV= ${DISTVERSION:R}
COMMENT= PostgreSQL database (client)
@@ -15,6 +16,7 @@ BUILD_DIRS= config src/include src/interfaces src/port \
INSTALL_DIRS= ${BUILD_DIRS}
CLIENT_ONLY= yes
+COMPONENT= -client
USE_LDCONFIG= yes
USES= pkgconfig
diff --git a/databases/postgresql93-contrib/Makefile b/databases/postgresql93-contrib/Makefile
index 8b31f49cb7e8..9d300791a8c7 100644
--- a/databases/postgresql93-contrib/Makefile
+++ b/databases/postgresql93-contrib/Makefile
@@ -4,7 +4,8 @@
PORTNAME= postgresql
PORTREVISION= 0
CATEGORIES= databases
-PKGNAMESUFFIX= -contrib
+PKGNAMESUFFIX?= ${DISTV:S/.//}-contrib
+DISTV= ${DISTVERSION:R}
MAINTAINER= pgsql@FreeBSD.org
COMMENT= The contrib utilities from the PostgreSQL distribution
@@ -22,6 +23,7 @@ BUILD_DIRS= src/port src/common contrib
INSTALL_DIRS= contrib
SLAVE_ONLY= yes
+COMPONENT= -contrib
CONFIGURE_ARGS+=--with-libxslt --with-libxml --with-openssl --disable-nls
LDFLAGS+= ${PTHREAD_LIBS} -L${PREFIX}/lib
diff --git a/databases/postgresql93-server/Makefile b/databases/postgresql93-server/Makefile
index 2c4dde4e4aae..808577168c16 100644
--- a/databases/postgresql93-server/Makefile
+++ b/databases/postgresql93-server/Makefile
@@ -3,7 +3,8 @@
DISTVERSION?= 9.3.0
PORTREVISION?= 1
-PKGNAMESUFFIX?= -server
+PKGNAMESUFFIX?= ${DISTV:S/.//}-server
+DISTV= ${DISTVERSION:R}
MAINTAINER?= pgsql@FreeBSD.org