aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2019-09-21 15:40:57 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2019-09-21 15:40:57 +0000
commite99070b4c8ebbdec35be34a7f7ac5916f9be98bf (patch)
tree4459477c995b440c41ad312c02f9f502f3785fcd /databases
parent9a6ccdeaec8bd4c42260a48e504a93e7b4964af2 (diff)
downloadports-e99070b4c8ebbdec35be34a7f7ac5916f9be98bf.tar.gz
ports-e99070b4c8ebbdec35be34a7f7ac5916f9be98bf.zip
databases/tiledb: Fix build on non-x86 (due to -Werror)
Build on non-x86 currently fails with: /wrkdirs/usr/ports/databases/tiledb/work/TileDB-1.6.2/external/src/blosc/shuffle.cc:280:4: error: #warning Hardware-acceleration detection not implemented for the target architecture. Only the generic shuffle/unshuffle routines will be available. [-Werror=cpp] 280 | #warning Hardware-acceleration detection not implemented for the target architecture. Only the generic shuffle/unshuffle routines will be available. | ^~~~~~~ /wrkdirs/usr/ports/databases/tiledb/work/TileDB-1.6.2/external/src/blosc/shuffle.cc: In function 'blosc::shuffle_implementation_t blosc::get_shuffle_implementation()': /wrkdirs/usr/ports/databases/tiledb/work/TileDB-1.6.2/external/src/blosc/shuffle.cc:290:22: error: unused variable 'cpu_features' [-Werror=unused-variable] 290 | blosc_cpu_features cpu_features = blosc_get_cpu_features(); | ^~~~~~~~~~~~ cc1plus: all warnings being treated as errors Don't add -Werror to fix build. PR: 240618 Approved by: portmgr (blanket: build fix), linimon (mentor)
Notes
Notes: svn path=/head/; revision=512518
Diffstat (limited to 'databases')
-rw-r--r--databases/tiledb/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/databases/tiledb/Makefile b/databases/tiledb/Makefile
index 58dd08e6cf4e..426f8305c2f0 100644
--- a/databases/tiledb/Makefile
+++ b/databases/tiledb/Makefile
@@ -23,7 +23,7 @@ RUN_DEPENDS= catch>=0:devel/catch \
USES= cmake compiler:c++11-lang ssl
CMAKE_ARGS= -DCATCH_INCLUDE_DIR=${LOCALBASE}/include/catch2
-CMAKE_OFF= TILEDB_CMAKE_IDE TILEDB_FORCE_ALL_DEPS TILEDB_HDFS TILEDB_S3 TILEDB_SUPERBUILD TILEDB_TESTS_AWS_S3_CONFIG TILEDB_VERBOSE
+CMAKE_OFF= TILEDB_CMAKE_IDE TILEDB_WERROR TILEDB_FORCE_ALL_DEPS TILEDB_HDFS TILEDB_S3 TILEDB_SUPERBUILD TILEDB_TESTS_AWS_S3_CONFIG TILEDB_VERBOSE
CMAKE_ON= TILEDB_CPP_API TILEDB_STATIC TILEDB_STATS TILEDB_TBB TILEDB_TBB_SHARED TILEDB_TESTS TILEDB_TOOLS TILEDB_WERROR
GH_ACCOUNT= TileDB-Inc