aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2009-09-03 15:23:49 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2009-09-03 15:23:49 +0000
commit5a6475a692f2a701cc0c2a54a1de1d62904ab336 (patch)
tree2a998b67fb0fab6d7e3c00b680684e4e36d90e0b /databases
parent3a1c790c78399b09cc6005f13675fd782dc06386 (diff)
Notes
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile2
-rw-r--r--databases/firebird-client/Makefile21
-rw-r--r--databases/firebird-server/Makefile220
-rw-r--r--databases/firebird-server/distinfo3
-rw-r--r--databases/firebird-server/files/RELNOTES108
-rw-r--r--databases/firebird-server/files/aliases.conf.in9
-rw-r--r--databases/firebird-server/files/patch-amd6476
-rw-r--r--databases/firebird-server/files/patch-builds%make.new%config%config.h.in20
-rw-r--r--databases/firebird-server/files/patch-builds%posix%make.defaults11
-rw-r--r--databases/firebird-server/files/patch-configure.in30
-rw-r--r--databases/firebird-server/files/patch-src%common%config%config.cpp11
-rw-r--r--databases/firebird-server/files/patch-src%install%misc%firebird.conf20
-rw-r--r--databases/firebird-server/files/patch-src%jrd%db_alias.cpp13
-rw-r--r--databases/firebird-server/files/patch-src%jrd%gds.cpp11
-rw-r--r--databases/firebird-server/files/patch-src%jrd%os%posix%config_root.cpp10
-rw-r--r--databases/firebird-server/files/patch-src%jrd%plugin_manager.cpp24
-rw-r--r--databases/firebird-server/files/patch-src%jrd%svc.cpp12
-rw-r--r--databases/firebird-server/files/patch-src%lock%lock.cpp15
-rw-r--r--databases/firebird-server/files/pkg-install.in71
-rw-r--r--databases/firebird-server/files/pkg-message.in26
-rw-r--r--databases/firebird-server/pkg-descr13
-rw-r--r--databases/firebird-server/pkg-plist34
-rw-r--r--databases/firebird-server/pkg-plist.client76
23 files changed, 0 insertions, 836 deletions
diff --git a/databases/Makefile b/databases/Makefile
index ae328471963c..493f22a496b2 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -57,8 +57,6 @@
SUBDIR += evolution-data-server
SUBDIR += exist
SUBDIR += fastdb
- SUBDIR += firebird-client
- SUBDIR += firebird-server
SUBDIR += firebird20-client
SUBDIR += firebird20-server
SUBDIR += fireprofile
diff --git a/databases/firebird-client/Makefile b/databases/firebird-client/Makefile
deleted file mode 100644
index 6c9feb8f740d..000000000000
--- a/databases/firebird-client/Makefile
+++ /dev/null
@@ -1,21 +0,0 @@
-# New ports collection makefile for: firebird-client
-# Date created: 2005 Mar 03
-# Whom: Renato Botelho <renato@galle.com.br>
-#
-# $FreeBSD$
-#
-
-PORTNAME= firebird
-PKGNAMESUFFIX= -client
-
-COMMENT= The open-source InterBase(tm) 6.0 spin-off (client)
-
-BROKEN= does not build
-
-MASTERDIR= ${.CURDIR}/../firebird-server
-
-PLIST= ${PKGDIR}/pkg-plist.client
-
-CLIENT_ONLY= yes
-
-.include "${MASTERDIR}/Makefile"
diff --git a/databases/firebird-server/Makefile b/databases/firebird-server/Makefile
deleted file mode 100644
index b8b97ade388b..000000000000
--- a/databases/firebird-server/Makefile
+++ /dev/null
@@ -1,220 +0,0 @@
-# New ports collection makefile for: Firebird
-# Date created: 20 December 2000
-# Whom: Geoffrey C. Speicher <geoff@sea-incorporated.com>
-#
-# $FreeBSD$
-#
-
-PORTNAME?= firebird
-PORTVERSION= 1.5.5
-CATEGORIES?= databases
-MASTER_SITES= SF/firebird/firebird/${PORTVERSION}-Release%20%28Source%29
-PKGNAMESUFFIX?= -server
-DISTNAME= firebird-1.5.5.4926
-
-MAINTAINER= skv@FreeBSD.org
-COMMENT?= The open-source InterBase(tm) 6.0 spin-off (Classic version)
-
-LATEST_LINK= ${PORTNAME}${PKGNAMESUFFIX}
-
-EXPIRATION_DATE= 2009-02-24
-DEPRECATED= no longer under development, please consider using Firebird2
-
-USE_BISON= build
-USE_BZIP2= yes
-USE_GMAKE= yes
-GNU_CONFIGURE= yes
-USE_AUTOTOOLS= autoconf:262 aclocal:19 libtool:22
-ACLOCAL_ARGS= --acdir=${ACLOCAL_DIR} -I ${LOCALBASE}/share/aclocal
-USE_GCC= 3.4
-
-LOCALSTATEDIR= /var/db/firebird
-CONFDIR= ${PREFIX}/etc/firebird
-LIBEXECDIR= ${PREFIX}/libexec/firebird
-PLIST_SUB= FIREBIRD_VERSION=${PORTVERSION} \
- LOCALSTATEDIR="var/db/firebird" CONFDIR="etc/firebird"
-
-# Don't use ld for linking, use gcc
-LD= ${CC}
-
-# Don't strip binary files
-STRIP=
-
-ONLY_FOR_ARCHS= i386 amd64
-CONFLICTS= firebird-client-2* firebird-server-2*
-
-WRKSRC= ${WRKDIR}/${DISTNAME}
-
-INSTALL_FB= ${INSTALL} ${COPY} -g firebird
-
-.if !defined(CLIENT_ONLY)
-# Server part stuff
-LIB_DEPENDS+= fbembed.1:${PORTSDIR}/databases/firebird-client
-
-AUTOGENARGS= --with-lock-manager
-
-ALL_TARGET= firebird_boot ref_databases msgs libfbembed intl otherfiles \
- inet_server extlib embed_gfix embed_gbak embed_gdef embed_util
-
-SUB_FILES= pkg-install pkg-message aliases.conf
-SUB_LIST+= LOCALSTATEDIR=${LOCALSTATEDIR}
-
-SUID_BIN= fb_inet_server fb_lock_mgr gds_drop
-UTIL_BIN= fb_lock_print gbak gdef gfix gsec gstat
-UDF_SO= ib_udf.so fbudf.so
-UDF_SQL= src/extlib/ib_udf.sql src/extlib/fbudf/fbudf.sql
-.else
-# Client part stuff
-AUTOGENARGS= --with-editline
-
-ALL_TARGET= firebird_basic libfbembed embed_isql embed_gpre \
- embed_gdef embed_qli libfbclient extlib
-#ALL_TARGET= firebird_basic libfbembed libfbclient \
-# client_gpre client_gdef client_isql client_qli extlib
-
-USE_LDCONFIG= yes
-CLIENT_BIN= gpre isql qli
-
-CONFIGURE_ENV+= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" PTHREAD_LIBS="${PTHREAD_LIBS}"
-
-.if !defined(NOPORTDOCS)
-PORTDOCS= *
-.endif
-.endif
-
-MAKE_ENV+= FIREBIRD_TMP="${WRKDIR}" FIREBIRD_LOCK="${WRKDIR}"
-
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 700042
-IGNORE= Client does not compile with GCC 4.2. Please use firebird2 instead
-.endif
-
-.if !defined(CLIENT_ONLY)
-pre-everything::
- @${ECHO_MSG} "NOTE: If the work directory is on an NFS mount, you will"
- @${ECHO_MSG} "require NFS client locking support for the build to"
- @${ECHO_MSG} "succeed. Currently this is only available on FreeBSD 5.0"
- @${ECHO_MSG} "or greater."
- @${ECHO_MSG}
- @${ECHO_MSG} "WARNING: The on-disk structure of the databases has"
- @${ECHO_MSG} "changed since version 1.0.x."
- @${ECHO_MSG} "Cancel this installation now and backup your databases"
- @${ECHO_MSG} "if you have not already done so."
-.if !defined(BATCH)
- @sleep 2
-.endif
-.endif
-
-.if !defined(CLIENT_ONLY)
-pre-su-install:
- @${SETENV} PKG_PREFIX="${PREFIX}" ${SH} ${PKGINSTALL} ${PORTNAME} PRE-INSTALL
-
-post-install:
- @${SETENV} PKG_PREFIX="${PREFIX}" ${SH} ${PKGINSTALL} ${PORTNAME} POST-INSTALL
- @${CAT} ${PKGMESSAGE}
-.endif
-
-.ifndef WITHOUT_IPC_CLEANUP
-pre-build:
-.ifndef PACKAGE_BUILDING
- @if [ `${ID} -u` -eq 0 ]; then \
- ${ECHO_MSG} "==> Please do not build ${PORTNAME} as 'root' because this may cause conflicts with SysV semaphores of running services."; exit 1; fi
-.endif
- [ -f ${WRKDIR}/ipcs.pre.build ] || /usr/bin/ipcs -s | ${TAIL} -n +3 | \
- ${GREP} -F `${ID} -un` | ${CAT} > ${WRKDIR}/ipcs.pre.build
-
-post-build:
- /usr/bin/ipcs -s | ${TAIL} -n +3 | ${GREP} -F `${ID} -un` | ${CAT} > ${WRKDIR}/ipcs.post.build
- /usr/bin/diff -n ${WRKDIR}/ipcs.pre.build ${WRKDIR}/ipcs.post.build | \
- ${TAIL} -n +2 | ${SED} -E 's/^s +([0-9]+).*$$/\/usr\/bin\/ipcrm -s \1/' > ${WRKDIR}/ipcrm.sh
- ${SH} ${WRKDIR}/ipcrm.sh
-.endif
-
-do-configure:
- @(cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ${MAKE_ENV} MAKE=${GMAKE} \
- ${AUTOTOOLS_VARS} ./autogen.sh --localstatedir=${LOCALSTATEDIR} \
- --prefix=${LOCALSTATEDIR} --exec-prefix=${PREFIX} \
- --libexecdir=${LIBEXECDIR} \
- --sysconfdir=${CONFDIR} --datadir=${DATADIR} ${AUTOGENARGS})
-
-post-configure:
- @${REINPLACE_CMD} -e 's|__attribute__ ((__unused__));||' \
- ${WRKSRC}/src/dsql/parse.cpp
-
-do-install:
-.if !defined(CLIENT_ONLY)
-
- ${INSTALL_PROGRAM} ${UTIL_BIN:S!^!${WRKSRC}/gen/firebird/bin/!} ${PREFIX}/bin
-
- ${INSTALL_PROGRAM} -o firebird -g firebird -m 6550 \
- ${SUID_BIN:S!^!${WRKSRC}/gen/firebird/bin/!} ${PREFIX}/sbin
-
- @${MKDIR} ${CONFDIR}
- ${INSTALL_DATA} ${WRKDIR}/aliases.conf ${CONFDIR}/aliases.conf.sample
-
- ${MKDIR} ${LIBEXECDIR}/udf ${LOCALSTATEDIR}/help ${LIBEXECDIR}/intl
-
- ${CHOWN} -R firebird:firebird ${LOCALSTATEDIR}
-
- ${INSTALL_FB} -m 0555 ${UDF_SO:S!^!${WRKSRC}/gen/firebird/UDF/!} ${LIBEXECDIR}/udf
- ${INSTALL_FB} -m 0444 ${UDF_SQL:S!^!${WRKSRC}/!} ${LIBEXECDIR}/udf
-
-.if !exists(${LOCALSTATEDIR}/security.fdb)
- ${INSTALL_FB} -m 0660 -o firebird ${WRKSRC}/gen/firebird/security.fdb \
- ${LOCALSTATEDIR}/security.fdb
-.endif
- ${INSTALL_FB} -m 0660 -o firebird ${WRKSRC}/gen/firebird/security.fdb \
- ${LOCALSTATEDIR}/security.fdb.sample
-
- ${INSTALL_FB} -m 0440 ${WRKSRC}/gen/firebird/help/help.fdb \
- ${LOCALSTATEDIR}/help
-
- ${INSTALL_FB} -m 0555 ${WRKSRC}/gen/firebird/intl/libfbintl.so ${LIBEXECDIR}/intl/fbintl
-
- ${INSTALL_DATA} ${FILESDIR}/RELNOTES ${LOCALSTATEDIR}
-.else
-# defined CLIENT_ONLY
- ${INSTALL_PROGRAM} ${CLIENT_BIN:S!^!${WRKSRC}/gen/firebird/bin/!} \
- ${PREFIX}/bin
-
- ${SED} -e "s=%%PREFIX%%=${PREFIX}=g" ${WRKSRC}/gen/firebird/misc/firebird.conf > ${WRKDIR}/firebird.conf
-
- @${MKDIR} ${CONFDIR}
-.if !exists(${CONFDIR}/firebird.conf)
- ${INSTALL_DATA} ${WRKDIR}/firebird.conf ${CONFDIR}
-.endif
- ${INSTALL_DATA} ${WRKDIR}/firebird.conf ${CONFDIR}/firebird.conf.sample
-
- ${INSTALL_DATA} ${WRKSRC}/gen/firebird/lib/libib_util.so \
- ${WRKSRC}/gen/firebird/lib/libfbclient.so.${PORTVERSION} \
- ${WRKSRC}/gen/firebird/lib/libfbembed.so.${PORTVERSION} \
- ${PREFIX}/lib
-
- ${LN} -fs libfbclient.so.${PORTVERSION} ${PREFIX}/lib/libfbclient.so.1
- ${LN} -fs libfbclient.so.1 ${PREFIX}/lib/libfbclient.so
-
- ${LN} -fs libfbembed.so.${PORTVERSION} ${PREFIX}/lib/libfbembed.so.1
- ${LN} -fs libfbembed.so.1 ${PREFIX}/lib/libfbembed.so
- ${LN} -fs libfbembed.so.1 ${PREFIX}/lib/libgds.so.1
- ${LN} -fs libfbembed.so.1 ${PREFIX}/lib/libgds.so
-
- @${MKDIR} ${PREFIX}/include
- ${INSTALL_DATA} ${WRKSRC}/gen/firebird/include/*.h ${PREFIX}/include
-
- @${MKDIR} ${DATADIR}
- ${INSTALL_DATA} ${WRKSRC}/gen/firebird/*.msg ${DATADIR}
-
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}/sql.extensions
- ${INSTALL_DATA} ${WRKSRC}/doc/WhatsNew ${WRKSRC}/doc/README.* ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/doc/README.user ${DOCSDIR}/README
- ${INSTALL_DATA} ${WRKSRC}/doc/sql.extensions/README.* ${DOCSDIR}/sql.extensions
-.endif
-
- @${ECHO_MSG} "===> Installing examples for ${PKGNAME}"
- @${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/gen/firebird/examples/v5/* ${EXAMPLESDIR}
-.endif
-
-.include <bsd.port.post.mk>
diff --git a/databases/firebird-server/distinfo b/databases/firebird-server/distinfo
deleted file mode 100644
index 9a9889e725c2..000000000000
--- a/databases/firebird-server/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (firebird-1.5.5.4926.tar.bz2) = f280d6a790e11fd306ad0d7455bbb0a1
-SHA256 (firebird-1.5.5.4926.tar.bz2) = 2362714c5b9a35cc6a1e56a83d2bdc49e4ceaee3faf1b02b6f6839766e5dcb0a
-SIZE (firebird-1.5.5.4926.tar.bz2) = 5170648
diff --git a/databases/firebird-server/files/RELNOTES b/databases/firebird-server/files/RELNOTES
deleted file mode 100644
index 87a8c5de91bf..000000000000
--- a/databases/firebird-server/files/RELNOTES
+++ /dev/null
@@ -1,108 +0,0 @@
-Firebird 1.5.3 FreeBSD Release Notes
---------------------------------------
-FB-V1.5.3.4870 Firebird 1.5 Release
-
- Welcome to the FreeBSD Firebird port!
-
- Firebird is installed SUID with owner and group `firebird'.
-This does affect where you can and cannot create databases when
-connecting remotely, as well as which existing databases you can
-access. If you want a database to be available remotely, be sure
-it's readable and writeable to group firebird.
-
- There may be times when you manage to get your system into a
-state where using any of the Firebird utilites (isql, gbak, gsec,
-etc.) gives you the message "semget failed". One surefire way to
-do this is to build and install the port. :) If this happens,
-make sure that the lock manager is not running and its semaphores
-have been removed. The former can be accomplished with 'ps ax
-|grep fb' and 'kill'; the latter with 'ipcs -s' and 'ipcrm -s'.
-
- For example, after building and installing the port, you will
-probably go through something like this:
-
-# isql /var/db/firebird/security.fdb
-Statement failed, SQLCODE = -902
-
-operating system directive semget failed
--No such file or directory
-
-# ipcs -s
-Semaphores:
-T ID KEY MODE OWNER GROUP
-s 1310720 252034728 --rw-rw-rw- root wheel
-
-# ipcrm -s 1310720
-
-and you should be in business.
-
- Once this is done, you should be able to connect normally to
-databases. Your first connection will restart the lock manager.
-
- There may be times, however, when you still get "semget failed"
-even though the lock manager is not running and the semaphores have
-been cleaned up. There seems to be a conflict with this release
-and the PostgreSQL 7 release as installed from the ports collection.
-If you're having trouble with Firebird and you're running PostgreSQL,
-try stopping PostgreSQL:
-
- /usr/local/etc/rc.d/pgsql.sh stop
-
-and see if that helps. Alternatively, increase the value of SEMMNS
-by 48 in your kernel configuration file. This can be found by getting
-the current value with 'sysctl -a | grep semmns'. You can either add
-this to your kernel config, or add the following line to /boot/loader.conf:
-
- kern.ipc.semmns=X
-
-where is is the current value plus 48. If this doesn't resolve the issue,
-try adding 48 again.
-
- Please note that as of RC8, the libgds.so symlink now points to
-libfbembed.so. This has been done to resolve compatability issues with
-older versions of Firebird. The FreeBSD port of RC7 had libgds.so
-pointing to libfbclient.so. libfbclient.so is a remote access-only
-shared library with threaded support, which requires target applications
-to link with a threaded library such as libc_r.so, libpthread.so or libthr.so.
-
- Super Server support in Firebird 1.5 for FreeBSD is not currently
-available due to the Firebird code using POSIX threads APIs not available
-in FreeBSD 4.x or not yet complete in FreeBSD 5.x. This issue will become
-more important once the scalability issues of Super Server have been
-resolved.
-
- This installation has already inserted the necessary line to
-/etc/inetd.conf so that you can connect to Firebird across the network.
-However you may need to add the remote host to /etc/hosts.equiv. For
-example, to allow the local machine to make connections to Firebird
-using TCP, the following command needs running:
-
- echo localhost >> /etc/hosts.equiv
-
-Please note that adding machines to /etc/hosts.equiv can reduce the
-security of your system. If in doubt, try connecting to Firebird with
-a username and password already defined in security.fdb. For example:
-
-gsec
-> add myuser -pass mypass
-> quit
-isql -u myuser -p mypass localhost:/usr/local/share/firebird/examples/employee.fdb
-
-This should reduce the need for hosts defined in /etc/hosts.equiv.
-
- Complete documentation for InterBase(tm) is available (free of
-charge) from http://www.interbase.com/ in PDF format. While
-InterBase and Firebird are two distinct entities, all InterBase
-documentation is pertinent to Firebird. More information on Firebird
-and InterBase can be found at the following:
-
- http://sourceforge.net/projects/firebird/
- http://www.ibphoenix.com/
- http://www.interbase2000.org/
- http://www.firebirdsql.org/
-
- Please also see the doc directory in the Firebird package for
-documentation specific to Firebird.
-
-Chris Knight
-<chris@e-easy.com.au>
diff --git a/databases/firebird-server/files/aliases.conf.in b/databases/firebird-server/files/aliases.conf.in
deleted file mode 100644
index 92b5b620c07a..000000000000
--- a/databases/firebird-server/files/aliases.conf.in
+++ /dev/null
@@ -1,9 +0,0 @@
-#
-# List of known database aliases
-# ------------------------------
-#
-# Examples:
-#
-# employee = %%EXAMPLESDIR%%/employee.fdb
-# security = /var/db/firebird/security.fdb
-#
diff --git a/databases/firebird-server/files/patch-amd64 b/databases/firebird-server/files/patch-amd64
deleted file mode 100644
index 1f4d465389b3..000000000000
--- a/databases/firebird-server/files/patch-amd64
+++ /dev/null
@@ -1,76 +0,0 @@
---- src/jrd/common.h.orig Mon Jan 23 20:52:45 2006
-+++ src/jrd/common.h Mon Jan 23 20:54:36 2006
-@@ -273,8 +273,14 @@
-
- #define UNIX 1
- #define IEEE 1
-+
-+#ifdef AMD64
-+#define IMPLEMENTATION isc_info_db_impl_freebsd_amd64 /* 67 next higher unique n
-+umber, See you later */
-+#else
- #define I386 1
- #define IMPLEMENTATION isc_info_db_impl_freebsd /* 61 */
-+#endif
-
- #define QUADFORMAT "ll"
- #define QUADCONST(n) (n##LL)
---- src/jrd/ibase.h.orig Mon Jan 23 20:51:38 2006
-+++ src/jrd/ibase.h Mon Jan 23 20:52:08 2006
-@@ -1577,6 +1577,8 @@
- isc_info_db_impl_linux_sparc = 65,
- isc_info_db_impl_linux_amd64 = 66,
-
-+ isc_info_db_impl_freebsd_amd64 = 67,
-+
- isc_info_db_impl_last_value /* Leave this LAST! */
- };
-
---- src/jrd/pag.cpp.orig Sat Mar 26 07:07:11 2005
-+++ src/jrd/pag.cpp Mon Jan 23 21:27:49 2006
-@@ -143,8 +143,9 @@
- static const int CLASS_NETBSD_I386 = 22; // NetBSD/i386
- static const int CLASS_DARWIN_PPC = 23; // Darwin/PowerPC
- static const int CLASS_LINUX_AMD64 = 24; // LINUX on AMD64 systems
-+static const int CLASS_FREEBSD_AMD64 = 25;// FreeBSD/amd64
-
--static const int CLASS_MAX10 = CLASS_LINUX_AMD64;
-+static const int CLASS_MAX10 = CLASS_FREEBSD_AMD64;
-
- // ARCHITECTURE COMPATIBILITY CLASSES
-
-@@ -188,7 +189,8 @@
- archIntel86, // CLASS_FREEBSD_I386
- archIntel86, // CLASS_NETBSD_I386
- archUnknown, // CLASS_DARWIN_PPC
-- archUnknown // CLASS_LINUX_AMD64
-+ archUnknown, // CLASS_LINUX_AMD64
-+ archUnknown // CLASS_FREEBSD_AMD64
- };
-
- #ifdef sun
-@@ -239,7 +241,12 @@
- #endif
-
- #ifdef FREEBSD
-+#ifdef i386
- #define CLASS CLASS_FREEBSD_I386
-+#endif
-+#ifdef AMD64
-+#define CLASS CLASS_FREEBSD_AMD64
-+#endif
- #endif
-
- #ifdef NETBSD
---- src/jrd/utl.cpp.orig Mon Jan 23 20:56:00 2006
-+++ src/jrd/utl.cpp Mon Jan 23 20:56:37 2006
-@@ -255,7 +255,8 @@
- "Firebird/Darwin/PowerPC", /* 63 */
- "Firebird/SINIX-Z", /* 64 */
- "Firebird/linux Sparc", /* 65 */
-- "Firebird/linux AMD64" /* 66 */
-+ "Firebird/linux AMD64", /* 66 */
-+ "Firebird/FreeBSD/amd64" /* 67 */
- };
-
-
diff --git a/databases/firebird-server/files/patch-builds%make.new%config%config.h.in b/databases/firebird-server/files/patch-builds%make.new%config%config.h.in
deleted file mode 100644
index 1ad510c8f674..000000000000
--- a/databases/firebird-server/files/patch-builds%make.new%config%config.h.in
+++ /dev/null
@@ -1,20 +0,0 @@
---- builds/make.new/config/config.h.in.orig Sun Jul 6 05:07:48 2003
-+++ builds/make.new/config/config.h.in Thu Mar 16 19:15:02 2006
-@@ -172,6 +172,7 @@
- #undef PowerPC
- #undef sparc
- #undef i386
-+#undef AMD64
- #undef mips
- #undef alpha
-
-@@ -190,5 +191,9 @@
- #undef SINIXZ
-
- #define FB_PREFIX "/usr/local/firebird"
-+#define FB_EXEC_PREFIX "/usr/local"
-+#define FB_CONF_PREFIX "/usr/local/etc/firebird"
-+#define FB_MSG_PREFIX "/usr/local/libdata/firebird"
-+#define FB_LIBEXEC_PREFIX "/usr/local/libexec/firebird"
-
- #endif
diff --git a/databases/firebird-server/files/patch-builds%posix%make.defaults b/databases/firebird-server/files/patch-builds%posix%make.defaults
deleted file mode 100644
index f7d4bc6362f3..000000000000
--- a/databases/firebird-server/files/patch-builds%posix%make.defaults
+++ /dev/null
@@ -1,11 +0,0 @@
---- builds/posix/make.defaults.orig Thu Mar 16 19:49:57 2006
-+++ builds/posix/make.defaults Thu Mar 16 19:51:18 2006
-@@ -94,7 +94,7 @@
- CHMOD= chmod
- CHMOD_6= chmod 666
- CHMOD_7= chmod 777
--CHMOD_S7= chmod 06777
-+CHMOD_S7= chmod 04555
- MV= mv -f
- TOUCH= touch
- CP= cp
diff --git a/databases/firebird-server/files/patch-configure.in b/databases/firebird-server/files/patch-configure.in
deleted file mode 100644
index ce1a65467bb9..000000000000
--- a/databases/firebird-server/files/patch-configure.in
+++ /dev/null
@@ -1,30 +0,0 @@
---- configure.in.orig Wed Dec 14 10:29:08 2005
-+++ configure.in Thu Mar 16 18:38:55 2006
-@@ -49,6 +49,16 @@
- SHRLIB_EXT=dylib
- ;;
-
-+ amd64-*-freebsd*)
-+ MAKEFILE_PREFIX=freebsd
-+ PLATFORM=FREEBSD
-+ AC_DEFINE(FREEBSD)
-+ AC_DEFINE(AMD64)
-+ LOCK_MANAGER_FLG=Y
-+ EDITLINE_FLG=N
-+ SHRLIB_EXT=so
-+ ;;
-+
- *-*-freebsd*)
- MAKEFILE_PREFIX=freebsd
- PLATFORM=FREEBSD
-@@ -612,6 +622,10 @@
- AC_SUBST(NEW_FIREBIRD_DIR)
-
- AC_DEFINE_UNQUOTED(FB_PREFIX, $(if test "x$prefix" = "xNONE" ; then echo \"$ac_default_prefix\"; else echo \"$prefix\"; fi))
-+AC_DEFINE_UNQUOTED(FB_EXEC_PREFIX, "$exec_prefix")
-+AC_DEFINE_UNQUOTED(FB_CONF_PREFIX, "$sysconfdir")
-+AC_DEFINE_UNQUOTED(FB_MSG_PREFIX, "$datadir")
-+AC_DEFINE_UNQUOTED(FB_LIBEXEC_PREFIX, "$libexecdir")
-
- AC_CONFIG_COMMANDS(,,[
- dnl ### GEN ### directories for preprocessed cpp, databases and output
diff --git a/databases/firebird-server/files/patch-src%common%config%config.cpp b/databases/firebird-server/files/patch-src%common%config%config.cpp
deleted file mode 100644
index 34645c66ca09..000000000000
--- a/databases/firebird-server/files/patch-src%common%config%config.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/common/config/config.cpp.orig Wed Mar 15 14:17:53 2006
-+++ src/common/config/config.cpp Wed Mar 15 14:18:30 2006
-@@ -106,7 +106,7 @@
- {TYPE_STRING, "RemoteBindAddress", (ConfigValue) 0},
- {TYPE_STRING, "ExternalFileAccess", (ConfigValue) "None"}, // location(s) of external files for tables
- {TYPE_STRING, "DatabaseAccess", (ConfigValue) "Full"}, // location(s) of databases
-- {TYPE_STRING, "UdfAccess", (ConfigValue) "Restrict UDF"}, // location(s) of UDFs
-+ {TYPE_STRING, "UdfAccess", (ConfigValue) "Restrict " FB_LIBEXEC_PREFIX "/udf"}, // location(s) of UDFs
- {TYPE_STRING, "TempDirectories", (ConfigValue) 0},
- {TYPE_BOOLEAN, "BugcheckAbort", (ConfigValue) false}, // whether to abort() engine when internal error is found
- {TYPE_BOOLEAN, "OldColumnNaming", (ConfigValue) false} // if true use old column naming rules
diff --git a/databases/firebird-server/files/patch-src%install%misc%firebird.conf b/databases/firebird-server/files/patch-src%install%misc%firebird.conf
deleted file mode 100644
index 4f8f1b416285..000000000000
--- a/databases/firebird-server/files/patch-src%install%misc%firebird.conf
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/install/misc/firebird.conf.orig Fri Sep 30 17:13:47 2005
-+++ src/install/misc/firebird.conf Wed Mar 15 17:03:43 2006
-@@ -60,7 +60,7 @@
- #
- # Type: string
- #
--#RootDirectory =
-+#RootDirectory = /var/db/firebird
-
-
- # ----------------------------
-@@ -126,7 +126,7 @@
- #
- # Type: string (special format)
- #
--#UdfAccess = Restrict UDF
-+UdfAccess = Restrict %%PREFIX%%/libexec/firebird/udf
-
-
- # ----------------------------
diff --git a/databases/firebird-server/files/patch-src%jrd%db_alias.cpp b/databases/firebird-server/files/patch-src%jrd%db_alias.cpp
deleted file mode 100644
index 293a9eb96e4f..000000000000
--- a/databases/firebird-server/files/patch-src%jrd%db_alias.cpp
+++ /dev/null
@@ -1,13 +0,0 @@
---- src/jrd/db_alias.cpp.orig Mon Aug 18 01:16:41 2003
-+++ src/jrd/db_alias.cpp Mon Jul 25 15:07:45 2005
-@@ -37,8 +37,8 @@
-
- bool ResolveDatabaseAlias(const char* alias, char* database)
- {
-- TEXT alias_filename[MAXPATHLEN];
-- gds__prefix(alias_filename, ALIAS_FILE);
-+ TEXT alias_filename[MAXPATHLEN] = FB_CONF_PREFIX "/";
-+ strlcat(alias_filename, ALIAS_FILE, MAXPATHLEN);
- ConfigFile aliasConfig(false);
- aliasConfig.setConfigFile(alias_filename);
-
diff --git a/databases/firebird-server/files/patch-src%jrd%gds.cpp b/databases/firebird-server/files/patch-src%jrd%gds.cpp
deleted file mode 100644
index b1c47c40439a..000000000000
--- a/databases/firebird-server/files/patch-src%jrd%gds.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/jrd/gds.cpp.orig Mon Jan 23 15:04:44 2006
-+++ src/jrd/gds.cpp Mon Jan 23 15:07:20 2006
-@@ -3697,7 +3697,7 @@
- Firebird::string msgPrefix(getenv(FB_MSG_ENV) ? getenv(FB_MSG_ENV) : "");
- if (msgPrefix.length() == 0)
- {
-- msgPrefix = prefix;
-+ msgPrefix = FB_MSG_PREFIX;
- }
- copyTo(msgPrefix, ib_prefix_msg_val, sizeof(ib_prefix_msg_val));
- ib_prefix_msg = ib_prefix_msg_val;
diff --git a/databases/firebird-server/files/patch-src%jrd%os%posix%config_root.cpp b/databases/firebird-server/files/patch-src%jrd%os%posix%config_root.cpp
deleted file mode 100644
index 3af960c1599e..000000000000
--- a/databases/firebird-server/files/patch-src%jrd%os%posix%config_root.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/jrd/os/posix/config_root.cpp.orig Mon Jul 25 15:19:18 2005
-+++ src/jrd/os/posix/config_root.cpp Mon Jul 25 15:19:49 2005
-@@ -152,6 +152,6 @@
-
- const char *ConfigRoot::getConfigFile() const
- {
-- static string file = root_dir + string(CONFIG_FILE);
-+ static string file = string(FB_CONF_PREFIX) + PathUtils::dir_sep + string(CONFIG_FILE);
- return file.c_str();
- }
diff --git a/databases/firebird-server/files/patch-src%jrd%plugin_manager.cpp b/databases/firebird-server/files/patch-src%jrd%plugin_manager.cpp
deleted file mode 100644
index 808568121478..000000000000
--- a/databases/firebird-server/files/patch-src%jrd%plugin_manager.cpp
+++ /dev/null
@@ -1,24 +0,0 @@
---- src/jrd/plugin_manager.cpp.orig Wed Mar 15 14:25:42 2006
-+++ src/jrd/plugin_manager.cpp Wed Mar 15 14:39:12 2006
-@@ -47,9 +47,7 @@
- void PluginManager::loadAllPlugins()
- {
- Firebird::list<Path>::iterator pathItr;
-- char fb_lib_path[MAXPATHLEN];
-- gds__prefix(fb_lib_path, "");
-- Firebird::string fbLibPath(fb_lib_path);
-+ Firebird::string fbLibPath(FB_LIBEXEC_PREFIX);
- Firebird::string checkDir;
-
- for(pathItr = searchPaths.begin(); pathItr != searchPaths.end(); ++pathItr)
-@@ -114,9 +112,7 @@
-
- PluginManager::Module *PluginManager::loadPluginModule(const Firebird::string& name)
- {
-- char fb_lib_path[MAXPATHLEN];
-- gds__prefix(fb_lib_path, "");
-- Firebird::string fbLibPath(fb_lib_path);
-+ Firebird::string fbLibPath(FB_LIBEXEC_PREFIX);
- Firebird::string checkPath;
- Firebird::list<Path>::iterator itr;
-
diff --git a/databases/firebird-server/files/patch-src%jrd%svc.cpp b/databases/firebird-server/files/patch-src%jrd%svc.cpp
deleted file mode 100644
index 42b12339bc36..000000000000
--- a/databases/firebird-server/files/patch-src%jrd%svc.cpp
+++ /dev/null
@@ -1,12 +0,0 @@
---- src/jrd/svc.cpp.orig Tue Jan 24 17:11:48 2006
-+++ src/jrd/svc.cpp Tue Jan 24 17:27:22 2006
-@@ -1902,7 +1902,8 @@
-
- #ifndef SUPERSERVER
- if (serv->serv_executable) {
-- gds__prefix(service_path, serv->serv_executable);
-+ strlcpy(service_path, FB_EXEC_PREFIX "/", MAXPATHLEN);
-+ strlcat(service_path, serv->serv_executable, MAXPATHLEN);
- service->svc_flags = SVC_forked;
- service_fork(service_path, service);
- }
diff --git a/databases/firebird-server/files/patch-src%lock%lock.cpp b/databases/firebird-server/files/patch-src%lock%lock.cpp
deleted file mode 100644
index 7f550183e379..000000000000
--- a/databases/firebird-server/files/patch-src%lock%lock.cpp
+++ /dev/null
@@ -1,15 +0,0 @@
---- src/lock/lock.cpp.orig Mon Mar 29 08:35:49 2004
-+++ src/lock/lock.cpp Wed Jul 27 14:01:51 2005
-@@ -2800,7 +2800,11 @@
- #ifdef DEBUG_MANAGER
- gds__prefix(string, DEBUG_MANAGER);
- #else
-- gds__prefix(string, LOCK_MANAGER);
-+ if (! getenv("FIREBIRD")) {
-+ strlcpy(string, FB_EXEC_PREFIX "/s" LOCK_MANAGER, MAXPATHLEN);
-+ }else {
-+ gds__prefix(string, LOCK_MANAGER);
-+ }
- #endif
- if (statistics(string, &stat_buf) == -1) {
- sprintf (errorstring, "can't start lock manager: %s", string);
diff --git a/databases/firebird-server/files/pkg-install.in b/databases/firebird-server/files/pkg-install.in
deleted file mode 100644
index ee702916f43c..000000000000
--- a/databases/firebird-server/files/pkg-install.in
+++ /dev/null
@@ -1,71 +0,0 @@
-#!/bin/sh
-
-# $FreeBSD$
-
-PATH=/bin:/usr/bin:/usr/sbin
-
-case $2 in
-PRE-INSTALL)
-
-if [ `id -u` -ne 0 ]; then
- echo; echo "You must be root to run this step!"; echo; echo
- exit 1
-fi
-
-nofbuid=0
-fbUID=`id -u firebird 2>/dev/null`
-if [ $? -ne 0 ]; then
- fbUID=90
- while [ ! -z `id -un $fbUID 2>/dev/null` ]
- do
- fbUID=$(($fbUID+1))
- done
- nofbuid=1
-fi
-
-fbGID=`pw groupshow firebird 2>/dev/null`
-if [ $? -ne 0 ]; then
- fbGID=90
- while [ ! -z `id -gn $fbGID 2>/dev/null` ]
- do
- fbGID=$(($fbGID+1))
- done
- echo "firebird:*:$fbGID:" >> /etc/group
-else
- fbGID=`echo $fbGID | awk -F: '{print $3}'`
-fi
-
-echo "firebird user using uid $fbUID"
-echo "firebird user using gid $fbGID"
-
-if which -s pw; then
- if [ $nofbuid -ne 0 ]; then
- pw useradd firebird -u $fbUID -g $fbGID -h - -s /bin/sh \
- -d /var/db/firebird -c "Firebird Database Administrator"
- fi
-else
- echo -n "unable to create user firebird - please create it manually,"
- echo " before reinstalling this package."
- exit 1
-fi
-;;
-
-POST-INSTALL)
-cd /var/db/firebird
-
-# Lock files
-
-for i in isc_init1 isc_lock1 isc_event1
-do
- FileName=$i.`hostname`
- touch $FileName
- chmod uga=rw $FileName
- chown firebird:firebird $FileName
-done
-
-touch firebird.log
-chown firebird:firebird firebird.log
-
-;;
-
-esac
diff --git a/databases/firebird-server/files/pkg-message.in b/databases/firebird-server/files/pkg-message.in
deleted file mode 100644
index fabc059d6a02..000000000000
--- a/databases/firebird-server/files/pkg-message.in
+++ /dev/null
@@ -1,26 +0,0 @@
-
----------------------------------------------------------
-Firebird is now installed.
-
-Before start the server ensure that the following line exists in /etc/services:
-
-gds_db 3050/tcp #InterBase Database Remote Protocol
-
-And add the following line to /etc/inetd.conf
-
-gds_db stream tcp nowait firebird %%PREFIX%%/sbin/fb_inet_server fb_inet_server
-
-And finally restart inetd.
-
-It is STRONGLY recommended that you change the SYSDBA
-password with:
-
-% gsec -user SYSDBA -pass masterkey
-GSEC> modify SYSDBA -pw newpassword
-GSEC> quit
-
-before doing anything serious with Firebird.
-
-See %%LOCALSTATEDIR%%/RELNOTES for more.
----------------------------------------------------------
-
diff --git a/databases/firebird-server/pkg-descr b/databases/firebird-server/pkg-descr
deleted file mode 100644
index ba570031da86..000000000000
--- a/databases/firebird-server/pkg-descr
+++ /dev/null
@@ -1,13 +0,0 @@
-Firebird is a relational database offering many ANSI SQL-99 features
-that runs on Linux, Windows, and a variety of Unix platforms. Firebird
-offers excellent concurrency, high performance, and powerful language
-support for stored procedures and triggers. It has been used in
-production systems, under a variety of names since 1981.
-
-For more information on Firebird and InterBase, see:
-
-WWW: http://sourceforge.net/projects/firebird/
-WWW: http://www.ibphoenix.com/
-WWW: http://www.interbase2000.org/
-WWW: http://www.interbase.com/
-WWW: http://www.firebirdsql.org/
diff --git a/databases/firebird-server/pkg-plist b/databases/firebird-server/pkg-plist
deleted file mode 100644
index b4cc040b2d23..000000000000
--- a/databases/firebird-server/pkg-plist
+++ /dev/null
@@ -1,34 +0,0 @@
-@comment $FreeBSD$
-bin/fb_lock_print
-bin/gbak
-bin/gdef
-bin/gfix
-bin/gsec
-bin/gstat
-libexec/firebird/intl/fbintl
-libexec/firebird/udf/fbudf.so
-libexec/firebird/udf/fbudf.sql
-libexec/firebird/udf/ib_udf.so
-libexec/firebird/udf/ib_udf.sql
-sbin/fb_inet_server
-sbin/fb_lock_mgr
-sbin/gds_drop
-@unexec (cmp -s %D/%%CONFDIR%%/aliases.conf %D/%%CONFDIR%%/aliases.conf.sample && rm -f %D/%%CONFDIR%%/aliases.conf) || true
-%%CONFDIR%%/aliases.conf.sample
-@exec [ -f %B/aliases.conf ] || cp %B/%f %B/aliases.conf
-@dirrmtry %%CONFDIR%%
-@dirrm libexec/firebird/intl
-@dirrm libexec/firebird/udf
-@dirrm libexec/firebird
-@cwd /
-@unexec (cmp -s %D/%%LOCALSTATEDIR%%/security.fdb %D/%%LOCALSTATEDIR%%/security.fdb.sample && rm -f %D/%%LOCALSTATEDIR%%/security.fdb) || true
-%%LOCALSTATEDIR%%/security.fdb.sample
-@exec [ -f %D/%%LOCALSTATEDIR%%/security.fdb ] || cp %D/%F %D/%%LOCALSTATEDIR%%/security.fdb
-%%LOCALSTATEDIR%%/RELNOTES
-%%LOCALSTATEDIR%%/help/help.fdb
-@unexec [ -s %D/%%LOCALSTATEDIR%%/firebird.log ] || rm -f %D/%%LOCALSTATEDIR%%/firebird.log
-@rmtry %%LOCALSTATEDIR%%/isc_event1.`hostname`
-@rmtry %%LOCALSTATEDIR%%/isc_init1.`hostname`
-@rmtry %%LOCALSTATEDIR%%/isc_lock1.`hostname`
-@dirrm %%LOCALSTATEDIR%%/help
-@dirrmtry %%LOCALSTATEDIR%%
diff --git a/databases/firebird-server/pkg-plist.client b/databases/firebird-server/pkg-plist.client
deleted file mode 100644
index 8b61d85d22d4..000000000000
--- a/databases/firebird-server/pkg-plist.client
+++ /dev/null
@@ -1,76 +0,0 @@
-@comment $FreeBSD$
-bin/gpre
-bin/isql
-bin/qli
-include/blr.h
-include/gds.h
-include/ib_util.h
-include/ibase.h
-include/iberror.h
-include/perf.h
-lib/libfbclient.so
-lib/libfbclient.so.1
-lib/libfbclient.so.%%FIREBIRD_VERSION%%
-lib/libfbembed.so
-lib/libfbembed.so.1
-lib/libfbembed.so.%%FIREBIRD_VERSION%%
-lib/libgds.so
-lib/libgds.so.1
-lib/libib_util.so
-@unexec if cmp -s %D/%%CONFDIR%%/firebird.conf %D/%%CONFDIR%%/firebird.conf.sample; then rm -f %D/%%CONFDIR%%/firebird.conf; fi
-%%CONFDIR%%/firebird.conf.sample
-@exec [ -f %B/firebird.conf ] || cp %B/%f %B/firebird.conf
-@dirrmtry %%CONFDIR%%
-%%DATADIR%%/de_DE.msg
-%%DATADIR%%/firebird.msg
-%%DATADIR%%/fr_FR.msg
-%%DATADIR%%/ja_JP.msg
-@dirrm %%DATADIR%%
-%%EXAMPLESDIR%%/align.h
-%%EXAMPLESDIR%%/api1.c
-%%EXAMPLESDIR%%/api10.c
-%%EXAMPLESDIR%%/api11.c
-%%EXAMPLESDIR%%/api12.c
-%%EXAMPLESDIR%%/api13.c
-%%EXAMPLESDIR%%/api14.e
-%%EXAMPLESDIR%%/api15.c
-%%EXAMPLESDIR%%/api16.c
-%%EXAMPLESDIR%%/api16t.c
-%%EXAMPLESDIR%%/api2.c
-%%EXAMPLESDIR%%/api3.c
-%%EXAMPLESDIR%%/api4.c
-%%EXAMPLESDIR%%/api5.c
-%%EXAMPLESDIR%%/api6.c
-%%EXAMPLESDIR%%/api7.c
-%%EXAMPLESDIR%%/api8.c
-%%EXAMPLESDIR%%/api9.c
-%%EXAMPLESDIR%%/api9f.c
-%%EXAMPLESDIR%%/api9f.sql
-%%EXAMPLESDIR%%/apifull.c
-%%EXAMPLESDIR%%/dyn1.e
-%%EXAMPLESDIR%%/dyn2.e
-%%EXAMPLESDIR%%/dyn3.e
-%%EXAMPLESDIR%%/dyn4.e
-%%EXAMPLESDIR%%/dyn5.e
-%%EXAMPLESDIR%%/dynfull.e
-%%EXAMPLESDIR%%/employe2.sql
-%%EXAMPLESDIR%%/employee.fdb
-%%EXAMPLESDIR%%/employee.gbk
-%%EXAMPLESDIR%%/example.h
-%%EXAMPLESDIR%%/readme
-%%EXAMPLESDIR%%/stat1.e
-%%EXAMPLESDIR%%/stat10.e
-%%EXAMPLESDIR%%/stat11.e
-%%EXAMPLESDIR%%/stat12.e
-%%EXAMPLESDIR%%/stat12t.e
-%%EXAMPLESDIR%%/stat2.e
-%%EXAMPLESDIR%%/stat3.e
-%%EXAMPLESDIR%%/stat4.e
-%%EXAMPLESDIR%%/stat5.e
-%%EXAMPLESDIR%%/stat6.e
-%%EXAMPLESDIR%%/stat7.e
-%%EXAMPLESDIR%%/stat8.e
-%%EXAMPLESDIR%%/stat9.e
-%%EXAMPLESDIR%%/udf.sql
-%%EXAMPLESDIR%%/udflib.c
-@dirrm %%EXAMPLESDIR%%